Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 14/06/2015, à 12:54

Knoppixx

[Résolu]Kernel driver not installed (rc=-1908)

Bonjour à toutes et à tous,

Je suis confronté à une erreur récurrente à chaque mise à jour de cette machine, bien connue sur ce forum, avec beaucoup de discussions ouvertes à ce sujet.

J'ai malheureusement essayé toutes les solutions proposées dans les messages, mais aucunes ne fonctionnent.

J'avais réinstallé cet ordinateur entièrement à la dernière mise à jour du noyau, pour exactement le même problème, car je n'avais pas trouvé de solution. Je ne peux pas refaire une installation neuve à chaque fois.

J'avais pourtant formellement interdit à la personne qui utilise ce PC de faire des mises à jours, que j'avais d'ailleurs désactivées. Elle a pourtant fait cette mise à jour pour une raison ou une autre que je ne saurais déterminer (peut-être en installant un programme en ligne de commandes ou en lançant directement le programme de MàJ). Peu importe, maintenant que c'ets fait, le problème est là et je ne compte pas tout réinstaller sur ce PC.

Merci à ceux qui voudront bien m'aider à me débarraser de ce problème.

Voici l'erreur :

Quand je lance Virtualbox deux fenêtre s'ouvrent.

Voici ce que dit la première :

Échec de l'ouverture de session pour la machine virtuelle Seven.
    The virtual machine 'Seven' has terminated unexpectedly during startup with exit code 1.

    Détails :
    Code d'erreur : NS_ERROR_FAILURE (0x80004005)
    Composant : Machine
    Interface : IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Et la seconde :

Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

    '/etc/init.d/vboxdrv setup'

    as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Avec comme réponse quand je lance la commande :

/etc/init.d/vboxdrv: command not found

Le PC est un thinkpad X22O avec un i5-2520M 2,5Ghz

Le noyau est :

3.16.0-25-generic

La version de VB est :

4.3.26_Ubuntu r98988

Merci de votre aide

Dernière modification par Knoppixx (Le 15/06/2015, à 23:05)

Hors ligne

#2 Le 15/06/2015, à 13:22

tiramiseb

Re : [Résolu]Kernel driver not installed (rc=-1908)

Salut,

J'avais réinstallé cet ordinateur entièrement à la dernière mise à jour du noyau, pour exactement le même problème

Meuh nan, 'faut pas abuser, c'est loin d'être un "problème" nécessitant une réinstallation !

D'autant plus que de laisser d'anciennes versions des paquets, c'est une faille de sécurité.

----

Si tu as installé VirtualBox avec le paquet proposé par la logithèque (sans passer par le site de VirtualBox lui-même), alors ce dont tu aurais besoin est virtualbox-dkms.

Soit tu ne l'as pas et l'installer devrait résoudre ton souci (pour toujours).
Soit tu l'as et il faut approfondir pourquoi ça ne marche pas.

Commence alors par :

sudo apt-get install virtualbox-dkms

DKMS, c'est le machin qui fait que les modules externes (dont celui de VirtualBox) se compilent tous seuls après mise à jour du kernel, sans que tu n'aies rien à faire.

----

Si tu as installé VirtualBox avec le paquet fourni par VirtualBox, alors je serais de mauvais conseil vu que je ne l'utilise pas, mais à ma connaissance ce script devrait dans ce cas exister.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Domotego : boutique dédiée à la domotique DIY - https://www.domotego.com
Consultant informatique indépendant - Geek et tout plein d'autres choses

Hors ligne

#3 Le 15/06/2015, à 14:34

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

Bonjour tiramiseb et merci de bien voiloir m'aider.

Voici le résultat de la commande :

knoppixx@ordinateur:~$ sudo apt-get install virtualbox-dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
virtualbox-dkms est déjà la plus récente version disponible.
virtualbox-dkms passé en « installé manuellement ».
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-3.19.0-18 linux-headers-3.19.0-18-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 15 non mis à jour.
3 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de virtualbox (4.3.26-dfsg-2ubuntu2) ...
insserv: script virtualbox: service vboxdrv already provided!
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet virtualbox (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de virtualbox-qt :
 virtualbox-qt dépend de virtualbox (= 4.3.26-dfsg-2ubuntu2) ; cependant :
 Le paquet virtualbox n'est pas encore configuré.
  Le paquet virtualbox-4.3 qui fournit virtualbox n'est pas installé.

dpkg: erreur de traitement du paquet virtualbox-qt (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de virtualbox-dkms :
 virtualbox-dkms dépend de virtualbox (>= 4.3.26-dfsg-2ubuntu2) ; cependant :
 Le paquet virtualbox n'est pas encore configuré.
  Le paquet virtualbox-4.3 qui fournit virtualbox n'est pas installé.

dpkg: erreur de traitement du paquet virtualbox-dkms (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                  Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                    Des erreurs ont été rencontrées pendant l'exécution :
 virtualbox
 virtualbox-qt
 virtualbox-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
knoppixx@ordinateur:~$ 
tiramiseb a écrit :

Si tu as installé VirtualBox avec le paquet fourni par VirtualBox, alors je serais de mauvais conseil vu que je ne l'utilise pas, mais à ma connaissance ce script devrait dans ce cas exister.

Je suis prêt à tout supprimer et réinstaller depuis zéro, si ça permet à virtualbox de fonctionner.

Hors ligne

#4 Le 15/06/2015, à 14:37

tiramiseb

Re : [Résolu]Kernel driver not installed (rc=-1908)

Je suis prêt à tout supprimer et réinstaller depuis zéro, si ça permet à virtualbox de fonctionner.

Il faut arrêter de croire que réinstaller est une solution ! big_smile

Ton problème ne semble pas très compliqué, je suis sûr qu'en étant devant le PC ce serait résolu en 10 ou 15 minutes (que ce soit moi ou un des autres "bons" de ce forum), le seul problème est qu'au travers d'un forum ça met plus de temps à trouver la bonne solution.

insserv: script virtualbox: service vboxdrv already provided!

Cela voudrait dire que tu as deux paquets qui fournissent ce service, donc que tu aurais essayé d'installer VirtualBox à partir de deux sources différentes éventuellement.

Que donnent ces commandes ?

dpkg -l | grep -i box
grep vboxdrv /etc/init/* /etc/init.d/*

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Domotego : boutique dédiée à la domotique DIY - https://www.domotego.com
Consultant informatique indépendant - Geek et tout plein d'autres choses

Hors ligne

#5 Le 15/06/2015, à 14:55

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

tiramiseb a écrit :

Ton problème ne semble pas très compliqué, je suis sûr qu'en étant devant le PC ce serait résolu en 10 ou 15 minutes (que ce soit moi ou un des autres "bons" de ce forum), le seul problème est qu'au travers d'un forum ça met plus de temps à trouver la bonne solution.

J'en doute pas une seconde, mais j'ai dû accumuler des couches à force de vouloir réparer cette erreur. smile

tiramiseb a écrit :

Que donnent ces commandes ?

~$ dpkg -l | grep -i box
ii  busybox-initramfs                                    1:1.22.0-9ubuntu1                          amd64        Standalone shell setup for initramfs
ii  busybox-static                                       1:1.22.0-9ubuntu1                          amd64        Standalone rescue shell with tons of builtin utilities
ii  checkbox                                             0.18-0ubuntu2                              all          System testing application (transitional package)
ii  checkbox-gui                                         0.18-0ubuntu2                              amd64        QML based interface for system testing based on Plainbox.
ii  checkbox-ng                                          0.3.1-1                                    all          PlainBox based test runner
ii  checkbox-ng-service                                  0.3.1-1                                    all          CheckBox D-Bus service
ii  checkbox-qt                                          0.18-0ubuntu2                              all          QT4 interface for checkbox
ii  dialog                                               1.2-20140911-1                             amd64        Displays user-friendly dialog boes from shell scripts
ii  dropbox                                              2015.02.12                                 amd64        cloud synchronization engine - CLI and Nautilus extension
ii  gir1.2-rb-3.0                                        3.1-1ubuntu3                               amd64        GObject introspection data for the rhythmbox music player
rc  liboxideqtcore0:amd64                                1.5.6-0ubuntu0.14.10.1                     amd64        Web browser engine library for Qt (core library and components)
rc  liboxideqtquick0:amd64                               1.5.6-0ubuntu0.14.10.1                     amd64        Web browser engine library for Qt (QtQuick library)
rc  librhythmbox-core7                                   2.99.1-0ubuntu1                            amd64        support library for the rhythmbo music player
ii  librhythmbox-core8                                   3.1-1ubuntu3                               amd64        support library for the rhythmbo music player
ii  lockfile-progs                                       0.1.17                                     amd64        Programs for locking and unlocking files and mailboxes
ii  plainbox-provider-checkbox                           0.4-1                                      amd64        CheckBox provider for PlainBox
ii  plainbox-provider-resource-generic                   0.3-1                                      amd64        CheckBox generic resource jobs provider
ii  plainbox-secure-policy                               0.5.4-1                                    all          policykit policy required to use plainbox (secure version)
ii  python3-checkbox                                     0.18-0ubuntu2                              all          CheckBox python3 library
ii  python3-checkbox-ng                                  0.3.1-1                                    all          PlainBox based test runner (Python 3 library)
ii  python3-checkbox-support                             0.2-2                                      all          collection of Python modules used by PlainBox providers
ii  python3-plainbox                                     0.5.4-1                                    all          toolkit for software and hardware testing (python3 module)
ii  rhythmbox                                            3.1-1ubuntu3                               amd64        music player and organizer for GNOME
ii  rhythmbox-data                                       3.1-1ubuntu3                               all          data files for rhythmbox
ii  rhythmbox-mozilla                                    3.1-1ubuntu3                               amd64        Rhythmbox Mozilla plugin
ii  rhythmbox-plugin-cdrecorder                          3.1-1ubuntu3                               amd64        burning plugin for rhythmbox music player
ii  rhythmbox-plugin-magnatune                           3.1-1ubuntu3                               amd64        Magnatune plugin for rhythmbox music player
ii  rhythmbox-plugin-zeitgeist                           3.1-1ubuntu3                               all          zeitgeist plugin for rhythmbox music player
ii  rhythmbox-plugins                                    3.1-1ubuntu3                               amd64        plugins for rhythmbox music player
iF  virtualbox                                           4.3.26-dfsg-2ubuntu2                       amd64        x86 virtualization solution - base binaries
pc  virtualbox-4.3                                       4.3.28-100309~Ubuntu~raring                amd64        Oracle VM VirtualBox
iU  virtualbox-dkms                                      4.3.26-dfsg-2ubuntu2                       all          x86 virtualization solution - kernel module sources for dkms
iU  virtualbox-qt                                        4.3.26-dfsg-2ubuntu2                       amd64        x86 virtualization solution - Qt based user interface
ii  whiptail                                             0.52.15-3ubuntu1                           amd64        Displays user-friendly dialog boes from shell scripts
ii  zenity                                               3.14.0-1                                   amd64        Display graphical dialog boxes from shell scripts
ii  zenity-common                                        3.14.0-1                                   all          Display graphical dialog boxes from shell scripts (common files)
knoppixx@ordinateur:~$ grep vboxdrv /etc/init/* /etc/init.d/*
/etc/init.d/vboxautostart-service:# Required-Start: vboxdrv
/etc/init.d/vboxautostart-service:# Required-Stop:  vboxdrv
/etc/init.d/vboxautostart-service:vboxdrvrunning() {
/etc/init.d/vboxautostart-service:    lsmod | grep -q "vboxdrv[^_-]"
/etc/init.d/vboxautostart-service:    vboxdrvrunning || {
/etc/init.d/vboxballoonctrl-service:# Required-Start: vboxdrv
/etc/init.d/vboxballoonctrl-service:# Required-Stop:  vboxdrv
/etc/init.d/vboxballoonctrl-service:vboxdrvrunning() {
/etc/init.d/vboxballoonctrl-service:    lsmod | grep -q "vboxdrv[^_-]"
/etc/init.d/vboxballoonctrl-service:        vboxdrvrunning || {
/etc/init.d/vboxdrv:# Provides:       vboxdrv
/etc/init.d/vboxdrv:DEVICE=/dev/vboxdrv
/etc/init.d/vboxdrv:    if ! running vboxdrv; then
/etc/init.d/vboxdrv:        if ! $MODPROBE vboxdrv > /dev/null 2>&1; then
/etc/init.d/vboxdrv:            failure "modprobe vboxdrv failed. Please use 'dmesg' to find out why"
/etc/init.d/vboxdrv:        MAJOR=`sed -n 's;\([0-9]\+\) vboxdrv;\1;p' /proc/devices`
/etc/init.d/vboxdrv:            MINOR=`sed -n 's;\([0-9]\+\) vboxdrv;\1;p' /proc/misc`
/etc/init.d/vboxdrv:            rmmod vboxdrv 2>/dev/null
/etc/init.d/vboxdrv:            rmmod vboxdrv 2>/dev/null
/etc/init.d/vboxdrv:        rmmod vboxdrv 2>/dev/null
/etc/init.d/vboxdrv:    if running vboxdrv; then
/etc/init.d/vboxdrv:        if ! rmmod vboxdrv 2>/dev/null; then
/etc/init.d/vboxdrv:            failure "Cannot unload module vboxdrv"
/etc/init.d/vboxdrv:      $DODKMS uninstall vboxhost vboxdrv vboxnetflt vboxnetadp > $LOG
/etc/init.d/vboxdrv:    if find /lib/modules/`uname -r` -name "vboxdrv\.*" 2>/dev/null|grep -q vboxdrv; then
/etc/init.d/vboxdrv:        find /lib/modules/`uname -r` -name "vboxdrv\.*" 2>/dev/null|xargs rm -f 2>/dev/null
/etc/init.d/vboxdrv:          --save-module-symvers /tmp/vboxdrv-Module.symvers \
/etc/init.d/vboxdrv:          --module-source "$MODULE_SRC/vboxdrv" \
/etc/init.d/vboxdrv:          --use-module-symvers /tmp/vboxdrv-Module.symvers \
/etc/init.d/vboxdrv:          --use-module-symvers /tmp/vboxdrv-Module.symvers \
/etc/init.d/vboxdrv:          --use-module-symvers /tmp/vboxdrv-Module.symvers \
/etc/init.d/vboxdrv:    if running vboxdrv; then
/etc/init.d/vboxdrv:        str="vboxdrv"
/etc/init.d/vboxweb-service:# Required-Start: vboxdrv
/etc/init.d/vboxweb-service:# Required-Stop:  vboxdrv
/etc/init.d/vboxweb-service:vboxdrvrunning() {
/etc/init.d/vboxweb-service:    lsmod | grep -q "vboxdrv[^_-]"
/etc/init.d/vboxweb-service:        vboxdrvrunning || {
/etc/init.d/virtualbox:# Provides:       vboxdrv virtualbox
/etc/init.d/virtualbox:	if ! running vboxdrv; then
/etc/init.d/virtualbox:		if ! modprobe vboxdrv > /dev/null 2>&1; then
/etc/init.d/virtualbox:			if ! find /lib/modules/`uname -r` -name "vboxdrv\.*" 2>/dev/null|grep -q vboxdrv; then
/etc/init.d/virtualbox:				log_failure_msg "modprobe vboxdrv failed. Please use 'dmesg' to find out why"
/etc/init.d/virtualbox:	if running vboxdrv; then
/etc/init.d/virtualbox:		if ! rmmod vboxdrv 2>/dev/null; then
/etc/init.d/virtualbox:			log_failure_msg "Cannot unload module vboxdrv"
/etc/init.d/virtualbox:	if running vboxdrv && running vboxnetflt && running vboxnetadp && running vboxpci; then

Hors ligne

#6 Le 15/06/2015, à 16:38

tiramiseb

Re : [Résolu]Kernel driver not installed (rc=-1908)

Pour commencer, je vois que dans ton premier message tu avais montré :

/etc/init.d/vboxdrv: command not found

Alors que là tu montres que ce fichier /etc/init.d/vboxdrv est bien existant.

Ensuite, je vois que tu as essayé d'installer un paquet « virtualbox-4.3 », dont la version précise est « 4.3.28-100309~Ubuntu~raring » : le "raring" signifie que le truc que tu as essayé d'installer était pour Ubuntu 13.04. C'est mauvais.
Ce qu'on voit aussi, c'est que les quatre paquets qui contiennent "virtualbox" dans leur nom sont mal installés (on devrait lire "ii" au début de la ligne).

On va faire la chose en trois étapes :

1/ supprimer les paquets liés à virtualbox
2/ vérifier qu'il n'y a bien plus rien lié à virtualbox (histoire de voir si tu n'as pas essayé de l'installer avec autre chose qu'un paquet)
3/ installer le paquet officiel d'Ubuntu

Tu m'as l'air de t'être bien empêtré en tout cas, pourtant tu verras en 3 que ce n'est pas compliqué d'installer VirtualBox smile


Alors, d'abord étape 1 :

sudo apt-get remove --purge virtualbox*

Puis étape 2 :

grep vbox /etc/init.d/*

Dernière modification par tiramiseb (Le 15/06/2015, à 16:38)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Domotego : boutique dédiée à la domotique DIY - https://www.domotego.com
Consultant informatique indépendant - Geek et tout plein d'autres choses

Hors ligne

#7 Le 15/06/2015, à 17:13

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

tiramiseb a écrit :

Tu m'as l'air de t'être bien empêtré en tout cas, pourtant tu verras en 3 que ce n'est pas compliqué d'installer VirtualBox smile

Je ne doute pas de cette simplicité, mais j'ai comme l'impression qu'il se passe quelque chose d'anormal, car j'ai déjà fait ces commandes quelques fois, en suivant tes indications à la lettre dans d'autres fils où tu aidais d'autres personne qui avaient le même problème que moi, mais sans jamais de succès. Cependant je préfère te croire que tout recommencer en étant accompagné sera beaucoup moins risqué et plus fructueux. smile

Voici le résultat des commandes :

~$ sudo apt-get remove --purge virtualbox*
[sudo] password for knoppixx: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de virtualbox-3.0 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-3.1 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-3.2 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-guest-modules pour l'expression rationnelle « virtualbox* »
Note : sélection de unity-scope-virtualbox pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-2.0 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-2.1 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-2.2 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-guest-source pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-guest-dkms pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-dbg pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-dkms pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-guest-x11 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-ose pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-guest-additions-iso pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-qt pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-guest-additions pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-4.0 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-4.1 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-4.2 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-4.3 pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-source pour l'expression rationnelle « virtualbox* »
Note : sélection de virtualbox-guest-utils pour l'expression rationnelle « virtualbox* »
Le paquet « virtualbox-2.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-2.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-2.2 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-3.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-3.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-3.2 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-4.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-4.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-4.2 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-additions » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-ose » n'est pas installé, et ne peut donc être supprimé
Le paquet « unity-scope-virtualbox » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-additions-iso » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-dbg » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-dkms » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-source » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-utils » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-guest-x11 » n'est pas installé, et ne peut donc être supprimé
Le paquet « virtualbox-source » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  dkms libgsoap5 linux-headers-3.19.0-18 linux-headers-3.19.0-18-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  virtualbox* virtualbox-4.3* virtualbox-dkms* virtualbox-qt*
0 mis à jour, 0 nouvellement installés, 4 à enlever et 15 non mis à jour.
3 partiellement installés ou enlevés.
Après cette opération, 89,9 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 213439 fichiers et répertoires déjà installés.)
Suppression de virtualbox-qt (4.3.26-dfsg-2ubuntu2) ...
Purge des fichiers de configuration de virtualbox-qt (4.3.26-dfsg-2ubuntu2) ...
Suppression de virtualbox-dkms (4.3.26-dfsg-2ubuntu2) ...
Suppression de virtualbox (4.3.26-dfsg-2ubuntu2) ...
Purge des fichiers de configuration de virtualbox (4.3.26-dfsg-2ubuntu2) ...
Suppression de virtualbox-4.3 (4.3.28-100309~Ubuntu~raring) ...
Purge des fichiers de configuration de virtualbox-4.3 (4.3.28-100309~Ubuntu~raring) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.14-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.3-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.1+15.04.20150202-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour mime-support (3.58ubuntu1) ...

Puis étape 2 :

knoppixx@ordinateur:~$ grep vbox /etc/init.d/*
knoppixx@ordinateur:~$ 

Hors ligne

#8 Le 15/06/2015, à 21:28

tiramiseb

Re : [Résolu]Kernel driver not installed (rc=-1908)

Ok, là tu n'as plus VirtualBox.

Maintenant, l'étape 2 et demi : vérifier si tu as bien les headers nécessaires à la compilation du module :

dpkg -l | grep linux-headers
uname -a

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Domotego : boutique dédiée à la domotique DIY - https://www.domotego.com
Consultant informatique indépendant - Geek et tout plein d'autres choses

Hors ligne

#9 Le 15/06/2015, à 21:35

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

Re,

J'ai failli passer à l'étape 3 mais j'ai préféré être sage. smile

Le retour des commandes :


~$ dpkg -l | grep linux-headers
ii  linux-headers-3.19.0-18                              3.19.0-18.18                               all          Header files related to Linux kernel version 3.19.0
ii  linux-headers-3.19.0-18-generic                      3.19.0-18.18                               amd64        Linux kernel headers for version 3.19.0 on 64 bit x86 SMP
ii  linux-headers-3.19.0-20                              3.19.0-20.20                               all          Header files related to Linux kernel version 3.19.0
ii  linux-headers-3.19.0-20-generic                      3.19.0-20.20                               amd64        Linux kernel headers for version 3.19.0 on 64 bit x86 SMP
ii  linux-headers-generic                                3.19.0.20.19                               amd64        Generic Linux kernel headers
Linux X220 3.16.0-25-generic #33-Ubuntu SMP Tue Nov 4 12:06:54 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

#10 Le 15/06/2015, à 21:39

tiramiseb

Re : [Résolu]Kernel driver not installed (rc=-1908)

Là il y a clairement un problème : Tu as bien les derniers headers (3.19.0-20), installés par le truc "generic", mais tu tournes sous une vieille version du noyau. Comment se fait-ce ? Qu'as-tu bricolé avec le noyau ?

=>

dpkg -l | grep linux-image

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Domotego : boutique dédiée à la domotique DIY - https://www.domotego.com
Consultant informatique indépendant - Geek et tout plein d'autres choses

Hors ligne

#11 Le 15/06/2015, à 21:51

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

tiramiseb a écrit :

Là il y a clairement un problème : Tu as bien les derniers headers (3.19.0-20), installés par le truc "generic", mais tu tournes sous une vieille version du noyau. Comment se fait-ce ? Qu'as-tu bricolé avec le noyau ?

La dernière chose suspecte que j'ai faite c'est d'installer linux-header-generic comme préconnisé dans un fil de discussion traitant de la même erreur. Ici je crois :

http://forum.ubuntu-fr.org/viewtopic.ph … #p15110501

Du coup j'ai fait : "sudo apt-get install linux-headers-3.16.0-25-generic"

=>

~$ dpkg -l | grep linux-image
rc  linux-image-3.11.0-12-generic                        3.11.0-12.19                               amd64        Linux kernel image for version 3.11.0 on 64 bit x86 SMP
ii  linux-image-3.11.0-20-generic                        3.11.0-20.35                               amd64        Linux kernel image for version 3.11.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-27-generic                        3.13.0-27.50                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-29-generic                        3.13.0-29.53                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-30-generic                        3.13.0-30.55                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-32-generic                        3.13.0-32.57                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-33-generic                        3.13.0-33.58                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-34-generic                        3.13.0-34.60                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-35-generic                        3.13.0-35.62                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-36-generic                        3.13.0-36.63                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-37-generic                        3.13.0-37.64                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-39-generic                        3.13.0-39.66                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-40-generic                        3.13.0-40.69                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-41-generic                        3.13.0-41.70                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-3.13.0-43-generic                        3.13.0-43.72                               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-3.16.0-25-generic                        3.16.0-25.33                               amd64        Linux kernel image for version 3.16.0 on 64 bit x86 SMP
rc  linux-image-extra-3.11.0-12-generic                  3.11.0-12.19                               amd64        Linux kernel extra modules for version 3.11.0 on 64 bit x86 SMP
ii  linux-image-extra-3.11.0-20-generic                  3.11.0-20.35                               amd64        Linux kernel extra modules for version 3.11.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-27-generic                  3.13.0-27.50                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-29-generic                  3.13.0-29.53                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-30-generic                  3.13.0-30.55                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-32-generic                  3.13.0-32.57                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-33-generic                  3.13.0-33.58                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-34-generic                  3.13.0-34.60                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-35-generic                  3.13.0-35.62                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-36-generic                  3.13.0-36.63                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-37-generic                  3.13.0-37.64                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-39-generic                  3.13.0-39.66                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-40-generic                  3.13.0-40.69                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-41-generic                  3.13.0-41.70                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-extra-3.13.0-43-generic                  3.13.0-43.72                               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-extra-3.16.0-25-generic                  3.16.0-25.33                               amd64        Linux kernel extra modules for version 3.16.0 on 64 bit x86 SMP

Hors ligne

#12 Le 15/06/2015, à 21:56

tiramiseb

Re : [Résolu]Kernel driver not installed (rc=-1908)

OK, tu as donc un vieux kernel d'avant-guerre et tu n'avais pas les headers correspondant.

Dans la mesure où, par défaut, ces choses-là sont correctement installées, j'imagine que tu as bidouillé des trucs à ce niveau.

Donc :

sudo apt-get install linux-generic

Ensuite, reboot pour être sur le dernier noyau.

Puis pour vérifier :

uname -a

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Domotego : boutique dédiée à la domotique DIY - https://www.domotego.com
Consultant informatique indépendant - Geek et tout plein d'autres choses

Hors ligne

#13 Le 15/06/2015, à 22:22

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

tiramiseb a écrit :

Puis pour vérifier :

:~$ uname -a
Linux X220 3.19.0-20-generic #20-Ubuntu SMP Fri May 29 10:10:47 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Okay. Tout à l'air de s'être bien passé.

Je suppose que je peux peux passer à l'étape numéro 3 maintenant.

Quelle est la meilleure façon d'installer virtualbox, en passant par la logithèque ?

Hors ligne

#14 Le 15/06/2015, à 22:24

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

tiramiseb a écrit :

Dans la mesure où, par défaut, ces choses-là sont correctement installées, j'imagine que tu as bidouillé des trucs à ce niveau.

C'est en effet embêtant de bidouiller sans trop savoir ce que l'on fait.

J'avoue que j'y vois beaucoup plus clair à présent.

Hors ligne

#15 Le 15/06/2015, à 22:36

tiramiseb

Re : [Résolu]Kernel driver not installed (rc=-1908)

Étape 3:

sudo apt-get install virtualbox virtualbox-dkms

Moi j'aime les lignes de commande smile


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Domotego : boutique dédiée à la domotique DIY - https://www.domotego.com
Consultant informatique indépendant - Geek et tout plein d'autres choses

Hors ligne

#16 Le 15/06/2015, à 23:03

Knoppixx

Re : [Résolu]Kernel driver not installed (rc=-1908)

tiramiseb a écrit :

Étape 3:

sudo apt-get install virtualbox virtualbox-dkms

Tout marche parfaitement maintenant.

tiramiseb a écrit :

Moi j'aime les lignes de commande smile

Je les aime bien aussi, c'est tellement pratique (et probablement indispensable dans de nombreux cas).

Je te remercie mille fois pour ton aide précieuse, et le temps que tu as consacré. J'en serais encore à perdre des heures sur les moteurs de recherche et sur les forum Linux, ou a réinstaller les systèmes (non j'en ai marre d'accumuler ses bêtises à mes bidouilles infructueuses en fait, je l'aurais laissé comme ça au pire, et tant pis pour le confort).

J'inciterais donc mon camarade à penser à te payer une bière. wink

Je passe en résolu. smile

Hors ligne

#17 Le 26/02/2017, à 19:12

vincent71

Re : [Résolu]Kernel driver not installed (rc=-1908)

Bonjour je n'arrive pas a lancer non plus virtualbox désolé du déterrage, mais vu qu'il y était arrivé j'ai essayé pareil et sa ne fonctionne toujours pas, voici quelque screen, merci de votre aide a tous.

http://zupimages.net/up/17/08/3cg3.png

http://zupimages.net/up/17/08/m9mr.png

Hors ligne

#18 Le 27/02/2017, à 14:56

vincent71

Re : [Résolu]Kernel driver not installed (rc=-1908)

Voila c'es bon j'ai reussi a faire fonctionner grace a cqfd93 il fallait juste que je desactive le secure boot du bios. merci.

ici

Hors ligne

#19 Le 27/02/2017, à 15:19

cqfd93

Re : [Résolu]Kernel driver not installed (rc=-1908)

Ah en plus, tu avais squatté une autre discussion avec le même problème que celui que j'ai détaché pour en faire une discussion autonome !!!

Et là, c'est une discussion vieille d'un an et demi et résolue, autant dire que tu n'avais pas beaucoup de chance qu'on te réponde…

Hors ligne