Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/05/2020, à 20:51

TravellingFroggy

[Résolu] Audacity & Budgie

Salut,

Je suis nouveau sur Budgie (20.04), mais sur Ubuntu depuis très longtemps, et j'adore !

Cependant, j'ai un gros souci, j'utilise régulièrement Audacity et il ne me semble pas bien fonctionner :

  • au démarrage la zone d'édition (avec les pistes) est complètement noire il faut retailler la fenêtre pour qu'elle apparaisse normalement : ce n'est pas catastrophique (je pourrais vivre avec) mais cela dénote d'un problème

  • il y a le même souci (zone noire) avec les vues mètres du micro et haut parleur (qui apparaissent aussi en les retaillant)

  • beaucoup plus ennuyeux : impossible d'activer le monitoring du micro - ce qui est une des raisons pour lesquelles j'utilise Audacity !

  • pour finir, lorsqu'on joue un son la piste et le curseur sur la piste sont bizarrement affiché (parfois on ne voit pas le curseur) et il n'est pas toujours possible d'effectuer une sélection

Bref, en l'état pour moi, Audacity est inutilisable et si je ne trouve pas de solution, je vais retourner sur une autre distribution qui fonctionne correctement avec Audacity ... mais cela m'ennuie beaucoup car je pensais (enfin) avoir trouver la distro qui me convient.


Tant qu'on est dans le domaine du son : dans les paramètres sonores, si je choisis un son d'alerte, autre que celui par défaut ... j'entends toujours la goutte d'eau en cas d'alerte et pas le nouveau son que j'ai choisi !

Dernière modification par TravellingFroggy (Le 05/06/2020, à 20:01)


The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#2 Le 28/05/2020, à 21:00

jeyubuntu

Re : [Résolu] Audacity & Budgie

Bonsoir a toi.
Désolé pour Audacity je ne peux pas t'aider je n'utilise pas ce programme néanmoins as tu essayé d'effectuer les mises a jour et de relancer ?
Pour les options sonores tu peux toujours essayer de sélectionner et redémarrer parfois c'est capricieux.


Mon PC est allergique a windows ;)
- Ubuntu budgie 20.04 LTS sur eeepc asus 1005pxd ,2go RAM ,HDD 250go

Hors ligne

#3 Le 28/05/2020, à 22:24

TravellingFroggy

Re : [Résolu] Audacity & Budgie

J'ai installé Audacity par snap et là, pas de souci, il fonctionne bien ... mais est en Anglais !
Ça reste dommage de devoir utiliser une version snap pour des histoires de thèmes et d'affichage ! sad


The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#4 Le 28/05/2020, à 22:59

jeyubuntu

Re : [Résolu] Audacity & Budgie

Peut être que la version deb n'est pas optimiser pour cette distribution ,la dessus il faudrait un aidant un peu plus calé que moi .
A tout hasard si tu veux tenter la version flatpak peut être qu'il y a une version fr ;-)


Mon PC est allergique a windows ;)
- Ubuntu budgie 20.04 LTS sur eeepc asus 1005pxd ,2go RAM ,HDD 250go

Hors ligne

#5 Le 28/05/2020, à 23:47

Guißert

Re : [Résolu] Audacity & Budgie

Bonjour,
Audacity installé depuis les dépôts (version 2.3.3) et tout fonctionne.
Je suis aussi en Budgie 20.04, système de fenêtrage X11, résolution 3840x2160 sans mise à l'échelle, pilote graphie NVidia pour GTX.
Je pense plutôt à un élément de gestion de l'écran (driver, résolutoin,...) qui perturbe l'affichage.

Hors ligne

#6 Le 29/05/2020, à 09:18

diesel

Re : [Résolu] Audacity & Budgie

Bonjour TravellingFroggy,

J'ai audacity sous ubuntu budgie 20.04 et ça fonctionne parfaitement.

Je te suggère la manip suivante :

sudo apt purge audacity

puis

sudo apt install audacity

Amicalement.

Jean-Marie


Je déteste qu'on cherche à me faire passer pour un con, j'y arrive déjà très bien tout seul.
Le mort, il sait pas qu'il est mort ; c'est pour les autres que c'est dur.................... Pour les cons, c'est pareil.

Hors ligne

#7 Le 29/05/2020, à 14:55

TravellingFroggy

Re : [Résolu] Audacity & Budgie

Bizarre, que je sois le seul à avoir le problème. J'avais vu une revue de Budgie, où la personne se plaignait d'un souci d'affichage avec Audacity, du coup, je pensais que c'était généralisé.

Cela vient peut-être du thème que j'utilise : vous utilisez quel thème ?

@diesel: merci, mais j'avais déjà testé de désinstaller et de réinstaller ... sans effet !


The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#8 Le 29/05/2020, à 23:12

Poun64

Re : [Résolu] Audacity & Budgie

Bonsoir TravellingFroggy, bonsoir toul'monde !

J'ai également été confronté à un problème d'affichage sur Audacity, mais c'était sur Xubuntu 20.04 (installation toute neuve).
J'ai cru un moment que c'était lié au bidouillage que je faisais sur le thème "Greybird" de Xubuntu, que j'attribuais aux applications QT comme Audacity.
Mon tuto ici : https://forum.kubuntu-fr.org/viewtopic.php?id=2051634
J'ai mis des semaines à déterminer d'où venait vraiment ce défaut. J'avais ouvert un sujet ici.

En résumé : comme pour Xubuntu 18.04 (qui ne m'a jamais posé problème de cet ordre), j'utilisais ma touche "Compose" en association avec d'autres touches pour écrire automatiquement des adresses mails.
Pour que ça fonctionne, je renseignais l'entrée suivante dans un fichier de configuration :

export GTK_IM_MODULE=xim

Et c'est ça qui cassait mon Audacity.
Les défauts d'affichage étaient les mêmes que toi, sauf que les zones qui s'affichaient mal n'étaient pas noires mais on voyait le bureau en transparence.
En image : https://zupimages.net/up/20/15/7rjc.png
La version des Snap fonctionnait bien, mais bien sûr en anglais...

hmm

Dernière modification par Poun64 (Le 29/05/2020, à 23:35)


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Xubuntu 20.04._LTS + Windows 10 - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Xubuntu 20.04._LTS + Windows 7 - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#9 Le 31/05/2020, à 03:45

Coeur Noir

Re : [Résolu] Audacity & Budgie

Pas de souci non plus sur une UBudgie 20.04 avec Audacity - même pas eu besoin de configurer quoi que ce soit pour le monitoring…

Par contre, faut bien avouer que les appli's en Qt affichent quelques couacs des fois : regarder la hauteur des barres d'outils insuffisante pour lire leur contenu ( justement là où on choisit la source d'enregistrement par exemple… ) :
audacity.png
On verra bien par là → https://discourse.ubuntubudgie.org/t/au … tools/3703 → si quelqu'un a une idée.

Dernière modification par Coeur Noir (Le 31/05/2020, à 03:59)


DébuterDocBien rédigerRetour commandeInsérer image | mes albums <>

Hors ligne

#10 Le 31/05/2020, à 07:15

diesel

Re : [Résolu] Audacity & Budgie

Non, je n'ai pas d'idée.

Cependant, si on laisse la souris dessus, on obtient une fenêtre popup avec le contenu "en cours", et si on clique, on a une liste de choix parfaitement lisible, elle.

Amicalement.

Jean-Marie


Je déteste qu'on cherche à me faire passer pour un con, j'y arrive déjà très bien tout seul.
Le mort, il sait pas qu'il est mort ; c'est pour les autres que c'est dur.................... Pour les cons, c'est pareil.

Hors ligne

#11 Le 31/05/2020, à 19:35

TravellingFroggy

Re : [Résolu] Audacity & Budgie

Désolé, effectivement c'est un problème de profil : avec un profil d'utilisateur vierge : c'est presque bon ... comme Coeur Noir j'ai les boites déroulantes qui sont pas très visible mais cela doit pouvoir s'arranger en changeant de thème.
Désolé de vous avoir fait perdre votre temps, je croyais avoir vérifié Audacity avec un profil vierge mais apparemment pas.

Je posterai de nouveau si j'ai plus d'infos à propos d'un thème pour visualiser les listes déroulantes correctement.


The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#12 Le 31/05/2020, à 22:45

Coeur Noir

Re : [Résolu] Audacity & Budgie

Et puis j'ai dit une ânerie, c'est pas en Qt Audacity, c'est en WxWidgets et GTK.

https://manual.audacityteam.org/man/themes.html & https://wiki.audacityteam.org/wiki/Theming_HowTo pour les aventuriers.

Dernière modification par Coeur Noir (Le 31/05/2020, à 22:53)


DébuterDocBien rédigerRetour commandeInsérer image | mes albums <>

Hors ligne

#13 Le 01/06/2020, à 17:47

Poun64

Re : [Résolu] Audacity & Budgie

Coeur Noir a écrit :

Et puis j'ai dit une ânerie, c'est pas en Qt Audacity, c'est en WxWidgets et GTK...

Oui, mais non... smile !
Sur une installation neuve de Xubuntu 20.04, en faisant :

sudo apt install audacity

...j'ai pourtant noté qu'il y avait des dépendances Qt5 qui s'installaient...
J'avais même enregistré la liste des dépendances qui s'installaient pour essayer de déterminer celles qui par la suite cassaient son affichage...

Dernière modification par Poun64 (Le 01/06/2020, à 17:49)


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Xubuntu 20.04._LTS + Windows 10 - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Xubuntu 20.04._LTS + Windows 7 - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#14 Le 03/06/2020, à 03:41

TravellingFroggy

Re : [Résolu] Audacity & Budgie

J'ai fait quelques tests, si on change la valeur dans Paramètres du Bureau Budgie => Style => Widgets pour Arc ou vimix-laptop, on pourra voir l'ensemble du contenu de la liste déroulante (au moins en hauteur).

Par contre, j'ai toujours des soucis d'affichage et je ne sais pas ce qu'il faut réinitialiser : j'ai remplacé tout .config, j'ai supprimé les dossiers .gtk-? et j'ai toujours les même problèmes d'affichage tel que décrit dans le post #1. Si je change le thème dans les préférences d'Audacity, on dirait que ça s'arrange mais la zone des pistes ne se refraichit pas et il est impossible de sélectionner dans cette zone. Avec un profil vierge, je n'ai pas tous ces problèmes, c'est donc bien un problème de configuration ... mais je ne sais pas quoi changer.

Dernière modification par TravellingFroggy (Le 03/06/2020, à 03:42)


The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#15 Le 03/06/2020, à 04:19

Poun64

Re : [Résolu] Audacity & Budgie

Dans ta distribution, as-tu un fichier caché nommé ".profile" ?
Sous Xubuntu il est dans /home/nom_du_user/
Édite-le et poste son contenu pour voir...

Dernière modification par Poun64 (Le 03/06/2020, à 04:21)


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Xubuntu 20.04._LTS + Windows 10 - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Xubuntu 20.04._LTS + Windows 7 - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#16 Le 03/06/2020, à 11:34

TravellingFroggy

Re : [Résolu] Audacity & Budgie

Salut Poun64,

Forcement, j'ai un fichier .profile, c'est un fichier standard de shell Unix.
Le mien est tout ce qu'il y a de plus standard et je ne pense pas que cela soit là-dedans qu'on trouvera une solution mais merci quand même.

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
	. "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/Bin" ] ; then
    PATH="$HOME/Bin:$PATH"
fi

The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#17 Le 03/06/2020, à 15:29

Poun64

Re : [Résolu] Audacity & Budgie

Effectivement, il est resté à la configuration de base.
Je ne faisais que réagir à ce que tu écrivais au dessus, à savoir :

TravellingFroggy a écrit :

Avec un profil vierge, je n'ai pas tous ces problèmes, c'est donc bien un problème de configuration... mais je ne sais pas quoi changer.

C'est dans celui-là que venaient se loger des instructions particulières pour la prise en compte de mes paramètres personnalisés.
Actuellement, j'y ai ajouté une ligne concernant "Xdotool" et j'y ai dû retirer celle qui faisait fonctionner la touche "Compose" mai qui cassait l'affichage d'Audacity...
A tout hasard, que contient chez-toi le fichier "/etc/profile" ?


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Xubuntu 20.04._LTS + Windows 10 - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Xubuntu 20.04._LTS + Windows 7 - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#18 Le 03/06/2020, à 15:45

TravellingFroggy

Re : [Résolu] Audacity & Budgie

rien que du classique : je n'y ai pas touché.

# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).

if [ "${PS1-}" ]; then
  if [ "${BASH-}" ] && [ "$BASH" != "/bin/sh" ]; then
    # The file bash.bashrc already sets the default PS1.
    # PS1='\h:\w\$ '
    if [ -f /etc/bash.bashrc ]; then
      . /etc/bash.bashrc
    fi
  else
    if [ "`id -u`" -eq 0 ]; then
      PS1='# '
    else
      PS1='$ '
    fi
  fi
fi

if [ -d /etc/profile.d ]; then
  for i in /etc/profile.d/*.sh; do
    if [ -r $i ]; then
      . $i
    fi
  done
  unset i
fi

The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#19 Le 03/06/2020, à 16:09

Poun64

Re : [Résolu] Audacity & Budgie

Exact, il est également dans sa version initiale...

Je n'ose pas te proposer ma méthode pour trouver le(s) coupable(s) :
1- Repartir sur une installation neuve pour test
2- Faire toutes les mises à jour disponibles
3- Installer Audacity
4- Redémarrer, tester Audacity et si ça marche créer une image des partitions / et /home
5- installer l'une après l'autre les applications avec les configurations qui te conviennent et à chaque fois revenir à l'étape 4.

Je sais, c'est barbant et ça prend du temps mais c'est avec cette méthode empirique que j'ai fini par trouver le coupable qui cassait mon Audacity...


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Xubuntu 20.04._LTS + Windows 10 - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Xubuntu 20.04._LTS + Windows 7 - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#20 Le 03/06/2020, à 16:42

TravellingFroggy

Re : [Résolu] Audacity & Budgie

oui, c'est ce que je pensais faire aussi


The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#21 Le 05/06/2020, à 20:00

TravellingFroggy

Re : [Résolu] Audacity & Budgie

J'ai fini par trouver le coupable : cela venait bien d'un fichier de configuration ... et forcemment, c'était le dernier ! tongue (Murphy n'est jamais très loin)
Donc j'avais un fichier .xinputrc qui contenait une seule ligne non commentée :

run_im xim

C'était donc bien un souci avec xim, comme indiqué par Poun64 au #8 mais cela se chargeait différemment !
Je me traîne ce fichier depuis 2016 ... mais à priori, il ne me sert pas : je l'ai donc renommé et Audacity s'exécute maintenant correctement ! big_smile

Voilà, pour le moment tous mes petits soucis avec Budgie sont résolus ... ou presque : je vais pouvoir en profiter maintenant !

Merci pour votre aide.

Dernière modification par TravellingFroggy (Le 05/06/2020, à 20:02)


The Computing Froggy
Ubuntero depuis 6.06                   Vive Lubuntu, Bodhi et elementaryOS pour faire renaître les PC un peu ancien.
____________________
Mistr@l Consulting : Le Département Informatique des TPE/PME/PMI et artisans, commerçants et professions libérales

Hors ligne

#22 Le 05/06/2020, à 20:55

Poun64

Re : [Résolu] Audacity & Budgie

Bonsoir TravellingFroggy, bonsoir toul'monde !

C'est sympa d'avoir expliqué le "pourquoi du comment" t'as résolu ton problème smile !

Je viens de vérifier chez-moi :
Sur mon Xubuntu 18.04.4, j'ai un fichier ".xinputrc" mais il contient :

# im-config(8) generated on Sun, 09 Sep 2018 01:26:03 +0200
run_im none
# im-config signature: 8d8f5505a9cf85c5ce092f5918c03a32  -

Et il est absent sur Xubuntu 20.04...


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Xubuntu 20.04._LTS + Windows 10 - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Xubuntu 20.04._LTS + Windows 7 - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#23 Le 07/06/2020, à 23:20

Coeur Noir

Re : [Résolu] Audacity & Budgie

https://github.com/diddlesnaps/audacity/issues/16

→ le snap audacity beta utilise dorénavant la langue de votre choix, et envoie bien son menu vers l'applet global-menu si active.


DébuterDocBien rédigerRetour commandeInsérer image | mes albums <>

Hors ligne

#24 Le 08/06/2020, à 19:02

Coeur Noir

Re : [Résolu] Audacity & Budgie

Et pour ce qui est du thème, si vous utilisez snap sachez dorénavant que toutes les variantes de couleur du thème ADAPTA existent en snap et sont donc applicables :
snap-explorers-better.png
Ici il manque les icônes, souci réglé depuis voir https://forum.ubuntu-fr.org/viewtopic.php?id=2053913

Dernière modification par Coeur Noir (Le 08/06/2020, à 20:29)


DébuterDocBien rédigerRetour commandeInsérer image | mes albums <>

Hors ligne