Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/03/2023, à 20:06

Onyx-974

installation de nodejs

bonjour a tous

lors de l'installation de nodejs pour ironfish

se message est apparue, est y en très peu de connaissance dans ubuntu.

pouvez vous m' aider ?

"dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/nodejs_18.15.0-deb-1nodesource1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"

Hors ligne

#2 Le 18/03/2023, à 20:14

sputnick

Re : installation de nodejs

La manière d'installer NodeJS est de faire:

au préalable:

sudo dpkg -r nodejs

et

sudo apt purge nodejs

Ensuite:

sudo apt update && sudo apt upgrade

Si il y a encore des erreurs:

sudo apt -f install

Pour installer proprement une version récente de NodeJS:

curl -fsSL https://deb.nodesource.com/setup_18.x | sudo -E bash - && sudo apt-get install -y nodejs

La version Ubuntu date de Mathusalem

Dernière modification par sputnick (Le 18/03/2023, à 21:36)


On ne peut pas mettre d'array dans un string!
https://sputnick.fr/

Hors ligne

#3 Le 18/03/2023, à 20:30

Onyx-974

Re : installation de nodejs

je viens de faire toutes les codes cites, le même message d'erreur.


"sudo dpkg -r nodejs
dpkg: avertissement: requête ignorée : suppression de nodejs, qui n'est pas installé
onyx-1@onyx1-H61H2-M2:~$ sudo apt purge nodejs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Le paquet « nodejs » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libass9 libbs2b0 libflashrom1 libflite1 libftdi1-2 libgstreamer-plugins-bad1.0-0 liblilv-0-0 libllvm13 libmysofa1 libpostproc55 librubberband2 libserd-0-0
  libsord-0-0 libsratom-0-0 libva-wayland2 libvidstab1.1 libzimg2 pocketsphinx-en-us
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
onyx-1@onyx1-H61H2-M2:~$ apt update && apt upgrade
Lecture des listes de paquets... Fait
E: Impossible d'ouvrir le fichier verrou /var/lib/apt/lists/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire /var/lib/apt/lists/
W: Problème de suppression du lien /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission non accordée)
W: Problème de suppression du lien /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission non accordée)
onyx-1@onyx1-H61H2-M2:~$ sudo apt -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libass9 libbs2b0 libflashrom1 libflite1 libftdi1-2 libgstreamer-plugins-bad1.0-0 liblilv-0-0 libllvm13 libmysofa1 libpostproc55 librubberband2 libserd-0-0
  libsord-0-0 libsratom-0-0 libva-wayland2 libvidstab1.1 libzimg2 pocketsphinx-en-us
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
onyx-1@onyx1-H61H2-M2:~$ curl -fsSL https://deb.nodesource.com/setup_19.x | sudo -E bash - && sudo apt-get install -y nodejs

## Installing the NodeSource Node.js 19.x repo...


## Populating apt-get cache...

+ apt-get update
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Atteint :2 http://fr.archive.ubuntu.com/ubuntu jammy InRelease                                                                                                                                                   
Atteint :3 http://fr.archive.ubuntu.com/ubuntu jammy-updates InRelease                                                                                                                                           
Atteint :4 http://fr.archive.ubuntu.com/ubuntu jammy-backports InRelease                                                                                                                                         
Atteint :5 https://cloud.r-project.org/bin/linux/ubuntu jammy-cran40/ InRelease                                                                                                                                   
Atteint :6 https://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                               
Réception de :7 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                                                                                                                               
Atteint :8 https://download.docker.com/linux/ubuntu jammy InRelease                                                                                                                                               
Atteint :9 https://deb.nodesource.com/node_18.x jammy InRelease                                                                                                                                                   
Atteint :10 https://ppa.launchpadcontent.net/c2d4u. … .0+/ubuntu jammy InRelease                                                                                                                         
Atteint :11 https://apt.runonflux.io jammy InRelease                                                                                                       
110 ko réceptionnés en 2s (72,9 ko/s)
Lecture des listes de paquets... Fait
W: https://apt.runonflux.io/dists/jammy/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

## Confirming "jammy" is supported...

+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_19.x/di … my/Release'

## Adding the NodeSource signing key to your keyring...

+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | gpg --dearmor | tee /usr/share/keyrings/nodesource.gpg >/dev/null
gpg: Attention : le propriétaire du répertoire personnel « /home/onyx-1/.gnupg »
            n'est pas sûr

## Creating apt sources list file for the NodeSource Node.js 19.x repo...

+ echo 'deb [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_19.x jammy main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_19.x jammy main' >> /etc/apt/sources.list.d/nodesource.list

## Running `apt-get update` for you...

+ apt-get update
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Atteint :2 http://fr.archive.ubuntu.com/ubuntu jammy InRelease                                                                                                                                                   
Atteint :3 http://fr.archive.ubuntu.com/ubuntu jammy-updates InRelease                                                                                                                                           
Atteint :4 http://fr.archive.ubuntu.com/ubuntu jammy-backports InRelease                                                                                                                                         
Réception de :5 https://deb.nodesource.com/node_19.x jammy InRelease [4563 B]                                                                                                                                   
Atteint :6 https://download.docker.com/linux/ubuntu jammy InRelease                                                                                                                                               
Atteint :7 https://ppa.launchpadcontent.net/c2d4u. … .0+/ubuntu jammy InRelease                                                                                                                           
Atteint :8 https://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                               
Réception de :9 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                                                                                                                               
Atteint :10 https://cloud.r-project.org/bin/linux/ubuntu jammy-cran40/ InRelease                                                                                                                                 
Atteint :11 https://apt.runonflux.io jammy InRelease                                                                                                                     
Réception de :12 https://deb.nodesource.com/node_19.x jammy/main amd64 Packages [778 B]
116 ko réceptionnés en 2s (72,2 ko/s)
Lecture des listes de paquets... Fait
W: https://apt.runonflux.io/dists/jammy/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

## Run `sudo apt-get install -y nodejs` to install Node.js 19.x and npm
## You may also need development tools to build native addons:
     sudo apt-get install gcc g++ make
## To install the Yarn package manager, run:
     curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | gpg --dearmor | sudo tee /usr/share/keyrings/yarnkey.gpg >/dev/null
     echo "deb [signed-by=/usr/share/keyrings/yarnkey.gpg] https://dl.yarnpkg.com/debian stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
     sudo apt-get update && sudo apt-get install yarn


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libass9 libbs2b0 libflashrom1 libflite1 libftdi1-2 libgstreamer-plugins-bad1.0-0 liblilv-0-0 libllvm13 libmysofa1 libpostproc55 librubberband2 libserd-0-0
  libsord-0-0 libsratom-0-0 libva-wayland2 libvidstab1.1 libzimg2 pocketsphinx-en-us
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  nodejs
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 29,3 Mo dans les archives.
Après cette opération, 189 Mo d'espace disque supplémentaires seront utilisés.
Réception de :1 https://deb.nodesource.com/node_19.x jammy/main amd64 nodejs amd64 19.8.1-deb-1nodesource1 [29,3 MB]
29,3 Mo réceptionnés en 3s (9894 ko/s)
Sélection du paquet nodejs précédemment désélectionné.
(Lecture de la base de données... 281510 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../nodejs_19.8.1-deb-1nodesource1_amd64.deb ...
Dépaquetage de nodejs (19.8.1-deb-1nodesource1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/include/node/common.gypi », qui appartient aussi au paquet libnode-dev 12.22.9~dfsg-1ubuntu3
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"

Hors ligne

#4 Le 18/03/2023, à 20:32

sputnick

Re : installation de nodejs

C'est:

sudo apt update && sudo apt upgrade

Essaye de comprendre ce que tu fait wink

Et utilise les balises code en sélectionnant tout puis en cliquant dans l'éditeur sur le bouton bleu <>

Dernière modification par sputnick (Le 18/03/2023, à 23:01)


On ne peut pas mettre d'array dans un string!
https://sputnick.fr/

Hors ligne

#5 Le 18/03/2023, à 20:38

Onyx-974

Re : installation de nodejs

désolé
même avec la bonne commande,
<<dpkg: erreur de traitement de l'archive /var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/include/node/common.gypi », qui appartient aussi au paquet libnode-dev 12.22.9~dfsg-1ubuntu3
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)>>

Hors ligne

#6 Le 18/03/2023, à 20:51

sputnick

Re : installation de nodejs

sudo dpkg -r libnode-dev
sudo apt purge libnode-dev
sudo apt update && sudo apt upgrade

On ne peut pas mettre d'array dans un string!
https://sputnick.fr/

Hors ligne

#7 Le 18/03/2023, à 21:19

Onyx-974

Re : installation de nodejs

ok s'est bon merci
si jamais je souhait avoir une version interieur la dernier
comment faire stp ?

Hors ligne

#8 Le 18/03/2023, à 21:32

sputnick

Re : installation de nodejs

Moi pas parler langue vous.

Mais pardon, pour Ubuntu, la version recommandée est:

sudo rm -f /etc/apt/sources.list.d/nodesource.list
apt purge nodejs
curl -fsSL https://deb.nodesource.com/setup_18.x | sudo -E bash - && sudo apt-get install -y nodejs

Dernière modification par sputnick (Le 18/03/2023, à 21:35)


On ne peut pas mettre d'array dans un string!
https://sputnick.fr/

Hors ligne

#9 Le 18/03/2023, à 21:37

Onyx-974

Re : installation de nodejs

merci a toi
j'ai oublie un mots désolé
merci de ton aide

Hors ligne

#10 Le 18/03/2023, à 21:42

xubu1957

Re : installation de nodejs

Bonjour,

Pour ajouter toi-même les balises code à ton message #3 :

  • Cliquer sur  le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

moko138 a écrit :

1) Les balises-code sont les < > (crochets bleus) de la barre de mise en forme.
Balisesmoko138.jpg
_ _ _

3) /!\  Si vous avez plusieurs retours à donner, séparez-les bien (toujours pour la lisibilité) :

comme
cela.

Comme demandé dans le premier message du tutoriel Retour utilisable de commande

"sudo dpkg -r nodejs
dpkg: avertissement: requête ignorée : suppression de nodejs, qui n'est pas installé
onyx-1@onyx1-H61H2-M2:~$ sudo apt purge nodejs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Le paquet « nodejs » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libass9 libbs2b0 libflashrom1 libflite1 libftdi1-2 libgstreamer-plugins-bad1.0-0 liblilv-0-0 libllvm13 libmysofa1 libpostproc55 librubberband2 libserd-0-0
  libsord-0-0 libsratom-0-0 libva-wayland2 libvidstab1.1 libzimg2 pocketsphinx-en-us
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
onyx-1@onyx1-H61H2-M2:~$ apt update && apt upgrade
Lecture des listes de paquets... Fait
E: Impossible d'ouvrir le fichier verrou /var/lib/apt/lists/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire /var/lib/apt/lists/
W: Problème de suppression du lien /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission non accordée)
W: Problème de suppression du lien /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission non accordée)
onyx-1@onyx1-H61H2-M2:~$ sudo apt -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libass9 libbs2b0 libflashrom1 libflite1 libftdi1-2 libgstreamer-plugins-bad1.0-0 liblilv-0-0 libllvm13 libmysofa1 libpostproc55 librubberband2 libserd-0-0
  libsord-0-0 libsratom-0-0 libva-wayland2 libvidstab1.1 libzimg2 pocketsphinx-en-us
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
onyx-1@onyx1-H61H2-M2:~$ curl -fsSL https://deb.nodesource.com/setup_19.x | sudo -E bash - && sudo apt-get install -y nodejs

## Installing the NodeSource Node.js 19.x repo...


## Populating apt-get cache...

+ apt-get update
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Atteint :2 http://fr.archive.ubuntu.com/ubuntu jammy InRelease                                                                                                                                                   
Atteint :3 http://fr.archive.ubuntu.com/ubuntu jammy-updates InRelease                                                                                                                                           
Atteint :4 http://fr.archive.ubuntu.com/ubuntu jammy-backports InRelease                                                                                                                                         
Atteint :5 https://cloud.r-project.org/bin/linux/ubuntu jammy-cran40/ InRelease                                                                                                                                   
Atteint :6 https://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                               
Réception de :7 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                                                                                                                               
Atteint :8 https://download.docker.com/linux/ubuntu jammy InRelease                                                                                                                                               
Atteint :9 https://deb.nodesource.com/node_18.x jammy InRelease                                                                                                                                                   
Atteint :10 https://ppa.launchpadcontent.net/c2d4u. … .0+/ubuntu jammy InRelease                                                                                                                         
Atteint :11 https://apt.runonflux.io jammy InRelease                                                                                                       
110 ko réceptionnés en 2s (72,9 ko/s)
Lecture des listes de paquets... Fait
W: https://apt.runonflux.io/dists/jammy/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

## Confirming "jammy" is supported...

+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_19.x/di … my/Release'

## Adding the NodeSource signing key to your keyring...

+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | gpg --dearmor | tee /usr/share/keyrings/nodesource.gpg >/dev/null
gpg: Attention : le propriétaire du répertoire personnel « /home/onyx-1/.gnupg »
            n'est pas sûr

## Creating apt sources list file for the NodeSource Node.js 19.x repo...

+ echo 'deb [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_19.x jammy main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_19.x jammy main' >> /etc/apt/sources.list.d/nodesource.list

## Running `apt-get update` for you...

+ apt-get update
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Réception de :1 file:/var/cuda-repo-ubuntu2204-12-0-local  InRelease [1575 B]
Atteint :2 http://fr.archive.ubuntu.com/ubuntu jammy InRelease                                                                                                                                                   
Atteint :3 http://fr.archive.ubuntu.com/ubuntu jammy-updates InRelease                                                                                                                                           
Atteint :4 http://fr.archive.ubuntu.com/ubuntu jammy-backports InRelease                                                                                                                                         
Réception de :5 https://deb.nodesource.com/node_19.x jammy InRelease [4563 B]                                                                                                                                   
Atteint :6 https://download.docker.com/linux/ubuntu jammy InRelease                                                                                                                                               
Atteint :7 https://ppa.launchpadcontent.net/c2d4u. … .0+/ubuntu jammy InRelease                                                                                                                           
Atteint :8 https://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                               
Réception de :9 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                                                                                                                               
Atteint :10 https://cloud.r-project.org/bin/linux/ubuntu jammy-cran40/ InRelease                                                                                                                                 
Atteint :11 https://apt.runonflux.io jammy InRelease                                                                                                                     
Réception de :12 https://deb.nodesource.com/node_19.x jammy/main amd64 Packages [778 B]
116 ko réceptionnés en 2s (72,2 ko/s)
Lecture des listes de paquets... Fait
W: https://apt.runonflux.io/dists/jammy/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

## Run `sudo apt-get install -y nodejs` to install Node.js 19.x and npm
## You may also need development tools to build native addons:
     sudo apt-get install gcc g++ make
## To install the Yarn package manager, run:
     curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | gpg --dearmor | sudo tee /usr/share/keyrings/yarnkey.gpg >/dev/null
     echo "deb [signed-by=/usr/share/keyrings/yarnkey.gpg] https://dl.yarnpkg.com/debian stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
     sudo apt-get update && sudo apt-get install yarn


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi libass9 libbs2b0 libflashrom1 libflite1 libftdi1-2 libgstreamer-plugins-bad1.0-0 liblilv-0-0 libllvm13 libmysofa1 libpostproc55 librubberband2 libserd-0-0
  libsord-0-0 libsratom-0-0 libva-wayland2 libvidstab1.1 libzimg2 pocketsphinx-en-us
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  nodejs
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 29,3 Mo dans les archives.
Après cette opération, 189 Mo d'espace disque supplémentaires seront utilisés.
Réception de :1 https://deb.nodesource.com/node_19.x jammy/main amd64 nodejs amd64 19.8.1-deb-1nodesource1 [29,3 MB]
29,3 Mo réceptionnés en 3s (9894 ko/s)
Sélection du paquet nodejs précédemment désélectionné.
(Lecture de la base de données... 281510 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../nodejs_19.8.1-deb-1nodesource1_amd64.deb ...
Dépaquetage de nodejs (19.8.1-deb-1nodesource1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/include/node/common.gypi », qui appartient aussi au paquet libnode-dev 12.22.9~dfsg-1ubuntu3
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"

et le #5 :

<<dpkg: erreur de traitement de l'archive /var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb (--unpack) :
tentative de remplacement de « /usr/include/node/common.gypi », qui appartient aussi au paquet libnode-dev 12.22.9~dfsg-1ubuntu3
dpkg-deb: erreur: le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/nodejs_19.8.1-deb-1nodesource1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)>>

Dernière modification par xubu1957 (Le 18/03/2023, à 22:21)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#11 Le 18/03/2023, à 21:48

Onyx-974

Re : installation de nodejs

ok merci

Hors ligne

#12 Le 18/03/2023, à 22:06

xubu1957

Re : installation de nodejs

Le dire c'est bien, le faire c'est mieux ! tongue

Lecture conseillée > memento des balises code.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#13 Le 18/03/2023, à 22:59

Onyx-974

Re : installation de nodejs

merci

Hors ligne

#14 Le 18/03/2023, à 23:26

krodelabestiole

Re : installation de nodejs

d'une manière générale je conseille plutôt nvm pour installer nodejs. ça permet de gérer facilement les différentes versions.

En ligne