Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 17/11/2022, à 19:14

inbox

[Résolu] x509 certificate signed by unknown authority Zscaler

Salut,

J'ai installé Ubuntu dans une VM, sur mon PC du boulot sous Windows. Lorsque je tente de mettre les Snaps à jour, j'obtiens l'erreur x509 certificate signed by unknown authority.

Après recherche, j'ai trouvé comment régler ce problème. Extraire du navigateur (Edge, Firefox, Chrome) sous Windows, le certificat root de Zscaler.
Dans Firefox, cela donne : Paramètres => Afficher les certificats => Autorités => Zscaler Root CA => Exporter.

Déplacer le certificat enregistré, dans le bon dossier :

sudo mv Téléchargements/ZscalerRootCA.crt /usr/share/ca-certificates

Adapter le chemin selon l'endroit ou vous avez stocké le certificat.
Prendre le certificat en compte niveau système :

sudo dpkg-reconfigure ca-certificates

=> cocher ZscalerRootCA.crt

Redémarrer.

Suite à cette ajout, la mise à jour des Snaps, fonctionne normalement.

Il semble que cela fonctionne aussi pour Docker.

A+

Dernière modification par inbox (Le 19/11/2022, à 01:39)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#2 Le 25/11/2022, à 20:51

alex2423

Re : [Résolu] x509 certificate signed by unknown authority Zscaler

ZScaler, sauf erreur de ma part, c'est un vpn d'entreprise.
Je suis un peu surpris que l'ajout du certificat se fait au niveau du navigateur et non pas au niveau du système, tu m'apprends quelque chose.

Si quelqu'un passe dans le coin, je serai curieux de savoir à quoi cela correspond

Hors ligne

#3 Le 26/11/2022, à 00:44

inbox

Re : [Résolu] x509 certificate signed by unknown authority Zscaler

C'est pour cette raison que j'ai posté dans "ubuntu en entreprise".

Au départ, je l'ai ajouté dans Firefox, car je n'arrivai pas à naviguer. Par la suite, j'ai cherché comment faire pour le système entier et j'ai trouvé ce que j'ai indiqué.

Il faudrait que j'essaye de n'ajouter le certificat qu'au niveau système.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne