Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/03/2022, à 09:52

Crestey

[Résolu] PB Accès NAS depuis changement de freebox à boxSFR

Bonjour à tous,
Je suis passé de freebox à redSFR depuis vendredi dernier. J'ai un nas qui fonctionnait bien en NFS avec ma freebox. Et je ne parviens pas à retrouver ce fonctionnement avec la box de sfr.

Je n'avais plus de réponse au ping avec la box sfr. Alors j'ai cru comprendre que pour la box SFR, tout se passe sur des adresses 192.168.1.XXX, et non 192.168.0.XXX
Du coup j'ai changé l'IP de mon NAS de 192.168.0.20 à 192.168.1.10 (les adresses 192.168.1.20 à 192.168.1.100 sont réservées pour le DHCP)
Et maintenant j'ai bien une réponse au ping.

Précédemment, pour faire fonctionner le nas en nfs j'avais renseigné le fichier /etc/systemd/system/mnt-nas1.mount avec

[Unit]
Description=Mount nas1 volume at boot
After=network-online.target

[Mount]
What=192.168.0.20:/mnt/HD_a2
Where=/mnt/nas1
Options=user,rw,nfsvers=3,nolock,proto=tcp,mountproto=tcp
Type=nfs

[Install]
WantedBy=multi-user.target

Ça fonctionnait très bien Mais là ça ne marche plus du tout.
Pourriez-vous m'aider à retrouvé mon fonctionnement NFS avec cette box SFR SVP
Merci, Dominique

EDIT : Quand je lance la ligne de commande de montage correspondante, j'obtiens les messages suivant :

crestey@crestey-Pegatron:~$ sudo mount -t nfs -vvvv 192.168.1.10:/mnt/HD_a2 /mnt/nas1 -o user,rw,nfsvers=3,nolock,proto=tcp,mountproto=tcp
mount.nfs: timeout set for Mon Mar 21 11:42:53 2022
mount.nfs: trying text-based options 'nfsvers=3,nolock,proto=tcp,mountproto=tcp,addr=192.168.1.10'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.10 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=6
mount.nfs: trying 192.168.1.10 prog 100005 vers 3 prot TCP port 1027
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 192.168.1.10:/mnt/HD_a2
crestey@crestey-Pegatron:~$

Dernière modification par Crestey (Le 21/03/2022, à 23:57)


Merci à tous.
Sous Ubuntu/XFCE depuis 2013. Ça fonctionne vraiment très bien.

Hors ligne

#2 Le 21/03/2022, à 18:43

Crestey

Re : [Résolu] PB Accès NAS depuis changement de freebox à boxSFR

C'est résolu. Le problème venait du fichier /etc/exports du nas qui contenait

/mnt/HD_a2 192.168.0.0/24(rw,no_root_squash,no_subtree_check)
/mnt/HD_a4 192.168.0.0/24(rw,no_root_squash,no_subtree_check)
/mnt/HD_b4 192.168.0.0/24(rw,no_root_squash,no_subtree_check)
/mnt/web_page 192.168.0.0/24(rw,no_root_squash,no_subtree_check)

Comme la box SFR travaille sur 192.168.1.X, il faut modifier ce fichier en :

/mnt/HD_a2 192.168.1.0/24(rw,no_root_squash,no_subtree_check)
/mnt/HD_a4 192.168.1.0/24(rw,no_root_squash,no_subtree_check)
/mnt/HD_b4 192.168.1.0/24(rw,no_root_squash,no_subtree_check)
/mnt/web_page 192.168.1.0/24(rw,no_root_squash,no_subtree_check)

Le fichier /etc/systemd/system/mnt-nas1.mount devient aussi

[Unit]
   Description=Mount nas1 volume at boot
[Mount]
   What=192.168.1.10:/mnt/HD_a2
   Where=/mnt/nas1
   Options=user,rw,nfsvers=3,nolock,proto=tcp,mountproto=tcp
   Type=nfs
[Install]
   WantedBy=multi-user.target

Et tout fonctionne

Dernière modification par Crestey (Le 22/03/2022, à 08:02)


Merci à tous.
Sous Ubuntu/XFCE depuis 2013. Ça fonctionne vraiment très bien.

Hors ligne