Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/07/2021, à 21:04

tomawok

Lenovo Legion Y520 ne veut pas démarrer sur ma clé Ubuntu

Salut (et à l'aide),

J'essaie d'installer Ubuntu sur un disque externe mais je n'arrive pas à booter sur ma clé USB (c'est la clé du shop).

Alors j'ai essayé sur l'ordi d'un ami et là tout va bien la clé est reconnue nikel, j'ai pu faire quelques manips et tout fonctionnait bien.

Ensuite j'ai essayé de le faire avec mon ordi qui a un SSD avec Windows dessus et un HDD avec Ubuntu, mais en arrivant dans le BIOS quand je choisis de booter sur ma clé (qui est détectée), mon ordi choisit quand même de booter sur Ubuntu ou sur Windows.

J'ai ensuite retiré les 2 disques et redémarré avec la clé et cette fois ça a marché, il avait pas vraiment le choix de toutes façons. J'ai pu avoir accès à la clé mais c'est très lent.

J'aimerais pouvoir booter sur ma clé sans avoir à débrancher mes disques, j'ai l'impression que mon ordi boote en priorité sur le SSD, et je voudrais changer ça, quelqu'un aurait une idée ?

Merci d'avance smile

(Chocolatine)

Hors ligne

#2 Le 16/07/2021, à 13:51

geole

Re : Lenovo Legion Y520 ne veut pas démarrer sur ma clé Ubuntu

Bonjour.
Il faut aller dans le bios pour dire que booter sur la clé est prioritaire.
Pour cela

https://forum.ubuntu-fr.org/viewtopic.php?id=2021030 a écrit :

- utiliser le bouton spéciale à l’aide d’une pointe, sur la face gauche du portable (à coté du casque/micro) afin de lancer le menu menant au bios. Dans mon cas l’ordi est vide os autre que freedos pour ceux ayant windows déjà installer il faudra reduire la partition d’installation et donc ne pas réinstaller windows (voir doc)
On accède au bios afin de regler les différents paramètres nécessaire à une installation
    - désactiver fastboot, secure boot
    - désactiver intel RST au profit de AHCI
        - il faut vérifier que l'uefi est activé en lieu et place de legacy
    - save and exit
Dans mon cas, les paramètres étaient déjà bien cochés

- brancher le media d’installation, redémarrer à l’aide d’une pointe et sélectionner boot menu, démarrer sur la clé

Dernière modification par geole (Le 16/07/2021, à 13:53)

Hors ligne

#3 Le 16/07/2021, à 20:38

tomawok

Re : Lenovo Legion Y520 ne veut pas démarrer sur ma clé Ubuntu

Salut, et merci pour ta réponse smile

J'ai bien essayé cette méthode :

  • fastboot & secure boot Disabled

  • AHCI plutôt que Intel RST

  • UEFI activé plutôt que Legacy

mais lorsque je déplace ma clé pour la mettre en prioritaire cela ne se sauvegarde pas après un redémarrage.
J'ai ensuite testé en changeant mon ordre de priorité :

  • Clé - Windows - Linux
    puis :

  • Clé - Linux - Windows

Tout se passe comme si la clé n'était pas reconnue, (sauf le fait que mon ordi attend entre 1min et 3min avant de lancer soit Windows, soit Linux (en fonction de l'ordre ci-dessus))
J'ai ensuite essayé en mode Legacy et là ça fonctionne, mon ordi boote sur ma clé si je lui demande mais est super lent hmm

Une idée de ce qu'il se passe ?

Hors ligne

#4 Le 17/07/2021, à 09:04

geole

Re : Lenovo Legion Y520 ne veut pas démarrer sur ma clé Ubuntu

Bonjour.
Le boot sur clé USB est naturellement lent.
As-tu pu installer?

Hors ligne