Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/06/2021, à 10:53

josuah

Header security malformed

Bonjour,
Je vous expose un problème qui me contraint à revenir sous W10 (j'avais abandonné Microsoft depuis le feu XP /!\), faute de solution pour le moment face à un comportement bizarre de ma machine et que je ne m'explique pas  (-_*)
J'évoluais tranquillement sous Lubuntu 18.04 depuis un an sans problème et tout d'un coup au boot, j'ai eu le message cité en sujet. Je n'avais pas accès au grub ni quoi que ce soit... J'avais d'ailleurs paramétré Lubuntu pour ne recevoir que les MAJS de sécu et rien d'autre afin d'avoir un comportement aussi stable que possible, un peu à la Debian quoi. Je n'avais que les Kernels proposés par Canonical.
J'ai tenté de réinstaller Lubuntu, 18.04 sans succès, le même message faisait suite... J'ai essayé Debian stable, l'installation échoue à grub-dummy.
Les versions en live fonctionnent super bien (Lubuntu 18.04, Debian 10), mon matos est reconnu...
J'ai essayé la 20.04 qui conduit à ce message :https://itectec.com/ubuntu/ubuntu-cant-mount-iso-file-as-loop-device-error-failed-to-setup-loop-device/
Visiblement, les kernels de Debian 10 ou Lubuntu 18.04 ont un problème avec l'efi sur mon pc. Ma machine n'a subi aucune maj de BIOS ou quoi que ce soit. Que je désactive l'efi ou pas, ça ne change rien. , Machine ASUS E403NA

Ma question est : Pourquoi ce problème alors que l'installation initiale sous la 18.04 s'est bien passée avec l'efi actif, il y a un an ? J'utilise Gnu/Linux depuis pas mal d'année mais là, j'avoue ne rien y comprendre.
Serait-il judicieux de partitionner manuellement car je m'en suis référé au partionnement automatique  à chaque fois?  Avec une partition EFI de 200 MO ?
Quelles sont vos idées, pistes ?
Sous W10, pas de problème de boot, enfin si, à la sortie de mise en veille, j'ai du désactiver le boot rapide car bogge avec le pilote de la CG, mais on s'en fout   :-D
Je vous remercie.

Dernière modification par josuah (Le 22/06/2021, à 10:56)


"Car j'ai de chaque chose extrait la quintessence. Tu m'as donné ta boue et j'en ai fait de l'or" -- Baudelaire

Hors ligne

#2 Le 22/06/2021, à 17:59

malbo

Re : Header security malformed

Bonjour,
Il y a des explications sur le problème dans ce fil : https://forum.ubuntu-fr.org/viewtopic.php?id=2061442
Le problème est dû à la partition EFI qui est pleine à 100 %. Quand on essaie de réinstaller, la partition EFI n'est pas vidée (j'en parle dans le post #41 du fil), ça explique pourquoi tu as retrouvé le même message après réinstallation de Lubuntu, 18.04.
EDIT : ce serait utile que tu fasses un Boot-info depuis une session live de Lubuntu 18.04 et que tu donnes l'URL de ce Boot-info dans ta réponse afin qu'on puisse vérifier qu'il s'agit bien de ça.

Dernière modification par malbo (Le 22/06/2021, à 18:03)

Hors ligne

#3 Le 22/06/2021, à 19:28

josuah

Re : Header security malformed

Merci malbo pour ta réponse qui m'aiguille merveilleusement bien sur l'origine de mon problème.
Je vais réinstaller ce weekend en partitionnant manuellement et te posterai un boot-info.
Mais avant, j'aimerais un complément de réponse pour faire les bons choix:
- Si je désactive l'EFI dans le bios avant l'installation, est-ce que cette partition sera quand même créée  ?
- Est-ce que ce sont les majs du kernel sur qui ont rempli la partition EFI en un an ?
Car mon problème est apparu peu de temps après une maj qui contenait un kernel supérieur. Je trouve dommage que cette partition passe au oubliette lors d'une installation "classique".

Merci pour tes conseils.

Dernière modification par josuah (Le 22/06/2021, à 19:30)


"Car j'ai de chaque chose extrait la quintessence. Tu m'as donné ta boue et j'en ai fait de l'or" -- Baudelaire

Hors ligne

#4 Le 22/06/2021, à 19:42

malbo

Re : Header security malformed

Je ne sais pas répondre avec certitude à tes questions. Fais ce que j'ai demandé dans l'EDIT du post #2 pour le Boot-info, et je pourrai être plus précis.

Hors ligne