Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 29/05/2006, à 22:58

domak

Problème avec fglrx

Salut,

Je suis sous Dapper et comme chaque jour, je télécharge mon lot de patchs.
Aujourd'hui, le driver proprio ATI a été mis à jour (j'ai une radeon 9200, oui je sais désolé...).
Dès que je tente de lancer une appli qui utilise open GL j'ai une palanquée de messages comme ci-dessous:

[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS
[fglrx] API ERROR: could not register entrypoint for SelectTextureTransformSGIS
[fglrx] API ERROR: could not register entrypoint for ClientActiveVertexStreamATI[fglrx] API ERROR: could not register entrypoint for VertexBlendEnviATI
[fglrx] API ERROR: could not register entrypoint for VertexBlendEnvfATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2sATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2svATI
...

Y'en a-t-il qui ont le même souci ? Je n'ai rien trouvé sur les forums en anglais alors j'hésite avant de faire une ouverture de bug.

Hors ligne

#2 Le 29/05/2006, à 23:20

NicoA380

Re : Problème avec fglrx

Tu as redémarré ou rechargé le module fglrx ?

Il y a peut-être une incompatibilité entre ce que as en mémoire (le module ancienne version), et les librairies OpenGL que tu veux charger (nouvelle version).

Le moins compliqué, le reboot,

sinon, alt+F1
sudo /etc/init.d/gdm stop
sudo rmmod fglrx
sudo /etc/init.d/gdm start

Tiens nous au courant !!

Hors ligne

#3 Le 29/05/2006, à 23:29

domak

Re : Problème avec fglrx

Yeap. J'ai rebooté (même punition) et je viens de m'appercevoir que j'avais aussi changé de noyeau:

uname -a
Linux domakistan 2.6.15-23-k7 #1 SMP PREEMPT Tue May 23 14:20:54 UTC 2006 i686 GNU/Linux

Si personne n'a d'idée, je tenterai un reconfigure du xorg.conf (j'hésite parce que je me souviens avoir pas mal galéré la première fois).

Hors ligne

#4 Le 29/05/2006, à 23:39

NicoA380

Re : Problème avec fglrx

Quelques petites vérification :

lsmod | grep fglrx
> tu dois trouver quelque chose

cat /var/log/Xorg.0.log | grep EE
et
cat /var/log/Xorg.0.log | grep WW
> remonte nous les lignes avec (EE) et (WW) si elles existent

glxinfo | grep rend
> tu devrais avoir yes

Hors ligne

#5 Le 29/05/2006, à 23:53

domak

Re : Problème avec fglrx

Merci de ton aide. Voici ce que tu m'as demandé:

domak@domakistan:~$ lsmod | grep fglrx
fglrx                 391980  8
agpgart                37072  2 fglrx,nvidia_agp

cat /var/log/Xorg.0.log | grep EE
Current Operating System: Linux domakistan 2.6.15-23-k7 #1 SMP PREEMPT Tue May 23 14:20:54 UTC 2006 i686
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER

cat /var/log/Xorg.0.log | grep WW
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
(WW) The directory "/usr/share/X11/fonts/CID" does not exist.
(WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID".
(WW) fglrx: No matching Device section for instance (BusID PCI:2:0:1) found
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Specified desktop setup not supported: 8

mais je ne peux pas lancer glxinfo (j'ai les mêmes messages que dans mon premier post)

Hors ligne

#6 Le 30/05/2006, à 00:11

domak

Re : Problème avec fglrx

Si tu vois un truc étrange:

domak@domakistan:~$ more /etc/X11/xorg.conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
#       Load    "extmod"
        SubSection "extmod"
                Option "omit xfree86-dga"
        EndSubSection
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr-latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "ATI Technologies, Inc. Radeon 9200 SE (RV280)"
        Driver          "fglrx"
        BusID           "PCI:2:0:0"
EndSection

Section "Monitor"
        Identifier      "Q17 Analog"
        Option          "DPMS"
        HorizSync       28-64
        VertRefresh     43-60
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon 9200 SE (RV280)"
        Monitor         "Q17 Analog"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

et (je viens de monter fglrx de la dernière place à la première sans plus de succès) :

 more /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fglrx
ide-cd
ide-disk
ide-generic
lp
mousedev
psmouse

Hors ligne

#7 Le 30/05/2006, à 00:33

yostral

Re : Problème avec fglrx

J'ai moi aussi ce problème avec la dernière version des drivers ATI (8.25.18) présents dans les dépôts.

Il semblerait que ce soit un bug des drivers avec principalement les vielles cartes (r2xx). Un rapport a été fait auprès d'ATI... malheureusement les devs d'Ubuntu n'y peuvent rien.

Donc soit tu retournes à la version précédente (8.24.8), soit tu passes par les drivers Libres, qui, chez moi, sont plus performants en 3D que les proprios...


Quand tout le reste a échoué, lisez le mode d'emploi.

Hors ligne

#8 Le 30/05/2006, à 08:00

NicoA380

Re : Problème avec fglrx

Je suis à jour sous Dapper, j'ai bien booté ce matin, et j'ai une radeon 8500 (consin très proche de la 9200 je crois).

On voit bien que le module fglrx est bien chargé, cependant, ce qui cloche est également visible :

Xorg.0.log a écrit :

(WW) fglrx: No matching Device section for instance (BusID PCI:2:0:1) found
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Specified desktop setup not supported: 8

Pourrais tu indiquer le résultat d'un "lspci -X | grep ATI"
exemple pour moi :

PCI:1:0:0 VGA compatible controller: ATI Technologies Inc Radeon R200 QL [Radeon 8500 LE]

PCI:1:0:0 est ce qui doit être indiqué dans le xorg.conf dans la Section "Device".

Il y a aussi, dans la Section "Module" ceci qui m'interpel :

xorg.conf a écrit :

#       Load    "extmod"
        SubSection "extmod"
                Option "omit xfree86-dga"
        EndSubSection

Chez moi je n'ai pas besoin de la subSection, je charge directement extmod.

Hors ligne

#9 Le 30/05/2006, à 08:11

proteus

Re : Problème avec fglrx

yostral a écrit :

J'ai moi aussi ce problème avec la dernière version des drivers ATI (8.25.18) présents dans les dépôts.

Il semblerait que ce soit un bug des drivers avec principalement les vielles cartes (r2xx). Un rapport a été fait auprès d'ATI... malheureusement les devs d'Ubuntu n'y peuvent rien.

Donc soit tu retournes à la version précédente (8.24.8), soit tu passes par les drivers Libres, qui, chez moi, sont plus performants en 3D que les proprios...

pareil pour moi sur une radeon 9250
en ce qui concerne les drivers libres, ils sont certes plus performants et permettent d'utiliser xgl/compiz sans pb , mais malheureusement, ils sont aussi tres instables et sont sources de tres nombreux plantages, kill de X puis retour a gdm, gel d'ecran etc...

Hors ligne

#10 Le 30/05/2006, à 09:44

ShaLouZa

Re : Problème avec fglrx

Problème avec fglrx ici aussi, mon serveur X ne se lance plus, j'ai été obligé de mettre le pilote ati, mais je perds le double écran du coup. sad

Pourtant j'ai encore le 8.24.8-1, installé en local, donc il n'a pas changé.

edit : ben d'ailleurs le problème est résolu en installant la version des dépôts. Ça rigole plus les mises à jour chez ATI.

Dernière modification par ShaLouZa (Le 30/05/2006, à 09:51)


«D'abord ils vous ignorent, puis ils rient de vous, puis ils vous combattent, puis vous gagnez.» Gandhi

Hors ligne

#11 Le 30/05/2006, à 11:11

cherchepa

Re : Problème avec fglrx

Meme probleme depuis ce matin
la maj a fait peter ma carte graphique... c tout relou
si qqn a une soluce, je suis preneur .
Au fait il se trouve comment les drivers libres ati?

#12 Le 30/05/2006, à 11:16

ShaLouZa

Re : Problème avec fglrx

Essayez un sudo apt-get dist-upgrade. J'ai remarqué que quelques paquets refusaient de s'installer par là MàJ normale, parce qu'ils auraient cassé des dépendances. En faisant un dist-upgrade ils se sont installés.


«D'abord ils vous ignorent, puis ils rient de vous, puis ils vous combattent, puis vous gagnez.» Gandhi

Hors ligne

#14 Le 30/05/2006, à 15:42

tof14

Re : Problème avec fglrx

Salut,

J'ai le même problème que domak avec la même carte. Chez moi, "lspci -X | grep ATI" me donne :

PCI:1:0:0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE]PCI:1:0:1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (Secondary)

Mais je ne vois ce qu'est le PCI:1:0:1.

Pour le driver radeon, j'ai suivi le tuto et c'est lent (+/-200 à glxgears).

Hors ligne

#15 Le 31/05/2006, à 08:09

cherchepa

Re : Problème avec fglrx

la version du wiki m' tout foutu en l'air... pas glop
comment on fait pour revenir a une ancienne version des drivers? vu qu ils marchaient tres bien....

#16 Le 31/05/2006, à 09:28

Sallé

Re : Problème avec fglrx

Le wiki a écrit :

On sauvegarde son fichier de configuration xorg :

$ sudo cp /etc/X11/xorg.conf /etc/X11/xorg.bak

Pour revenir à l'ancienne version, il faut restaurer l'ancien xorg.conf donc ici ça donne

sudo cp /etc/X11/xorg.bak /etc/X11/xorg.conf

En tout cas ça a marché pour moi, et pas qu'une fois big_smile

Hors ligne

#17 Le 01/06/2006, à 00:11

domak

Re : Problème avec fglrx

Il y a eu une ouverture de bug:
https://launchpad.net/distros/ubuntu/+bug/47371
je vais attendre un peu avant de tout bousiller chez moi...

Hors ligne

#18 Le 01/06/2006, à 13:17

Mahabtux

Re : Problème avec fglrx

Pour ceux qui veulent un peut bricoler voir ici :
http://forum.ubuntu-fr.org/viewtopic.php?pid=318440#p318440


http://www.saveurs-soufies.com/

Hors ligne

#19 Le 02/06/2006, à 13:13

Sallé

Re : Problème avec fglrx

La solution proposée ici (post n°5) marche chez moi  big_smile

Hors ligne