Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 17/05/2022, à 13:06

PDemong

[Résolu][ProtonVPN] DNS - mon resolv.conf n'est plus bon

Bonjour,

j'ai un souci depuis quelques jours : mon fichier /etc/resolv.conf s'est modifié et contient un nameserver qui ne me sert à rien.

ThinkPad-T420:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 127.0.0.53

Conséquence : que je sois connecté à mon routeur en mode filaire ou en mode wifi, internet ne fonctionnait plus.

Pour débloquer ma situation, je modifie à la main mon fichier resolv.conf en remplaçant le nameserver comme suit :

nameserver 192.168.1.1

Mais à chaque reboot, je dois recommencer cette correction car je me retrouve avec un nameserver = 127.0.0.53.

J'ai tenté de modifier le contenu de /etc/resolvconf/resolv.conf.d/ comme suit, sans succès 

ThinkPad-T420:/etc/resolvconf/resolv.conf.d$ ll
total 24
drwxr-xr-x 2 root root 4096 mai   16 23:24 ./
drwxr-xr-x 5 root root 4096 mai   16 22:54 ../
-rw-r--r-- 1 root root   23 mai   16 22:52 base
-rw-r--r-- 1 root root  282 nov.  29  2016 head
-rw-r--r-- 1 root root   53 mai   16 23:24 original
-rw-r--r-- 1 root root   52 mai   16 23:23 original.bkp
-rw-r--r-- 1 root root    0 mai   16 22:52 tail
ThinkPad-T420:/etc/resolvconf/resolv.conf.d$ more *
::::::::::::::
base
::::::::::::::
nameserver 192.168.1.1
::::::::::::::
head
::::::::::::::
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

::::::::::::::
original
::::::::::::::
# Generated by NetworkManager
nameserver 192.168.1.1
::::::::::::::
original.bkp
::::::::::::::
# Generated by NetworkManager
nameserver 127.0.0.53
::::::::::::::
tail
::::::::::::::

Quelqu'un aurait-il une idée ?
Merci d'avance

Dernière modification par PDemong (Le 19/05/2022, à 07:39)

Hors ligne

#2 Le 18/05/2022, à 07:42

bruno

Re : [Résolu][ProtonVPN] DNS - mon resolv.conf n'est plus bon

Bonjour,

Comme indiqué dans l'en-tête du fichier, /etc/resolv.conf est généré automatiquement par NetworkManager et ne doit pas être modifié directement. Son contenu est correct, 127.0.0.53 est le résolveur cache local fourni par systemd-resolved.
Si cela ne fonctionne pas il faut commencer par regarder si le service systemd-resolved est bien actif :

systemctl status systemd-resolved

regarder les résolveurs distants et la configuration réseau :

resolvectll status --no-pager
nmcli | tee

Les modifications sous  /etc/resolvconf/resolv.conf.d/  devraient fonctionner si le paquet resolvconf est installé (après redémarrage des services concernés) mais ce n'est  normalement pas nécessaire.
Les résolveurs DNS doivent être définis soit au niveau du routeur, soit dans la configuration réseau (applet réseau en mode graphique), soit au niveau de systemd-resolved (/etc/systemd/resolved.conf).

Hors ligne

#3 Le 18/05/2022, à 07:52

PDemong

Re : [Résolu][ProtonVPN] DNS - mon resolv.conf n'est plus bon

Bonjour bruno,

j'ai lancé les commandes proposées et voici leur retour : j'aurais bien besoin d'un coup de main pour savoir quoi en déduire...
REMARQUE : j'ai lancé les commandes APRES avoir modifié manuellement mon fichier pour pouvoir aller sur internet...

ThinkPad-T420:~$ systemctl status systemd-resolved
● systemd-resolved.service - Network Name Resolution
     Loaded: loaded (/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-05-17 06:56:44 CEST; 24h ago
       Docs: man:systemd-resolved.service(8)
             https://www.freedesktop.org/wiki/Software/systemd/resolved
             https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
             https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
   Main PID: 893 (systemd-resolve)
     Status: "Processing requests..."
      Tasks: 1 (limit: 9338)
     Memory: 9.3M
     CGroup: /system.slice/systemd-resolved.service
             └─893 /lib/systemd/systemd-resolved

mai 17 06:58:58 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (UDP) for DNS server ::1.
mai 17 06:59:00 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (TCP) for DNS server ::1.
mai 17 06:59:00 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (UDP) for DNS server ::1.
mai 17 06:59:05 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (TCP) for DNS server ::1.
mai 17 06:59:05 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (UDP) for DNS server ::1.
mai 17 06:59:11 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (TCP) for DNS server ::1.
mai 17 06:59:16 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (UDP) for DNS server ::1.
mai 17 06:59:32 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (TCP) for DNS server ::1.
mai 17 06:59:32 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (UDP) for DNS server ::1.
mai 17 06:59:47 patrick-ThinkPad-T420 systemd-resolved[893]: Using degraded feature set (TCP) for DNS server ::1.


atrick@patrick-ThinkPad-T420:~$ resolvectl status --no-pager
Global
       LLMNR setting: no                  
MulticastDNS setting: no                  
  DNSOverTLS setting: no                  
      DNSSEC setting: no                  
    DNSSEC supported: no                  
  Current DNS Server: 192.168.1.1         
         DNS Servers: 192.168.1.1         
          DNSSEC NTA: 10.in-addr.arpa     
                      16.172.in-addr.arpa 
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa 
                      18.172.in-addr.arpa 
                      19.172.in-addr.arpa 
                      20.172.in-addr.arpa 
                      21.172.in-addr.arpa 
                      22.172.in-addr.arpa 
                      23.172.in-addr.arpa 
                      24.172.in-addr.arpa 
                      25.172.in-addr.arpa 
                      26.172.in-addr.arpa 
                      27.172.in-addr.arpa 
                      28.172.in-addr.arpa 
                      29.172.in-addr.arpa 
                      30.172.in-addr.arpa 
                      31.172.in-addr.arpa 
                      corp                
                      d.f.ip6.arpa        
                      home                
                      internal            
                      intranet            
                      lan                 
                      local               
                      private             
                      test                

Link 4 (ipv6leakintrf0)
      Current Scopes: DNS
DefaultRoute setting: yes
       LLMNR setting: yes
MulticastDNS setting: no 
  DNSOverTLS setting: no 
      DNSSEC setting: no 
    DNSSEC supported: no 
  Current DNS Server: ::1
         DNS Servers: ::1
          DNS Domain: ~. 

Link 3 (wlp3s0)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

Link 2 (enp0s25)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

patrick@patrick-ThinkPad-T420:~$ nmcli | tee
wlp3s0: connecté à SFR_9328
	"Intel Centrino Advanced-N 6205"
	wifi (iwlwifi), 10:0B:A9:B7:B2:70, hw, mtu 1500
	ip4 par défaut
	inet4 192.168.1.63/24
	route4 0.0.0.0/0
	route4 192.168.1.0/24
	route4 169.254.0.0/16
	inet6 fe80::ca71:8ffd:9262:ebf4/64
	route6 fe80::/64

ipv6leakintrf0: connecté à pvpn-ipv6leak-protection
	"ipv6leakintrf0"
	dummy, F6:ED:71:1E:6F:18, sw, mtu 1500
	ip6 par défaut
	inet6 fdeb:446c:912d:8da::/64
	inet6 fe80::35b8:da22:e4e6:c1e1/64
	route6 fdeb:446c:912d:8da::/64
	route6 fe80::/64
	route6 ::/0

enp0s25: indisponible
	"Intel 82579LM"
	ethernet (e1000e), 00:21:CC:BC:75:94, hw, mtu 1500

lo: non-géré
	"lo"
	loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
	servers: ::1
	interface: ipv6leakintrf0

	servers: 192.168.1.1
	interface: wlp3s0

Utilisez « nmcli device show » pour obtenir des informations complètes sur les périphériques connus et « nmcli connection show » pour obtenir une vue d'ensemble des profils de connexions actifs.

Consultez les pages de manuel nmcli(1) et nmcli-examples(7) pour les détails complets d'utilisation.

Dernière modification par PDemong (Le 18/05/2022, à 08:00)

Hors ligne

#4 Le 19/05/2022, à 07:17

PDemong

Re : [Résolu][ProtonVPN] DNS - mon resolv.conf n'est plus bon

La situation est revenue à la normale depuis hier.
Maintenant que j'y pense, les problèmes DNS ont débutés lorsque j'ai laissé tourner un programme VPN (ProtonVPN) durant une nuit ...
Et hier soir, après avoir forcé manuellement mon resolv.conf pour accéder à internet, j'ai utilisé de nouveau ProtonVPN, puis je l'ai arrêté proprement.
J'ai rebooté ensuite mon ordi et je n'ai plus de souci de DNS... même avec le resolv.conf suivant :

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 127.0.0.53

Hors ligne

#5 Le 19/05/2022, à 07:28

xubu1957

Re : [Résolu][ProtonVPN] DNS - mon resolv.conf n'est plus bon

Bonjour,

PDemong a écrit :

les problèmes DNS ont débutés lorsque j'ai laissé tourner un programme VPN (ProtonVPN) durant une nuit

Voir la discussion de karabouya

Dernière modification par xubu1957 (Le 19/05/2022, à 07:29)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 19/05/2022, à 07:38

PDemong

Re : [Résolu][ProtonVPN] DNS - mon resolv.conf n'est plus bon

xubu1957 a écrit :

Bonjour,

PDemong a écrit :

les problèmes DNS ont débutés lorsque j'ai laissé tourner un programme VPN (ProtonVPN) durant une nuit

Voir la discussion de karabouya

Ah ben voilà, c'est donc cela!
Et en effet, j'ai hier désinstallé puis réinstallé ProtonVPN. Bon donc cela confirme la cause du problème et sa solution : j'imagine qu'il faut
- désinstaller ProtonVPN
- rebooter et vérifier si on accède de nouveau à internet (sinon modifier temporairement son resolv.conf)
- installer de nouveau ProtonVPN

Hors ligne

#7 Le 19/05/2022, à 07:51

xubu1957

Re : [Résolu][ProtonVPN] DNS - mon resolv.conf n'est plus bon

Quel retour pour :

nmcli device

?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne