Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/04/2022, à 18:59

leportois

[résolu]Installation cartopy

Bonjour,
j'essaie d'installer cartopy sur mon installation de python, via pip.
J'ai installé les dépendances, suivant cette page : Lien pour installer cartopy , c'est à dire GEOS, Shapely, et pyshp.

J'ai une erreur quand je fais "pip install cartopy" :

ERROR: Command errored out with exit status 1:
   command: /usr/bin/python3 /tmp/tmpgaji0t5h get_requires_for_build_wheel /tmp/tmpx73i0b47
       cwd: /tmp/pip-install-4a8vx64_/cartopy
  Complete output (1 lines):
  Proj version 6.3.1 is installed, but cartopy requires at least version 8.0.0.
  ----------------------------------------
ERROR: Command errored out with exit status 1: /usr/bin/python3 /tmp/tmpgaji0t5h get_requires_for_build_wheel /tmp/tmpx73i0b47 Check the logs for full command output.

Je comprends que mon package proj est obsolète. Or si je fais

pip install proj --upgrade

j'ai le résultat suivant :

Requirement already up-to-date: proj in ./.local/lib/python3.8/site-packages (0.2.0)
Requirement already satisfied, skipping upgrade: arrow>=0.15.6 in ./.local/lib/python3.8/site-packages (from proj) (1.2.2)
Requirement already satisfied, skipping upgrade: click>=7.1.2 in ./.local/lib/python3.8/site-packages (from proj) (8.1.2)
Requirement already satisfied, skipping upgrade: python-dateutil>=2.7.0 in ./.local/lib/python3.8/site-packages (from arrow>=0.15.6->proj) (2.8.2)
Requirement already satisfied, skipping upgrade: six>=1.5 in /usr/lib/python3/dist-packages (from python-dateutil>=2.7.0->arrow>=0.15.6->proj) (1.14.0)

Que faire ?

Dernière modification par leportois (Le 20/04/2022, à 07:48)


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#2 Le 13/04/2022, à 19:36

Vobul

Re : [résolu]Installation cartopy


Vobul

Utilisez le retour utilisable de commandes !!!
J'aime la langue française, mais je parle franglais, deal with it.

Hors ligne

#3 Le 14/04/2022, à 06:46

leportois

Re : [résolu]Installation cartopy

Je vais retenter avec un peu plus de temps quand je pourrai, mais pour l'instant toujours la même erreur.


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#4 Le 14/04/2022, à 12:12

Vobul

Re : [résolu]Installation cartopy

Mais t'as installé ce qu'il fallait comme indiqué sur le lien ?


Vobul

Utilisez le retour utilisable de commandes !!!
J'aime la langue française, mais je parle franglais, deal with it.

Hors ligne

#5 Le 14/04/2022, à 12:47

leportois

Re : [résolu]Installation cartopy

J'ai bien suivi ca :

!apt-get install libproj-dev proj-data proj-bin
!apt-get install libgeos-dev
!pip install cython
!pip install cartop

Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#6 Le 14/04/2022, à 14:04

Vobul

Re : [résolu]Installation cartopy

rassure-moi, t'as bien enlevé les "!" n'est-ce pas ? Non je demande car on a tout vu ici. Si tu peux poster les commandes en entier (voir lien dans ma signature).


Vobul

Utilisez le retour utilisable de commandes !!!
J'aime la langue française, mais je parle franglais, deal with it.

Hors ligne

#7 Le 15/04/2022, à 05:56

leportois

Re : [résolu]Installation cartopy

J'ai bien enlevé les "!", et j'ai tapé "sudo apt get". Je te poste le retour :

regis@correa:~$ sudo apt-get install libproj-dev proj-data proj-bin
[sudo] Mot de passe de regis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libproj-dev est déjà la version la plus récente (6.3.1-1).
proj-bin est déjà la version la plus récente (6.3.1-1).
proj-bin passé en « installé manuellement ».
proj-data est déjà la version la plus récente (6.3.1-1).
proj-data passé en « installé manuellement ».
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chktex dvdauthor dvgrab dvidvi geoip-database gnome-software-common latexmk
  libalgorithm-c3-perl libapt-pkg5.90 libb-hooks-op-check-perl
  libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-locale1.67.0
  libboost-program-options1.67.0 libboost-random1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libc-ares2 libclass-c3-perl
  libclass-c3-xs-perl libclass-xsaccessor-perl libcodec2-0.8.1
  libdata-optlist-perl libdevel-callchecker-perl libdevel-caller-perl
  libdevel-lexalias-perl libdvdread4 libdynaloader-functions-perl
  libemail-date-format-perl libemf1 libept1.5.90 libevent-2.1-6 libexiv2-14
  libffi6:i386 libfile-homedir-perl libfprint-2-tod1 libfprint0
  libfwupdplugin1 libgeos-3.7.2 libgtkspell3-3-0 libgutenprint-common
  libgutenprint9 libgweather-3-15 libipc-shareable-perl libiptc0 libisc1100
  libisl21 libjs-sphinxdoc libjs-three libjs-underscore liblivemedia64
  libllvm10:i386 libllvm11 libllvm11:i386 libllvm9 libllvm9:i386 liblwres161
  libmime-lite-perl libmime-types-perl libmlt++3 libmlt-data libmlt6
  libmodule-implementation-perl libmodule-runtime-perl libmro-compat-perl
  libmysofa0 libnettle6:i386 libnfs12 libnode64 libopencv-core3.2
  libopencv-imgproc3.2 libopencv-video3.2 libpadwalker-perl
  libparams-classify-perl libparams-util-perl libplymouth4 libpoppler90
  libprocps7 libproj13 libpython2.7-dev libqpdf21 libqt5websockets5
  libquicktime2 libref-util-perl librttr-core0.9.6 libsombok3
  libsub-identify-perl libsub-install-perl libsub-quote-perl
  libsys-hostname-long-perl libvariable-magic-perl libvlc-dev libx265-176
  libxml-sax-base-perl libxstring-perl libxxhash0 melt nodejs-doc
  oxygen-icon-theme printer-driver-gutenprint python-cairo python-cffi-backend
  python-configparser python-crypto python-entrypoints python-gobject-2
  python-ipaddress python-pygments python3-asn1crypto python3-enchant
  qml-module-qtquick-extras qtcore4-l10n recordmydesktop ruby-did-you-mean
  runit-helper texlive-metapost texlive-metapost-doc
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
regis@correa:~$ sudo apt-get install libgeos-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgeos-dev est déjà la version la plus récente (3.8.0-1build1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chktex dvdauthor dvgrab dvidvi geoip-database gnome-software-common latexmk
  libalgorithm-c3-perl libapt-pkg5.90 libb-hooks-op-check-perl
  libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-locale1.67.0
  libboost-program-options1.67.0 libboost-random1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libc-ares2 libclass-c3-perl
  libclass-c3-xs-perl libclass-xsaccessor-perl libcodec2-0.8.1
  libdata-optlist-perl libdevel-callchecker-perl libdevel-caller-perl
  libdevel-lexalias-perl libdvdread4 libdynaloader-functions-perl
  libemail-date-format-perl libemf1 libept1.5.90 libevent-2.1-6 libexiv2-14
  libffi6:i386 libfile-homedir-perl libfprint-2-tod1 libfprint0
  libfwupdplugin1 libgeos-3.7.2 libgtkspell3-3-0 libgutenprint-common
  libgutenprint9 libgweather-3-15 libipc-shareable-perl libiptc0 libisc1100
  libisl21 libjs-sphinxdoc libjs-three libjs-underscore liblivemedia64
  libllvm10:i386 libllvm11 libllvm11:i386 libllvm9 libllvm9:i386 liblwres161
  libmime-lite-perl libmime-types-perl libmlt++3 libmlt-data libmlt6
  libmodule-implementation-perl libmodule-runtime-perl libmro-compat-perl
  libmysofa0 libnettle6:i386 libnfs12 libnode64 libopencv-core3.2
  libopencv-imgproc3.2 libopencv-video3.2 libpadwalker-perl
  libparams-classify-perl libparams-util-perl libplymouth4 libpoppler90
  libprocps7 libproj13 libpython2.7-dev libqpdf21 libqt5websockets5
  libquicktime2 libref-util-perl librttr-core0.9.6 libsombok3
  libsub-identify-perl libsub-install-perl libsub-quote-perl
  libsys-hostname-long-perl libvariable-magic-perl libvlc-dev libx265-176
  libxml-sax-base-perl libxstring-perl libxxhash0 melt nodejs-doc
  oxygen-icon-theme printer-driver-gutenprint python-cairo python-cffi-backend
  python-configparser python-crypto python-entrypoints python-gobject-2
  python-ipaddress python-pygments python3-asn1crypto python3-enchant
  qml-module-qtquick-extras qtcore4-l10n recordmydesktop ruby-did-you-mean
  runit-helper texlive-metapost texlive-metapost-doc
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
regis@correa:~$ pip install cythno
ERROR: Could not find a version that satisfies the requirement cythno (from versions: none)
ERROR: No matching distribution found for cythno
regis@correa:~$ pip install cython
Collecting cython
  Using cached Cython-0.29.28-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.manylinux_2_24_x86_64.whl (1.9 MB)
Installing collected packages: cython
  WARNING: The scripts cygdb, cython and cythonize are installed in '/home/regis/.local/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed cython-0.29.28
regis@correa:~$ pip install cartopy
Collecting cartopy
  Using cached Cartopy-0.20.2.tar.gz (10.8 MB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... error
  ERROR: Command errored out with exit status 1:
   command: /usr/bin/python3 /tmp/tmp1dg1uwx8 get_requires_for_build_wheel /tmp/tmp4z9uf0k7
       cwd: /tmp/pip-install-3jgkex8h/cartopy
  Complete output (1 lines):
  Proj version 6.3.1 is installed, but cartopy requires at least version 8.0.0.
  ----------------------------------------
ERROR: Command errored out with exit status 1: /usr/bin/python3 /tmp/tmp1dg1uwx8 get_requires_for_build_wheel /tmp/tmp4z9uf0k7 Check the logs for full command output.
regis@correa:~$ apt-get install proj-data
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock-frontend - open (13: Permission non accordée)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Avez-vous les droits du superutilisateur ?
regis@correa:~$ sudo apt-get install python3-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
python3-dev est déjà la version la plus récente (3.8.2-0ubuntu2).
python3-dev passé en « installé manuellement ».
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chktex dvdauthor dvgrab dvidvi geoip-database gnome-software-common latexmk
  libalgorithm-c3-perl libapt-pkg5.90 libb-hooks-op-check-perl
  libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-locale1.67.0
  libboost-program-options1.67.0 libboost-random1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libc-ares2 libclass-c3-perl
  libclass-c3-xs-perl libclass-xsaccessor-perl libcodec2-0.8.1
  libdata-optlist-perl libdevel-callchecker-perl libdevel-caller-perl
  libdevel-lexalias-perl libdvdread4 libdynaloader-functions-perl
  libemail-date-format-perl libemf1 libept1.5.90 libevent-2.1-6 libexiv2-14
  libffi6:i386 libfile-homedir-perl libfprint-2-tod1 libfprint0
  libfwupdplugin1 libgeos-3.7.2 libgtkspell3-3-0 libgutenprint-common
  libgutenprint9 libgweather-3-15 libipc-shareable-perl libiptc0 libisc1100
  libisl21 libjs-sphinxdoc libjs-three libjs-underscore liblivemedia64
  libllvm10:i386 libllvm11 libllvm11:i386 libllvm9 libllvm9:i386 liblwres161
  libmime-lite-perl libmime-types-perl libmlt++3 libmlt-data libmlt6
  libmodule-implementation-perl libmodule-runtime-perl libmro-compat-perl
  libmysofa0 libnettle6:i386 libnfs12 libnode64 libopencv-core3.2
  libopencv-imgproc3.2 libopencv-video3.2 libpadwalker-perl
  libparams-classify-perl libparams-util-perl libplymouth4 libpoppler90
  libprocps7 libproj13 libpython2.7-dev libqpdf21 libqt5websockets5
  libquicktime2 libref-util-perl librttr-core0.9.6 libsombok3
  libsub-identify-perl libsub-install-perl libsub-quote-perl
  libsys-hostname-long-perl libvariable-magic-perl libvlc-dev libx265-176
  libxml-sax-base-perl libxstring-perl libxxhash0 melt nodejs-doc
  oxygen-icon-theme printer-driver-gutenprint python-cairo python-cffi-backend
  python-configparser python-crypto python-entrypoints python-gobject-2
  python-ipaddress python-pygments python3-asn1crypto python3-enchant
  qml-module-qtquick-extras qtcore4-l10n recordmydesktop ruby-did-you-mean
  runit-helper texlive-metapost texlive-metapost-doc
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
regis@correa:~$ pip install cython
Requirement already satisfied: cython in ./.local/lib/python3.8/site-packages (0.29.28)
regis@correa:~$ pip install cartopy
Collecting cartopy
  Using cached Cartopy-0.20.2.tar.gz (10.8 MB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... error
  ERROR: Command errored out with exit status 1:
   command: /usr/bin/python3 /tmp/tmpod_tu1uj get_requires_for_build_wheel /tmp/tmpbgyx857i
       cwd: /tmp/pip-install-_6wag4i4/cartopy
  Complete output (1 lines):
  Proj version 6.3.1 is installed, but cartopy requires at least version 8.0.0.
  ----------------------------------------
ERROR: Command errored out with exit status 1: /usr/bin/python3 /tmp/tmpod_tu1uj get_requires_for_build_wheel /tmp/tmpbgyx857i Check the logs for full command output.
regis@correa:~$ pip instal proj --upgrade
ERROR: unknown command "instal" - maybe you meant "install"
regis@correa:~$ pip install proj --upgrade
Requirement already up-to-date: proj in ./.local/lib/python3.8/site-packages (0.2.0)
Requirement already satisfied, skipping upgrade: arrow>=0.15.6 in ./.local/lib/python3.8/site-packages (from proj) (1.2.2)
Requirement already satisfied, skipping upgrade: click>=7.1.2 in ./.local/lib/python3.8/site-packages (from proj) (8.1.2)
Requirement already satisfied, skipping upgrade: python-dateutil>=2.7.0 in ./.local/lib/python3.8/site-packages (from arrow>=0.15.6->proj) (2.8.2)
Requirement already satisfied, skipping upgrade: six>=1.5 in /usr/lib/python3/dist-packages (from python-dateutil>=2.7.0->arrow>=0.15.6->proj) (1.14.0)
regis@correa:~$ 

Dernière modification par leportois (Le 15/04/2022, à 05:57)


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#8 Le 15/04/2022, à 09:17

Vobul

Re : [résolu]Installation cartopy

Alors j'ai tenté une install dans un container 20.04, et en effet vu que le libproj est en version 6, ça ne fonctionne pas.

Après j'ai tenté dans un container 22.04 où libproj est en version 8 et là ça fonctionne comme il faut.

Donc t'as plusieurs solutions :

- upgrader à 22.04
- tenter d'installer libproj 8 sur 20.04 au risque de casser ton système
- utiliser cartopy dans une version moins récente qui ne nécessite pas libproj 8 mais 6
- utiliser cartopy dans un container docker 22.04 (une bonne solution de mon point de vue mais je suis familier avec docker)


Vobul

Utilisez le retour utilisable de commandes !!!
J'aime la langue française, mais je parle franglais, deal with it.

Hors ligne

#9 Le 16/04/2022, à 07:00

leportois

Re : [résolu]Installation cartopy

Je vais upgrader. Je n'avais pas vu que mon système n'etait pas a jour. En tout cas merci de te pencher sur mon cas smile

edit : ca démarre fort, la mise à niveau s'arrête après la récupération des paquets....

Dernière modification par leportois (Le 16/04/2022, à 07:16)


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#10 Le 16/04/2022, à 09:16

iznobe

Re : [résolu]Installation cartopy

Bonjour ,

leportois a écrit :

Je n'avais pas vu que mon système n'etait pas a jour.

En fait la version 22.04 , n' es pas encore officiellement sortie , ca ne saurait tarder , mais il se peut que pendant quelques mois , il y ait encore des petits soucis avec cette version qu' il n' est pas ( encore ) conseillée d' utiliser pour une station de travail .


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

En ligne

#11 Le 16/04/2022, à 11:58

leportois

Re : [résolu]Installation cartopy

En fait je suis en train de mettre à jour vers 21.10. On verra si ca résout les problemes, normalement 22.04 devrait sortir bientot non ?
Comme la mise à jour passait pas, je met à jour en ligne de commande, au moins je vois ou ca bloque.


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#12 Le 16/04/2022, à 16:01

leportois

Re : [résolu]Installation cartopy

Ma mise à niveau a crashé, je dois recréer un live USB depuis le pc de ma femme et réinstaller... Donc les news arriveront plus tard.


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#13 Le 17/04/2022, à 11:30

leportois

Re : [résolu]Installation cartopy

Donc pas mieux avec un ubuntu fraichement réinstallé (et visiblement en 21.10) :

 pip install cartopy
Collecting cartopy
  Using cached Cartopy-0.20.2.tar.gz (10.8 MB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... error
  ERROR: Command errored out with exit status 1:
   command: /usr/bin/python3 /tmp/tmp3kg0q87r_in_process.py get_requires_for_build_wheel /tmp/tmpin897dcp
       cwd: /tmp/pip-install-p_dae_4y/cartopy_2118f806fcf44861814388875d58c98c
  Complete output (1 lines):
  Proj version 7.2.1 is installed, but cartopy requires at least version 8.0.0.
  ----------------------------------------
WARNING: Discarding https://files.pythonhosted.org/packages/f6/55/1e1c737dc9436b320deead73d1c455ddbb74b8b6992081863492f6f6378a/Cartopy-0.20.2.tar.gz#sha256=4d08c198ecaa50a6a6b109d0f14c070e813defc046a83ac5d7ab494f85599e35 (from https://pypi.org/simple/cartopy/) (requires-python:>=3.7). Command errored out with exit status 1: /usr/bin/python3 /tmp/tmp3kg0q87r_in_process.py get_requires_for_build_wheel /tmp/tmpin897dcp Check the logs for full command output.
  Using cached Cartopy-0.20.1.tar.gz (10.8 MB)

Edit : si c'est mieux, il m'a installé cartopy 19
Je fais les essais et je vous tiens au courant;

Dernière modification par leportois (Le 17/04/2022, à 11:31)


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne

#14 Le 17/04/2022, à 12:20

Vobul

Re : [résolu]Installation cartopy

> Proj version 7.2.1 is installed, but cartopy requires at least version 8.0.0.

Tu es passé de la version 6 à la version 7, mais t'as toujours besoin de la 8 wink


Vobul

Utilisez le retour utilisable de commandes !!!
J'aime la langue française, mais je parle franglais, deal with it.

Hors ligne

#15 Le 18/04/2022, à 09:04

EdLeH

Re : [résolu]Installation cartopy

Bonjour,
en installant proj via pip peut-être que ça donnerait une version compatible ?

Hors ligne

#16 Le 20/04/2022, à 07:47

leportois

Re : [résolu]Installation cartopy

Bon je vous confirme que ca fonctionne : cartopy 20 ne passait pas il a installé cartopy 19 qui fonctionne. Merci à tous ceux qui ont aidé smile


Si les poils dans la main étaient urticants, yaurait moins de branleurs

Hors ligne