Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/03/2022, à 13:01

eric63

[Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Salut
harghhhh ! je suis dégoûté mad
je cherchais ce matin à remettre sur mes bureaux le cube sphère cylindre avec ses fenêtres survolant celui ci et les effets qui vont bien.
Avec horreur je constate que ces effets inutiles donc indispensables ont disparus et après recherche depuis plasma 5.23 voir lien forum pclinux
déjà je m’étonne que personne n’en ait parlé sur ce forum et que personne dans les annonces de nouveautés de plasma n’en ait touché un mot

Donc je sais je suis coupable aussi vu que je n’utilisais plus cet effet depuis quelques temps (au moins 5.22)
mais moi je l’adorais cet effet aussi indispensable que les fenêtres molles
l’ effet aurait été lâché faute de temps pour s’en occuper  (ils sont sur wayland principalement) et les effets sont compliqués à maintenir
et il n’y a visiblement pas d’ouverture de reprise de ces effets un mail d’explications des developeurs et les questions réponses au demandes de bug qui éclaire un peu le sujet et ses conséquences futures voir les questions réponses bugs

wait and see ou adieu ?
ça me fait réfléchir à mon maintient sur kde:
j’ai toujours suivi kde depuis le début sur mandrake 7 ça date de très longtemps et je n’ai jamais trouvé gnome ou d’autres plus attractifs et qui correspondent à ce que j’attends d’un environnement 
gnome semble avoir un fork pour intégrer une partie des effets

Dernière modification par eric63 (Le 30/10/2023, à 18:22)


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#2 Le 13/03/2022, à 15:26

abecidofugy

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Salut,

Je pense qu’ils tiennent des statistiques, et si cette fonctionnalité n’était pas (plus) exploitée par suffisamment de gens, ils ont dû simplifier tout ça en la retirant.

À titre perso, franchement, ce n’est pas ce qui fait que je suis et reste sous KDE plasma.

Mais je compatis à ton manque.

Hors ligne

#3 Le 13/03/2022, à 15:56

eric63

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

C’est le coup de ma frustration ça devrait me passer d’ici quelques jours smile
les devs semble indiquer que le cube serait réimplanté mais que cela nécessite de repartir de zéro pour que cela soit compatible (wayland? qt6 ?)
donc je vais attendre patiemment et suivre les nouvelles.


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#4 Le 15/05/2022, à 15:30

IAI_Kmer

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

bonjour à tous. je suis très surpris voir déçu vu que sous kubuntu 20.04 je l'utilisait constamment. je suis partant pour que cette fonctionnalité soit réintégré sur kubuntu 22.04. ma version plasma actuelle est 5.24.4

Hors ligne

#5 Le 30/05/2022, à 10:47

pierpiotr

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Bonjour,
Je plussoie; J'utilise le bureau en cube pour répartir mon travail. C'est un avantage de productivité qui disparaît :-(


Kubuntu 22.04 LTS sur DELL Inspiron 7490 - i7 - RAM 16Go - SSD 500Go - nVidia GeForce MX250
Au bureau : Kubuntu 20.04 LTS  (64b) - PC tour LDLC PC Zi-Artist - i7-3770 @ 3.4/3.9Ghz - RAM 16Go - SSD 120Go - DD 1To - nVidia GEForce GT 640 1Go

Hors ligne

#6 Le 30/05/2022, à 11:41

abecidofugy

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

pierpiotr a écrit :

Bonjour,
Je plussoie; J'utilise le bureau en cube pour répartir mon travail. C'est un avantage de productivité qui disparaît :-(

Rien ne t’empêche d’utiliser les bureaux, sauf que tu n’auras pas pour l’instant le cube.

Et sinon, il y a les activités. Je n’utilise que ça.

Hors ligne

#7 Le 31/05/2022, à 09:37

pierpiotr

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

abecidofugy a écrit :

Rien ne t’empêche d’utiliser les bureaux, sauf que tu n’auras pas pour l’instant le cube.

Oui mais avec retour sur la barre des taches et clic. Comme dans W. Moins marrant que d'atteindre un bord de l'écran et tourner ses bureaux à la souris.

abecidofugy a écrit :

Et sinon, il y a les activités. Je n’utilise que ça.

Sans doute. Depuis le temps que j'utilise KDE je ne me suis pas encore bien penché sur la question. À explorer...

Dernière modification par pierpiotr (Le 31/05/2022, à 09:38)


Kubuntu 22.04 LTS sur DELL Inspiron 7490 - i7 - RAM 16Go - SSD 500Go - nVidia GeForce MX250
Au bureau : Kubuntu 20.04 LTS  (64b) - PC tour LDLC PC Zi-Artist - i7-3770 @ 3.4/3.9Ghz - RAM 16Go - SSD 120Go - DD 1To - nVidia GEForce GT 640 1Go

Hors ligne

#8 Le 31/05/2022, à 10:32

abecidofugy

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

pierpiotr a écrit :
abecidofugy a écrit :

Rien ne t’empêche d’utiliser les bureaux, sauf que tu n’auras pas pour l’instant le cube.

Oui mais avec retour sur la barre des taches et clic. Comme dans W. Moins marrant que d'atteindre un bord de l'écran et tourner ses bureaux à la souris.

Non, tu peux affecter un raccourci clavier pour passer d’un bureau à l’autre. Pareil pour les activités wink

Hors ligne

#9 Le 31/05/2022, à 11:39

pierpiotr

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

abecidofugy a écrit :

Non, tu peux affecter un raccourci clavier pour passer d’un bureau à l’autre. Pareil pour les activités wink

Je vais essayer ça, merci.


Kubuntu 22.04 LTS sur DELL Inspiron 7490 - i7 - RAM 16Go - SSD 500Go - nVidia GeForce MX250
Au bureau : Kubuntu 20.04 LTS  (64b) - PC tour LDLC PC Zi-Artist - i7-3770 @ 3.4/3.9Ghz - RAM 16Go - SSD 120Go - DD 1To - nVidia GEForce GT 640 1Go

Hors ligne

#10 Le 31/08/2022, à 20:39

eric63

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

un essai réussi aux retours des extinctions de fenêtres de feu et autres joyeusetés des effets qui allaient avec le cube.
Je suis raide fan surtout l’effet incinerate : magnifique sur kde 5.25.3
effet Burn-My-Windows GNOME Shell
Oui ça tue la productivité mais on est pas obligé de les utiliser
et un peu de bonheur dans ce monde de brute smile
et l'auteur à initier le cube mais sur gnome 40-41-42 et sur arch
mais bon, gnome shell n’est pas plasma.

Dernière modification par eric63 (Le 31/08/2022, à 20:39)


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#11 Le 05/12/2022, à 23:22

eric63

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Petite avancée pour le cube en cours. smile
Je dis petite car chez moi ça ne fonctionne pas mais il se peut que je ne fasse pas ce qu’il faut
le site qui en parle
j’ai suivi les indications données pour ubuntu

On Ubuntu

sudo apt install cmake extra-cmake-modules kwin-dev \
    libkf5config-dev libkf5configwidgets-dev libkf5coreaddons-dev \
    libkf5windowsystem-dev libkf5globalaccel-dev libkf5xmlgui-dev qtbase5-dev

After you installed all the required dependencies, you can build the effect:

git clone https://github.com/zzag/kwin-effects-cube.git
cd kwin-effects-cube
cmake -B build -S . \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr

cmake --build build --parallel
cmake --install build

Donc je commence le pas à pas explicatif

kubu@kubu-MS-7821:~$ sudo apt install cmake extra-cmake-modules kwin-dev     libkf5config-dev libkf5configwidgets-dev libkf5coreaddons-dev     libkf5windowsystem-dev libkf5globalaccel-dev libkf5xmlgui-dev qtbase5-dev
[sudo] Mot de passe de kubu : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
cmake est déjà la version la plus récente (3.24.2-1ubuntu1).
extra-cmake-modules est déjà la version la plus récente (5.100.0-0ubuntu1~ubuntu22.10~ppa1).
kwin-dev est déjà la version la plus récente (4:5.26.4-0ubuntu1~ubuntu22.10~ppa1).
libkf5config-dev est déjà la version la plus récente (5.100.0-0ubuntu1~ubuntu22.10~ppa1).
libkf5configwidgets-dev est déjà la version la plus récente (5.100.0-0ubuntu1~ubuntu22.10~ppa1).
libkf5coreaddons-dev est déjà la version la plus récente (5.100.0-0ubuntu1~ubuntu22.10~ppa1).
libkf5windowsystem-dev est déjà la version la plus récente (5.100.0-0ubuntu1~ubuntu22.10~ppa1).
libkf5globalaccel-dev est déjà la version la plus récente (5.100.0-0ubuntu1~ubuntu22.10~ppa1).
libkf5xmlgui-dev est déjà la version la plus récente (5.100.0-0ubuntu1~ubuntu22.10~ppa1).
qtbase5-dev est déjà la version la plus récente (5.15.6+dfsg-1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  dctrl-tools dh-dkms dkms
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
kubu@kubu-MS-7821:~$ 
kubu@kubu-MS-7821:~$ git clone https://github.com/zzag/kwin-effects-cube.git
Clonage dans 'kwin-effects-cube'...
remote: Enumerating objects: 363, done.
remote: Counting objects: 100% (6/6), done.
remote: Compressing objects: 100% (6/6), done.
remote: Total 363 (delta 0), reused 1 (delta 0), pack-reused 357
Réception d'objets: 100% (363/363), 1.05 Mio | 10.19 Mio/s, fait.
Résolution des deltas: 100% (250/250), fait.
kubu@kubu-MS-7821:~$
kubu@kubu-MS-7821:~$ cd kwin-effects-cube
kubu@kubu-MS-7821:~/kwin-effects-cube$ 
kubu@kubu-MS-7821:~/kwin-effects-cube$ cmake -B build -S . \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr
-- The C compiler identification is GNU 12.2.0
-- The CXX compiler identification is GNU 12.2.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Installing in the same prefix as Qt, adopting their path scheme.
-- Looking for __GLIBC__
-- Looking for __GLIBC__ - found
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_DATE_TIME
-- Performing Test HAVE_DATE_TIME - Success
CMake Warning (dev) at /usr/share/ECM/modules/ECMFindModuleHelpers.cmake:113 (message):
  Your project should require at least CMake 3.16.0 to use FindKF5.cmake
Call Stack (most recent call first):
  /usr/share/ECM/find-modules/FindKF5.cmake:30 (ecm_find_package_version_check)
  CMakeLists.txt:26 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Found KF5Config: /usr/lib/x86_64-linux-gnu/cmake/KF5Config/KF5ConfigConfig.cmake (found version "5.100.0") 
-- Found KF5ConfigWidgets: /usr/lib/x86_64-linux-gnu/cmake/KF5ConfigWidgets/KF5ConfigWidgetsConfig.cmake (found version "5.100.0") 
-- Found KF5CoreAddons: /usr/lib/x86_64-linux-gnu/cmake/KF5CoreAddons/KF5CoreAddonsConfig.cmake (found version "5.100.0") 
-- Found KF5GlobalAccel: /usr/lib/x86_64-linux-gnu/cmake/KF5GlobalAccel/KF5GlobalAccelConfig.cmake (found version "5.100.0") 
-- Found Gettext: /usr/bin/msgmerge (found version "0.21") 
-- Found KF5I18n: /usr/lib/x86_64-linux-gnu/cmake/KF5I18n/KF5I18nConfig.cmake (found version "5.100.0") 
-- Found X11: /usr/include   
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Found KF5WindowSystem: /usr/lib/x86_64-linux-gnu/cmake/KF5WindowSystem/KF5WindowSystemConfig.cmake (found version "5.100.0") 
-- Found KF5XmlGui: /usr/lib/x86_64-linux-gnu/cmake/KF5XmlGui/KF5XmlGuiConfig.cmake (found version "5.100.0") 
-- Found KF5: success (found suitable version "5.100.0", minimum required is "5.94.0") found components: Config ConfigWidgets CoreAddons GlobalAccel I18n WindowSystem XmlGui 
-- Found epoxy: /usr/lib/x86_64-linux-gnu/libepoxy.so (found version "1.5.10") 
CMake Warning (dev) at /usr/share/ECM/modules/ECMFindModuleHelpers.cmake:113 (message):
  Your project should require at least CMake 3.16.0 to use FindXCB.cmake
Call Stack (most recent call first):
  /usr/share/ECM/find-modules/FindXCB.cmake:67 (ecm_find_package_version_check)
  CMakeLists.txt:37 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Found XCB_XCB: /usr/lib/x86_64-linux-gnu/libxcb.so (found version "1.15") 
-- Found XCB: /usr/lib/x86_64-linux-gnu/libxcb.so (found version "1.15") found components: XCB 
-- The following OPTIONAL packages have been found:

 * KF5Auth (required version >= 5.100.0)
 * KF5Codecs (required version >= 5.100.0)

-- The following REQUIRED packages have been found:

 * ECM
 * Qt5Network (required version >= 5.15.6)
 * Qt5Qml (required version >= 5.15.6)
 * Qt5QmlModels (required version >= 5.15.6)
 * Qt5Quick
 * Qt5 (required version >= 5.15.0)
 * KF5GlobalAccel (required version >= 5.94.0)
 * Gettext
 * KF5I18n (required version >= 5.94.0)
 * KF5XmlGui (required version >= 5.94.0)
 * KF5 (required version >= 5.94.0)
 * epoxy
 * XCB, X protocol C-language Binding, <https://xcb.freedesktop.org/>
 * Qt5DBus (required version >= 5.15.2)
 * KF5Config (required version >= 5.98.0)
 * Qt5Core (required version >= 5.15.2)
 * KF5CoreAddons (required version >= 5.98.0)
 * Qt5Gui (required version >= 5.15.2)
 * KWinEffects (required version >= 5.25.0)
 * KWinDBusInterface

-- Configuring done
-- Generating done
-- Build files have been written to: /home/kubu/kwin-effects-cube/build
kubu@kubu-MS-7821:~/kwin-effects-cube$ 
kubu@kubu-MS-7821:~/kwin-effects-cube$ cmake --build build --parallel
[ 11%] Automatic MOC for target kwin_cube_config
[ 11%] Automatic MOC for target kwin4_effect_cube
[ 11%] Built target kwin_cube_config_autogen
[ 23%] Generating ui_cubeeffectkcm.h
[ 23%] Generating kwineffects_interface.cpp, kwineffects_interface.h
[ 29%] Generating cubeconfig.h, cubeconfig.cpp
[ 29%] Built target kwin4_effect_cube_autogen
[ 35%] Generating cubeconfig.h, cubeconfig.cpp
[ 41%] Generating kwineffects_interface.moc
[ 47%] Building CXX object src/CMakeFiles/kwin4_effect_cube.dir/cubeeffect.cpp.o
[ 52%] Building CXX object src/CMakeFiles/kwin4_effect_cube.dir/kwin4_effect_cube_autogen/mocs_compilation.cpp.o
[ 58%] Building CXX object src/kcm/CMakeFiles/kwin_cube_config.dir/kwineffects_interface.cpp.o
[ 64%] Building CXX object src/CMakeFiles/kwin4_effect_cube.dir/main.cpp.o
[ 70%] Building CXX object src/kcm/CMakeFiles/kwin_cube_config.dir/cubeeffectkcm.cpp.o
[ 76%] Building CXX object src/kcm/CMakeFiles/kwin_cube_config.dir/kwin_cube_config_autogen/mocs_compilation.cpp.o
[ 82%] Building CXX object src/kcm/CMakeFiles/kwin_cube_config.dir/cubeconfig.cpp.o
[ 88%] Building CXX object src/CMakeFiles/kwin4_effect_cube.dir/cubeconfig.cpp.o
[ 94%] Linking CXX shared module kwin4_effect_cube.so
[100%] Linking CXX shared module kwin_cube_config.so
[100%] Built target kwin4_effect_cube
[100%] Built target kwin_cube_config
kubu@kubu-MS-7821:~/kwin-effects-cube$ 
kubu@kubu-MS-7821:~/kwin-effects-cube$ cmake --install build
-- Install configuration: "Release"
-- Installing: /usr/lib/x86_64-linux-gnu/qt5/plugins/kwin/effects/plugins/kwin4_effect_cube.so
CMake Error at build/src/cmake_install.cmake:52 (file):
  file INSTALL cannot copy file
  "/home/kubu/kwin-effects-cube/build/src/kwin4_effect_cube.so" to
  "/usr/lib/x86_64-linux-gnu/qt5/plugins/kwin/effects/plugins/kwin4_effect_cube.so":
  Permission denied.
Call Stack (most recent call first):
  build/cmake_install.cmake:47 (include)
kubu@kubu-MS-7821:~/kwin-effects-cube$
kubu@kubu-MS-7821:~/kwin-effects-cube$ sudo cmake --install build
-- Install configuration: "Release"
-- Installing: /usr/lib/x86_64-linux-gnu/qt5/plugins/kwin/effects/plugins/kwin4_effect_cube.so
-- Up-to-date: /usr/share/kwin/effects/cube/qml
-- Installing: /usr/share/kwin/effects/cube/qml/Cube.qml
-- Installing: /usr/share/kwin/effects/cube/qml/CubeCameraController.qml
-- Installing: /usr/share/kwin/effects/cube/qml/DesktopView.qml
-- Installing: /usr/share/kwin/effects/cube/qml/main.qml
-- Installing: /usr/share/kwin/effects/cube/qml/CubeFace.qml
-- Installing: /usr/lib/x86_64-linux-gnu/qt5/plugins/kwin/effects/configs/kwin_cube_config.so
kubu@kubu-MS-7821:~/kwin-effects-cube$ 

donc je vois bien dans ma configuration du système/ comportement de l’espace de travail/ effets de bureau /gestion des fenêtres /Cube
mais avec meta+C rien ne se passe
essayer de passer sous x11 ou wayland de rebooter l’ordi rien de plus


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#12 Le 25/12/2022, à 22:35

pierpiotr

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Bonjour,
Je suis coincé avec une erreur en rouge :

CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:28 (find_package):
  Could not find a package configuration file provided by "Qt5Quick" with any
  of the following names:

    Qt5QuickConfig.cmake
    qt5quick-config.cmake

  Add the installation prefix of "Qt5Quick" to CMAKE_PREFIX_PATH or set
  "Qt5Quick_DIR" to a directory containing one of the above files.  If
  "Qt5Quick" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  CMakeLists.txt:19 (find_package)

et pour finir

-- Configuring incomplete, errors occurred!
See also "/home/pierre/kwin-effects-cube/build/CMakeFiles/CMakeOutput.log".
gmake: Makefile: No such file or directory
gmake: *** No rule to make target 'Makefile'.  Stop.
CMake Error: Error processing file: /home/pierre/kwin-effects-cube/build/cmake_install.cmake

Kubuntu 22.04 LTS sur DELL Inspiron 7490 - i7 - RAM 16Go - SSD 500Go - nVidia GeForce MX250
Au bureau : Kubuntu 20.04 LTS  (64b) - PC tour LDLC PC Zi-Artist - i7-3770 @ 3.4/3.9Ghz - RAM 16Go - SSD 120Go - DD 1To - nVidia GEForce GT 640 1Go

Hors ligne

#13 Le 26/12/2022, à 10:47

eric63

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Salut et bonnes fêtes

après quelle commande tu es coincé avec des alertes en rouge ?


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#14 Le 26/12/2022, à 11:14

pierpiotr

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Oui, bonne fêtes à tous !
J'avais tenté d'installer avant QtQuick 3D comme indiqué dans la page que tu donnes en lien.
Je suis coincé après cette salve de commandes :

git clone https://github.com/zzag/kwin-effects-cube.git
cd kwin-effects-cube
cmake -B build -S . \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr
cmake --build build --parallel
cmake --install build

Kubuntu 22.04 LTS sur DELL Inspiron 7490 - i7 - RAM 16Go - SSD 500Go - nVidia GeForce MX250
Au bureau : Kubuntu 20.04 LTS  (64b) - PC tour LDLC PC Zi-Artist - i7-3770 @ 3.4/3.9Ghz - RAM 16Go - SSD 120Go - DD 1To - nVidia GEForce GT 640 1Go

Hors ligne

#15 Le 26/12/2022, à 12:17

eric63

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

il faut bien différencier les commandes données dans le premier pavé noir car la fin ne fonctionne pas si tu tapes tel quel
regarde bien commentj’ai fait pour chaque commandes ou bloc de commandes dans les pavés noirs suivants
le dernier c’est

kubu@kubu-MS-7821:~/kwin-effects-cube$ sudo cmake --install build

et pas

 kubu@kubu-MS-7821:~/kwin-effects-cube$ cmake --install build

ça ne fonctionne pas en utilisateur normal mais en sudo cela fonctionne sans erreur
Après chez moi le cube ne s’installe pas quand même


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#16 Le 26/12/2022, à 13:50

pierpiotr

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

En reprenant pas à pas, ce n'est pas la dernière commande qui plante, c'est :

cmake -B build -S . \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr
CMake Error at /usr/lib/x86_64-linux-gnu/cmake/Qt5/Qt5Config.cmake:28 (find_package):
  Could not find a package configuration file provided by "Qt5Quick" with any
  of the following names:

    Qt5QuickConfig.cmake
    qt5quick-config.cmake

  Add the installation prefix of "Qt5Quick" to CMAKE_PREFIX_PATH or set
  "Qt5Quick_DIR" to a directory containing one of the above files.  If
  "Qt5Quick" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  CMakeLists.txt:19 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/pierre/kwin-effects-cube/kwin-effects-cube/kwin-effects-cube/build/CMakeFiles/CMakeOutput.log".

Kubuntu 22.04 LTS sur DELL Inspiron 7490 - i7 - RAM 16Go - SSD 500Go - nVidia GeForce MX250
Au bureau : Kubuntu 20.04 LTS  (64b) - PC tour LDLC PC Zi-Artist - i7-3770 @ 3.4/3.9Ghz - RAM 16Go - SSD 120Go - DD 1To - nVidia GEForce GT 640 1Go

Hors ligne

#17 Le 26/12/2022, à 14:40

eric63

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

il faudrait que tu donnes la commande entière que tu poses
parce que là on ne vois pas comment tu poses la commande et c’est très important comme cela

kubu@kubu-MS-7821:~/Téléchargements/qtquick3d-everywhere-src-5.15.6$ make
le résultat de la commande
kubu@kubu-MS-7821:~/Téléchargements/qtquick3d-everywhere-src-5.15.6$

J'avais tenté d'installer avant QtQuick 3D comme indiqué dans la page que tu donnes en lien.

et tu n’as eut aucune erreur pour la compilation de QtQuick 3D ?

Dernière modification par eric63 (Le 26/12/2022, à 14:52)


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#18 Le 30/10/2023, à 14:35

eric63

Re : [Le retour pour 2024.02] Plus de bureaux en cube pour plasma 5.23

Bonne nouvelle le cube revient big_smile
Bon il faudra encore attendre un peu que plasma6 s’invite dans nos PCs début février 2024 mais sincèrement ça me manquait.
cube plasma

Dernière modification par eric63 (Le 30/10/2023, à 14:37)


Kubuntu 24.04 - 64 bits + backports bêta = plasma 5.27.11 KDE 5.115.0 Qt 5.15.13 et noyau 6.8.0-31  Asus B760+D4  i5-12400F 4.4Ghz DDR4 32Go nvidia RTX 3060 12GB 3écrans
Comment installer une brother avec le script de demonipuch
J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne