Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/04/2021, à 20:16

xunil2003

impossible d'installer avec pip de python 2.7.12 une classe

Bonjour,

J'a n'arrive pas a installer quoi ue ce soi avec pip de Python 2.7.12

laurent@MSI-GT780DX:~$ pip install dlna
Traceback (most recent call last):
  File "/home/laurent/.local/bin/pip", line 7, in <module>
    from pip._internal.cli.main import main
  File "/home/laurent/.local/lib/python2.7/site-packages/pip/_internal/cli/main.py", line 60
    sys.stderr.write(f"ERROR: {exc}")
                                   ^
SyntaxError: invalid syntax
laurent@MSI-GT780DX:~$ 

ma distrib

laurent@MSI-GT780DX:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.7 LTS
Release:        16.04
Codename:       xenial
laurent@MSI-GT780DX:~$ 

Comment puis-je faire ?

Merci d'avnce pour vos avis et conseils.


- AMD R9 5950x 64 Go Ram / Intel Pentium I7 960 - 12 Go Ram - 6 T0 - Kubuntu 12.04 x64 / Kubuntu 14.04 x64 / Kubuntu 16.04 x64 / Kubuntu 18.04 x64 /  Kubuntu 20.04 x64 / Mint
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4
- Raspberry PI 1 / Raspberry PI 2 / Raspberry PI 3 / Raspberry PI 4 : 4Gb
JE SUIS CHARLIE

Hors ligne

#2 Le 30/04/2021, à 20:22

MPython Alaplancha

Re : impossible d'installer avec pip de python 2.7.12 une classe

Bonjour,
Il te faut utiliser pip3 avec un module écrit en python3 comme pour ton cas.

pip3 install dlna

# Là pour le plaisir de découvrir ...
# Envie d'apprendre Bash ou Python? Pensez aux MOOC ---> https://forum.ubuntu-fr.org/viewtopic.php?id=2030646

Hors ligne

#3 Le 30/04/2021, à 20:27

MPython Alaplancha

Re : impossible d'installer avec pip de python 2.7.12 une classe

et il me semble que sur la 16.04, il faut avoir recours à un PPA pour installer python3.6...

édit: J'ai vérifié. Sur la 16.04, c'est python3.5 par défaut d'ou l'exception syntax error sur l'écriture du Fstring qui existe à partir de python3.6

doc extrait a écrit :

Ubuntu 16.04

La dernière version (3.6) n'est pas dans les dépots de la dernière LTS 16.04.
La version 3.6 comporte des différences significatives par rapport à la version précédente (entre autres avec les F String) et peut être nécessaire.

Pour installer Python 3.6 avec Ubuntu 16.04, il faut ajouter un ppa :

    soit jonathonf/python-3.6
    soit deadsnakes/ppa

Puis on installe Python 3.6.

Les commandes complètes avec, par exemple, jonathon ppa :

$ sudo add-apt-repository ppa:jonathonf/python-3.6
$ sudo apt update
$ sudo apt install python3.6

Pour invoquer l'interpréteur, il faut taper python3 ou python3.6 !

Je crois que deadsnakes/ppa propose python3.7 (à vérifier)

Dernière modification par MPython Alaplancha (Le 30/04/2021, à 20:44)


# Là pour le plaisir de découvrir ...
# Envie d'apprendre Bash ou Python? Pensez aux MOOC ---> https://forum.ubuntu-fr.org/viewtopic.php?id=2030646

Hors ligne

#4 Le 30/04/2021, à 21:15

xunil2003

Re : impossible d'installer avec pip de python 2.7.12 une classe

Re,

J'ai installer la version 0.1.5 qui égl ou supérieur a python 3.3
https://pypi.org/project/dlna/0.1.5/

laurent@MSI-GT780DX:~$ sudo  pip3 install dlna==0.1.5
The directory '/home/laurent/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.                                                                                                                                
The directory '/home/laurent/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.                                                                                                                                       
Requirement already satisfied (use --upgrade to upgrade): dlna==0.1.5 in ./.local/lib/python3.5/site-packages
Requirement already satisfied (use --upgrade to upgrade): urllib3 in ./.local/lib/python3.5/site-packages (from dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): Twisted in ./.local/lib/python3.5/site-packages (from dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): requests in ./.local/lib/python3.5/site-packages (from dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): lxml in ./.local/lib/python3.5/site-packages (from dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): hyperlink>=17.1.1 in ./.local/lib/python3.5/site-packages (from Twisted->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): attrs>=19.2.0 in ./.local/lib/python3.5/site-packages (from Twisted->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): incremental>=16.10.1 in ./.local/lib/python3.5/site-packages (from Twisted->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): zope.interface>=4.4.2 in ./.local/lib/python3.5/site-packages (from Twisted->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): constantly>=15.1 in ./.local/lib/python3.5/site-packages (from Twisted->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): Automat>=0.8.0 in ./.local/lib/python3.5/site-packages (from Twisted->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): idna<3,>=2.5 in ./.local/lib/python3.5/site-packages (from requests->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): chardet<5,>=3.0.2 in ./.local/lib/python3.5/site-packages (from requests->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): certifi>=2017.4.17 in ./.local/lib/python3.5/site-packages (from requests->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): setuptools in ./.local/lib/python3.5/site-packages (from zope.interface>=4.4.2->Twisted->dlna==0.1.5)
Requirement already satisfied (use --upgrade to upgrade): six in ./.local/lib/python3.5/site-packages (from Automat>=0.8.0->Twisted->dlna==0.1.5)
You are using pip version 8.1.1, however version 21.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.                                                                                                                   
laurent@MSI-GT780DX:~$

j'ai toujours le même proleme

laurent@MSI-GT780DX:~$ /home/laurent/.local/bin/dlna device
Traceback (most recent call last):
  File "/home/laurent/.local/bin/dlna", line 7, in <module>
    from dlna.client import run
  File "/home/laurent/.local/lib/python3.5/site-packages/dlna/client.py", line 16
    print(f"=> Device {i}:\n{json.dumps(d, ensure_ascii=False, indent=4)}\n")
                                                                           ^
SyntaxError: invalid syntax
laurent@MSI-GT780DX:~$ 
laurent@MSI-GT780DX:~$ ls -al /home/laurent/.local/bin/dlna
-rwxrwxr-x 1 laurent laurent 211 avril 30 21:57 /home/laurent/.local/bin/dlna
laurent@MSI-GT780DX:~$ 

Merci.


- AMD R9 5950x 64 Go Ram / Intel Pentium I7 960 - 12 Go Ram - 6 T0 - Kubuntu 12.04 x64 / Kubuntu 14.04 x64 / Kubuntu 16.04 x64 / Kubuntu 18.04 x64 /  Kubuntu 20.04 x64 / Mint
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4
- Raspberry PI 1 / Raspberry PI 2 / Raspberry PI 3 / Raspberry PI 4 : 4Gb
JE SUIS CHARLIE

Hors ligne

#5 Le 30/04/2021, à 21:26

MPython Alaplancha

Re : impossible d'installer avec pip de python 2.7.12 une classe

L'erreur est explicite:

print(f"=> Device {i}:\n{json.dumps(d, ensure_ascii=False, indent=4)}\n")
                                                                           ^
SyntaxError: invalid syntax

Il ne digère pas les Fstring (print(f"...")). wink
Quelle est la version de ton python3?

python3 --version

# Là pour le plaisir de découvrir ...
# Envie d'apprendre Bash ou Python? Pensez aux MOOC ---> https://forum.ubuntu-fr.org/viewtopic.php?id=2030646

Hors ligne

#6 Le 30/04/2021, à 22:12

beuguissime

Re : impossible d'installer avec pip de python 2.7.12 une classe

Salut,

Attention à être très vigilant en forçant une montée de version de python (via une installation globale avec sudo apt). C'est une brique fondamentale du système d'exploitation et c'est un coup à mettre tout le SE en vrac. Perso, je pratique plus ce genre de chose. Si je me souviens bien, pseudofab a documenté une telle procédure dans un des fils de ce forum pour son propre cas.

Sinon, oui, ton problème est lié à l'usage des f-string qui nécessite une version minimale bien spécifique de python3.

Bonne chance.

Hors ligne

#7 Le 30/04/2021, à 22:36

iznobe

Re : impossible d'installer avec pip de python 2.7.12 une classe

xunil2003 a écrit :
laurent@MSI-GT780DX:~$ sudo  pip3 install dlna==0.1.5
The directory '/home/laurent/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.                                                                                                                                
The directory '/home/laurent/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.   

Bonjour , ca m' etonnerait qu on t '  es dit d' utiliser sudo et pip dans la meme commande ...

d ' ou toutes les erreurs de permissions cité ci - dessus !

terminal a écrit :

the permissions and owner of that directory. If executing pip with sudo

terminal a écrit :

or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory.

Dernière modification par iznobe (Le 30/04/2021, à 22:47)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#8 Le 30/04/2021, à 23:17

beuguissime

Re : impossible d'installer avec pip de python 2.7.12 une classe

Ah oui tiens, je n'avais pas fait attention au sudo pip. Comme le relève iznobe, c'est aussi un bon moyen de mettre en vrac le système de dépendances géré par APT.

Installe les modules python tiers en local en exécutant pip ou pip3 comme simple utilisateur.

Hors ligne

#9 Le 30/04/2021, à 23:24

MPython Alaplancha

Re : impossible d'installer avec pip de python 2.7.12 une classe

beuguissime a écrit :

Si je me souviens bien, pseudofab a documenté une telle procédure dans un des fils de ce forum pour son propre cas.

Tu évoques la proposition de metalux?
https://forum.ubuntu-fr.org/viewtopic.p … #p21980479 ?


# Là pour le plaisir de découvrir ...
# Envie d'apprendre Bash ou Python? Pensez aux MOOC ---> https://forum.ubuntu-fr.org/viewtopic.php?id=2030646

Hors ligne

#10 Le 30/04/2021, à 23:34

beuguissime

Re : impossible d'installer avec pip de python 2.7.12 une classe

Exact, j'avais souvenir d'avoir survolé cette discussion qui évoquait le problème des f-string (et leur expérimentation dans le cadre d'un mooc).

Hors ligne