Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/11/2020, à 03:29

abecidofugy

WSL avant de commencer

Salut,

Je viens de lire tous les topics consacrés à WSL dans cette section, en passant par le moteur de recherche du forum.

Mais j’avais néanmoins quelques questions avant installation. C’est parti.

— peut-on passer d’une LTS Ubuntu à l’autre, en sous système. En gros, je ne voudrais pas devoir tout réinstaller dans 1 an et demi, date de sortie de la prochaine LTS
— peut-on utiliser Visual Studio Code Windows avec des fichiers sous le sous-système Linux ?
— peut-on utiliser Firefox dans WSL pour avoir du live preview (gulp-cli) si je développais un thème sous Windows ?
— peut-on utiliser Dreamweaver (dont je paie la licence avec le Creative Cloud d’Adobe) question qui rejoint un peu la 2)
— question subsidiaire : vous pensez que Choqok pourrait passer ?

J’envisage WSL car pour l‘instant je ne peux plus jouir de mon double-boot vu que la box SFR est « subitement devenue incompatible avec Linux » (mise à jour de leur firmware de m*rde, de leur boîte de m*rde !).

J’ai aussi une VM Virtualbox, mais je la trouve lente. Et si WSL répondait à mes question 2 et 4, ça serait un énorme plus puisque que je pourrais bosser un peu comme sous un Mac…

Merci de vos réponses.

Dernière modification par abecidofugy (Le 18/11/2020, à 19:37)


Kubuntu et KDE neon 20.04.1 LTS en VM dans host Windows 10 (24 Go de ram) / Kubuntu en double-boot avec Win10 / Ubuntu 16.04 et 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print
Sur Element (ancien Riot) : @patricius:matrix.org

Hors ligne

#2 Le 18/11/2020, à 10:26

geole

Re : WSL avant de commencer

Bonjour
Je vais te donner une réponse très rapide
1)  Pour  la mise à niveau.   Cela ne pourra pas être pire que sous ubuntu
      Je te donnerais un réponse plus précise lorsque j'aurais booté en windows
2) Tu peux utiliser tous les outils graphiques que tu souhaites.
3)  En version 16.04, le bureau était installable facilement. Avec ubuntu 20.04,   je ne ne sais pas faire sous ubuntu, je pense que c'est à  cause de l'abandon de X11 par ubuntu   
4) Le firefox standard se lance sans difficulté en frappant la commande

firefox

5) Je te donnerais  aussi le retour de cette commande

sudo apt install Choqok

   Si en plus, cela résout le problème du bureau gnome

5) Il existe deux versions de WSL, le wsl1 (ancien) et le wsl2 (nouveau)
Je n'ai pas réussi a migré   : Au bout de quelques heures  de moulinage, le logiciel m'a dit qu'il manquait des librairies...   J'ai donc tout recommencé en installant wsl2 et ubuntu 20.04. Du coup, je ne sais pas si la mise à niveau de la version  18.04 en 20.04 aurait réussi.

6)  Attention firefox existe aussi sous windows. Cela ferait doublon. Mais cela fonctionne

Dernière modification par geole (Le 18/11/2020, à 13:08)

Hors ligne

#3 Le 18/11/2020, à 12:30

maxire

Re : WSL avant de commencer

Salut,

Un complément, WSL2 n'est installable que si le processeur de la machine hôte possède les capacités de virtualisation ad hoc et que celles-ci sont activées dans le menu de paramétrage de firmware sinon c'est WSL1 qui est installé.

geole a écrit :

2) Tu peux utiliser tous les outils graphiques que tu souhaites.

À condition d'installer une version de serveur graphique X11 sous Windows tout de même comme celui fourni par Cygwin.


Maxire
Archlinux/Mate + Ubuntu 18.04 + Lubuntu 18.04 + Archlinux/Gnome + Windows 10 Familial sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#4 Le 18/11/2020, à 13:15

abecidofugy

Re : WSL avant de commencer

@maxire : oui, mon UEFI permet la virtualisation, c’est la même option que pour Virtualbox : https://zdnet4.cbsistatic.com/hub/i/201 … upport.jpg

Par contre, on peut utiliser Virtualbox ET WSL en même temps (ponctuellement bien sûr, car je ne vois pas pourquoi alourdir le flux de travail ^^).

@geole : très bien, j’attends tes retours.

Donc si j’ai bien compris, WSL est disponible à partir de tout l’environnement Windows, on n’a pas besoin de se mettre dans un « container » comme sous Virtualbox ? C’est génial qu’on puisse avoir pareillement la live preview à partir de Firefox Windows ou Firefox WSL.

Dernière question : la page WSL suffit et rassemble toutes les informations pour avoir un serveur graphique sous Ubuntu ?

Merci à vous.


Kubuntu et KDE neon 20.04.1 LTS en VM dans host Windows 10 (24 Go de ram) / Kubuntu en double-boot avec Win10 / Ubuntu 16.04 et 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print
Sur Element (ancien Riot) : @patricius:matrix.org

Hors ligne

#5 Le 18/11/2020, à 13:43

geole

Re : WSL avant de commencer

En fait  Microsoft  sait s’adapter
Il livre maintenant WSL2 qui est son O.S. de base. Celui-ci travaille en virtuel avec pas mal d’O.S. libres mais actuellement très peu de logiciels windows:   Que windows 10    en version récente.   J’ai vu un schéma très  clair. ===> https://blog.eleven-labs.com/assets/201 … ecture.png
J’utilise  XMING pour gérer le graphisme X11.  En cela j’ai suivi la documentation de ubuntu et de pas mal de liens vus dans internet

Pour le moment, je dois patienter un peu pour la mise à jour

 sudo apt update
Hit:1 http://archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://archive.ubuntu.com/ubuntu focal-updates InRelease [111 kB]
Get:3 http://archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Get:4 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Reading package lists... Done
E: Release file for http://archive.ubuntu.com/ubuntu/dists/focal-updates/InRelease is not valid yet (invalid for another 17min 7s). Updates for this repository will not be applied.
E: Release file for http://archive.ubuntu.com/ubuntu/dists/focal-backports/InRelease is not valid yet (invalid for another 17min 30s). Updates for this repository will not be applied.
E: Release file for http://security.ubuntu.com/ubuntu/dists/focal-security/InRelease is not valid yet (invalid for another 16min 55s). Updates for this repository will not be applied.


cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.1 LTS"


sudo do-release-upgrade -d
Checking for a new Ubuntu release
There is no development version of an LTS available.
To upgrade to the latest non-LTS development release
set Prompt=normal in /etc/update-manager/release-upgrades.

Puis après correction du fichier

 sudo do-release-upgrade -d
Checking for a new Ubuntu release
Upgrades to the development release are only
available from the latest supported release.

Il faudrait donc que je passe en 20.10. avec cette commande

sudo do-release-upgrade

Elle a pas mal téléchargé.  J ai réussi à stopper tant bien que mal. Cela sera pour plus tard. Le mécanisme est  bien présent.

Dernière modification par geole (Le 18/11/2020, à 14:08)

Hors ligne

#6 Le 18/11/2020, à 14:50

geole

Re : WSL avant de commencer

Voila le flacon de PAIC

sudo apt update
Get:1 http://security.ubuntu.com/ubuntu groovy-security InRelease [108 kB]
Hit:2 http://archive.ubuntu.com/ubuntu groovy InRelease
Get:3 http://archive.ubuntu.com/ubuntu groovy-updates InRelease [108 kB]
Hit:4 http://archive.ubuntu.com/ubuntu groovy-backports InRelease
Get:5 http://security.ubuntu.com/ubuntu groovy-security/main amd64 Packages [92.2 kB]
Get:6 http://security.ubuntu.com/ubuntu groovy-security/universe amd64 Packages [22.2 kB]
Fetched 331 kB in 1s (352 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.


sudo apt install choqok
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  bsdmainutils calendar libdns-export1109 libffi7 libhogweed5 libicu66 libjson-c4 libmpdec2 libnettle7 ncal popularity-contest python3-entrypoints
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  acl adwaita-icon-theme apg aptdaemon aptdaemon-data aspell aspell-en at-spi2-core avahi-daemon avahi-utils bluez bubblewrap cheese-common colord colord-data cracklib-runtime crda cups-pk-helper
  dconf-cli dictionaries-common dns-root-data dnsmasq-base docbook-xml emacsen-common enchant-2 evolution-data-server evolution-data-server-common fontconfig fprintd gcr gdm3 geoclue-2.0
  gir1.2-accountsservice-1.0 gir1.2-atk-1.0 gir1.2-atspi-2.0 gir1.2-freedesktop gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-gdm-1.0 gir1.2-geoclue-2.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-graphene-1.0 gir1.2-gtk-3.0 gir1.2-gweather-3.0 gir1.2-harfbuzz-0.0 gir1.2-ibus-1.0 gir1.2-json-1.0 gir1.2-mutter-7 gir1.2-nm-1.0
  gir1.2-nma-1.0 gir1.2-notify-0.7 gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-rsvg-2.0 gir1.2-secret-1 gir1.2-soup-2.4 gir1.2-upowerglib-1.0 gir1.2-vte-2.91 gjs gkbd-capplet gnome-control-center
  gnome-control-center-data gnome-control-center-faces gnome-desktop3-data gnome-keyring gnome-keyring-pkcs11 gnome-menus gnome-online-accounts gnome-session gnome-session-bin
  gnome-session-common gnome-settings-daemon gnome-settings-daemon-common gnome-shell gnome-shell-common gnome-startup-applications gnome-user-docs gstreamer1.0-clutter-3.0 gstreamer1.0-gl
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-x gtk-update-icon-cache hicolor-icon-theme humanity-icon-theme hunspell-en-us i965-va-driver ibus
  ibus-data ibus-gtk ibus-gtk3 iio-sensor-proxy im-config intel-media-va-driver ipp-usb iw kaccounts-providers kactivities-bin kactivitymanagerd kde-cli-tools kde-cli-tools-data kdeconnect kded5
  keditbookmarks kio kpackagelauncherqml kpackagetool5 kpeople-vcard kwayland-data kwayland-integration language-selector-gnome libaa1 libaacs0 libaccounts-glib0 libaccounts-qt5-1 libaom0
  libappindicator3-1 libasound2-plugins libaspell15 libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data libatspi2.0-0 libavahi-client3 libavahi-common-data libavahi-common3 libavahi-core7
  libavahi-glib1 libavc1394-0 libavcodec58 libavformat58 libavutil56 libbdplus0 libbluetooth3 libbluray2 libboost-thread1.71.0 libcaca0 libcairo-gobject2 libcairo2 libcamel-1.2-62
  libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra-pulse libcdparanoia0 libcheese-gtk25 libcheese8 libchromaprint1 libclutter-1.0-0 libclutter-1.0-common libclutter-gst-3.0-0
  libclutter-gtk-1.0-0 libcodec2-0.9 libcogl-common libcogl-pango20 libcogl-path20 libcogl20 libcolord-gtk1 libcolord2 libcolorhug2 libcrack2 libcups2 libdaemon0 libdatrie1 libdav1d4
  libdbus-glib-1-2 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdbusmenu-qt5-2 libdouble-conversion3 libdv4 libebackend-1.2-10 libebook-1.2-20 libebook-contacts-1.2-3 libecal-2.0-1
  libedata-book-1.2-26 libedata-cal-2.0-1 libedataserver-1.2-25 libedataserverui-1.2-2 libegl-mesa0 libegl1 libenchant-2-2 libepoxy0 libevdev2 libexif12 libfakekey0 libfam0 libfprint-2-2
  libgail-common libgail18 libgbm1 libgck-1-0 libgcr-base-3-1 libgcr-ui-3-1 libgd3 libgdata-common libgdata22 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgdm1 libgee-0.8-2
  libgeoclue-2-0 libgeocode-glib0 libgjs0g libgles2 libgme0 libgnome-autoar-0-0 libgnome-bluetooth13 libgnome-desktop-3-19 libgnomekbd-common libgnomekbd8 libgoa-1.0-0b libgoa-1.0-common
  libgoa-backend-1.0-1 libgomp1 libgpgmepp6 libgphoto2-6 libgphoto2-l10n libgphoto2-port12 libgraphene-1.0-0 libgraphite2-3 libgsm1 libgsound0 libgssdp-1.2-0 libgstreamer-gl1.0-0
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtop-2.0-11 libgtop2-common libgupnp-1.2-0
  libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libgweather-3-16 libgweather-common libhandy-1-0 libharfbuzz-icu0 libharfbuzz0b libhfstospell11 libhunspell-1.7-0 libhyphen0 libibus-1.0-5 libical3
  libiec61883-0 libieee1284-3 libigdgmm11 libimobiledevice6 libinput-bin libinput10 libjack-jackd2-0 libjansson4 libjavascriptcoregtk-4.0-18 libjbig0 libjpeg-turbo8 libjpeg8 libkaccounts2
  libkf5activities5 libkf5archive5 libkf5attica5 libkf5auth-data libkf5auth5 libkf5authcore5 libkf5bluezqt-data libkf5bluezqt6 libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5
  libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5
  libkf5contacts-data libkf5contacts5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data libkf5declarative5
  libkf5doctools5 libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5 libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5
  libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5 libkf5idletime5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5
  libkf5kcmutils-data libkf5kcmutils5 libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiogui5 libkf5kiontlm5 libkf5kiowidgets5 libkf5kirigami2-5 libkf5notifications-data libkf5notifications5
  libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5people-data libkf5people5 libkf5peoplebackend5
  libkf5peoplewidgets5 libkf5plasma5 libkf5plasmaquick5 libkf5pty-data libkf5pty5 libkf5pulseaudioqt2 libkf5purpose-bin libkf5purpose5 libkf5quickaddons5 libkf5service-bin libkf5service-data
  libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5su-bin libkf5su-data libkf5su5 libkf5textwidgets-data libkf5textwidgets5
  libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5waylandclient5 libkf5webkit5 libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-bin
  libkf5xmlgui-data libkf5xmlgui5 libkwalletbackend5-5 libkworkspace5-5 liblcms2-2 libldb2 libmbim-glib4 libmbim-proxy libmd4c0 libmediaart-2.0-0 libmfx1 libminizip1 libmm-glib0 libmozjs-78-0
  libmp3lame0 libmpg123-0 libmtdev1 libmutter-7-0 libmysqlclient21 libndp0 libnl-3-200 libnl-genl-3-200 libnl-route-3-200 libnm0 libnma-common libnma0 libnorm1 libnotify4 libnspr4 libnss-mdns
  libnss3 libopenjp2-7 libopenmpt0 libopus0 liborc-0.4-0 libpam-fprintd libpam-gnome-keyring libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libpcre2-16-0 libpcsclite1
  libpgm-5.2-0 libphonenumber7 libpixman-1-0 libplist3 libpolkit-qt5-1-1 libpoppler-glib8 libpoppler102 libprotobuf23 libpulse-mainloop-glib0 libpwquality-common libpwquality1 libqca-qt5-2
  libqca-qt5-2-plugins libqmi-glib5 libqmi-proxy libqt5core5a libqt5dbus5 libqt5gui5 libqt5multimedia5 libqt5network5 libqt5networkauth5 libqt5positioning5 libqt5printsupport5 libqt5qml5
  libqt5qmlmodels5 libqt5qmlworkerscript5 libqt5quick5 libqt5quickcontrols2-5 libqt5quickparticles5 libqt5quicktemplates2-5 libqt5quickwidgets5 libqt5sensors5 libqt5sql5 libqt5sql5-sqlite
  libqt5svg5 libqt5texttospeech5 libqt5waylandclient5 libqt5waylandcompositor5 libqt5webchannel5 libqt5webengine-data libqt5webenginecore5 libqt5webenginewidgets5 libqt5webkit5 libqt5widgets5
  libqt5x11extras5 libqt5xml5 librabbitmq4 libraw1394-11 libre2-8 librest-0.7-0 librsvg2-2 librsvg2-common librygel-core-2.6-2 librygel-db-2.6-2 librygel-renderer-2.6-2 librygel-server-2.6-2
  libsamplerate0 libsane-common libsane1 libsbc1 libsecret-1-0 libsecret-common libshine3 libshout3 libsignon-plugins-common1 libsignon-qt5-1 libsmbclient libsnapd-glib1 libsnappy1v5 libsnmp-base
  libsnmp35 libsoup-gnome2.4-1 libsoxr0 libspeechd2 libspeex1 libspeexdsp1 libsrt1-gnutls libssh-gcrypt-4 libstartup-notification0 libswresample3 libtag1v5 libtag1v5-vanilla libtalloc2 libtcl8.6
  libteamdctl0 libtelepathy-qt5-0 libtevent0 libthai-data libthai0 libtheora0 libtiff5 libtwolame0 libudisks2-0 libupower-glib3 libusbmuxd6 libv4l-0 libv4lconvert0 libva-drm2 libva-x11-2 libva2
  libvdpau1 libvisual-0.4-0 libvoikko1 libvpx6 libvte-2.91-0 libvte-2.91-common libwacom-bin libwacom-common libwacom2 libwavpack1 libwayland-cursor0 libwayland-egl1 libwayland-server0
  libwbclient0 libwebkit2gtk-4.0-37 libwebp6 libwebpdemux2 libwebpmux3 libwebrtc-audio-processing1 libwhoopsie-preferences0 libwhoopsie0 libwoff1 libx264-160 libx265-192 libxatracker2
  libxcb-composite0 libxcb-damage0 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-render-util0 libxcb-render0 libxcb-res0 libxcb-shm0 libxcb-util1 libxcb-xinerama0 libxcb-xinput0 libxcb-xkb1
  libxcb-xv0 libxcursor1 libxfont2 libxkbcommon-x11-0 libxkbcommon0 libxklavier16 libxss1 libxvidcore4 libxvmc1 libyelp0 libzmq5 libzvbi-common libzvbi0 media-player-info mesa-va-drivers
  mesa-vdpau-drivers mobile-broadband-provider-info modemmanager mutter-common mysql-common network-manager network-manager-gnome network-manager-pptp ocl-icd-libopencl1 p11-kit p11-kit-modules
  pinentry-gnome3 plasma-framework poppler-data ppp pptp-linux pulseaudio pulseaudio-module-bluetooth python3-aptdaemon python3-aptdaemon.gtk3widgets python3-cairo python3-cups
  python3-cupshelpers python3-defer python3-ibus-1.0 python3-ldb python3-macaroonbakery python3-protobuf python3-rfc3339 python3-talloc python3-tz qml-module-org-kde-bluezqt
  qml-module-org-kde-kconfig qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-people qml-module-org-kde-purpose
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtgraphicaleffects qml-module-qtqml qml-module-qtqml-models2 qml-module-qtquick-controls qml-module-qtquick-controls2
  qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qtquick-particles2 qml-module-qtquick-privatewidgets qml-module-qtquick-templates2 qml-module-qtquick-window2
  qml-module-qtquick2 qml-module-ubuntu-onlineaccounts qt5-gtk-platformtheme qtspeech5-speechd-plugin qttranslations5-l10n qtwayland5 rtkit rygel samba-libs sane-utils session-migration sgml-base
  sgml-data signon-plugin-oauth2 sonnet-plugins sshfs switcheroo-control system-config-printer system-config-printer-common system-config-printer-udev tcl8.6 ubuntu-docs ubuntu-mono
  ubuntu-wallpapers ubuntu-wallpapers-groovy unzip update-inetd upower usb-modeswitch usb-modeswitch-data usbmuxd va-driver-all vdpau-driver-all wamerican whoopsie-preferences wireless-regdb
  wpasupplicant x11-xkb-utils x11-xserver-utils xdg-dbus-proxy xfonts-base xfonts-encodings xfonts-utils xml-core xserver-common xserver-xephyr xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-input-wacom xserver-xorg-legacy xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware xwayland yaru-theme-gnome-shell yelp
  yelp-xsl zenity zenity-common
Suggested packages:
  aspell-doc spellutils avahi-autoipd colord-sensor-argyll docbook docbook-dsssl docbook-xsl docbook-defguide evolution gnome-orca gnome-software | gnome-packagekit gnome-user-share realmd
  libcanberra-gtk-module desktop-base usbguard chrome-gnome-shell gir1.2-telepathyglib-0.12 gnome-themes-standard-data gnome-backgrounds gir1.2-telepathylogger-0.2 gvfs hunspell
  openoffice.org-hunspell | openoffice.org-core i965-va-driver-shaders ibus-clutter ibus-doc python3-nautilus indicator-application libbluray-bdj cups-common libdv-bin oss-compat
  libenchant-2-voikko fam libgd-tools gphoto2 libvisual-0.4-plugins libusbmuxd-tools jackd2 kde-telepathy-send-file liblcms2-utils avahi-autoipd | zeroconf opus-tools pcscd
  qt5-image-formats-plugins qt5-qmltooling-plugins libraw1394-doc librsvg2-bin hplip snmp-mibs-downloader speex voikko-fi gstreamer1.0-libav libteam-utils network-manager-openconnect-gnome
  network-manager-openvpn-gnome network-manager-vpnc-gnome network-manager-pptp-gnome opencl-icd pinentry-doc poppler-utils ghostscript fonts-japanese-mincho | fonts-ipafont-mincho
  fonts-japanese-gothic | fonts-ipafont-gothic fonts-arphic-ukai fonts-arphic-uming fonts-nanum pavumeter pavucontrol paman paprefs ubuntu-sounds gstreamer1.0-plugins-ugly rygel-playbin
  rygel-preferences rygel-ruih rygel-tracker tumbler unpaper sgml-base-doc perlsgml w3-recs opensp libxml2-utils hspell gnome-software python3-smbc tcl-tclreadline ubuntu-wallpapers-karmic
  ubuntu-wallpapers-lucid ubuntu-wallpapers-maverick ubuntu-wallpapers-natty ubuntu-wallpapers-oneiric ubuntu-wallpapers-precise ubuntu-wallpapers-quantal ubuntu-wallpapers-raring
  ubuntu-wallpapers-saucy ubuntu-wallpapers-trusty ubuntu-wallpapers-utopic ubuntu-wallpapers-vivid ubuntu-wallpapers-wily ubuntu-wallpapers-xenial ubuntu-wallpapers-yakkety
  ubuntu-wallpapers-zesty ubuntu-wallpapers-artful ubuntu-wallpapers-bionic ubuntu-wallpapers-cosmic ubuntu-wallpapers-disco ubuntu-wallpapers-eoan ubuntu-wallpapers-focal zip comgt wvdial
  libvdpau-va-gl1 wpagui libengine-pkcs11-openssl nickle cairo-5c xorg-docs-core debhelper xfonts-100dpi | xfonts-75dpi xfonts-scalable xinput firmware-amd-graphics xserver-xorg-video-r128
  xserver-xorg-video-mach64 firmware-misc-nonfree
The following NEW packages will be installed:
  acl adwaita-icon-theme apg aptdaemon aptdaemon-data aspell aspell-en at-spi2-core avahi-daemon avahi-utils bluez bubblewrap cheese-common choqok colord colord-data cracklib-runtime crda
  cups-pk-helper dconf-cli dictionaries-common dns-root-data dnsmasq-base docbook-xml emacsen-common enchant-2 evolution-data-server evolution-data-server-common fontconfig fprintd gcr gdm3
  geoclue-2.0 gir1.2-accountsservice-1.0 gir1.2-atk-1.0 gir1.2-atspi-2.0 gir1.2-freedesktop gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-gdm-1.0
  gir1.2-geoclue-2.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-graphene-1.0 gir1.2-gtk-3.0 gir1.2-gweather-3.0 gir1.2-harfbuzz-0.0 gir1.2-ibus-1.0 gir1.2-json-1.0 gir1.2-mutter-7
  gir1.2-nm-1.0 gir1.2-nma-1.0 gir1.2-notify-0.7 gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-rsvg-2.0 gir1.2-secret-1 gir1.2-soup-2.4 gir1.2-upowerglib-1.0 gir1.2-vte-2.91 gjs gkbd-capplet
  gnome-control-center gnome-control-center-data gnome-control-center-faces gnome-desktop3-data gnome-keyring gnome-keyring-pkcs11 gnome-menus gnome-online-accounts gnome-session
  gnome-session-bin gnome-session-common gnome-settings-daemon gnome-settings-daemon-common gnome-shell gnome-shell-common gnome-startup-applications gnome-user-docs gstreamer1.0-clutter-3.0
  gstreamer1.0-gl gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-x gtk-update-icon-cache hicolor-icon-theme humanity-icon-theme hunspell-en-us
  i965-va-driver ibus ibus-data ibus-gtk ibus-gtk3 iio-sensor-proxy im-config intel-media-va-driver ipp-usb iw kaccounts-providers kactivities-bin kactivitymanagerd kde-cli-tools
  kde-cli-tools-data kdeconnect kded5 keditbookmarks kio kpackagelauncherqml kpackagetool5 kpeople-vcard kwayland-data kwayland-integration language-selector-gnome libaa1 libaacs0
  libaccounts-glib0 libaccounts-qt5-1 libaom0 libappindicator3-1 libasound2-plugins libaspell15 libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data libatspi2.0-0 libavahi-client3 libavahi-common-data
  libavahi-common3 libavahi-core7 libavahi-glib1 libavc1394-0 libavcodec58 libavformat58 libavutil56 libbdplus0 libbluetooth3 libbluray2 libboost-thread1.71.0 libcaca0 libcairo-gobject2 libcairo2
  libcamel-1.2-62 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra-pulse libcdparanoia0 libcheese-gtk25 libcheese8 libchromaprint1 libclutter-1.0-0 libclutter-1.0-common
  libclutter-gst-3.0-0 libclutter-gtk-1.0-0 libcodec2-0.9 libcogl-common libcogl-pango20 libcogl-path20 libcogl20 libcolord-gtk1 libcolord2 libcolorhug2 libcrack2 libcups2 libdaemon0 libdatrie1
  libdav1d4 libdbus-glib-1-2 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdbusmenu-qt5-2 libdouble-conversion3 libdv4 libebackend-1.2-10 libebook-1.2-20 libebook-contacts-1.2-3 libecal-2.0-1
  libedata-book-1.2-26 libedata-cal-2.0-1 libedataserver-1.2-25 libedataserverui-1.2-2 libegl-mesa0 libegl1 libenchant-2-2 libepoxy0 libevdev2 libexif12 libfakekey0 libfam0 libfprint-2-2
  libgail-common libgail18 libgbm1 libgck-1-0 libgcr-base-3-1 libgcr-ui-3-1 libgd3 libgdata-common libgdata22 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgdm1 libgee-0.8-2
  libgeoclue-2-0 libgeocode-glib0 libgjs0g libgles2 libgme0 libgnome-autoar-0-0 libgnome-bluetooth13 libgnome-desktop-3-19 libgnomekbd-common libgnomekbd8 libgoa-1.0-0b libgoa-1.0-common
  libgoa-backend-1.0-1 libgomp1 libgpgmepp6 libgphoto2-6 libgphoto2-l10n libgphoto2-port12 libgraphene-1.0-0 libgraphite2-3 libgsm1 libgsound0 libgssdp-1.2-0 libgstreamer-gl1.0-0
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtop-2.0-11 libgtop2-common libgupnp-1.2-0
  libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libgweather-3-16 libgweather-common libhandy-1-0 libharfbuzz-icu0 libharfbuzz0b libhfstospell11 libhunspell-1.7-0 libhyphen0 libibus-1.0-5 libical3
  libiec61883-0 libieee1284-3 libigdgmm11 libimobiledevice6 libinput-bin libinput10 libjack-jackd2-0 libjansson4 libjavascriptcoregtk-4.0-18 libjbig0 libjpeg-turbo8 libjpeg8 libkaccounts2
  libkf5activities5 libkf5archive5 libkf5attica5 libkf5auth-data libkf5auth5 libkf5authcore5 libkf5bluezqt-data libkf5bluezqt6 libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5
  libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5
  libkf5contacts-data libkf5contacts5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data libkf5declarative5
  libkf5doctools5 libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5 libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5
  libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5 libkf5idletime5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5
  libkf5kcmutils-data libkf5kcmutils5 libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiogui5 libkf5kiontlm5 libkf5kiowidgets5 libkf5kirigami2-5 libkf5notifications-data libkf5notifications5
  libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5people-data libkf5people5 libkf5peoplebackend5
  libkf5peoplewidgets5 libkf5plasma5 libkf5plasmaquick5 libkf5pty-data libkf5pty5 libkf5pulseaudioqt2 libkf5purpose-bin libkf5purpose5 libkf5quickaddons5 libkf5service-bin libkf5service-data
  libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5su-bin libkf5su-data libkf5su5 libkf5textwidgets-data libkf5textwidgets5
  libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5waylandclient5 libkf5webkit5 libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-bin
  libkf5xmlgui-data libkf5xmlgui5 libkwalletbackend5-5 libkworkspace5-5 liblcms2-2 libldb2 libmbim-glib4 libmbim-proxy libmd4c0 libmediaart-2.0-0 libmfx1 libminizip1 libmm-glib0 libmozjs-78-0
  libmp3lame0 libmpg123-0 libmtdev1 libmutter-7-0 libmysqlclient21 libndp0 libnl-3-200 libnl-genl-3-200 libnl-route-3-200 libnm0 libnma-common libnma0 libnorm1 libnotify4 libnspr4 libnss-mdns
  libnss3 libopenjp2-7 libopenmpt0 libopus0 liborc-0.4-0 libpam-fprintd libpam-gnome-keyring libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libpcre2-16-0 libpcsclite1
  libpgm-5.2-0 libphonenumber7 libpixman-1-0 libplist3 libpolkit-qt5-1-1 libpoppler-glib8 libpoppler102 libprotobuf23 libpulse-mainloop-glib0 libpwquality-common libpwquality1 libqca-qt5-2
  libqca-qt5-2-plugins libqmi-glib5 libqmi-proxy libqt5core5a libqt5dbus5 libqt5gui5 libqt5multimedia5 libqt5network5 libqt5networkauth5 libqt5positioning5 libqt5printsupport5 libqt5qml5
  libqt5qmlmodels5 libqt5qmlworkerscript5 libqt5quick5 libqt5quickcontrols2-5 libqt5quickparticles5 libqt5quicktemplates2-5 libqt5quickwidgets5 libqt5sensors5 libqt5sql5 libqt5sql5-sqlite
  libqt5svg5 libqt5texttospeech5 libqt5waylandclient5 libqt5waylandcompositor5 libqt5webchannel5 libqt5webengine-data libqt5webenginecore5 libqt5webenginewidgets5 libqt5webkit5 libqt5widgets5
  libqt5x11extras5 libqt5xml5 librabbitmq4 libraw1394-11 libre2-8 librest-0.7-0 librsvg2-2 librsvg2-common librygel-core-2.6-2 librygel-db-2.6-2 librygel-renderer-2.6-2 librygel-server-2.6-2
  libsamplerate0 libsane-common libsane1 libsbc1 libsecret-1-0 libsecret-common libshine3 libshout3 libsignon-plugins-common1 libsignon-qt5-1 libsmbclient libsnapd-glib1 libsnappy1v5 libsnmp-base
  libsnmp35 libsoup-gnome2.4-1 libsoxr0 libspeechd2 libspeex1 libspeexdsp1 libsrt1-gnutls libssh-gcrypt-4 libstartup-notification0 libswresample3 libtag1v5 libtag1v5-vanilla libtalloc2 libtcl8.6
  libteamdctl0 libtelepathy-qt5-0 libtevent0 libthai-data libthai0 libtheora0 libtiff5 libtwolame0 libudisks2-0 libupower-glib3 libusbmuxd6 libv4l-0 libv4lconvert0 libva-drm2 libva-x11-2 libva2
  libvdpau1 libvisual-0.4-0 libvoikko1 libvpx6 libvte-2.91-0 libvte-2.91-common libwacom-bin libwacom-common libwacom2 libwavpack1 libwayland-cursor0 libwayland-egl1 libwayland-server0
  libwbclient0 libwebkit2gtk-4.0-37 libwebp6 libwebpdemux2 libwebpmux3 libwebrtc-audio-processing1 libwhoopsie-preferences0 libwhoopsie0 libwoff1 libx264-160 libx265-192 libxatracker2
  libxcb-composite0 libxcb-damage0 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-render-util0 libxcb-render0 libxcb-res0 libxcb-shm0 libxcb-util1 libxcb-xinerama0 libxcb-xinput0 libxcb-xkb1
  libxcb-xv0 libxcursor1 libxfont2 libxkbcommon-x11-0 libxkbcommon0 libxklavier16 libxss1 libxvidcore4 libxvmc1 libyelp0 libzmq5 libzvbi-common libzvbi0 media-player-info mesa-va-drivers
  mesa-vdpau-drivers mobile-broadband-provider-info modemmanager mutter-common mysql-common network-manager network-manager-gnome network-manager-pptp ocl-icd-libopencl1 p11-kit p11-kit-modules
  pinentry-gnome3 plasma-framework poppler-data ppp pptp-linux pulseaudio pulseaudio-module-bluetooth python3-aptdaemon python3-aptdaemon.gtk3widgets python3-cairo python3-cups
  python3-cupshelpers python3-defer python3-ibus-1.0 python3-ldb python3-macaroonbakery python3-protobuf python3-rfc3339 python3-talloc python3-tz qml-module-org-kde-bluezqt
  qml-module-org-kde-kconfig qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-people qml-module-org-kde-purpose
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtgraphicaleffects qml-module-qtqml qml-module-qtqml-models2 qml-module-qtquick-controls qml-module-qtquick-controls2
  qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qtquick-particles2 qml-module-qtquick-privatewidgets qml-module-qtquick-templates2 qml-module-qtquick-window2
  qml-module-qtquick2 qml-module-ubuntu-onlineaccounts qt5-gtk-platformtheme qtspeech5-speechd-plugin qttranslations5-l10n qtwayland5 rtkit rygel samba-libs sane-utils session-migration sgml-base
  sgml-data signon-plugin-oauth2 sonnet-plugins sshfs switcheroo-control system-config-printer system-config-printer-common system-config-printer-udev tcl8.6 ubuntu-docs ubuntu-mono
  ubuntu-wallpapers ubuntu-wallpapers-groovy unzip update-inetd upower usb-modeswitch usb-modeswitch-data usbmuxd va-driver-all vdpau-driver-all wamerican whoopsie-preferences wireless-regdb
  wpasupplicant x11-xkb-utils x11-xserver-utils xdg-dbus-proxy xfonts-base xfonts-encodings xfonts-utils xml-core xserver-common xserver-xephyr xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-input-wacom xserver-xorg-legacy xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware xwayland yaru-theme-gnome-shell yelp
  yelp-xsl zenity zenity-common
0 upgraded, 683 newly installed, 0 to remove and 0 not upgraded.
Need to get 257 MB/257 MB of archives.
After this operation, 1080 MB of additional disk space will be used.
Do you want to continue? [Y/n]

===> Je suis en train d'installer tous les paquets de la version 20.10 (groovy) !!!!!!!!!!!!!

Dernière modification par geole (Le 18/11/2020, à 14:55)

Hors ligne

#7 Le 18/11/2020, à 17:17

geole

Re : WSL avant de commencer

Puis une vaisselle nickel.   Mais je ne connais pas  l’application du "canari?" vert
1605719019.png
"In order to use Choqok you need an account at one of the supported micro-blogging services.
Would you like to add your account now?"

La trace de démarrage

gvim ESSAI.txt

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.10
DISTRIB_CODENAME=groovy
DISTRIB_DESCRIPTION="Ubuntu 20.10"



sudo choqok:
org.kde.choqok: Choqok  1.7.0
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
org.kde.choqok:
QCommandLineParser: already having an option named "h"
QCommandLineParser: already having an option named "help-all"
QCommandLineParser: already having an option named "v"
org.kde.choqok:
org.kde.choqok:
org.kde.choqok:
Icon theme "breeze" not found.
org.kde.choqok.lib:
org.kde.choqok.lib:
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.1'
org.kde.choqok.lib:
org.kde.choqok.lib: ()
org.kde.choqok.lib: 0 accounts loaded.
org.kde.choqok.lib: 0
org.kde.choqok:
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_nowlistening"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_nowlistening" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_filter"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_filter" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_quickfilter"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_quickfilter" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_searchaction"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_searchaction" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
kf.xmlgui: Shortcut for action  "search" "Search..." set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_imagepreview"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_imagepreview" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_untiny"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_untiny" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_videopreview"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_videopreview" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: All plugins loaded...
DESKTOP-5V9JT1E:~$
a@DESKTOP-5V9JT1E:~$
a@DESKTOP-5V9JT1E:~$ sudo choqok
[sudo] password for a:
org.kde.choqok: Choqok  1.7.0
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
org.kde.choqok:
QCommandLineParser: already having an option named "h"
QCommandLineParser: already having an option named "help-all"
QCommandLineParser: already having an option named "v"
org.kde.choqok:
org.kde.choqok:
org.kde.choqok:
Icon theme "breeze" not found.
org.kde.choqok.lib:
org.kde.choqok.lib:
QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.1'
org.kde.choqok.lib:
org.kde.choqok.lib: ()
org.kde.choqok.lib: 0 accounts loaded.
org.kde.choqok.lib: 0
org.kde.choqok:
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_nowlistening"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_nowlistening" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_filter"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_filter" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_quickfilter"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_quickfilter" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_searchaction"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_searchaction" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
kf.xmlgui: Shortcut for action  "search" "Search..." set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_imagepreview"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_imagepreview" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_untiny"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_untiny" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: Loading Plugin: "choqok_videopreview"
org.kde.choqok.lib: Successfully loaded plugin ' "choqok_videopreview" '
org.kde.choqok.lib: Emitting pluginLoaded()
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: All plugins loaded...

Et la trace du plantage....   Le package est-il au point en 20.10 pour la france?

org.kde.choqok.lib: Current LANG: "C"
org.kde.choqok.lib: All plugins loaded...
org.kde.choqok:
org.kde.choqok:
org.kde.choqok:
org.kde.choqok.lib:
org.kde.choqok.lib: 0
org.kde.choqok.lib:
Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.
kf.sonnet.clients.hspell: HSpellDict::HSpellDict: Init failed
kf.sonnet.core: No language dictionaries for the language: "C" trying to load en_US as default
org.kde.choqok.lib: Current LANG: "C"

Dernière modification par geole (Le 18/11/2020, à 18:00)

Hors ligne

#8 Le 18/11/2020, à 18:23

abecidofugy

Re : WSL avant de commencer

geole a écrit :

Et la trace du plantage....   Le package est-il au point en 20.10 pour la france?

C’est quelle version ? 1.7.0 ? Avec cette version-là, pas de souci sous 20.04


Kubuntu et KDE neon 20.04.1 LTS en VM dans host Windows 10 (24 Go de ram) / Kubuntu en double-boot avec Win10 / Ubuntu 16.04 et 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print
Sur Element (ancien Riot) : @patricius:matrix.org

Hors ligne

#9 Le 18/11/2020, à 18:47

geole

Re : WSL avant de commencer

sudo choqok:
org.kde.choqok: Choqok  1.7.0


En fait cela fonctionne peut-être. Il n'y a pas plantage. Mais je ne sais pas quoi faire avec... Cela semble être en attente  comme si c'était un serveur!

Hors ligne

#10 Le 18/11/2020, à 18:53

abecidofugy

Re : WSL avant de commencer

Il faut ajouter un compte Twitter, ou autre. Tu dois confirmer par un code. Le logiciel est simple à prendre en main. C’est super si ça marche.


Kubuntu et KDE neon 20.04.1 LTS en VM dans host Windows 10 (24 Go de ram) / Kubuntu en double-boot avec Win10 / Ubuntu 16.04 et 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print
Sur Element (ancien Riot) : @patricius:matrix.org

Hors ligne

#11 Le 18/11/2020, à 18:59

krodelabestiole

Re : WSL avant de commencer

abecidofugy a écrit :

— peut-on passer d’une LTS Ubuntu à l’autre, en sous système. En gros, je ne voudrais pas devoir tout réinstaller dans 1 an et demi, date de sortie de la prochaine LTS

mouais, mais perso j'évite ! en général il n'y a pas 10000 trucs à réinstaller / reconfigurer, il faut juste garder un backup de ses fichiers, des fichiers de config qu'on modifie et la liste des paquets installés manuellement.


abecidofugy a écrit :

— peut-on utiliser Visual Studio Code Windows avec des fichiers sous le sous-système Linux ?

oui, VSCode intègre parfaitement WSL.


abecidofugy a écrit :

— peut-on utiliser Dreamweaver (dont je paie la licence avec le Creative Cloud d’Adobe) question qui rejoint un peu la 2)

pour dreamweaver par contre, aucune idée.
je suppose qu'on pourra accéder aux fichiers depuis n'importe quel programme avec la commande wsl --mount (pour l'instant sur la preview)

Hors ligne

#12 Le 18/11/2020, à 20:06

abecidofugy

Re : WSL avant de commencer

@geole :  Le WSL ne permet pas de faire fonctionner n'importe quelle distribution : seules les versions LTS d'Ubuntu sont supportées. La première distribution Linux concernée fut Trusty (14.04), puis Xenial (16.04) et maintenant Bionic (18.04).

Extrait du wiki.


Kubuntu et KDE neon 20.04.1 LTS en VM dans host Windows 10 (24 Go de ram) / Kubuntu en double-boot avec Win10 / Ubuntu 16.04 et 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print
Sur Element (ancien Riot) : @patricius:matrix.org

Hors ligne

#13 Le 18/11/2020, à 21:18

maxire

Re : WSL avant de commencer

abecidofugy a écrit :

@geole :  Le WSL ne permet pas de faire fonctionner n'importe quelle distribution : seules les versions LTS d'Ubuntu sont supportées. La première distribution Linux concernée fut Trusty (14.04), puis Xenial (16.04) et maintenant Bionic (18.04).

Extrait du wiki.

Pas vraiment,  la dernière fois que j'ai testé WSL il me semble que  Debian était proposée par l'installateur Windows ainsi que quelques autres distributions, je cite de mémoire c'est à vérifier.


Maxire
Archlinux/Mate + Ubuntu 18.04 + Lubuntu 18.04 + Archlinux/Gnome + Windows 10 Familial sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#14 Le 18/11/2020, à 21:28

xubu1957

Re : WSL avant de commencer

Bonjour,

Dans > wikipedia/wiki/Windows_Subsystem_for_Linux#Vue_d'ensemble :

La première version de WSL fournit une interface noyau compatible Linux développée par Microsoft, qui ne contient aucun code source du noyau Linux. Cette interface permet d'exécuter un espace utilisateur GNU comme celui d'Ubuntu, openSUSE, SUSE Linux Enterprise Server, Debian ou Kali Linux. Un tel espace utilisateur peut contenir un shell Bash avec des outils en ligne de commande GNU / Linux natifs (sed, awk, etc.), des interpréteurs de langage de programmation (Ruby, Python, etc.) et même des applications graphiques (utilisant un serveur X11 côté hôte).

L'architecture a été repensée dans WSL2, avec un noyau Linux s'exécutant dans une machine virtuelle légère.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#15 Le 18/11/2020, à 21:32

krodelabestiole

Re : WSL avant de commencer

maxire a écrit :

Pas vraiment,  la dernière fois que j'ai testé WSL il me semble que  Debian était proposée par l'installateur Windows ainsi que quelques autres distributions, je cite de mémoire c'est à vérifier.

oui, mais en ce qui concerne ubuntu, seules les LTS sont dispos.

Hors ligne

#16 Le 19/11/2020, à 18:57

geole

Re : WSL avant de commencer

krodelabestiole a écrit :
maxire a écrit :

Pas vraiment,  la dernière fois que j'ai testé WSL il me semble que  Debian était proposée par l'installateur Windows ainsi que quelques autres distributions, je cite de mémoire c'est à vérifier.

oui, mais en ce qui concerne ubuntu, seules les LTS sont dispos.

Bonjour
Ne pas oublier qu'il existe la commande do-release-upgrade
que je n'ai pas su stopper suffisamment vite.   Donc je suis en version 20.10 sous windows depuis quelques jours!
voir do-release-upgrade -d
qui semble me télécharger du hirsute
Mais on me dit que ce n'est pas encore valide:  Cela serait  en cours de mise à jour et je dois attendre encore 16 minutes et 38 secondes!  On remet alors en état.

Hors ligne

#17 Le 20/11/2020, à 19:12

geole

Re : WSL avant de commencer

Voici la suite

ESKTOP-5V9JT1E:~$
a@DESKTOP-5V9JT1E:~$ sudo do-release-upgrade -d
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [819 B]
Get:2 Upgrade tool [1276 kB]
Fetched 1276 kB in 0s (0 B/s)
authenticate 'hirsute.tar.gz' against 'hirsute.tar.gz.gpg'
extracting 'hirsute.tar.gz'
[screen is terminating]
a@DESKTOP-5V9JT1E:~$
a@DESKTOP-5V9JT1E:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=21.04
DISTRIB_CODENAME=hirsute
DISTRIB_DESCRIPTION="Ubuntu Hirsute Hippo (development branch)"
a@DESKTOP-5V9JT1E:~$
a@DESKTOP-5V9JT1E:/boot$ ls -ls /boot
total 0
a@DESKTOP-5V9JT1E:/boot$

Tout c'est fait  assez classiquement et assez rapidement mais a été éliminé de l'écran lorsque terminé.

Hors ligne