Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/08/2020, à 13:22

ludique

[Résolu] Pb connexion NAS Synology

Bonjour,

Je n'arrive pas à installer correctement un NAS Synology (DS220j) sur une version 18.04.4.
J'ai suivi la procédure indiqué dans la doc Ubuntu : https://doc.ubuntu-fr.org/synology

Ca marcherai presque sauf que :
1 - Ca ne monte pas automatiquement
2 - Pour monter les répertoire je suis obligé d'utiliser sudo
3 - J'ai bien un accès en lecture à mon NAS. Mais dès que je veux ajouter ou supprimer un fichier je dois passer par sudo (tout ca n'est pas surprenant vraiment puisque les répertoires dans média appartiennent à root).

Et je ne m'en sort pas ...
Si qq'1 a une idée.

Ludique

Dernière modification par Ayral (Le 02/08/2020, à 18:29)

Hors ligne

#2 Le 01/08/2020, à 13:26

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Pour commencer, donne le contenu de ces deux fichiers :

cat /etc/hosts
cat /etc/fstab

Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#3 Le 01/08/2020, à 13:36

ludique

Re : [Résolu] Pb connexion NAS Synology

Donc j'ai :

127.0.0.1	localhost
127.0.1.1	bobo12
192.168.1.17    Gargamelle

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

et :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=f229d252-8568-41cd-9da1-bf852f1fc73d /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
#UUID=D835-67C8  /boot/efi       vfat    umask=0077      0       1
# /fichiers was on /dev/sdb1 during installation
UUID=0ddd761b-b2b4-475c-b822-410007ab004b /fichiers       ext4    defaults        0       2
# /home was on /dev/sda4 during installation
UUID=3ebc6f2f-48e6-4d85-81e9-b541774963e9 /home           ext4    defaults        0       2
# swap was on /dev/sda3 during installation
UUID=16fad589-cb75-4195-9b99-93f7da814c2f none            swap    sw              0       0
#
UUID=269fdda8-5924-4492-ae50-a2a112617d06 /fichiers2 auto nosuid,nodev,nofail 0 0

/dev/disk/by-id/usb-Corsair_VoyagerGT_A408000000000494-0:0-part2 /mnt/usb-Corsair_VoyagerGT_A408000000000494-0:0-part2 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0
/dev/disk/by-id/usb-Corsair_VoyagerGT_A408000000000494-0:0-part1 /mnt/usb-Corsair_VoyagerGT_A408000000000494-0:0-part1 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0
UUID=D835-67C8	/boot/efi	vfat	defaults	0	1
UUID=7f53f234-48d8-4414-8907-8815150b24f9 /fichiers3 auto nosuid,nodev,nofail 0 0



##########################################################
# Modifié pour monter les dir partagés du syno  au boot  #
##########################################################

//Gargamelle/Jean/	/media/bobo12/Nas_Jean		cifs	_netdev,credentials=/home/bobo12/.Jean,auto,rw 0 0
//Gargamelle/Josette/	/media/bobo12/Nas_Josette 	cifs	_netdev,credentials=/home/bobo12/.Jean,auto,rw 0 0
//Gargamelle/Video/	/media/bobo12/Nas_Video 	cifs	_netdev,credentials=/home/bobo12/.Jean,auto,rw 0 0
//Gargamelle/music/	/media/bobo12/Nas_Musique 	cifs	_netdev,credentials=/home/bobo12/.Jean,auto,rw 0 0
//Gargamelle/Photo/	/media/bobo12/Nas_Photo 	cifs	_netdev,credentials=/home/bobo12/.Jean,auto,rw 0 0
##Note : Pour utiliser le nfs 
#Syno:/volume1/photo /media/deadbox1/Syno_Photo nfs _netdev,auto,rw 0 0

Hors ligne

#4 Le 01/08/2020, à 15:20

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Et donc, les points de montage ne se montent pas automatiquement au boot ? Càd que les dossiers /media/bobo12/Nas_Jean, etc. sont vides ?

Tu es sûr de l'adresse IP du NAS ?

Tu as bien créé un compte sur le NAS qui correspond à celui que tu as déclaré dans le fichier /home/bobo12/.Jean ? et il a les droits d'accès aux dossiers qui sont partagés du côté du NAS ?


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#5 Le 01/08/2020, à 15:47

ludique

Re : [Résolu] Pb connexion NAS Synology

IL ne sont pas montés. Lorsque j’essaie de les monter j'ai un message "... Opération permitted for root only"

Si je lance Nautilus avec sudo je peux les monter.
Si je sors et que je relance Nautilus je peux lire mais pas écrire.
Si je relance Nautilus avec sudo jepeux écrire ...

Je n'ai aucun droit sur ces partage tant que je nuis pas en sudo. Je peux juste lire.

Dernière modification par ludique (Le 01/08/2020, à 15:53)

Hors ligne

#6 Le 01/08/2020, à 15:57

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Pour être sûr de la situation, au boot (sans monter les montages manuellement) :

ls -l /media/bobo12
sudo ls /media/bobo12/Nas_Jean

Pour la deuxième commande, inutile de donner la liste des fichiers éventuelle, dis-moi juste si ça liste des fichiers ou si le dossier est vide.

Et pour les autres questions, donc ? L'utilisateur que tu as créé sur le NAS − et que tu as déclaré dans le dossier de credentials − a bien les droits de lecture/écriture sur les dossiers que tu partages ? Si tu te connectes avec en utilisant l'interface web de ton NAS, tu as bien accès au contenu des dossiers en question, tu peux créer un fichier dedans, etc. ?


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#7 Le 01/08/2020, à 16:08

ludique

Re : [Résolu] Pb connexion NAS Synology

ls -l /media/bobo12

total 20
drwxr-xr-x 2 root root 4096 août   1 12:44 Nas_Jean
drwxr-xr-x 2 root root 4096 août   1 12:45 Nas_Josette
drwxr-xr-x 2 root root 4096 août   1 12:45 Nas_Musique
drwxr-xr-x 2 root root 4096 août   1 12:45 Nas_Photo
drwxr-xr-x 2 root root 4096 août   1 12:46 Nas_Video

Oui il est vide

Pour les autres question je pense avoir tout fait correctement mais je n'en suis pas sur je découvre ca depuis ce matin. Je vois bien les fichiers que j'ai ajouter via ubuntu (en Sudo).
Je ne sais pas trop comment vérifier que tout est OK.

Je viens d'ajouter un fichier en drag 'n drop et ca fonctionne.

Dernière modification par ludique (Le 01/08/2020, à 16:10)

Hors ligne

#8 Le 01/08/2020, à 16:17

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Première chose à faire : être sûr que tu as correctement paramétré les choses du côté du NAS, en passant par son interface web.

Si tu as suivi la doc, tu as dû voir ça à la fin du point 1.2 :

Pour monter automatiquement les répertoires du synology, il faut :
1. Posséder un compte valide sur le Synology. Nativement le Synology possède un compte "admin" utilisé lors de sa première installation. Cependant je vous conseille de créer un compte "user". Travailler quotidiennement sous "admin" comporte des risques….
2. Je vais supposer que :
- le compte "user" que je nomme "dbx1" existe sur le syno ;
- le "user" sous Ubuntu (donc de votre PC) soit "deadbox1" ;
- les répertoires de montage sur le PC seront tous dans le répertoires /media/deadbox1.

Personnellement, j'utilise le compte admin du NAS pour monter mes partages, c'est plus simple. Mais si tu veux faire comme dans la doc :
- tu as bien créé un compte d'utilisateur simple sur le NAS ? si oui, sous quel nom (celui qu'il appelle "dbx1" dans l'exemple de la doc) ?
- si tu as effectivement créé ce compte et que tu te connectes avec au NAS en passant par son interface web, est-ce qu'il a les droits nécessaires pour gérer les dossiers partagés ? Tu peux le vérifier simplement : l'interface web du NAS a probablement une appli de gestions de fichiers ; quand tu es connecté avec ton compte créé précédemment, en utilisant cette appli, est-ce que tu peux accéder aux dossiers que tu cherches à partager pour voir leur contenu et est-ce que tu peux écrire dedans (par exemple simplement créer un sous-dossier dedans) ?

Dernière modification par abelthorne (Le 01/08/2020, à 16:18)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#9 Le 01/08/2020, à 16:24

ludique

Re : [Résolu] Pb connexion NAS Synology

Oui  tout ca est OK.
J'ai créé un compte "Jean" avec lequel je peux créer des sous dossier et ajouter des fichier via l'interface web. Tout ca fonctionne aussi avec Admin.

Hors ligne

#10 Le 01/08/2020, à 16:33

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Et dans le fichier /home/bobo12/.Jean, tu as bien indiqué ce compte "Jean" (attention à la syntaxe : "jean" et "Jean" sont deux noms de compte différents) avec son mot de passe ? Est-ce que tu as indiqué un domaine (si c'est le cas, je pense qu'il y a une erreur dans la doc et que l'option devrait être "domain" et pas "domaine") ?

Si tout est bon et que les montages ne sont pas montés actuellement (sinon, démonte-les ou redémarre), que donne le retour de la commande suivante ?

sudo mount -a

EDIT : accessoirement, comment est-ce que ton PC est connecté au réseau : ethernet ou wi-fi ?

Dernière modification par abelthorne (Le 01/08/2020, à 16:35)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#11 Le 01/08/2020, à 16:47

ludique

Re : [Résolu] Pb connexion NAS Synology

Oui c'est bien Jean (avec une majuscule) et je n'ai pas indiqué de domain (je ne sais pas trop à quoi ca correspond dans mon cas)

après un redemarrage, sudo mount -a monte bien les partages mais je ne peux toujours rien écrire.

Et je suis connecté en ethernet

Le fichier .Jean ne s'ouvre qu'avec Sudo. Est-ce normal ?

Dernière modification par ludique (Le 01/08/2020, à 16:48)

Hors ligne

#12 Le 01/08/2020, à 16:55

abelthorne

Re : [Résolu] Pb connexion NAS Synology

C'est très bizarre. Si sudo mount -a les monte, ça veut dire qu'ils sont bien paramétrés, donc la question est de savoir pourquoi il ne les monte pas au boot. Si tu étais en wi-fi, ça pourrait s'expliquer mais en ethernet c'est plus curieux.

À tout hasard, essaie de modifier ton fstab comme ça :

//192.168.1.17/Jean/	/media/bobo12/Nas_Jean		cifs	credentials=/home/bobo12/.Jean,vers=2.0,auto,rw 0 0

Idem pour les autres lignes : remplacement de Gargamelle par l'IP du NAS, suppression de l'option _netdev et ajout de l'option vers=2.0. Puis redémarre et dis-moi si les montages se font automatiquement. Et éventuellement si tu peux écrire dedans (mais je ne pense pas que ce sera le cas).

Pour le fichier .Jean qui ne s'ouvre qu'avec sudo, ça me paraît bizarre. Donne le retour de :

ls -la | grep .Jean

Dernière modification par abelthorne (Le 01/08/2020, à 16:57)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#13 Le 01/08/2020, à 17:09

ludique

Re : [Résolu] Pb connexion NAS Synology

La modification du fstab n'a rien changé.

Le crédential pose en recvnche un pb

ls: impossible d'accéder à '.gvfs': Permission non accordée
-rw-------  1 root   root       37 août   1 10:14 .Jean

Hors ligne

#14 Le 01/08/2020, à 17:32

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Ah, c'est pas normal qu'il appartienne à root. Cela dit, ça ne devrait pas avoir d'effet sur ton problème. Je vois qu'il y a aussi un dossier que tu n'as pas la permission de gérer, probablement parce qu'il est à root aussi. Tu as peut-être lancé des commandes à un moment en utilisant sudo quand il ne fallait pas.

Quel est le nom de ton compte utilisateur ? "bobo12" ? "jean" ? "Jean" ?


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#15 Le 01/08/2020, à 17:51

ludique

Re : [Résolu] Pb connexion NAS Synology

Oui c'est surement ca.
Mon compte ubuntu est bobo12
Mon compte sur le nas est Jean
J'ai modifier le cred .Jean
maintenant ls -la | grep .Jean donne

-rw-------  1 bobo12 bobo12     36 août   1 17:28 .Jean

Mais ca ne change rien au résultat.
Depuis que je fais des essai. j'ai des message d'erreur démarrage que je n'arrive pas à attraper ni à lire (ca va beaucoup trop vite). Je suppose qu'ils sont lié à l'échec de connexion au Nas. Mais si je savais ou les retrouver ca aiderai peut-être à comprendre.

Oui les fichiers dans media/bobo12 ont été créé avec sudo. C'est ce qui est indiqué dans la doc.

Dernière modification par ludique (Le 01/08/2020, à 17:54)

Hors ligne

#16 Le 01/08/2020, à 18:02

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Oui, pour créer les dossiers dans /media, c'est normal que tu aies dû utiliser sudo. Mais je pense que tu l'as aussi utilisé par moment sans que ce soit indispensable et ça a attribué certains des tes fichiers perso à root. C'est pas forcément récent, ça peut être il y a plusieurs mois.

Avec la modification du fstab, les dossiers ne sont pas montés au démarrage mais le sont si tu fais un sudo mount -a, c'est bien ça ?

Donne-moi le retour de la commande suivante pour vérifier un truc :

cat /etc/network/interfaces

Dernière modification par abelthorne (Le 01/08/2020, à 18:02)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#17 Le 01/08/2020, à 18:17

ludique

Re : [Résolu] Pb connexion NAS Synology

Oui c'est bien ca. Je ne savais pas si tu le voulais avant ou après montage. Mais ca ne change rien

bobo12@bobo12:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
bobo12@bobo12:~$ sudo mount -a
[sudo] Mot de passe de bobo12 : 
mount error(16): Device or resource busy
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
bobo12@bobo12:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
bobo12@bobo12:~$ 

Hors ligne

#18 Le 01/08/2020, à 18:31

abelthorne

Re : [Résolu] Pb connexion NAS Synology

La seule hypothèse que j'ai pour le problème de montage (les droits d'écriture, c'est autre chose), c'est que le réseau n'est pas actif au moment où les points déclarés dans le fstab sont montés. En ethernet, ce serait curieux, d'autant que le fichier interfaces et normal. Il y a éventuellement un truc que tu peux vérifier mais ça ne nous avancera pas forcément si ça fonctionne :
- redémarre ;
- à l'écran de connexion, ne te connecte pas mais bascule sur une console (ctrl + alt + F1, F2, F3...);
- connecte-toi en mode texte en rentrant ton identifiant et ton mot de passe (en aveugle pour ce dernier) ;
- une fois connecté, fais un ping sur l'IP du NAS :

ping 192.168.1.17

Attends quelques secondes pour voir les retours (ctrl + C pour l'interrompre) : tu as des retours normaux ou des messages "Destination Host Unreachable" ?

Une fois ce petit test effectué, tu peux repasser sur la session graphique (normalement ctrl + alt + F7 mais selon les variantes d'Ubuntu, ça peut être F1, F2... essaie-les différentes touches de fonction jusqu'à tomber dessus) et te connecter normalement.

Autre chose à tester : utiliser le compte admin du NAS plutôt que ton compte Jean dans les credentials, notamment pour le problème d'écriture dans les dossiers.

Dernière modification par abelthorne (Le 01/08/2020, à 18:31)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#19 Le 01/08/2020, à 18:46

ludique

Re : [Résolu] Pb connexion NAS Synology

Ca ping bien, autour des 250 ms.

Je vais modifier le cred pour mettre les identifiants  Admin.

Hors ligne

#20 Le 01/08/2020, à 18:55

ludique

Re : [Résolu] Pb connexion NAS Synology

L'utilisation du compte Admin ne me donne pas plus d'accès en écriture.

Hors ligne

#21 Le 01/08/2020, à 18:59

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Tu es sûr qu'il s'appelle "Admin" et pas "admin" ?


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#22 Le 01/08/2020, à 19:17

ludique

Re : [Résolu] Pb connexion NAS Synology

Tu as raison c'est plutôt admin. Mais les deux fonctionnent pour accéder au Nas.

J'ai quand même corrigé le cred, des fois que ca change qqchose pour les connexion hors applicatif web.
Mais le fonctionnement reste le même : mount obligatoire et pas d'accès en écriture.

Hors ligne

#23 Le 01/08/2020, à 19:23

abelthorne

Re : [Résolu] Pb connexion NAS Synology

On va essayer un autre truc au cas où : déplacer le fichier credentials au niveau système, des fois qu'il ne soit pas accessible dans ton dossier perso.

sudo mv ~/.Jean /etc/nas-credentials

Ensuite, modifie ton fstab pour remplacer l'adresse. Dans les lignes du NAS, remplace ça :

credentials=/home/bobo12/.Jean

par ça :

credentials=/etc/nas-credentials

Est-ce qu'il y a plusieurs comptes utilisateurs sur ton PC qui ont besoin d'accéder au NAS ? ou des comptes sur d'autres machines ? Parce que si ce n'est pas le cas, on pourrait modifier les points de montage pour te les attribuer, ce qui devrait corriger le problème d'écriture. Mais si c'est le cas, ça va poser problème pour les autres utilisateurs.


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne

#24 Le 01/08/2020, à 19:39

ludique

Re : [Résolu] Pb connexion NAS Synology

Toujours la même chose.

Non il n'y a que moi qui utilise ce PC. On peut effectivement les attribuer à mon compte. Mais je ne sais pas faire ...

Hors ligne

#25 Le 01/08/2020, à 19:53

abelthorne

Re : [Résolu] Pb connexion NAS Synology

Essaie de modifier les options de montage dans ton fstab comme ça :

//Gargamelle/Jean/	/media/bobo12/Nas_Jean	cifs	credentials=/etc/nas-credentials,vers=2.0,iocharset=utf8,uid=1000,gid=1000 0 2

Le fichier /etc/nas-credentials ne change normalement pas. uid=1000 et guid=1000, ça veut dire qu'on monte les points pour l'utilisateur 1000, qui est le premier créé à l'installation d'Ubuntu. Je suppose que c'est le cas pour ton compte mais tu peux le vérifier avec la commande id si tu veux en être sûr.

Pour les autres options, vers=2.0 est relative à la version de Samba. Tu n'en as pas forcément besoin avec ton NAS mais c'est le cas pour moi (avec un NAS QNAP). iocharset=utf8, c'est pour indiquer que les fichiers partagés doivent être encodés en UTF-8 (encodage utilisé par Ubuntu). Le 0 2 à la fin au lieu de 0 0 est lié à la vérification de disque par fsck au boot. Normalement, on n'utilise 0 0 que pour la partition système mais ce n'est pas très important.

Avec ces modifs, je ne pense pas que ça va résoudre le problème du montage automatique mais une fois sur ta session, monte les partages avec sudo mount -a et vérifie si tu peux écrire dessus. Si ce n'est pas le cas, donne-moi le retour de la commande suivante (avec les montages actifs) :

ls -l /media/bobo12

Dernière modification par abelthorne (Le 02/08/2020, à 10:36)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

Hors ligne