Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/01/2020, à 16:42

Phildu59

Problème pour compiler Gwhere (RESOLU)

Bonjour,
Je cherche à compiler Gwhere, un utilitaire servant à cataloguer des médias. http://www.gwhere.org/home.php3?idLanguage=fr
En éxécutant ./configure j'ai le message suivant :

checking for gtk-config... no
checking for GTK - version >= 1.2.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error: Cannot find GTK: Is gtk-config in path?

J'ai pourtant installé les bibliothèques GTK

sudo apt-get install build-essential libgtk2.0-dev
sudo apt-get install gtk2.0

Si au lieu de compiler, je cherche à l'installer avec le deb, des dépendances ne sont pas satisfaites.
Le paquet est cassé.

sudo dpkg -i GWhere-x.x.x.deb

Je tiens à conserver ce programme car j'y ai mis tous mes catalogues depuis de nombreuses années.

Merci.

Dernière modification par Phildu59 (Le 24/01/2020, à 19:46)

Hors ligne

#2 Le 24/01/2020, à 17:50

kevlar

Re : Problème pour compiler Gwhere (RESOLU)

Bonjour.
D'après le message d'erreur, c'est un programme qui utilisait Gtk série 1.x (je suis surpris qu'il ne demande pas la vers ion 1.4 mini ).
Je n'ai pas trouvé sur le site indiqué de paquet .DEB, et je n'ai même pas pu télécharger la source.
Je vois un contournement possible : sur le site, il est indiqué, d'une part, qu'une version Windows existe, et, d'autre part, que GWhere sait exporter ses données dans d'autres formats. Ce que je ferais, c'est lancer la version Windows via Wine, puis exporter les données dans un format "ouvert" pour les récupérer avec un logiciel toujours maintenu (là je ne connais pas, il faudra que d'autres personnes répondent).
Bon courage.

Hors ligne

#3 Le 24/01/2020, à 19:45

Phildu59

Re : Problème pour compiler Gwhere (RESOLU)

J'ai bien cherché et finalement trouvé. Il me semblait bien que les anciens dépôts le proposaient. Les archives de la mailing liste de Gwhere (https://lists.nongnu.org/archive/html/g … 00001.html) indiquent un lien http://de.archive.ubuntu.com/ubuntu/ lucid/universe Packages.
Le deb fourni sur le site de l'auteur ne foncitonne pas. Par contre, ce paquet du lien ci-dessus "gwhere_0.2.3.dfsg.1-4_amd64.deb" m'a permis de l'installer sans erreurs de dépendances.

Merci qui ?

Hors ligne

#4 Le 24/01/2020, à 19:46

kamaris

Re : Problème pour compiler Gwhere (RESOLU)

Quelques pistes pour le remplacement de gwhere : https://doc.ubuntu-fr.org/catalogage

Hors ligne