Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 31/12/2019, à 00:16

Titou16

Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Bonjour à tous,

J'ai un soucis suite à l'installation d'Ubuntu mate (mais je pense que ce serait le cas aussi avec d'autres variantes) sur un PC Dell Inspiron 3780 originellement pourvu de Windows 10. Pour installer Ubuntu, j'ai changé le disque SSD M2 Nvme d'origine (Intel Optane) par un Crucial P1.

Au début tout s'est bien passé. Installation, puis redemarrage 2 ou 3 fois de suite sans problème. Et puis après les choses se sont corsées. Le PC ne démarrait plus. Suite à echec du demarrage (écran noir pendant plusieurs minute), je redemarrais et je tombais sur le menu Grub2. Selectionner le demarrage normal d'Ubuntu redonnait un ecran noir. Choisir une option du menu advanced option for ubuntu se soldait par l'affichage de loading initial ramdisk et puis plus rien.

Même sur la clé bootable qui a servi à l'installation ça ne bootait pas. Un détail qui a peut être de l'importance, si le PC n'est pas branché à son chargeur il ne demarre jamais, il se passe systèmatiquement ce que je viens d'expliquer. Si le chargeur est branché, à force d'insister 3, 5, 10 fois (on dirait une loterie) il finit par booter. Si quelqu'un a une explication à ce curieux phénomène, je suis preneur...

Pour tenter de résoudre le problème, j'ai parcouru le net et constaté que j'étais loin d'être le seul qui a ce problème et sur différente marque de PC. Et puis j'ai réinstallé en prenant bien soin de créer une partition ESP au tout début du disque suivant la lecture de la page du support Dell (https://www.dell.com/support/article/fr … fi?lang=fr)

Mais après ça le problème est resté entier. Alors, j'ai lancé boot repair pour tenter de réparer le Grub. Mais ça n'y change rien. Voici les rapports de boot repair :

Celui d'avant la réparation : http://paste.ubuntu.com/p/WBW4J4JBkV/

Et celui d'après la réparation : http://paste.ubuntu.com/p/fqVJQq4Hs9/

Maintenant je suis à cours de solution. Merci d'avance à ceux qui m'apporteront leur aide et leurs connaissances pour arranger ça.

Dernière modification par Titou16 (Le 31/12/2019, à 00:19)

Hors ligne

#2 Le 31/12/2019, à 14:16

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Bonjour
Ton problème est très certainement matériel et en amont du boot puisque tu dis "Au début tout s'est bien passé. Installation, puis redemarrage 2 ou 3 fois de suite sans problème."
Lorsqu'on regarde le contenu du boot-info, on voit que le disque NVMe est bien présent

======================== "ls -l /dev/disk/by-id" output: ======================
lrwxrwxrwx 1 root root 13 Dec 26 20:13 nvme-CT500P1SSD8_1935E21BBA69 -> ../../nvme0n1
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-CT500P1SSD8_1935E21BBA69-part1 -> ../../nvme0n1p1
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-CT500P1SSD8_1935E21BBA69-part2 -> ../../nvme0n1p2
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-CT500P1SSD8_1935E21BBA69-part3 -> ../../nvme0n1p3
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-CT500P1SSD8_1935E21BBA69-part4 -> ../../nvme0n1p4
lrwxrwxrwx 1 root root 15 Dec 26 20:14 nvme-CT500P1SSD8_1935E21BBA69-part5 -> ../../nvme0n1p5
lrwxrwxrwx 1 root root 13 Dec 26 20:13 nvme-eui.000000000000000100a07519e21bba69 -> ../../nvme0n1
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-eui.000000000000000100a07519e21bba69-part1 -> ../../nvme0n1p1
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-eui.000000000000000100a07519e21bba69-part2 -> ../../nvme0n1p2
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-eui.000000000000000100a07519e21bba69-part3 -> ../../nvme0n1p3
lrwxrwxrwx 1 root root 15 Dec 26 20:13 nvme-eui.000000000000000100a07519e21bba69-part4 -> ../../nvme0n1p4
lrwxrwxrwx 1 root root 15 Dec 26 20:14 nvme-eui.000000000000000100a07519e21bba69-part5 -> ../../nvme0n1p5

Que le systeme a prévu de booter en mode EFI sur cette partition
=================== efibootmgr -v
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0002,0003
Boot0002  ubuntu    HD(1,GPT,1a926461-fb69-49bd-bfc9-f891bd26136b,0x800,0x17800)/File(EFIubuntushimx64.efi)
Boot0003* UEFI:  USB DISK 3.0 PMAP, Partition 1    PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(1,MBR,0xc3072e18,0x800,0x3ae7800)..BO
=================== UEFI/Legacy mode:
BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot enabled.

qui est celle-ci
=================== blkid:
/dev/nvme0n1p1: UUID="A46A-56B4" TYPE="vfat" PARTUUID="1a926461-fb69-49bd-bfc9-f891bd26136b"

dev/nvme0n1p1   A46A-56B4                              vfat 

C'est bien une partition de boot EFI

A mot avis, il faudrait que tu inspectes le bios pour savoir en quel mode il accède à ce SSD    AHCI?  RAIDS?    IRST?   autre?

Hors ligne

#3 Le 05/01/2020, à 13:04

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Bonjour,

Merci pour votre aide et désolé de ne pas avoir pu vous répondre plus tôt.

Le mode est AHCI.

J'ai bien fait ce qui est demandé à la fin du fichier à savoir booter sur nvme0n1p1/EFI/ubuntu/shimx64.efi. Mais du reste cette option était déjà celle configurée dans le BIOS suite à l'application de boot repair. Je n'ai donc fait que vérifier dans un premier temps. Et puis comme ça marchait pas, j'ai supprimé ce lien et l'ai refait manuellement. Aucune amélioration.

C'est le coté aléatoire qui me déroute. Je ne m'explique pas que, sans rien changer au système, des fois il démarre et d'autres fois non.

Hors ligne

#4 Le 05/01/2020, à 17:50

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

En relisant ton post, vu que tu dis que tout semble en ordre, quelque chose m'interpelle, le Timeout

geole a écrit :

BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0002,0003
Boot0002  ubuntu    HD(1,GPT,1a926461-fb69-49bd-bfc9-f891bd26136b,0x800,0x17800)/File(EFIubuntushimx64.efi)
Boot0003* UEFI:  USB DISK 3.0 PMAP, Partition 1    PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(1,MBR,0xc3072e18,0x800,0x3ae7800)..BO

Je me dis que le fait qu'e le PC boote aléatoirement pourrait résulter de ce que certaines opérations ont le temps de se faire parfois et d'autres fois non avant l'intervention d'un Timeout. Le fait qu'il boote quand il est branché sur le secteur alors qu'il ne boote pas sur batterie m'amène à penser que peut être la séquence de boot se déroule légèrement moins vite sur batterie et qu'elle est interrompue par le Timeout avant de s'être terminée. Est ce une idée stupide?

Est il possible de modifier la durée du Timeout pour la tester?

Hors ligne

#5 Le 05/01/2020, à 18:21

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Pour un test d'attente de 30 secondes du boot efi

sudo efibootmgr  -t   30

Mais j'avais compris que le problème n'était pas efi car tu dis
"je redemarrais et je tombais sur le menu Grub2. Selectionner le demarrage normal d'Ubuntu redonnait un ecran noir. Choisir une option du menu advanced option for ubuntu se soldait par l'affichage de loading initial ramdisk et puis plus rien."

Cela ressemble plus a un problème de carte graphique.

As-tu essayé le menu recovery ?

Hors ligne

#6 Le 05/01/2020, à 23:20

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Tu veux parler du choix du menu advanced option for ubuntu? Si je le choisi ça me met loading initial ramdisk et puis il ne se passe plus rien. Je vais essayer de modifier le timeout peut être pas à 30s mais à 3s pour voir. Vu que parfois ça boot ça doit pas se jouer à grand chose si le problème vient bien de là.

Hors ligne

#7 Le 05/01/2020, à 23:42

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Au moment où tu auras réussis à booter, Peux-tu donner le retour de cette commande

cat /boot/grub/grub.cfg

D'autre part, peux-tu aller dans le bios et regarder avec quelle option, il prévoit d'accéder au SSD   AHCI? IDE? RAID? IRST? autre valeur ?

Hors ligne

#8 Le 06/01/2020, à 20:20

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Salut,

Il accède en AHCI.  La modif du timeout n'a rien donné. Voici le résultat de la commande que tu m'as demandé d'executer :

christophe@christophe-Inspiron-3780:~$ cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#[/i]

[i]### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi[/i]

[i]if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi[/i]

[i]export menuentry_id_option[/i]

[i]if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi[/i]

[i]function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}
function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}[/i]

[i]if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod ext2
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root  024ff718-b0e4-4c58-9204-57ed80030b36
else
  search --no-floppy --fs-uuid --set=root 024ff718-b0e4-4c58-9204-57ed80030b36
fi
    font="/usr/share/grub/unicode.pf2"
fi[/i]

[i]if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=C
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=10
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=hidden
    set timeout=10
  # Fallback hidden-timeout code in case the timeout_style feature is
  # unavailable.
  elif sleep --interruptible 10 ; then
    set timeout=10
  fi
fi
### END /etc/grub.d/00_header ###[/i]

[i]### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 60,59,55; then
  clear
fi[/i]

[i]color_normal=light-gray/black[/i]

[i]if [ -e ${prefix}/themes/ubuntu-mate/theme.txt ]; then
  insmod png
  theme=${prefix}/themes/ubuntu-mate/theme.txt
fi
### END /etc/grub.d/05_debian_theme ###[/i]

[i]### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
	set gfxpayload="${1}"
	if [ "${1}" = "keep" ]; then
		set vt_handoff=vt.handoff=1
	else
		set vt_handoff=
	fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-024ff718-b0e4-4c58-9204-57ed80030b36' {
	recordfail
	load_video
	gfxmode $linux_gfx_mode
	insmod gzio
	if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
	insmod part_gpt
	insmod ext2
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root  024ff718-b0e4-4c58-9204-57ed80030b36
	else
	  search --no-floppy --fs-uuid --set=root 024ff718-b0e4-4c58-9204-57ed80030b36
	fi
        linux	/boot/vmlinuz-5.0.0-37-generic root=UUID=024ff718-b0e4-4c58-9204-57ed80030b36 ro  quiet splash $vt_handoff
	initrd	/boot/initrd.img-5.0.0-37-generic
}
submenu 'Advanced options for Ubuntu' $menuentry_id_option 'gnulinux-advanced-024ff718-b0e4-4c58-9204-57ed80030b36' {
	menuentry 'Ubuntu, with Linux 5.0.0-37-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.0.0-37-generic-advanced-024ff718-b0e4-4c58-9204-57ed80030b36' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod ext2
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root  024ff718-b0e4-4c58-9204-57ed80030b36
		else
		  search --no-floppy --fs-uuid --set=root 024ff718-b0e4-4c58-9204-57ed80030b36
		fi
		echo	'Loading Linux 5.0.0-37-generic ...'
	        linux	/boot/vmlinuz-5.0.0-37-generic root=UUID=024ff718-b0e4-4c58-9204-57ed80030b36 ro  quiet splash $vt_handoff
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-5.0.0-37-generic
	}
	menuentry 'Ubuntu, with Linux 5.0.0-37-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.0.0-37-generic-recovery-024ff718-b0e4-4c58-9204-57ed80030b36' {
		recordfail
		load_video
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod ext2
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root  024ff718-b0e4-4c58-9204-57ed80030b36
		else
		  search --no-floppy --fs-uuid --set=root 024ff718-b0e4-4c58-9204-57ed80030b36
		fi
		echo	'Loading Linux 5.0.0-37-generic ...'
	        linux	/boot/vmlinuz-5.0.0-37-generic root=UUID=024ff718-b0e4-4c58-9204-57ed80030b36 ro recovery nomodeset 
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-5.0.0-37-generic
	}
	menuentry 'Ubuntu, with Linux 5.0.0-23-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.0.0-23-generic-advanced-024ff718-b0e4-4c58-9204-57ed80030b36' {
		recordfail
		load_video
		gfxmode $linux_gfx_mode
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod ext2
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root  024ff718-b0e4-4c58-9204-57ed80030b36
		else
		  search --no-floppy --fs-uuid --set=root 024ff718-b0e4-4c58-9204-57ed80030b36
		fi
		echo	'Loading Linux 5.0.0-23-generic ...'
	        linux	/boot/vmlinuz-5.0.0-23-generic root=UUID=024ff718-b0e4-4c58-9204-57ed80030b36 ro  quiet splash $vt_handoff
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-5.0.0-23-generic
	}
	menuentry 'Ubuntu, with Linux 5.0.0-23-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.0.0-23-generic-recovery-024ff718-b0e4-4c58-9204-57ed80030b36' {
		recordfail
		load_video
		insmod gzio
		if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
		insmod part_gpt
		insmod ext2
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root  024ff718-b0e4-4c58-9204-57ed80030b36
		else
		  search --no-floppy --fs-uuid --set=root 024ff718-b0e4-4c58-9204-57ed80030b36
		fi
		echo	'Loading Linux 5.0.0-23-generic ...'
	        linux	/boot/vmlinuz-5.0.0-23-generic root=UUID=024ff718-b0e4-4c58-9204-57ed80030b36 ro recovery nomodeset 
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initrd.img-5.0.0-23-generic
	}
}[/i]

[i]### END /etc/grub.d/10_linux ###[/i]

[i]### BEGIN /etc/grub.d/20_linux_xen ###[/i]

[i]### END /etc/grub.d/20_linux_xen ###[/i]

[i]### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###[/i]

[i]### BEGIN /etc/grub.d/25_custom ###[/i]

[i]menuentry "EFI/BOOT/bkpbootx64.efi" {
search --fs-uuid --no-floppy --set=root A46A-56B4
chainloader (${root})/EFI/BOOT/bkpbootx64.efi
}[/i]

[i]menuentry "EFI/BOOT/fbx64.efi" {
search --fs-uuid --no-floppy --set=root A46A-56B4
chainloader (${root})/EFI/BOOT/fbx64.efi
}[/i]

[i]menuentry "EFI/ubuntu/fwupx64.efi" {
search --fs-uuid --no-floppy --set=root A46A-56B4
chainloader (${root})/EFI/ubuntu/fwupx64.efi
}[/i]

[i]menuentry "EFI/ubuntu/mmx64.efi" {
search --fs-uuid --no-floppy --set=root A46A-56B4
chainloader (${root})/EFI/ubuntu/mmx64.efi
}
### END /etc/grub.d/25_custom ###[/i]

[i]### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###[/i]

[i]### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
	fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###[/i]

[i]### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###[/i]

[i]### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Dernière modification par Titou16 (Le 06/01/2020, à 21:43)

Hors ligne

#9 Le 06/01/2020, à 20:29

cqfd93

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Modération

Bonjour,

Pour ajouter toi-même les balises code à ton message #9 :

  • Cliquer sur le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message
    1471986854.png


cqfd93

En ligne

#10 Le 06/01/2020, à 21:44

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

cqfd93 a écrit :

Modération

Bonjour,

Pour ajouter toi-même les balises code à ton message #9 :

Bonjour,

C'est fait smile

Hors ligne

#11 Le 07/01/2020, à 20:51

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Bon j'ai un peu avancé. Je sais pas si je suis allé dans la bonne direction mais j'ai fait une modif (que je décris ci dessous) et il semble que ça démarre à tous les coups quand le portable est branché sur le secteur.

Avant de décrire ce que j'ai fait, je rajoute le constat des désagréments suivants avant que j'ai eu fait la modif : ça fait 2 fois qu'il plante totalement pendant que je m'en sers. Et dernière chose, si je ferme l’écran pour une durée assez longue (disons >30 minutes par ex), il se réveille pas. Je précise que ces plantages et dysfonctionnements ont eu lieu avant la modif que j'ai faite. Seule solution, l’arrêt brutal et le redémarrage. 

Alors voilà ce que j'ai fait. J'ai suivi les instruction du paragraphe 4.1 de ce lien : https://doc.ubuntu-fr.org/intel_graphics

Donc suite à ça, le démarrage sur secteur semble se faire à 100%. Par contre il démarre toujours pas sur batterie (ce qui est pas génial pour un portable). Pour ce qui est des plantages etdu non reveil, pas encore testé.

Dernière modification par Titou16 (Le 07/01/2020, à 20:52)

Hors ligne

#12 Le 13/01/2020, à 11:55

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

geole a écrit :

Au moment où tu auras réussis à booter, Peux-tu donner le retour de cette commande

cat /boot/grub/grub.cfg

D'autre part, peux-tu aller dans le bios et regarder avec quelle option, il prévoit d'accéder au SSD   AHCI? IDE? RAID? IRST? autre valeur ?

Alors, qu'est ce que tu en penses?

Hors ligne

#13 Le 14/01/2020, à 18:38

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Bonsoir
Penser de quoi?
Pour le démarrage sur batterie, Peux-tu être précis... y a-il au moins quelque chose qui s'affiche?
Je  ne comprends pas très bien ta phrase "Pour ce qui est des plantages et du non réveil, pas encore testé."

Hors ligne

#14 Le 16/01/2020, à 12:26

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

geole a écrit :

Bonsoir
Penser de quoi?

Ben c'était par rapport à ta demande de donner le retour de la commande cat /boot/grub/grub.cfg. Je suppose que si tu m'as demandé ça c'était pour vérifier quelque chose. Du coup t'as rien vu d'anormal?

geole a écrit :

Pour le démarrage sur batterie, Peux-tu être précis... y a-il au moins quelque chose qui s'affiche?

Pour le démarrage sur batterie, oui le démarrage se passe comme pour le démarrage sur secteur dans un premier temps. Affichage du logo Dell suivi d'un écran noir. après ça soit l'ordinateur démarre et l'écran de connexion d'Ubuntu Mate s'affiche soit l'écran reste noir indéfiniment. Sur secteur c'est aléatoire. ça démarre ou pas, c'est la loterie. Sur batterie, ça démarre jamais. A ce moment là je force l'arrêt. Et après un échec que ce soit sur batterie ou sur secteur, après l'affichage du logo Dell je tombe sur le menu Grub. A ce moment là je sélectionne Advanced options for ubuntu. Puis  Ubuntu, with Linux 5.0.0-37. A ce stade, sur secteur ça démarre dans 80% des cas environ (sinon je recommence). Sur batterie, jamais et aucun choix ne fonctionne.

geole a écrit :

Je  ne comprends pas très bien ta phrase "Pour ce qui est des plantages et du non réveil, pas encore testé."

Je disais que j'avais oublié de préciser que, en plus des problèmes de démarrage, j'avais expérimenté des plantages en cours d'utilisation et en sorti de veille lors de l'utilisation sur batterie. Suite à ça j'avais appliqué la procédure décrite là : https://doc.ubuntu-fr.org/intel_graphics au paragraphe 4.1.
Et dans un premier temps, le PC a démarré sur secteur à 100% plusieurs fois de suite (ce qui n'a hélas pas duré). Par contre, après avoir appliqué cette procédure, j'ai pas réessayé de l'utiliser sur batterie ni de le mettre en veille. Donc je sais pas si cette intervention résout ces problèmes. Mais vu qu'au final elle n'a pas solutionné les problèmes de démarrage c'est peu probable.

Hors ligne

#15 Le 16/01/2020, à 18:27

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Bonsoir
Lorsque ubuntu est installé dans un NVMe, Boot-info omet de lister le fichier /boot/grub/grub.cfg.  C'est pour cela que je te l'avais demandé au cas où il y aurait  quelque chose d'anormal  bien mis en évidence.  Mais je n'ai rien vu de spécial.
Le choix d'advanced mode    ajoute au moins l'option "nomodeset" et probablement quelques autres que je ne connais pas.

Si cela est possible, je te propose de le faire bavarder un peu plus...

Lorsque tu auras un boot réussi, Tu vas modifier le fichier /boot/grub/grub.cfg
Spécialement cette ligne

        linux	/boot/vmlinuz-5.0.0-37-generic root=UUID=024ff718-b0e4-4c58-9204-57ed80030b36 ro  quiet splash $vt_handoff

qui est théoriquement en position 152
Tu feras en sorte qu'elle devienne

        linux	/boot/vmlinuz-5.0.0-37-generic root=UUID=024ff718-b0e4-4c58-9204-57ed80030b36 ro      $vt_handoff

Au boot suivant,  cela devrait un peu plus bavarder. En espérant qu'il y aura des lignes explicatives assez parlantes

Tu as aussi une autre façon de procéder expliquée au paragraphe 7.3 de  https://doc.ubuntu-fr.org/kernel#modifi … sur_disque si tu peux au moins obtenir le début d'affichage quite à le forcer

Dernière modification par geole (Le 16/01/2020, à 18:29)

Hors ligne

#16 Le 17/01/2020, à 10:30

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Salut,

J'ai fait ce que tu demandes et en effet ça le fait afficher tout un listing au démarrage. Mais il s'affiche si peu de temps que je ne peux ni le lire ni même le filmer. La camera n'a pas le temps de faire le point entre l'écran noir et l'écran illuminé par le texte qui apparaît un demi seconde. Donc tout est flou et inexploitable sur le film.

Alors je me suis dit qu'il existe peut être un moyen d'obtenir ce listing dans une sorte de rapport de démarrage. J'ai essayé boot-info (https://doc.ubuntu-fr.org/tutoriel/boot-info) mais ça ne convient pas. Je vois bien que le rapport qu'il édite n'a rien à voir avec le listing qui défile au démarrage. Sais tu s'il un moyen d'obtenir un tel rapport de démarrage?

Hors ligne

#17 Le 17/01/2020, à 11:21

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Bonjour
Je pensais qu'il allait bloquer   sur un événement te permettant de lire ce qui était affiché.
Comme tu peux booter de temps en temps, mémorise bien l'heure du boot foiré.  Il y a des outils pour récupérer si cela a été mémorisé
avec la commande suivante faite a partir d'une instance opérartionnelle  . Il faut bien paramétrer  le jour et l'heure de début et de fin

journalctl --no-pager --since "2020-01-01 12:12:12" --until "2020-01-10 16:16:16"   >Trace0.txt && gedit Trace0.txt

.

On peux aussi utiliser boot-info pour récupérer les traces de la session précédente. Mais je ne sais pas si cela marche très bien

sudo boot-info  -trace 500

Hors ligne

#18 Le 18/01/2020, à 14:20

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Salut Geole,

Hélas ça ne marche pas. Car quand il ne démarre pas il n'affiche que très peu de chose et je pense pas que ce soit d'une grande aide. Il y a 3 cas :

1)  Redémarrage suite à la fermeture normale d'une session
     a) Très rarement, il démarre directement.
     b) Il affiche la ligne suivante et se fige :

EFI stub: UEFI Secure Boot is enabled.

2) Au redémarrage suite à un echec  de démarrage. Là je tombe sur le menu Grub. Si je choisis Ubuntu, with Linux 5.0.0-37-generic il affiche  :

Loading Linux 5.0.0-37-generic ...
Loading initial ramdisk ...

Là il faut noter que parfois il démarre quand même après avoir affiché ces 2 lignes. Et d'autres fois il reste bloqué dessus. C'est d'ailleurs le moyen qui me permet de démarrer dans 90% des cas.

3) Au redémarrage suite à un echec  de démarrage, si je choisis Ubuntu, with Linux 5.0.0-37-generic (recovery), il affiche ceci et bloque dessus.

EFI stub: UEFI Secure Boot is enabled.
Loading initial ramdisk ...

Hors ligne

#19 Le 18/01/2020, à 16:17

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Je ne sais que te dire.....
Dans un premier temps, vas dans bios et enlève l option secure boot.. Cela enlèvera une partie de boot qui dialogue en mode secure.

Hors ligne

#20 Le 20/01/2020, à 21:42

Titou16

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Non ça ne fonctionne pas non plus. Le problème semble insoluble et je commence à me demander si y a pas une incompatibilité entre ce SSD Cristal P1 et la carte mère. J'ai évoqué cette hypothèse avec le service Dell et il ne l'a ni confirmé ni infirmé. Je sais pas si je vais pas finir par en acheter un autre de la même marque que l'original.

En tout cas merci pour ton aide et le temps que tu m'as consacré.

Dernière modification par Titou16 (Le 20/01/2020, à 21:43)

Hors ligne

#21 Le 20/01/2020, à 23:26

geole

Re : Problèmes de démarrage lié à l'UEFI sur Dell inspiron 3780

Titou16 a écrit :

Je commence à me demander si y a pas une incompatibilité entre ce SSD Cristal P1 et la carte mère. .

Bonsoir.
Pour en avoir la certitude, télécharge windows10 et installe-le

Hors ligne