Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/11/2019, à 10:15

Dominique FRETON

Montage dossier NAS Synology avec Autofs sous Kubuntu 19.10

Bonjour,

Je ne parvient pas à monter un dossier distant avec Autofs, qui me renvoie les messages "automount:syntax error while parsing map" et "automount:syntax error in map near".

Message status autofs :

administrateur@Zalman:~$ sudo automount -f -v
automount: program is already running.
administrateur@Zalman:~$ sudo service autofs status
● autofs.service - Automounts filesystems on demand
   Loaded: loaded (/lib/systemd/system/autofs.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2019-11-26 09:00:13 CET; 50min ago
     Docs: man:autofs(8)
  Process: 26160 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /var/run/autofs.pid (code=exited, status=0/SUCCESS)
 Main PID: 26167 (automount)
    Tasks: 3 (limit: 4915)
   Memory: 2.1M
   CGroup: /system.slice/autofs.service
           └─26167 /usr/sbin/automount --pid-file /var/run/autofs.pid

nov. 26 09:00:13 Zalman systemd[1]: Starting Automounts filesystems on demand...
nov. 26 09:00:13 Zalman automount[26167]: #
nov. 26 09:00:13 Zalman automount[26167]: syntax error while parsing map.
nov. 26 09:00:13 Zalman automount[26167]: syntax error in map near [ bogus option ]
nov. 26 09:00:13 Zalman systemd[1]: Started Automounts filesystems on demand.
administrateur@Zalman:~$ 

/etc/fstab

# <file system> <mount point> <type> <options> <dump> <pass>

UUID=72a4ea19-d9ab-4448-ae8d-f27c71314d38	/	ext4	errors=remount-ro	0	1
/dev/disk/by-label/Travail	/mnt/Travail	auto	nosuid,nodev,nofail,x-gvfs-show	0	0
LABEL=Administratif	/mnt/Administratif	auto	nosuid,nodev,nofail,x-gvfs-show	0	0
LABEL=Bureautique	/mnt/Bureautique	auto	nosuid,nodev,nofail,x-gvfs-show	0	0
/dev/disk/by-id/scsi-22e67c50500d00000-part1	/mnt/scsi-22e67c50500d00000-part1	auto	nosuid,nodev,nofail,x-gvfs-show	0	0
/dev/disk/by-id/scsi-22e292ca300d00000-part1	/mnt/scsi-22e292ca300d00000-part1	auto	nosuid,nodev,nofail,x-gvfs-show	0	0
LABEL=Sirikali	/mnt/Sirikali	auto	nosuid,nodev,nofail,x-gvfs-show	0	0
LABEL=DD250Go /mnt/DD250Go auto nosuid,nodev,nofail,x-gvfs-show 0 0

#//192.168.1.97/Administratif/Test     /NAS/Test     cifs       credentials=/home/administrateur/.cred-file,iocharset=utf8,gid=100,uid=1000,_netdev   0   0
#192.168.1.97:/Volume2/Administratif/Test    /nas    nfs    user,noauto    0   0

/etc/automaster

# Sample auto.master file
# This is a 'master' automounter map and it has the following format:
# mount-point [map-type[,format]:]map [options]
# For details of the format look at auto.master(5).
#
#/misc	/etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
#	"nosuid" and "nodev" options unless the "suid" and "dev"
#	options are explicitly given.
#
#/net	-hosts
#
# Include /etc/auto.master.d/*.autofs
# The included files must conform to the format of this file.
#
+dir:/etc/auto.master.d
#
# If you have fedfs set up and the related binaries, either
# built as part of autofs or installed from another package,
# uncomment this line to use the fedfs program map to access
# your fedfs mounts.
#/nfs4  /usr/sbin/fedfs-map-nfs4 nobind
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master
/nas	/etc/auto.nas --ghost,--timeout=60     #Le 20-11-2019 Fonctionnel
#/nas	/etc/auto.nas
#/nas	/etc/auto.nas --timeout 300 --browse
#/nas    /etc/auto.nas   uid=1000,gid=1000,--timeout=30

/etc/auto.nas

#Test  -fstype=nfs,rw,intr   192.168.1.97:/volume2/Administratif/Test        #Le 20-11-2019 Fonctionnel. Ne fonctionne plus après redemarrage du pc
#Test  -fstype=nfs,rw,uid=1000,guid=1000,rsize=8192,wsize=8192   192.168.1.97:/volume2/Administratif/Test

#test2  -fstype=nfs4      192.168.1.97:/volume2/Administratif/Test
Test -fstype=cifs,credentials=/home/administrateur/Bureau/.cred-file,user=admin,uid=1000,gid=1000 ://192.168.1.97/volume2/Administratif/Test
#Test -fstype=cifs,credentials=/home/administrateur/Bureau/.cred-file,user=admin,vers=3.0 ://192.168.1.97/Administratif/Test

#Test    -fstype=fuse,allow_other,user=admin:mjk4B12*    :curlftpfs\#192.168.1.97:/volume2/Administratif/Test
#Test    -fstype=fuse,allow_other,user=admin:mjk4B12* ftp://192.168.1.97/Administratif/Test

#   sftp://admin@192.168.1.97:22/Administratif/Administratif|pass64=bWprNEIxMio=        #freefilesync       #   sudo /etc/init.d/autofs reload

J'accède au serveur en sftp avec FreeFileSync, et en smb avec Dolphin.

Par quel bout prendre le problème ?

Cordialement

Hors ligne