Contenu | Rechercher | Menus

Annonce

Ubuntu Party les 18 et 19 mai 2019 à Paris
Grand rendez-vous tout public organisé par Ubuntu-FR, avec install-party, ateliers et conférences.
Venez y (re)découvrir ou faire découvrir le Libre et Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/12/2005, à 22:50

APLC

[résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

Bonjour,

J'utilise photoshop 7 sous Wine avec ubuntu.
Mon problème est le suivant: certains raccourcis sous photoshop sont composés de Alt+Clic
le problème, c'est que Gnome interprète Alt+clic comme un déplacement de fenetre, et je suis donc bloqué sous photoshop.

Y'a-t'il un moyen pour désactiver dans gnome le Alt-clic ?
j'ai cherché dans Système -> Préférences > Raccourcis clavier
mais j'ai pas trouvé (j'ai mis désactiver à "Déplacer la fenêtre", mais ça ne semble pas changer grand chose...)

Merci d'avance pour votre aide

Dernière modification par APLC (Le 29/12/2005, à 21:30)

Hors ligne

#2 Le 29/12/2005, à 12:06

papadon

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

Bonjour,
vous pouvez supprimer l'action de la touche <alt> avec l'éditeur de configuration Gconf (menu Applications->Outils système).
Descendez dans "apps->metacity->general" et supprimez ou spécifiez la touche dans "mouse_button_modifier". wink

Hors ligne

#3 Le 29/12/2005, à 14:52

jib

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

APLC a écrit :

J'utilise photoshop 7 sous Wine avec ubuntu.

Vraiment ? J'aurais cru que tu utilisais photoshop avec Wine sur Ubuntu... tongue
--------> F|

Le plus simple, c'est de passer par Système -> Préférences -> Raccourci Clavier...

Dernière modification par jib (Le 29/12/2005, à 14:53)

#4 Le 29/12/2005, à 21:29

APLC

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

papadon a écrit :

Bonjour,
vous pouvez supprimer l'action de la touche <alt> avec l'éditeur de configuration Gconf (menu Applications->Outils système).
Descendez dans "apps->metacity->general" et supprimez ou spécifiez la touche dans "mouse_button_modifier". wink

Yes! c'est ça!! merci beaucoup!!!!! smile

jib a écrit :
APLC a écrit :

J'utilise photoshop 7 sous Wine avec ubuntu.

Vraiment ? J'aurais cru que tu utilisais photoshop avec Wine sur Ubuntu... tongue
--------> F|

ça doit être ça, ouais big_smile

Hors ligne

#5 Le 22/02/2006, à 17:21

Ptitpoul

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

Préférences > Fenêtres permet également de remplacer <alt> par <ctrl> ou <win> pour déplacer les fenêtres

#6 Le 22/02/2006, à 17:37

Black_pignouf

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

APLC, j'en profite pour te poser une question, quand tu redimensionnes tes fenêtres "Calques", "Alpha" ou "historique", est-ce que ca plante? Chez moi, oui, et c'est assez énervant. Je dois redémarrer X à chaque fois. sad

Ah! Et je trouve le Ctrl+Alt+"+" et Ctrl+Alt+"-" assez cocasses.
Et quand tu changes de bureau, toutes les options de Photoshop se déplacent aussi? neutral

Pour ton histoire de Alt+Clic, tu peux aussi simplement maximiser ta fenêtre, qui ne pourra plus bouger.

Hors ligne

#7 Le 06/10/2016, à 13:55

remi2710

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

Avec ubuntu 16.04, gconf ne marche pas. La méthode passant par CCSM est mieux et compatible avec ubuntu 14.04 et plus (au moins, j'ai pas essayé en dessous):

sudo apt-get install ccsm
sudo apt-get update
ccsm

Une fois le logiciel lancé, il faut aller dans Gestion des fenêtre > Déplacement fenêtre > Lancer le déplacement de la fenêtre (verion souris) et changer ou désactiver le raccourci.

sinon, utilisez dconf, c'est la version qui marche de gconf

Hors ligne

#8 Le 08/01/2019, à 12:55

-= yehyoman =-

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

bonjour, le sujet date un peu, et pourtant je suis confronté au même problème "désactivé le alt+click"
Différence notoire je suis sur Lubuntu,

@:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"

@:~$  cat /proc/version
Linux version 4.15.0-43-generic (buildd@lgw01-amd64-001) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018

j'ai tenté d'installer gconf-editor ( car gconf est obsolète) mais il n'y a pas : apps->metacity->general

ccsm -> il n'y a pas compiz sur Lubuntu donc je ne pense pas...
dconf -> paquet obsolète

il y a il de nouvelles solutions ?

Dernière modification par -= yehyoman =- (Le 08/01/2019, à 12:57)


00101011 00100000 01101111 01101110 00100000 01101001 01101101 01110000 01101111 01110011 01100101 00100000 01100100 00100000 01100011 01101111 01101110 01110100 01110010 01100001 01101001 01101110 01110100 01100101 01110011 00100000 00101011 00100000 01101111 01101110 00100000 01110011 01100101 00100000 01101100 01101001 01100010 11101000 01110010 01100101

Hors ligne

#9 Le 08/01/2019, à 13:24

Roschan

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

dconf-editor

Hors ligne

#10 Le 08/01/2019, à 16:38

-= yehyoman =-

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

ok

et c'est bien la clé :

mouse_button_modifier

???

c'est bizard ! la clé est réglé sur la touche <Super> et non sur <Alt>
pourtant c'est bien alt+click qui déplace mes fenêtres...

Dernière modification par -= yehyoman =- (Le 08/01/2019, à 16:38)


00101011 00100000 01101111 01101110 00100000 01101001 01101101 01110000 01101111 01110011 01100101 00100000 01100100 00100000 01100011 01101111 01101110 01110100 01110010 01100001 01101001 01101110 01110100 01100101 01110011 00100000 00101011 00100000 01101111 01101110 00100000 01110011 01100101 00100000 01101100 01101001 01100010 11101000 01110010 01100101

Hors ligne

#11 Le 08/01/2019, à 16:59

Roschan

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

le remplacement de gconf-editor est dconf-editor mais après avoir mieux lu la question je ne pense pas qu'il y ait un rapport avec ton cas puisque Lubuntu utilise un gestionnaire de fenêtres sans aucun lien avec ces technologies, il faut regarder dans les réglages du gestionnaire de fenêtres de Lubuntu

Hors ligne

#12 Le 08/01/2019, à 17:13

-= yehyoman =-

Re : [résolu][Gnome] Désactiver le Alt-Clic (déplacement de fenetre)

super je comprend mieux.
je m'oriente donc vers OpenBox, et en particulier vers le rc.xml (où sont définis les paramètres de comportement d'Openbox et les raccourcis clavier,)

le fichier rc.xml est long! j'ai pas la tête à ça la desuite !!! (je laisse en suspends et je regarderai en détails plus tard...)

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

hmm "bon je me rends compte que mon problème n'a plus de rapport direct avec Unity donc pour suivre ce problème sur LXDE j'ai recréer un fil qui y correspond."

Dernière modification par -= yehyoman =- (Le 11/01/2019, à 12:38)


00101011 00100000 01101111 01101110 00100000 01101001 01101101 01110000 01101111 01110011 01100101 00100000 01100100 00100000 01100011 01101111 01101110 01110100 01110010 01100001 01101001 01101110 01110100 01100101 01110011 00100000 00101011 00100000 01101111 01101110 00100000 01110011 01100101 00100000 01101100 01101001 01100010 11101000 01110010 01100101

Hors ligne