Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 17/08/2018, à 07:00

Claude LENDREVIE

[résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Je viens d'acquérir un nouveau pc de bureau sur lequel je n'ai installé que Ubuntu 18.04 lts (64 bits).
Sur l'ancien pc doté de la version 16.04 lts (32 bits), j'ai un site Joomla 3.8.11 en fin de développement, et qui fonctionne correctement en frontend.
Après transfert de l'un vers l'autre de l'ensemble (site & bdd) par Akeeba backup et Akkeba kickstart sur le nouveau pc, je rencontre un dysfonctionnement total en frontend (aucun fonctionnement, blocage immédiat et affichage de 3 erreurs) :

Code:

Notice: Only variables should be assigned by reference in /var/www/html/nom_du_site/plugins/system/form_xml_override/form_xml_override.php on line 15

Notice: Only variables should be assigned by reference in /var/www/html/nom_du_site/plugins/system/contentoptimizer/contentoptimizer.php on line 64

Ces 2 lignes de code php ici incriminées sont identiques :


---> $app =& JFactory::getApplication();


Ce sont les messages d'erreurs qui sont également affichés dès l'exploitation en back-end (onglet "système").

Momentanément, je me contente de désactiver les 2 plugins qui créent ce problème (ils ne me sont pas indispensables). Tout en notant que ces 2 erreurs ne sont pas bloquantes (cf. notices).

Mais la 3ème erreur est beaucoup plus grave, car totalement bloquante. Aucun accès au frontend du site. Voici son message :

Error: [] operator not supported for strings: [] operator not supported for strings

Pour info, ma version de php est la 7.2.7 : elle refuserait l'utilisation des caractères '[' et ']'. Alors que sur mon ancien pc, la version utilisée est php 7.0 qui fonctionne fort bien.

Mon idée pour remédier à ce problème
1. constat actuel : j'ai un dossier /etc/php qui contient le sous-dossier php7.2,
2. je souhaiterai installer également la version php7.0, en second sous-dossier dans mon répertoire php,
3. je renommerai le dossier php7.2 (ex: php7.2 bloquant),
4. je renommerai le dossier php7.0 en php7.2
Car la version 18.04 d'Ubuntu fait le lien direct entre Apache2 et php7.2.
Mais avec un risque inhérent aux prochaines màj automatiques qui pourraient bien venir m'écraser la version php 7.0 qui s'y cache (par précaution, je ferais donc un dossier complémentaire pour sauvegarde).

Qui pourrait me décrire le jeu de commandes en terminal nécessaire pour retrouver le nom précis du paquet php 7.0, et son installation dans un sous-dossier php7.0 ?

ps : pour vous aider dans vos réflexions et recherches, je rappelle que la seule différence entre mon ancien pc et le nouveau réside dans la version de leur SE, à savoir :

* ancien pc (fonctionnement site ok en frontend) : linux ubuntu 16.04 lts (32 bits)
* nouveau pc (aucun fonctionnement site en frontend) : linux ubuntu 18.04 lts (64bits)

Dernière modification par Claude LENDREVIE (Le 18/08/2018, à 09:25)

Hors ligne

#2 Le 18/08/2018, à 07:27

Claude LENDREVIE

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Ma question semble tomber à une période où nos spécialistes d'Ubuntu seraient à la plage ... comme notre Président : aucune réponse depuis hier matin !

Hors ligne

#3 Le 18/08/2018, à 07:39

xubu1957

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Bonjour,

Tu avais vu > developpez.net/forums/d133867/php/langage/fonctions/tableaux-fatal-error-operator-not-supported-for-strings ?

_ _ _

Tu as regardé dans le forum.joomla.fr ?

Dernière modification par xubu1957 (Le 18/08/2018, à 07:42)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#4 Le 18/08/2018, à 07:56

Claude LENDREVIE

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Merci beaucoup, xubu1957 (nb: tu m'as déjà distillé de bons conseils dans le passé) !
Je viens de consulter ton 1er lien. Et je comprends tout à fait. Quand j'écris mes propres scripts, j'ai bien ce réflexe.
Mais, utilisant le CMS Joomla, je me trouve subitement confronté à de nombreux scripts tiers qui me plantent. Et je ne me vois pas passer mon temps à les corriger, et à voir ultérieurement ressurgir ces erreurs après la moindre màj de composants, modules ou/et plugins !

Que diable, comment se fait-il que php7.0 accepte l'absence de prédéfinition d'un tableau, et que la nouvelle mouture php 7.2.2 ne l'accepterait pas ?
Je pense qu'une installation de php7.0 en lieu et place de php7.2 -comme je l'ai décrite- serait plus simple ... et plus pérenne.
Qu'en penses-tu ?

Quant à interroger les spécialistes de Joomla, je l'ai déjà fait. Mais sans autre résultat que de revenir à php7.0 !

Hors ligne

#5 Le 18/08/2018, à 08:01

xubu1957

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Je pense qu'une installation de php7.0 en lieu et place de php7.2 -comme je l'ai décrite- serait plus simple ... et plus pérenne.
Qu'en penses-tu ?

Ma question semble tomber à une période où nos spécialistes d'Ubuntu seraient à la plage ... comme notre Président : aucune réponse depuis hier matin !

1 ) J'y connais rien !

2) Je suis dans la pataugeoire, comme Macron ! tongue

_ _ _

How to change the PHP version you’re using
If you have multiple PHP versions installed on your Ubuntu server, you can change what version is the default one.

Comment changer la version de PHP que vous utilisez
Si vous avez plusieurs versions de PHP installées sur votre serveur Ubuntu, vous pouvez changer la version par défaut.

To set PHP 7.0 as the default, run:
Pour définir PHP 7.0 par défaut, exécutez :

update-alternatives --set php /usr/bin/php7.0

To set PHP 7.2 as the default, run:
Pour définir PHP 7.2 par défaut, exécutez :

update-alternatives --set php /usr/bin/php7.2

If you’re following our LAMP tutorials and you’re using Apache, you can configure Apache to use PHP 7.2 with the following command:
Si vous suivez nos tutoriels LAMP et que vous utilisez Apache, vous pouvez configurer Apache pour utiliser PHP 7.2 avec la commande suivante :

a2enmod php7.2

And then restart Apache for the changes to take effect:
Et puis redémarrez Apache pour que les modifications prennent effet :

systemctl restart apache2

> thishosting.rocks/install-php-on-ubuntu

Dernière modification par xubu1957 (Le 18/08/2018, à 08:36)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 18/08/2018, à 08:17

Claude LENDREVIE

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Regrets éternels ! Mais pour l'instant, bien merci pour ton conseil. Peut-^etre suffit-il d'ajouter une bibliothèque particulière à php7.2, mais laquelle ?

ps : regarde comme il m'est impossible d'écrire correctement tout caractère français accentué utilisant l'accent circonflexe ou le tréma ! J'ai certainement mal choisi le type de français lors de ma récente installation d'Ubuntu 18.04 sur un tout nouvel ordinateur. Est-il encore possible de corriger ceci ?

Hors ligne

#7 Le 18/08/2018, à 08:29

xubu1957

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Tu avais regardé la Doc > configurer_le_clavier#ajouter_des_agencements_de_clavier_standards ?

Il faudrait tester: Français (variante obsolète).

Dernière modification par xubu1957 (Le 18/08/2018, à 08:30)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#8 Le 18/08/2018, à 08:50

Claude LENDREVIE

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

xubu1957 a écrit :

Tu avais regardé la Doc > configurer_le_clavier#ajouter_des_agencements_de_clavier_standards ?

Il faudrait tester: Français (variante obsolète).

Excellent : c'était bien ce type de Français qu'il fallait choisir. Merci encore.

Hors ligne

#9 Le 18/08/2018, à 09:24

Claude LENDREVIE

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

@ xbuntu1957 :
Ta méthode -et le lien pour lire l'article complet- pour installer une version supplémentaire de php, et l'utiliser par défaut est excellente. Je retrouve le fonctionnement normal de mon site.

Merci, merci ... et bon week-end. Tu peux partir à la plage maintenant ! (je t'écris de Nice où on cherche en ce moment plutôt l'ombre que le soleil)

Hors ligne

#10 Le 18/08/2018, à 09:33

xubu1957

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

Merci, merci ... et bon week-end. Tu peux partir à la plage maintenant !

Je dois éviter le soleil, je reste à l'ombre ! wink


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#11 Le 18/08/2018, à 11:41

Claude LENDREVIE

Re : [résolu] Site inopérant après passage de 16.04lts vers 18.04lts

xubu1957 a écrit :

Merci, merci ... et bon week-end. Tu peux partir à la plage maintenant !

Je dois éviter le soleil, je reste à l'ombre ! wink

Et je suis dans le même cas sans doute : trop exposé dans ma prime jeunesse, et aujourd'hui apparaît sur mon visage quelque forme de mélanomes que je suis obligé de faire supprimer !
Rien ne va plus sur cette terr.

ps: je viens enfin de retrouver mes fonctions d'impression (après recherches chez Brother et réinstallation de drivers). Combien j'apprécie tes aides !

Hors ligne