Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/07/2018, à 20:29

jemo

Mise en veille curieuse et lenteur de la mise en route

Bonjour,
J'utilise xubuntu depuis plusieurs années.
J'ai installé la dernière version LTS depuis plus d'un mois.
J'ai également kubuntu et Windows sur mon DD et des partitions communes accessibles pour les trois.
Depuis quelques jours, le temps entre la validation de mon mot de passe et l'ouverture de la session (en veille) est plus long que d'habitude.
Cela ne me gène pas trop, mais lorsque je clique sur la mise en veille, parfois cette dernière ne se fait pas du tout et la page d'accueil réapparaît; d'autres fois, il semble que la mise en veille se fait bien, mais le voyant de mon ordinateur (médion) au lieu de clignoter reste allumé (je ne sais donc pas s'il est vraiment en veille...).
J'ai essayé de trouver une solution dans le forum: j'ai installé cafféine, mais je n'en comprends pas le fonctionnement ... et ça n'arrange rien.
Merci de m'aider.

Hors ligne

#2 Le 12/07/2018, à 20:36

xubu1957

Re : Mise en veille curieuse et lenteur de la mise en route

Bonjour,

Regarde, pour la lenteur au démarrage > Boot Ubuntu de plus de 5 minutes [Résolu].


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#3 Le 12/07/2018, à 20:54

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Merci pour la proposition xubu1957
Malheureusement, après installation de "haveged", la mise en veille demeure aussi difficile (ce qui ne m'a pas permis d'expérimenter la sortie de veille!).

Quelques instants après : Après avoir réussi la mise en veille (pourquoi?...) le redémarrage a été très rapide! donc, une partie des problèmes serait résolue!

Dernière modification par jemo (Le 13/07/2018, à 00:08)

Hors ligne

#4 Le 13/07/2018, à 00:11

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

En complément:
Après plusieurs essais, la reprise après mise en veille demeure souvent plus lente qu’auparavant et la mise en veille capricieuse...

Hors ligne

#5 Le 13/07/2018, à 06:09

xubu1957

Re : Mise en veille curieuse et lenteur de la mise en route

Bonjour,

Tu avais consulté la Doc > veille_et_hibernation ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#6 Le 13/07/2018, à 18:12

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

J'ai consulté la doc que tu proposes xubu1957.
Un peu complexe pour moi, même en reprenant plusieurs fois!

Une première indication:
la commande

systemctl suspend

ne fonctionne pas à tous les coups!

En 3.3.1, il est proposé:

La solution pour remédier à ce problème est la désactivation du kernel mode setting (KMS): pour cela, il faut mettre l'option nomodeset au démarrage. Éditer /etc/default/grub et ajouter nomodeset à la ligne GRUB_CMDLINE_LINUX, puis sudo update-grub

Je ne dispose pas des connaissances suffisantes pour exécuter cette proposition... comment mettre l'option nomodeset au démarrage...

Hors ligne

#7 Le 13/07/2018, à 19:45

xubu1957

Re : Mise en veille curieuse et lenteur de la mise en route


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#8 Le 14/07/2018, à 00:17

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Bonsoir,
Je suis très perdu...
Il me semble que la dernière doc propose de passer par un "média d'installation", par exemple le DVD d'installation que j'ai gravé et utilisé pour la dernière installation LTS.
La suite me semble très risquée et très compliquée...
Par contre, j'ai ouvert :
/etc/default/grub
ce qui donne ce résultat:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

La ligne
GRUB_CMDLINE_LINUX=""
a en plus du texte =""
dois-je ajouter nomodeset après ="" ?

La note 2 m'inquiète encore plus:

Note 2 : Si après modification ça ne redémarre plus et plus d’invite de session (gnome) alors au (multiboot) Grub, placez-vous sur la ligne de l'Ubuntu qui plante et tapez la touche "e" (mode édition du grub). Retirez le nomodeset puis ctrl+x (pour sauver). Démarrez, si ça démarre ouvrez une console et éditez le fichier grub pour remettre la ligne comme avant:" GRUB_CMDLINE_LINUX="" " et faites un "sudo update-grub" pour enregistrer la modification.

Je crains de me trouver dans l’impossibilité d'ouvrir l'ordinateur... ou de devoir tout réinstaller.

Hors ligne

#9 Le 14/07/2018, à 08:40

Arzon

Re : Mise en veille curieuse et lenteur de la mise en route

Bonjour,
Je viens récemment de pas mal galérer pour faire marcher la mise en veille, suite à l'installation d'une carte pci....c'est encore assez frais dans ma tête.
Si je comprends bien : la mise en veille ne fonctionne pas avec "systemctl suspend" et quand ça marche, c'est au retour de veille que c'est très lent pour revenir ?
C'est un portable ?
Est-ce que la veille a dejà fonctionné sur la 18.04 ou bien ça coince depuis l'ajout d'un matériel ?
Est-ce que ça marche avec un autre noyau (selection du noyau avec grub) au démarrage ?
Est-ce que ça a déjà marché avec une autre version ?
Si ça ne marche pas que depuis la 18.04 sans avoir rien modifié au matériel, je recommanderai d'attendre la mise à jour 18.04.1 qui va régler pas mal de bugs.

Sinon, c'est vrai que la doc est assez costaud.
Tu peux modifier la ligne de grub comme ça : GRUB_CMDLINE_LINUX="nomodeset"
Ce n'est pas bien risqué puisque tu peux editer la ligne au moment du grub.
C'est expliqué ici : https://askubuntu.com/questions/38780/h … led-ubuntu
Je l'avais fait ... sans aucun résultat pour ma part mais ça à l'air de fonctionner sur les portables...

Tu peux aussi installer le paquet 'pm-utils' qui permet de mettre en veille en executant 'pm-suspend'.
Celà génère un fichier log (/var/log/pm-suspend.log) où on peut voir ce qui bloque la mise en veille avec un peu de chance.

Hors ligne

#10 Le 14/07/2018, à 14:21

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Merci Arzon
J'ai ajouté nomodeset, mais cela a aggravé la situation: écran noir en sortie de veille, donc obligation de fermer en force; mise en veille pas normale (au bruit de l'ordi, il semble bien qu'il soit en veille, toutefois le voyant lumineux de l'ordi reste allumé alors qu'il devrait clignoter... parfois mise en veille normale.
J'ai donc ôté nomodeset!
Je crois que je vais patienter pour attendre 18.04.1
Ce qui me semble curieux c'est que ce problème n'existait pas après l'installation du 18.04 LTS: il n'est apparu que récemment.
Je n'ai pas ajouté d'appareil relié par usb.

Dernière modification par jemo (Le 15/07/2018, à 00:02)

Hors ligne

#11 Le 15/07/2018, à 16:12

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Finallement, j'ai changé de noyau au démarrage: pour l'instant tout va bien; la mise en veille se fait bien et la sortie de veille est rapide.
Merci pour votre aide.

Hors ligne

#12 Le 15/07/2018, à 16:52

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

@xubu1957:

Salut,

Concernant la mise en veille avec les noyaux 4.15, se pourrait-il que ce bug s'applique dans le cas de @jemo ?

Ubuntu 18.04 sleep issue

Ubuntu 18.04 error on waking up from sleep : Read-error on swap device

Il y est conseillé d'ajouter le paramètre scsi_mod.scan=sync à la ligne de commande de GRUB comme moyen de contournement ?

A+

Dernière modification par ylag (Le 15/07/2018, à 16:55)

En ligne

#13 Hier à 09:36

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Bonjour
Ça recommence! La mise en veille redevient très aléatoire!
Je ne sais plus que tenter!
Comment ajouter scsi_mod.scan=sync à la ligne de commande de GRUB comme moyen de contournement ?

Hors ligne

#14 Hier à 09:44

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

A la suite de mon dernier envoi, j'ai voulu redémarrer pour faciliter le fonctionnement de la mise en veille.
j'ai obtenu une réponse que je n'avais jamais eue jusque là:
"Erreur reçue lors de la déconnexion.
Le gestionnaire de session doit être en mode attente lors d'une requête de mise hors tension."
Je ne sais pas interpréter ce message!

Ce message réapparaît chaque fois que je clique sur la fermeture de l'ordinateur: je vais être contraint de le fermer en force.

Dernière modification par jemo (Hier à 09:52)

Hors ligne

#15 Hier à 09:55

xubu1957

Re : Mise en veille curieuse et lenteur de la mise en route

Bonjour,

En attendant une solution plus efficace :

Tu peux essayer de redémarrer avec les touches_magiques ?

Le 15/03/2018, moko138 a écrit :

(...)
Plutôt que l'extinction mécanique forcée, qui détériore les composants et qui laisse en vrac les systèmes de fichiers des partitions montées, il faut préférer  les touches_magiques.

En l'occurrence, tu pouvais repasser en session graphique : Ctrl Alt F7
puis employer ces touches magiques.

Concrètement, pour redémarrer:
Alt+Sys  r e i s  (*)    u (*)    b

(*) attendre quelques secondes.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#16 Hier à 14:10

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Merci xubu1957
J'ai bien tapé Ctrl Alt F7 (ce qui ne produit pas d'effet visible)
Par contre Alt+Syst entraîne la mise en route de l'impression écran.

Dans:
https://doc.ubuntu-fr.org/touches_magiques
il est indiqué :

Pré-requis
Pour pouvoir accéder aux touches magiques, il faut que cette fonctionnalité ait été activée dans le noyau. Par défaut sur Ubuntu, cette fonctionnalité est activée partiellement. Le fichier /proc/sys/kernel/sysrq s'il existe indique le fait que cette option est activée.
Si vous compilez vous-même votre noyau, il vous faut mettre l'option Magic SysRq key du menu Kernel Hacking à oui

Je n'ai pas le fichier syrrq
Faut-il compiler le noyau? Je n'ai jamais fait ça!

Hors ligne

#17 Hier à 15:35

xubu1957

Re : Mise en veille curieuse et lenteur de la mise en route

J'en étais resté à la procédure de secours pour redémarrer.

Pour la compilation, c'est pas dans mes cordes d'utilisateur lambda.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#18 Hier à 16:13

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

jemo a écrit :

Je n'ai pas le fichier syrrq

C'est plutôt sysrq

Pour tester l'option scsi_mod.scan=sync, fait comme pour nomodeset  dans la note 2 de ton commentaire #8 en remplacant nomodeset par le paramètre suggéré plus haut...

A+

Dernière modification par ylag (Hier à 16:23)

En ligne

#19 Hier à 16:59

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Merci ylag; ça devient compliqué...
que veux-tu dire par "le paramètre suggéré plus haut"?

Hors ligne

#20 Hier à 17:15

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

jemo a écrit :

que veux-tu dire par "le paramètre suggéré plus haut"?

C'est l'expression scsi_mod.scan=sync que tu dois passer dans la ligne de commande du démarrage, comme tu semblais l'avoir fait pour nomodeset.
Réfère-toi au paragraphe 7.10 de cette page de la doc, déjà suggérée par @xubu1957 au commentaire #7:

https://doc.ubuntu-fr.org/kernel#exempl … oyau_linux

Ajout: Méfie-toi du paragraphe 7.10.2 de cette doc. Pour pérenniser de façon sécuritaire, il vaut mieux modifier directement le fichier /etc/default/grub à l'aide de ton éditeur de fichiers. (À mon avis...)

A+

Dernière modification par ylag (Hier à 19:26)

En ligne

#21 Hier à 20:50

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Bonsoir et merci ylag.

J'ai été très attentif à suivre le procédure.
En 7.10.1, j'ai constaté qu'après "quiet splash", il y avait déjà "$vt_handoff".
J'ai tenté tout de même d'ajouter "scsi_mod.scan=sync":
La mise en veille s'est déroulée normalement et immédiatement.
Par contre, impossible de sortir de la veille: écran noir.
Je n'ai donc pas validé.
... et j'en suis toujours au même point avec un comportement aléatoire pour la mise en veille et la sortie de veille...

Hors ligne

#22 Aujourd'hui à 09:34

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Je constate plutôt une aggravation: de plus en plus j'ai un écran noir à la sortie de l'état de veille.
La procédure avec les "touches magiques" que j'ai imprimée ne fonctionne pas : rien ne se passe, même en attendant quelques secondes comme indiqué à 2 reprises.

Hors ligne

#23 Aujourd'hui à 13:55

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Peut-être une piste dans cette discussion récente:

Ecran noir apres une sortie de mise en veille (Xubuntu)

A+

En ligne

#24 Aujourd'hui à 16:54

jemo

Re : Mise en veille curieuse et lenteur de la mise en route

Merci ylag
J'ai remplacé light-locker par xscreensaver sans succès!

Hors ligne

#25 Aujourd'hui à 17:43

ylag

Re : Mise en veille curieuse et lenteur de la mise en route

Salut,

Au risque de dire une énormité, as-tu tenté des entrées aléatoires au clavier et/ou des mouvements de la souris (ou pavé tactile, selon le cas...) lors de l'écran noir en sortie de veille ?

A+

Dernière modification par ylag (Aujourd'hui à 17:44)

En ligne