Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/06/2018, à 16:22

Azerlynks

Problème configuration Virtualhost

Bonjour/Bonsoir

Tout d'abord, sachez que je ne suis pas un habitué de tout ce qui est réseau/linux etc... mais comme
Windows à décidé de me pourir la vie, je me suis tourné vers ubuntu...

bref

J'ai un serveur (apache etc..) qui doit me servir a travailler en local (sites web entre autre) sur mon PC. 
Par souci de confort, je souhaite pouvoir accéder a mes sites en local non pas avec:

localhost/monsite.dev/

mais avec:

monsite.dev

le "site" qui me sert de test s'appelle monsite.dev et ne contient pour l'instant qu'une ligne de php qui dit "coucou"...

Ce que j'ai déja:

- sudo nano /etc/hosts

127.0.0.1       localhost
127.0.1.1       lXXXXXXXXX

[...]

127.0.0.1 monsite.dev

- sudo nano /etc/apache2/sites-available/monsite.dev.conf

<VirtualHost monsite.dev:80> 

ServerAdmin webmaster@monsite.dev 
ServerName monsite.dev
ServerAlias www.monsite.dev 
DocumentRoot /var/www/html/monsite.dev
<Directory /var/www/html/monsite.dev> 
Options Indexes FollowSymLinks 
AllowOverride all 
Require all granted 
</Directory> 

ErrorLog ${APACHE_LOG_DIR}/monsite.dev-error.log 
CustomLog ${APACHE_LOG_DIR}/monsite.dev-access.log combined 
</VirtualHost> 

Emplacement localhost:
cd /var/www/html

Quand je rentre sur le navigateur(Firefox) "monsite.dev":

Hum, nous ne parvenons pas à trouver ce site.

Impossible de se connecter au serveur à l’adresse www.monsite.dev.
Si l’adresse est correcte, voici trois autres choses que vous pouvez essayer de faire :

    Réessayer ultérieurement.
    Vérifier votre connexion au réseau.
    Si vous êtes connecté au travers d’un pare-feu, vérifier que Firefox a la permission d’accéder au Web.

Je peux:
- Accéder au site grâce à localhost (je tape localhost et je suis sur le site)
- Accéder a phpmyadmin: localhost/phpmyadmin/
- ping monsite.dev (aucun paquet perdu)

et j'ai également fait:
a2ensite et reload apache

ubuntu 16.04 LTS
Server version: Apache/2.4.18 (Ubuntu)

J’espère que j'ai rien oublié et que c'est assez clair
Merci pour le temps que vous prenez.

Hors ligne

#2 Le 07/06/2018, à 16:32

bruno

Re : Problème configuration Virtualhost

Bonjour,

Il ne faut pas utiliser de faux noms de domaine avec .dev (celui-ci est déclaré et réservé). Remplace tes pseudo domaines par : monsite.home.arpa (tu peux aussi utiliser .test ou .localhost, réf : https://www.iana.org/assignments/specia … names.xml)

Hors ligne

#3 Le 07/06/2018, à 17:07

Azerlynks

Re : Problème configuration Virtualhost

Ouah.....

Une réponse rapide qui fonctionne....
Un grand merci bruno.

Hors ligne