Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/01/2018, à 18:24

guillaume.fontaine

[Résolu]problème de boot

Bonjour,
Je viens juste de réinstaller une ubuntu.
Au démarrage de l'ordinateur, je n'arrive pas jusqu'a grub. Je tombe sur le BIOS.
Dans le Bios, mon disque ssd (sda) où est installé grub (et ubuntu) est absent du "boot option priorities".
Par contre, il est dans la section "boot override".
Problème matériel ou mauvaise intall de grub ?
Pour info, mon grub-info

Je me demande donc si je dois envoyer l'ordi en SAV ?

D'avance merci

Dernière modification par guillaume.fontaine (Le 31/03/2018, à 19:51)

Hors ligne

#2 Le 28/01/2018, à 19:34

rentabilicus

Re : [Résolu]problème de boot

Tentes une réinstallation.

Si cela persiste essaies le logiciel freeware en live Boot Repair Disk (si tu as la possibilité d'avoir accès à un autre micro...) pour réparer le grub.

Dernière modification par rentabilicus (Le 28/01/2018, à 19:39)

Hors ligne

#3 Le 29/01/2018, à 14:30

guillaume.fontaine

Re : [Résolu]problème de boot

J'ai déjà essayé de réinstaller ubuntu et idem.
J'ai aussi essayé boot-repair et aucun changement...

Hors ligne

#4 Le 02/02/2018, à 19:04

rentabilicus

Re : [Résolu]problème de boot

Ton ordi reconnait-il ton DD ?

Hors ligne

#5 Le 02/02/2018, à 21:54

guillaume.fontaine

Re : [Résolu]problème de boot

J'arrive a booter dessus (et utiliser ubuntu) en utilisant le menu démarrage du BIOS. Mais je retourne dans le bios à chaque redémarrage et donc menu démarrage du bios pour démarrer ubuntu...

Hors ligne

#6 Le 02/02/2018, à 21:54

??

Re : [Résolu]problème de boot

guillaume.fontaine a écrit :

J'ai déjà essayé de réinstaller ubuntu et idem.
J'ai aussi essayé boot-repair et aucun changement...

Bonsoir.

Si tu as fais la réparation recommandée par boot-repair, Il faudrait que tu positionnes ton bios pour qu'il boote sur sdb puis sdc
Si cela ne fonctionne pas,  refais la réparation recommandée et poste l'url qui sera généré pendant cette réparation afin qu'on comprenne.

Dernière modification par ?? (Le 02/02/2018, à 21:56)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide

Hors ligne

#7 Le 02/02/2018, à 22:00

guillaume.fontaine

Re : [Résolu]problème de boot

sdb et sdc sont 2 disques en RAID1. Et il n'y a pas si longtemps, je bootais sur sda (le disque où est installé ubuntu)...

Hors ligne

#8 Le 02/02/2018, à 22:03

guillaume.fontaine

Re : [Résolu]problème de boot

De mémoire, la réparation recommandée avait refusée d'installer grub sur mon disque en RAID1. Seulement sda possible (et moi c'est plutôt ça que je recherche: grub sur sda).

Hors ligne

#9 Le 02/02/2018, à 22:40

??

Re : [Résolu]problème de boot

guillaume.fontaine a écrit :

Dans le Bios, mon disque ssd (sda) où est installé grub (et ubuntu) est absent du "boot option priorities".
Par contre, il est dans la section "boot override".
D'avance merci

si cela avait déjà fonctionné et que tu ne peux plus remettre SDA dans la liste.
il faudrait voir en faisant une installation en EFI comment cela  va réagir.
Pour cela , il faut modifier le bios pour qu'il boote en EFI et refaire un boot-info afin de savoir si on retrouve une trace d'une ancienne installation en EFI.

Dernière modification par ?? (Le 05/02/2018, à 19:41)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide

Hors ligne

#10 Le 05/02/2018, à 19:31

guillaume.fontaine

Re : [Résolu]problème de boot

Le boot-info après réinstall de grub avec boot-repair avec dans le bios le démarrage rapide de remis.

Hors ligne

#11 Le 05/02/2018, à 19:52

??

Re : [Résolu]problème de boot

guillaume.fontaine a écrit :

sdb et sdc sont 2 disques en RAID1. Et il n'y a pas si longtemps, je bootais sur sda (le disque où est installé ubuntu)...

Bonjour
De toute façon ton installation de ta version 32 bits est parfaite.
Je ne suis pas trop surpris  que le boot-repair ne puisse pas s'installer sur les RAIDS. On a au moins les codes d'erreurs

Reinstall the GRUB of sda1 into the MBR of sdb
Installing for i386-pc platform.
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: error: embedding is not possible, but this is required for cross-disk install.
grub-install /dev/sdb: exit code of grub-install /dev/sdb:1

Reinstall the GRUB of sda1 into the MBR of sdc
Installing for i386-pc platform.
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: error: embedding is not possible, but this is required for cross-disk install.
grub-install /dev/sdc: exit code of grub-install /dev/sdc:1

Il faut donc que tu trouves la solution pour que SDA soit le disque de démarrage  indiqué par le bios.
Tu as dit toi-même qu'avant c'était possible.
Qu'elle était donc cette version qui était présente et qui  savait booter?   Une version EFI ?   C'est à dire en 64 bits alors que maintenant tu as installé une version 32 bits.

Dernière modification par ?? (Le 05/02/2018, à 19:53)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide

Hors ligne

#12 Le 06/02/2018, à 11:43

guillaume.fontaine

Re : [Résolu]problème de boot

?? a écrit :

Qu'elle était donc cette version qui était présente et qui  savait booter?   Une version EFI ?   C'est à dire en 64 bits alors que maintenant tu as installé une version 32 bits.

C'était une Cubuntu et je ne sais plus si le mode démarrage rapide était activé. Là j'ai mis une ubuntu 16.04.03 en 64bits.

Le dernier boot-repair (réparation recommandée sur sda1 en plus de sda) a planté l'ordi au démarrage (on arrive en console root...)
J'ai refait une install d'buntu 16.04.03 en 64bits avec le bios en démarrage rapide.

Le bios ne permet toujours pas de booter ; seules sont présentes mon lecteur DVD (qui boot bien sur le dvd d'install) et intel volume 1 (qui ne boot pas : curseur qui se balade sur un écran noir avant de revenir au bios). Je peux toujours booter via le menu de démarrage du bios sur le disque ssd.

Dernière modification par guillaume.fontaine (Le 06/02/2018, à 12:11)

Hors ligne

#13 Le 06/02/2018, à 17:25

rentabilicus

Re : [Résolu]problème de boot

Excellent si tu arrives à rooter en mode console :

J'ai moi-même eu cette difficulté et je te joins mon tuto pour t'en sortir :

Commences au niveau de la commande blkid stp

Good luck !!!

Hors ligne

#14 Le 06/02/2018, à 18:35

??

Re : [Résolu]problème de boot

guillaume.fontaine a écrit :

Le bios ne permet toujours pas de booter .......... Je peux toujours booter via le menu de démarrage du bios sur le disque ssd.

Une certaine contradiction.

Si ton micro-ordinateur est un portable, peux-tu indiquer sa référence commerciale?
Si c'est un fixe, peux-tu indiquer le référence de la carte mère?
Peut-tu refaire un boot-info?
A part ce problème de boot, as-tu d'autres  problèmes?

Dernière modification par ?? (Le 06/02/2018, à 18:35)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide

Hors ligne

#15 Le 11/02/2018, à 11:25

guillaume.fontaine

Re : [Résolu]problème de boot

Pour la contradiction big_smile je complète ma phrase : Le bios ne permet toujours pas de booter automatiquement .......... Je peux toujours booter via le menu de démarrage du bios sur le disque ssd.

C'est une tour avec une carte mère X99-A.

Et le boot-info du système en place : http://paste.ubuntu.com/=Yrgc7Hrydm/

Et je n'ai d'autre problème

Hors ligne

#16 Le 11/02/2018, à 16:39

??

Re : [Résolu]problème de boot

guillaume.fontaine a écrit :

Bonjour,
Je viens juste de réinstaller une ubuntu.
Au démarrage de l'ordinateur, je n'arrive pas jusqu'a grub. Je tombe sur le BIOS.
Dans le Bios, mon disque ssd (sda) où est installé grub (et ubuntu) est absent du "boot option priorities".
Par contre, il est dans la section "boot override".
Problème matériel ou mauvaise intall de grub ?

D'avance merci

Si cette portion de ton bios ressemble à cet écran
http://kmpic.asus.com/images/2015/07/21 … 55eaf5.png
tu as un bios EFI. Dans ce cas, fais une installation EFI en reformatant ton SSD avec le gparted du support d'installation
  a) suppression de toutes les partitions
  b) création d'une table de partition au format GPT avec l'onglet périphériques
  c) Creation d'une partition FA32 de 35 Mo
  d) Mise des drapeaux boot ou/et ESP sur cette partition.
puis réinstalles ubuntu

Si cette portion de bios ne mentionne pas le mot EFI, fais une photo et postes la photo dans  un site de partage de photo tel que pix.toile-libre.org et donnes le lien qui sera généré.

Dernière modification par ?? (Le 25/02/2018, à 12:07)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide

Hors ligne

#17 Le 13/02/2018, à 16:06

rentabilicus

Re : [Résolu]problème de boot

Créer une partition en FAT32  sous linux... On croit rêver !!!

=> Les partitions FAT32 sont réservées à Windows... Tu t'es trompé de forum mon gars.

Vois-tu apparaitre ton DD dans le Bios avec  l'EFI ?

Le Bios est un soft qui reconnait les différents périphériques branchés à partir de ta carte mère lors du démarrage de ta machine.

Si dans la fenêtre réservée au DD tu ne le vois pas cela veut dire qu'il n'est pas reconnu par le BIOS et qu'il lui est impossible de Booter car il ne le reconnait pas comme périphérique (Il lui est manquant).

Dans ce cas là vérifies le branchement de ton DD sur ton port SATA de ta carte mère et sur ton DD lui-même.

Ou alors ton cable de branchement entre ta carte mère et ton DD est défectueux => Essaies avec un autre cable SATA.

Dans tous les cas tu dois voir apparaitre ton DD de boot dans le Bios via l'EFI sinon ta machine ne pourra nullement booter.

Hors ligne

#18 Le 13/02/2018, à 16:14

Nasman

Re : [Résolu]problème de boot

> rentabilicus
As tu déjà vu le type de de système de fichiers d'une partition efi destinée à faire démarrer un linux en mode EFI - et les en-têtes des fichiers .efi ?


PC fixe et portable avec Xenial 64 bits

Hors ligne

#19 Le 25/02/2018, à 12:02

guillaume.fontaine

Re : [Résolu]problème de boot

Voici mon bios:
La page d'accueil:
1519552321.jpg
Le haut de la page du boot (en sachant que pour la première ligne j'ai essayé en fast boot enabled et disabled) :
1519552544.jpg
Le bas de la page de boot (mon disque avec ubuntu est le P7 : Samsung SSD)
1519552701.jpg
Et le menu boot que je me sert pour booter sur le disque SSD où j'ai fait l'install d'ubuntu (et qui fonctionne : je vous écris de là) :
1519552839.jpg

Une idée du problème ?

Hors ligne

#20 Le 25/02/2018, à 12:14

??

Re : [Résolu]problème de boot

rentabilicus a écrit :

Créer une partition en FAT32  sous linux... On croit rêver !!!

=> Les partitions FAT32 sont réservées à Windows... Tu t'es trompé de forum mon gars.

.

Bonjour
Si tu considères mes conseils comme stupides, tu seras la goutte d'eau  qui fait déborder le vase.... Je quitte le forum.
Continues de faire profiter de tes conseils ceux qui ont des problèmes  de mise en route de matériel du siècle dernier.


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide

Hors ligne

#21 Le 31/03/2018, à 19:51

guillaume.fontaine

Re : [Résolu]problème de boot

Au final c'était un problème de bios. Pour régler le problème :
-paramètres par défaut du bios
-enlever le fast boot

Et maintenant ça boot automatiquement sans problème !

Hors ligne