Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/01/2018, à 15:07

Endash

[Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

Bonjour,

J'ai fait deux choses récemment: je suis passé à la 17.10 et j'ai supprimé simple-scan car je n'utilise que xsane.

Or, je viens de découvrir que xsane n'est plus installé:

$ xsane
Le programme « xsane » n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt install xsane

Et quand j'essaye d'installer:

$ sudo apt-get install xsane
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 xsane : Dépend: libsane1 (>= 1.0.24) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

J'ai donc tenté de me rabattre sur simple-scan:

$ simple-scan
Le programme « simple-scan » n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt install simple-scan

Ce qui est normal, puisque je l'avais désinstallé. J'essaye donc de le réinstaller, mais je tombe sur la même erreur:

$ sudo apt install simple-scan
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 simple-scan : Dépend: libsane1 (>= 1.0.24) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Si j'essaye d'installer libsane1 directement:

$ sudo apt install libsane1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libsane1 : Dépend: libsane-common (= 1.0.27-1~experimental2ubuntu2.1) mais 1.0.27+git20171206-zesty0 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

J'imagine que forcer l'installation de la version expérimentale pourrait résoudre le problème, mais je me dis que le problème est plus profond que ça.

Voici ce que donne l'update et l'upgrade:

$ sudo apt-get update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu artful InRelease
Atteint:2 http://fr.archive.ubuntu.com/ubuntu artful-updates InRelease
Atteint:3 http://fr.archive.ubuntu.com/ubuntu artful-security InRelease                         
Atteint:4 http://archive.canonical.com artful InRelease                                         
Lecture des listes de paquets... Fait 
$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  colord
0 mis à jour, 0 nouvellement installés, 0 à enlever et [u][b]1 non mis à jour[/b][/u].

Pas plus de chance avec dist-upgrade:

$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  colord
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.

Or je vois qu'xsane est bien évidemment disponible sur 17.10 donc ses dépendances aussi. Par conséquent, je suppose avoir un problème avec ma configuration des dépôts ou truc de ce genre que je ne maîtrise pas assez. D'où ma demande d'aide sur ce forum: quelqu'un sait-il comment réparer ce que j'ai cassé ?

J'imagine que j'ai un problème avec la liste des dépôts

Dernière modification par Endash (Le 15/01/2018, à 19:00)


Asus Zenbook UX305F sous Xubuntu 18.04

Hors ligne

#2 Le 06/01/2018, à 15:28

bipede

Re : [Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

Comment es-tu passé à la 17.10 ?
Mise à jour ou installation ?
D’après ce que je peux lire sur ton post, tu aurais le paquet libsane issu d'un dépôt unstable sous zesti, et c'est ça qui coincerait.


Desktop: MSI - Intel® Core™ i5-3330 CPU @ 3.00GHz × 4 - RAM 8 go- Ubuntu 18.04 - Système sur SSD 64 Go - /home sur HDD 500 Go.
Laptop: DELL Inspiron-15 3567 - Intel® Core™ i5-7200 CPU @ 2.50GHz × 4 - RAM 8 go - HDD 1 To - Ubuntu 18.04 avec /home séparé.

Mon site: Les contributions du bipède

Hors ligne

#3 Le 06/01/2018, à 15:34

Endash

Re : [Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

Je suis passé par une mise-à-jour.


Asus Zenbook UX305F sous Xubuntu 18.04

Hors ligne

#4 Le 15/01/2018, à 14:50

Endash

Re : [Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

Je me permets d'insister. J'ai des notes de frais à scanner big_smile

Quelqu'un saurait-il me dire comment nettoyer les paquets et repartir sur une base saine ?


Asus Zenbook UX305F sous Xubuntu 18.04

Hors ligne

#5 Le 15/01/2018, à 17:47

eric63

Re : [Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

salut
est ce que tu as essayé ce post


kdeïste convaincu avec Kubuntu 18.04 + backports = plasma 5.12.6 et KDE framaworks 5.47.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#6 Le 15/01/2018, à 18:02

grandtoubab

Re : [Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

Salut
Pour identifier les dépots qui fournissent libsane1 sur ton installation

apt-cache policy libsane1

idem avec  libsane-common

 apt-cache policy libsane-common

Dernière modification par grandtoubab (Le 15/01/2018, à 18:10)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#7 Le 15/01/2018, à 19:00

Endash

Re : [Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

Wow, merci eric63, l'installation de aptitude a fonctionné ! Sujet résolu !


Asus Zenbook UX305F sous Xubuntu 18.04

Hors ligne

#8 Le 15/01/2018, à 20:26

eric63

Re : [Résolu] xsane dépend libsane1 (>= 1.0.24) mais ne sera pas installé

tu devais avoir deux versions de libsane
vérifie ce que te dit grandtoubab pour voir si t'as pas un ppa en sus

Dernière modification par eric63 (Le 15/01/2018, à 20:29)


kdeïste convaincu avec Kubuntu 18.04 + backports = plasma 5.12.6 et KDE framaworks 5.47.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne