Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 25/01/2017, à 15:20

EnZ0

[RESOLU] Dépendances non satisfaites

Depuis deux jours, il m'est impossible d'effectuer les mises à jour du système (Ubuntu Gnome 17.04)

Installation de paquet ou sudo apt-get update && sudo apt-get upgrade, le résultat est le même :

Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 wine32-development:i386 : Dépend: libwine-development:i386 (= 2.0~rc6-1ubuntu1) mais il n'est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Si je tente la commande indiquée, rien de mieux :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libjson-c3:i386
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
The following additional packages will be installed:
  libwine-development:i386
Les NOUVEAUX paquets suivants seront installés :
  libwine-development:i386
0 mis à jour, 1 nouvellement installés, 0 à enlever et 43 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/18,5 Mo dans les archives.
Après cette opération, 173 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
dpkg: avertissement: analyse du fichier '/var/lib/dpkg/status' vers la ligne 13125 paquet 'wine-stable' :
 on ne peut utiliser que des versions exactes dans le champ « Provides ». 
(Lecture de la base de données... 260419 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libwine-development_2.0~rc6-1ubuntu1_i386.deb ...
Dépaquetage de libwine-development:i386 (2.0~rc6-1ubuntu1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libwine-development_2.0~rc6-1ubuntu1_i386.deb (--unpack) :
 impossible d'ouvrir « /usr/lib/i386-linux-gnu/wine-development/mshtml.dll.so.dpkg-new »: Opération non permise
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libwine-development_2.0~rc6-1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

En testant sudo dpkg --configure -a j'obtiens

dpkg: avertissement: analyse du fichier '/var/lib/dpkg/status' vers la ligne 13125 paquet 'wine-stable' :
 on ne peut utiliser que des versions exactes dans le champ « Provides ». 
Paramétrage de libwine-development:amd64 (2.0~rc6-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...
dpkg: des problèmes de dépendances empêchent la configuration de wine32-development:i386 :
 wine32-development:i386 dépend de libwine-development (= 2.0~rc6-1ubuntu1) ; cependant :
  Le paquet libwine-development:i386 n'est pas installé.

dpkg: erreur de traitement du paquet wine32-development:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de wine64-development (2.0~rc6-1ubuntu1) ...
Paramétrage de wine-development (2.0~rc6-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour wine-development (2.0~rc6-1ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 wine32-development:i386

Je ne sais pas comment remédier au problème.

Quelqu'un saurait-il m'aiguiller ?

Merci beaucoup pour votre aide !

Dernière modification par EnZ0 (Le 26/01/2017, à 17:20)

Hors ligne

#2 Le 25/01/2017, à 21:56

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Manifestement, ce sont des paquets liés à Wine qui posent problème. Tu peux commencer par les supprimer et ça devrait résoudre la situation :

sudo apt-get remove --purge wine-development wine64-development wine32-development:i386 libwine-development libwine-development:i386

Ensuite, pour ce qui est de les réinstaller, c'est une autre affaire vu qu'il y a un conflit de dépendances. Mais pourquoi est-ce que tu as des paquets de Wine qui sont apparemment (au vu de leur nom) liés à son développement ?

Hors ligne

#3 Le 25/01/2017, à 22:17

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Bonsoir abelthorne et merci de ton aide !

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet « libwine-development:i386 » n'est pas installé, et ne peut donc être supprimé. Peut-être vouliez-vous écrire « libwine-development » ?
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 playonlinux : Dépend: wine ou
                        wine-development mais ne sera pas installé
 winetricks : Dépend: wine
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

J'ai tenté la désinstallation également de playonlinux mais même résultat.
Wine est installé depuis longue date, et pour les versions de développement, vraisemblablement parce que je n'arrivais pas à faire tourner la seule application Microsoft qu'il me fallait impérativement (Onenote). Mais ça ne marche pas pour autant de toute manière, donc sa désinstallation ne me dérange pas.

Hors ligne

#4 Le 25/01/2017, à 22:36

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Wine est installé depuis longue date, et pour les versions de développement, vraisemblablement parce que je n'arrivais pas à faire tourner la seule application Microsoft qu'il me fallait impérativement (Onenote). Mais ça ne marche pas pour autant de toute manière, donc sa désinstallation ne me dérange pas.

En fait, je n'entendait pas la version de développement de Wine (plus à jour que la stable) mais des paquets liés au développement-même de Wine, probablement pour le compiler, ce genre de chose. Il va falloir supprimer tout ce qui a trait à Wine, commence par donner le retour de :

apt-cache policy wine*

Je vois que tu postes dans la section Zesty (Ubuntu 17.04, actuellement en alpha). Tu es sur cette version ou tu t'es planté de section ?

Dernière modification par abelthorne (Le 25/01/2017, à 22:37)

Hors ligne

#5 Le 25/01/2017, à 22:55

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Je suis bien en 17.04

Pour le retour, voici :

apt-cache policy wine*
winetricks:
  Installé : 0.0+20170101-1ubuntu2
  Candidat : 0.0+20170101-1ubuntu2
 Table de version :
 *** 0.0+20170101-1ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
        100 /var/lib/dpkg/status
wine1.9-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-gecko:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
winefish:
  Installé : (aucun)
  Candidat : 1.3.3-0dl1ubuntu2
 Table de version :
     1.3.3-0dl1ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-binfmt:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
wine32-preloader:i386:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
wine32-development-tools:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-development:
  Installé : 2.0~rc6-1ubuntu1
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
 *** 2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        100 /var/lib/dpkg/status
wine1.9-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-preloader:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine1.8-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-development-tools:
  Installé : (aucun)
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
     2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine1.6-dev:
  Installé : (aucun)
  Candidat : 1:1.8.4ubuntu1
 Table de version :
     1:1.8.4ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine1.8-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.0:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.2:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.3:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.5:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.6:
  Installé : 1:1.8.4ubuntu1
  Candidat : 1:1.8.4ubuntu1
 Table de version :
 *** 1:1.8.4ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        100 /var/lib/dpkg/status
wine1.7:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.8:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.9:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.5-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine32-development:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.7-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.6-amd64:
  Installé : (aucun)
  Candidat : 1:1.8.4ubuntu1
 Table de version :
     1:1.8.4ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-development:
  Installé : 2.0~rc6-1ubuntu1
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
 *** 2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
        100 /var/lib/dpkg/status
wine32-tools:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.6-i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-stable:
  Installé : 1.8.6-3ubuntu1
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
 *** 1.8.6-3ubuntu1 100
        100 /var/lib/dpkg/status
wine32:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64:
  Installé : 1.8.6-3ubuntu1
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
 *** 1.8.6-3ubuntu1 100
        100 /var/lib/dpkg/status
wine1.5-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-gecko2.21:
  Installé : (aucun)
  Candidat : 2.21-0ubuntu1
 Table de version :
     2.21-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/multiverse amd64 Packages
wine-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-development-preloader:
  Installé : (aucun)
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
     2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-mono0.0.8:
  Installé : (aucun)
  Candidat : 0.0.8-0ubuntu1
 Table de version :
     0.0.8-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/multiverse amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/multiverse i386 Packages
wine1.7-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.9-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.7-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.5-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-tools:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-mono:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.8-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine32-development-preloader:i386:
  Installé : (aucun)
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
     2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages

Hors ligne

#6 Le 26/01/2017, à 02:47

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Donc :

sudo apt-get remove --purge winetricks wine64-development wine1.6 wine-development wine-stable wine64

Une fois que c'est fait, tente une mise à jour :

sudo apt-get update && sudo apt-get dist-upgrade

Et tu donneras la liste de tes dépôts tiers :

ls /etc/apt/sources.list.d

Hors ligne

#7 Le 26/01/2017, à 08:55

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Pas mieux :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 playonlinux : Dépend: wine ou
                        wine-development mais ne sera pas installé
 wine32-development:i386 : Dépend: libwine-development:i386 (= 2.0~rc6-1ubuntu1) mais ne sera pas installé
                           Recommande: wine-development:i386 (= 2.0~rc6-1ubuntu1)
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Merci encore pour le temps que tu m'accordes abelthorme !

Hors ligne

#8 Le 26/01/2017, à 09:00

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Quand tu as fait la première commande, il a réussi à désinstaller tous les paquets concernés ? Si tu refais un apt-cache policy wine* tu vois encore des paquets qui sont en statut "installé" ?

Dans le doute, tu peux essayer de supprimer les mêmes paquets mais en version 32 bits, je ne suis pas sûr qu'apt-cache les affiche même quand ils sont installés. Je les mets tous, même si certains ne peuvent pas être dispo en 32 bits, ne t'étonne pas si tu as des messages disant qu'ils n'existent pas :

sudo apt-get remove --purge winetricks:i386 wine64-development:i386 wine1.6:i386 wine-development:i386 wine-stable:i386 wine64:i386

Dernière modification par abelthorne (Le 26/01/2017, à 09:01)

Hors ligne

#9 Le 26/01/2017, à 09:06

EnZ0

Re : [RESOLU] Dépendances non satisfaites

A priori oui, il en reste :

sudo apt-cache policy wine*
winetricks:
  Installé : 0.0+20170101-1ubuntu2
  Candidat : 0.0+20170101-1ubuntu2
 Table de version :
 *** 0.0+20170101-1ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
        100 /var/lib/dpkg/status
wine1.9-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-gecko:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
winefish:
  Installé : (aucun)
  Candidat : 1.3.3-0dl1ubuntu2
 Table de version :
     1.3.3-0dl1ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-binfmt:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
wine32-preloader:i386:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
wine32-development-tools:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-development:
  Installé : 2.0~rc6-1ubuntu1
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
 *** 2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        100 /var/lib/dpkg/status
wine1.9-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-preloader:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine1.8-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-development-tools:
  Installé : (aucun)
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
     2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine1.6-dev:
  Installé : (aucun)
  Candidat : 1:1.8.4ubuntu1
 Table de version :
     1:1.8.4ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine1.8-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.0:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.2:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.3:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.5:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.6:
  Installé : 1:1.8.4ubuntu1
  Candidat : 1:1.8.4ubuntu1
 Table de version :
 *** 1:1.8.4ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        100 /var/lib/dpkg/status
wine1.7:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.8:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.9:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.5-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine32-development:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.7-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.6-amd64:
  Installé : (aucun)
  Candidat : 1:1.8.4ubuntu1
 Table de version :
     1:1.8.4ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-development:
  Installé : 2.0~rc6-1ubuntu1
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
 *** 2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
        100 /var/lib/dpkg/status
wine32-tools:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.6-i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-stable:
  Installé : 1.8.6-3ubuntu1
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
 *** 1.8.6-3ubuntu1 100
        100 /var/lib/dpkg/status
wine32:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64:
  Installé : 1.8.6-3ubuntu1
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
 *** 1.8.6-3ubuntu1 100
        100 /var/lib/dpkg/status
wine1.5-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-gecko2.21:
  Installé : (aucun)
  Candidat : 2.21-0ubuntu1
 Table de version :
     2.21-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/multiverse amd64 Packages
wine-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.4-i386:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-development-preloader:
  Installé : (aucun)
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
     2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-mono0.0.8:
  Installé : (aucun)
  Candidat : 0.0.8-0ubuntu1
 Table de version :
     0.0.8-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/multiverse amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu zesty/multiverse i386 Packages
wine1.7-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.9-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.7-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.5-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine64-tools:
  Installé : (aucun)
  Candidat : 1.8.6-3ubuntu2
 Table de version :
     1.8.6-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
wine-mono:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine1.8-amd64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wine32-development-preloader:i386:
  Installé : (aucun)
  Candidat : 2.0~rc6-1ubuntu1
 Table de version :
     2.0~rc6-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu zesty/universe i386 Packages

Et pour ta deuxième commande :

sudo apt-get remove --purge winetricks:i386 wine64-development:i386 wine1.6:i386 wine-development:i386 wine-stable:i386 wine64:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de « winetricks » au lieu de « winetricks:i386 »
Note : sélection de « wine-development » au lieu de « wine-development:i386 »
Note : sélection de « wine-stable » au lieu de « wine-stable:i386 »
E: Impossible de trouver le paquet wine64-development:i386
E: Impossible de trouver le paquet wine64:i386

Hors ligne

#10 Le 26/01/2017, à 10:43

abelthorne

Re : [RESOLU] Dépendances non satisfaites

En fait, il reste tous les paquets, ils n'ont pas été désinstallés. Donc, refais la commande suivante et fais bien attention à ce qu'il te dit :

sudo apt-get remove --purge winetricks wine64-development wine1.6 wine-development wine-stable wine64

Fais un copier-coller de l'ensemble du processus, ce sera plus pratique pour voir ce qui déconne.

Hors ligne

#11 Le 26/01/2017, à 10:46

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Voici :

nom_utilisateur@Asubuntu:~$ sudo apt-get remove --purge winetricks wine64-development wine1.6 wine-development wine-stable wine64
[sudo] Mot de passe de nom_utilisateur : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 playonlinux : Dépend: wine ou
                        wine-development mais ne sera pas installé
 wine32-development:i386 : Dépend: libwine-development:i386 (= 2.0~rc6-1ubuntu1) mais ne sera pas installé
                           Recommande: wine-development:i386 (= 2.0~rc6-1ubuntu1)
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
nom_utilisateur@Asubuntu:~$

Hors ligne

#12 Le 26/01/2017, à 11:05

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Bon, ça se complique. On va essayer de procéder par étapes. D'abord ces paquets :

sudo apt-get remove --purge playonlinux winetricks wine1.6 wine-stable wine64

Dernière modification par abelthorne (Le 26/01/2017, à 11:05)

Hors ligne

#13 Le 26/01/2017, à 11:15

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Ca ne va pas te plaire :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 wine32-development:i386 : Dépend: libwine-development:i386 (= 2.0~rc6-1ubuntu1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Hors ligne

#14 Le 26/01/2017, à 12:43

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Mets la sortie complète, en incluant la ligne de commande, que je sois sûr de ce qu'il se passe. Parce que là, par exemple, je ne sais pas du tout si ce que tu me donnes est le résultat de la commande précédente ou si elle s'est bien déroulée et que c'est le résultat d'un apt --fix-broken install... Étant donné qu'il n'y a plus playonlinux dans la liste des dépendances cassées, je suis un peu perdu.

Si c'est bien le résultat de la commande, que donne ça ?

sudo apt-get install -f

Dernière modification par abelthorne (Le 26/01/2017, à 12:43)

Hors ligne

#15 Le 26/01/2017, à 14:14

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Oui c'est exactement le résultat de ta commande, j'essaie de te suivre à la lettre.
Voici, qui a l'air bien mieux, quel as tu es !

nom_utilisateur@Asubuntu:~$ sudo apt-get install -f
[sudo] Mot de passe de nom_utilisateur : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libasn1-8-heimdal:i386 libbsd0:i386 libgsm1:i386 libgssapi3-heimdal:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhx509-5-heimdal:i386 libjson-c3:i386 libkrb5-26-heimdal:i386
  libldap-2.4-2:i386 libltdl7:i386 libmpg123-0:i386 libodbc1:i386
  libopenal1:i386 libosmesa6:i386 libpcap0.8:i386 libroken18-heimdal:i386
  libsasl2-2:i386 libsasl2-modules:i386 libsasl2-modules-db:i386
  libsndio6.1:i386 libwind0-heimdal:i386 libxcomposite1:i386 libxcursor1:i386
  ocl-icd-libopencl1:i386
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libwine-development:i386 wine32-development:i386
0 mis à jour, 0 nouvellement installés, 2 à enlever et 75 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 571 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
dpkg: avertissement: analyse du fichier '/var/lib/dpkg/status' vers la ligne 13125 paquet 'wine-stable' :
 on ne peut utiliser que des versions exactes dans le champ « Provides ». 
dpkg: avertissement: analyse du fichier '/var/lib/dpkg/status' vers la ligne 13125 paquet 'wine-stable' :
 on ne peut utiliser que des versions exactes dans le champ « Provides ». 
(Lecture de la base de données... 260418 fichiers et répertoires déjà installés.)
Suppression de wine32-development:i386 (2.0~rc6-1ubuntu1) ...
Suppression de libwine-development:i386 (2.0~rc6-1ubuntu1) ...
dpkg: avertissement: analyse du fichier '/var/lib/dpkg/status' vers la ligne 13125 paquet 'wine-stable' :
 on ne peut utiliser que des versions exactes dans le champ « Provides ». 
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...

J'ai fait derrière un sudo apt-get update && sudo apt-get upgrade qui termine par :

Des erreurs ont été rencontrées pendant l'exécution :
 /tmp/apt-dpkg-install-nXjCLR/32-humanity-icon-theme_0.6.12_all.deb
 /tmp/apt-dpkg-install-nXjCLR/46-libwine_1.8.6-3ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

D'ailleurs, pour les mises à jour tu préconises upgrade ou dist-upgrade ?

J'ai oublié plus haut mon ls /etc/apt/sources.list.d le voici :

ls /etc/apt/sources.list.d
atareao-ubuntu-atareao-zesty.list
intellinuxgraphics.list
intellinuxgraphics.list.distUpgrade
intellinuxgraphics.list.save
jd-team-ubuntu-jdownloader-xenial.list
jd-team-ubuntu-jdownloader-xenial.list.distUpgrade
jd-team-ubuntu-jdownloader-xenial.list.save
kazam-team-stable-series-trusty.list
kazam-team-stable-series-trusty.list.distUpgrade
kazam-team-stable-series-trusty.list.save
libreoffice-ppa-trusty.list
libreoffice-ppa-trusty.list.distUpgrade
libreoffice-ppa-trusty.list.save
libreoffice-ubuntu-ppa-xenial.list
libreoffice-ubuntu-ppa-xenial.list.distUpgrade
libreoffice-ubuntu-ppa-xenial.list.save
linrunner-tlp-trusty.list
linrunner-tlp-trusty.list.distUpgrade
linrunner-tlp-trusty.list.save
megasync.list
megasync.list.distUpgrade
megasync.list.save
mono-xamarin.list
mono-xamarin.list.distUpgrade
mono-xamarin.list.save
nerdherd-ubuntu-cloud-wily.list
nerdherd-ubuntu-cloud-wily.list.distUpgrade
nerdherd-ubuntu-cloud-wily.list.save
notepadqq-team-ubuntu-notepadqq-xenial.list
notepadqq-team-ubuntu-notepadqq-xenial.list.distUpgrade
notepadqq-team-ubuntu-notepadqq-xenial.list.save
pelle-vincent-n-ubuntu-telepad-ppa-xenial.list
pelle-vincent-n-ubuntu-telepad-ppa-xenial.list.distUpgrade
pelle-vincent-n-ubuntu-telepad-ppa-xenial.list.save
sebastian-stenzel-ubuntu-cryptomator-xenial.list
sebastian-stenzel-ubuntu-cryptomator-xenial.list.distUpgrade
sebastian-stenzel-ubuntu-cryptomator-xenial.list.save
strukturag-libde265-trusty.list
strukturag-libde265-trusty.list.distUpgrade
strukturag-libde265-trusty.list.save
wiznote-team-ubuntu-ppa-xenial.list
wiznote-team-ubuntu-ppa-xenial.list.distUpgrade
wiznote-team-ubuntu-ppa-xenial.list.save
xenial-partner.list
xenial-partner.list.distUpgrade
xenial-partner.list.save

Dernière modification par EnZ0 (Le 26/01/2017, à 14:15)

Hors ligne

#16 Le 26/01/2017, à 14:29

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Pour les mises à jour, utilise plutôt dist-upgrade, ça gère les dépendances quand il faut installer de nouveaux paquets (ce que ne fait pas upgrade).

Il faudra faire un tri sérieux dans ta liste de dépôts tiers, vu que plein de versions ont l'air mélangées mais logiquement, les dépôts ont été mis à jour. Il va falloir les passer en revue manuellement.

À part ça, c'est volontaire le passage à Zesty (17.04) qui est encore en alpha ? Parce que c'est un sacré merdier, je ne sais pas si on va s'en sortir.

Quoi qu'il en soit, maintenant qu'il a apparemment réussi à supprimer deux paquets problématiques, qu'est-ce que ça donne en retentant ça ?

sudo apt-get remove --purge plyonlinux winetricks wine64-development wine1.6 wine-development wine-stable wine64

Dernière modification par abelthorne (Le 26/01/2017, à 14:29)

Hors ligne

#17 Le 26/01/2017, à 14:41

EnZ0

Re : [RESOLU] Dépendances non satisfaites

En voulant passer de la LTS à la 16.10, j'ai mal opéré et me suis retrouvé en 17.04... si je pouvais faire machine arrière, je le ferais.

Voici le résultat demandé :

sudo apt-get remove --purge playonlinux winetricks wine64-development wine1.6 wine-development wine-stable wine64
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-wine libasn1-8-heimdal:i386 libbsd0:i386 libgsm1:i386
  libgssapi3-heimdal:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libjson-c3:i386
  libkrb5-26-heimdal:i386 libldap-2.4-2:i386 libltdl7:i386 libmpg123-0:i386
  libodbc1:i386 libopenal1:i386 libosmesa6:i386 libpcap0.8:i386
  libroken18-heimdal:i386 libsasl2-2:i386 libsasl2-modules:i386
  libsasl2-modules-db:i386 libsndio6.1:i386 libwind0-heimdal:i386 libwine
  libwine-development libxcomposite1:i386 libxcursor1:i386
  ocl-icd-libopencl1:i386 python-olefile python3-olefile
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  playonlinux* wine-development* wine-stable* wine1.6* wine64*
  wine64-development* winetricks*
0 mis à jour, 0 nouvellement installés, 7 à enlever et 2 non mis à jour.
74 partiellement installés ou enlevés.
Après cette opération, 6 636 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 260410 fichiers et répertoires déjà installés.)
Suppression de wine1.6 (1:1.8.4ubuntu1) ...
Suppression de playonlinux (4.2.10-2ubuntu1) ...
Suppression de winetricks (0.0+20170101-1ubuntu2) ...
Suppression de wine-stable (1.8.6-3ubuntu2) ...
Suppression de wine64 (1.8.6-3ubuntu2) ...
Suppression de wine-development (2.0~rc6-1ubuntu1) ...
Suppression de wine64-development (2.0~rc6-1ubuntu1) ...
Paramétrage de python-apt-common (1.4.0~beta2) ...
Paramétrage de libapt-inst2.0:amd64 (1.4~beta4ubuntu1) ...
Paramétrage de libxapian30:amd64 (1.4.3-1) ...
Paramétrage de plasma-scriptengine-javascript (4:16.12.1-0ubuntu2) ...
Paramétrage de libwnck-3-common (3.20.1-3) ...
Paramétrage de python3-pil:amd64 (4.0.0-4) ...
Paramétrage de apt-transport-https (1.4~beta4ubuntu1) ...
Paramétrage de libgpgme++2v5 (4:4.14.10-1ubuntu3) ...
Paramétrage de libopenjp2-7:amd64 (2.1.2-1.1) ...
Paramétrage de python3-apt (1.4.0~beta2) ...
Paramétrage de libisc160:amd64 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de libx264-148:amd64 (2:0.148.2748+git97eaef2-1) ...
Paramétrage de libisc-export160 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de iio-sensor-proxy (2.0-3) ...
iio-sensor-proxy.service is a disabled or a static unit, not starting it.
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu1) ...
Paramétrage de libgtk-3-common (3.22.7-1ubuntu2) ...
Paramétrage de network-manager-pptp (1.2.4-2) ...
Paramétrage de apt-utils (1.4~beta4ubuntu1) ...
Paramétrage de libklibc (2.0.4-8ubuntu4) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:i386 (2.51.0-2) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:amd64 (2.51.0-2) ...
Paramétrage de libasound2-data (1.1.3-4) ...
Paramétrage de xserver-xorg-video-openchrome (1:0.5.0-3) ...
Paramétrage de libdns-export162 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47ubuntu1) ...
Paramétrage de fonts-wine (1.8.6-3ubuntu2) ...
Paramétrage de libharfbuzz0b:amd64 (1.4.2-1) ...
Paramétrage de python-xapian (1.4.3-1) ...
Traitement des actions différées (« triggers ») pour sgml-base (1.29) ...
Paramétrage de hdparm (9.51+ds-1) ...
Paramétrage de libgtk-3-0:amd64 (3.22.7-1ubuntu2) ...
Paramétrage de gnustep-common (2.6.8-2.1) ...
Paramétrage de libasound2:amd64 (1.1.3-4) ...
Paramétrage de libasound2:i386 (1.1.3-4) ...
Paramétrage de python-debian (0.1.30) ...
Paramétrage de libisccc140:amd64 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de gtk-update-icon-cache (3.22.7-1ubuntu2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...
Paramétrage de libck-connector0:amd64 (0.4.6-6) ...
Paramétrage de liblwres141:amd64 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de consolekit (0.4.6-6) ...
Paramétrage de libwireshark-data (2.2.4+gcc3dc1b-1) ...
Installation de la nouvelle version du fichier de configuration /etc/wireshark/init.lua ...
Paramétrage de libgail-3-0:amd64 (3.22.7-1ubuntu2) ...
Paramétrage de libpam-ck-connector:amd64 (0.4.6-6) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-1) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.7-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Paramétrage de lib32z1 (1:1.2.8.dfsg-4ubuntu1) ...
Paramétrage de gdbserver (7.12-0ubuntu4) ...
Paramétrage de libwsutil7:amd64 (2.2.4+gcc3dc1b-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu4) ...
Paramétrage de kde-runtime-data (4:16.12.1-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour dbus (1.10.10-1ubuntu2) ...
Paramétrage de python-apt (1.4.0~beta2) ...
Paramétrage de libwscodecs1:amd64 (2.2.4+gcc3dc1b-1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Paramétrage de python-pil:amd64 (4.0.0-4) ...
Paramétrage de gdb (7.12-0ubuntu4) ...
Paramétrage de python3-debian (0.1.30) ...
Paramétrage de libbrlapi0.6:amd64 (5.4-6ubuntu1) ...
Paramétrage de network-manager-pptp-gnome (1.2.4-2) ...
Paramétrage de zlib1g-dev:i386 (1:1.2.8.dfsg-4ubuntu1) ...
Paramétrage de libdns162:amd64 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de klibc-utils (2.0.4-8ubuntu4) ...
Paramétrage de xbrlapi (5.4-6ubuntu1) ...
Paramétrage de libharfbuzz-icu0:amd64 (1.4.2-1) ...
Paramétrage de libwnck-3-0:amd64 (3.20.1-3) ...
Paramétrage de gir1.2-gtk-3.0:amd64 (3.22.7-1ubuntu2) ...
Paramétrage de libwiretap6:amd64 (2.2.4+gcc3dc1b-1) ...
Paramétrage de python3-brlapi (5.4-6ubuntu1) ...
Paramétrage de gir1.2-wnck-3.0:amd64 (3.20.1-3) ...
Paramétrage de kde-runtime (4:16.12.1-0ubuntu2) ...
Removing obsolete conffile /etc/sysctl.d/30-baloo-inotify-limit.conf ...
Paramétrage de libisccfg140:amd64 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de python-imaging (4.0.0-4) ...
Paramétrage de libgtk-3-bin (3.22.7-1ubuntu2) ...
Paramétrage de brltty (5.4-6ubuntu1) ...
update-initramfs: deferring update (trigger activated)
Paramétrage de libbind9-140:amd64 (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de libwireshark8:amd64 (2.2.4+gcc3dc1b-1) ...
Paramétrage de kdebase-runtime (4:16.12.1-0ubuntu2) ...
Paramétrage de bind9-host (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de wireshark-common (2.2.4+gcc3dc1b-1) ...
Paramétrage de dnsutils (1:9.10.3.dfsg.P4-10.1ubuntu3) ...
Paramétrage de wireshark-qt (2.2.4+gcc3dc1b-1) ...
Paramétrage de wireshark (2.2.4+gcc3dc1b-1) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47ubuntu1) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.125ubuntu9) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-22-generic
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...

C'est plutôt convaincant mis à part :

Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'

Je note bien le dist-upgrade pour les mises à jour wink

Hors ligne

#18 Le 26/01/2017, à 14:43

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Vraiment mieux même test pour les MAJ :

sudo apt-get update && sudo apt-get dist-upgrade
Atteint:1 http://fr.archive.ubuntu.com/ubuntu zesty InRelease
Atteint:2 http://security.ubuntu.com/ubuntu zesty-security InRelease           
Atteint:3 http://ppa.launchpad.net/atareao/atareao/ubuntu zesty InRelease      
Atteint:4 http://archive.canonical.com/ubuntu zesty InRelease                  
Atteint:5 http://fr.archive.ubuntu.com/ubuntu zesty-updates InRelease          
Atteint:6 http://fr.archive.ubuntu.com/ubuntu zesty-backports InRelease
Lecture des listes de paquets... Fait                         
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  fonts-wine libasn1-8-heimdal:i386 libbsd0:i386 libgsm1:i386
  libgssapi3-heimdal:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libjson-c3:i386
  libkrb5-26-heimdal:i386 libldap-2.4-2:i386 libltdl7:i386 libmpg123-0:i386
  libodbc1:i386 libopenal1:i386 libosmesa6:i386 libpcap0.8:i386
  libroken18-heimdal:i386 libsasl2-2:i386 libsasl2-modules:i386
  libsasl2-modules-db:i386 libsndio6.1:i386 libwind0-heimdal:i386 libwine
  libwine-development libxcomposite1:i386 libxcursor1:i386
  ocl-icd-libopencl1:i386 python-olefile python3-olefile
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront mis à jour :
  humanity-icon-theme libwine
2 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/19,4 Mo dans les archives.
Après cette opération, 21,5 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 259887 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../humanity-icon-theme_0.6.12_all.deb ...
Dépaquetage de humanity-icon-theme (0.6.12) sur (0.6.11) ...
Préparation du dépaquetage de .../libwine_1.8.6-3ubuntu2_amd64.deb ...
Dépaquetage de libwine:amd64 (1.8.6-3ubuntu2) sur (1.8.6-3ubuntu1) ...
Paramétrage de humanity-icon-theme (0.6.12) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...
Paramétrage de libwine:amd64 (1.8.6-3ubuntu2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-3ubuntu2) ...

Plus d'erreurs !

Comme wine est incriminé, je n'ose tester la version 2 qui vient tout juste de sortir http://www.generation-nt.com/wine-linux … 38495.html et qui permettrait l'usage de Onenote, irremplacable malheureusement

Dernière modification par EnZ0 (Le 26/01/2017, à 14:45)

Hors ligne

#19 Le 26/01/2017, à 16:35

abelthorne

Re : [RESOLU] Dépendances non satisfaites

Je pense qu'il serait judicieux de virer aussi ce libwine qui reste :

sudo apt-get remove --purge libwine

Et vérifier éventuellement qu'il n'y a pas d'autres paquets du même genre :

apt-cache policy *wine*

(Ça va être plus long qu'avant.)

C'est plutôt la version de Wine que tu avais installée qui posait problème. Il faudrait installer la version "normale".

A priori, tu n'as pas de dépôt dédié et tous les paquets venaient des dépôts Ubuntu. Tu peux tenter l'ajout du PPA de WineHQ :

sudo add-apt-repository ppa:wine/wine-builds
sudo apt-get update

Puis installation de Wine :

sudo apt-get install --install-recommends winehq-devel

Idéalement, il faudrait faire le tri avant dans tous tes dépôts tiers pour :
1) Vérifier qu'il n'y en a pas qui proposent Wine (apparemment non à en juger par la sortie d'apt-cache mais bon...).
2) Vérifier ceux qui sont dispo pour Zesty (ou Xenial/Yakkety au pire, selon ce qu'ils contiennent) et virer ceux qui sont obsolètes.

Avis perso : tu devrais faire une sauvegarde de toutes tes données et réinstaller Ubuntu 16.10 de zéro. Utiliser au quotidien une alpha à trois mois de sa sortie, c'est l'assurance d'avoir des galères régulièrement.

Dernière modification par abelthorne (Le 26/01/2017, à 16:37)

Hors ligne

#20 Le 26/01/2017, à 17:18

EnZ0

Re : [RESOLU] Dépendances non satisfaites

Merci pour tes conseils éclairés, et effectivement, je pense à cette réinstallation en 16.10, voire en LTS.

Pour la désinstallation de libwine, je n'ai plus le paquet, j'ai fait un petit tri et viré l'inutile.

apt-cache policy *wine* ne me renvoie plus rien d'installé, apparemment c'est bon pour ce point.

Je te remercie sincèrement pour ton aide, c'est grâce à un support communautaire comme celui que tu fournis qu'on avance et qu'on tient le coup sur des alternatives à M$. Sans cela et l'excellence des réponses, beaucoup lâcheraient.

Alors encore merci abelthorne pour ce que tu apportes, et encore plus sur des versions alpha ! J'espère que tu trouves toi aussi tout le soutien que tu mérites quand tu es confronté à un souci (si ça t'arrive ! )

Bien à toi et avec ton mon respect,
EnZ0

Hors ligne