Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/01/2017, à 11:53

joreveur

clé USB persistent démarrer sans prompt

Bonjour
j'ai un portable ASUS X205TA et je n'arrive pas à installer Lubuntu sur cette machine (mais c'est un autre sujet...)

Actuellement j'ai créé une partition sur le disque interne EXT4 nommée casper-rw,

j'ai créé une clé USB persistent sur laquelle je démarre Lubuntu 16.04.1 et tout va bien smile  (à part quelques freeze de temps à autre)

j'ai modifié grub.cfg ci dessous, mais j'aimerai que ça démarre directement sans  attendre une entrée au clavier.

Merci de votre aide

   

if loadfont /boot/grub/font.pf2 ; then
	set gfxmode=auto
	insmod efi_gop
	insmod efi_uga
	insmod gfxterm
	terminal_output gfxterm
fi

set menu_color_normal=white/green
set menu_color_highlight=black/light-gray

menuentry " Lubuntu 16.04.1" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/lubuntu.seed boot=casper quiet splash persistent locale=fr ---
	initrd	/casper/initrd.lz
}

Cordialement

Dernière modification par joreveur (Le 24/01/2017, à 12:08)

Hors ligne

#2 Le 24/01/2017, à 19:55

f.x0

Re : clé USB persistent démarrer sans prompt

Bonjour joreveur,

Tu devrais plutôt modifier le fichier /etc/default/grub plutôt que le fichier /boot/grub/grub.cfg

en tout cas regardes les options décrites ici ça devrait être OK


SOPI

Hors ligne

#3 Le 25/01/2017, à 09:19

joreveur

Re : clé USB persistent démarrer sans prompt

bonjour @f.x0

je tiens à préciser que je ne tiens à modifier que le fichier qui est sur la clé c'est à dire boot/grub.cfg

Bien cordialement

Hors ligne

#4 Le 25/01/2017, à 10:58

jplemoine

Re : clé USB persistent démarrer sans prompt

@joreveur :
enb début du fichier /boot/grub/grub.cfg, il y a ça :

#                                                                                                            
# DO NOT EDIT THIS FILE                                                                                      
#                                                                                                            
# It is automatically generated by grub-mkconfig using templates                                             
# from /etc/grub.d and settings from /etc/default/grub                                                       
#                                                                                                            

Donc, si tu modifies le fichier, tes modifications vont être perdues un jour ou l'autre...
Donc, je confirme ce que t'as conseillé f.x0


Cordialement, Jean-Philippe.
Système principal Sous Ubuntu de 2009 à février 2015 - Xubuntu depuis.
Xubuntu 16.04 (poste principal portable) - Ubuntu 16.04 server (desktop converti en serveur DHCP, DNS, dépôt local et supervision (shinken))
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)

Hors ligne

#5 Le 25/01/2017, à 11:45

joreveur

Re : clé USB persistent démarrer sans prompt

Bonjour,
je me suis peut-être mal expliqué
sur ma clé (Fat 32) il y a un fichier à la racine  /boot/grub.cfg que j'ai déjà modifié et que je souhaite encore modifier pour  ne plus avoir de menu et démarrer directement.

Donc je démarre de cette clé usb, après avoir fait Enter
Sur mon disque dur il a une partition casper-rw  et pas de fichier casper-rw sur la clé
Une fois démarré, j'ai regardé et il n'y a pas le fichier que tu m'indiques /boot/grub/grub.cfg ,  et de toute façon ce n'est pas celui là que je voulais modifier

Bien à toi

Hors ligne

#6 Le 25/01/2017, à 18:33

f.x0

Re : clé USB persistent démarrer sans prompt

OK ton fichier se trouve dans /boot/grub.cfg et pas dans /boot/grub/grub.cfg.

Par contre as-tu un fichier /etc/default/grub ???


SOPI

Hors ligne

#7 Le 25/01/2017, à 22:08

joreveur

Re : clé USB persistent démarrer sans prompt

Bonsoir,
En regardant bien, J'ai un fichier /media/cdrom/boot/grub/grub.cfg (que j'ai modifié avant démarrage) qui contient

if loadfont /boot/grub/font.pf2 ; then
	set gfxmode=auto
	insmod efi_gop
	insmod efi_uga
	insmod gfxterm
	terminal_output gfxterm
fi

set menu_color_normal=white/green
set menu_color_highlight=black/light-gray

menuentry " Lubuntu 16.04.1" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/lubuntu.seed boot=casper quiet splash persistent locale=fr ---
	initrd	/casper/initrd.lz
}

et un fichier /etc/default/grub qui contient :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Bien à toi

Hors ligne

#8 Le 26/01/2017, à 00:14

f.x0

Re : clé USB persistent démarrer sans prompt

Comme il s'agit d'un live persistent il est fort possible
qu'il n'existe pas de fichier /media/cdrom/etc/default/grub

si c'est bien le cas, tu peux modifier ton fichier
/media/cdrom/boot/grub/grub.cfg

comme expliqué ici  et ici


SOPI

Hors ligne