Contenu | Rechercher | Menus

Annonce

Ubuntu Party les 18 et 19 mai 2019 à Paris
Grand rendez-vous tout public organisé par Ubuntu-FR, avec install-party, ateliers et conférences.
Venez y (re)découvrir ou faire découvrir le Libre et Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 04/11/2006, à 17:05

greguti

wifi : connexion qui disparait après qq heures...

Hello,

je ne sais pas exactement depuis quand j'ai ce bug, mais j'ai pu le répéter plusieurs fois depuis quelques jours. Edgy Eft updgradée depuis une Dapper, avec connexion wifi à ma freebox. Mon ordi est un Asus S6J avec puce wifi intégrée. Ca marchait impec sous Dapper Drake.

Maintenant, quand je laisse mon ordi connecté pendant quelques heures et que je reviens le voir ensuite, je me rends compte que la connexion wifi n'est plus active du tout (très chiant pour Amule par exemple). Je croyais que c'était un problème de mise en hibernation, mais non, puisque le gestionnaire d'énergie de Gnome est réglé pour que l'ordi reste toujours allumé quand il est branché sur secteur (et bien sûr le bug apparaît quand je suis sur secteur).

Plus précisément, les 'Préfèrences de Gestion d'énergie" indiquent :

Sur secteur : "mettre l'écran en veille après 1h", "mettre l'ordinateur en veille après "jamais" ", "régler la luminosité de l'écran 100%"

J'aimerais bien pouvoir relancer la connexion wifi rapidement, mais ça m'est impossible. Dans l'outil "Réglages du réseau" du panneau Système -> Administration, j'ai beau tenter de réactiver la connexion wifi, rien ne se passe. Me voilà obligé de redémarrer à chaque fois...

Je sais que l'outil de connexion wifi est assez buggé sous Edgy, alors qu'il fonctionnait très bien sous Dapper, mais j'avais réussi à m'y faire, grâce au paquet wifi-radar qui me permet de détecter les réseaux wifi autour de mon pc (ensuite je n'ai plus qu'à saisir à la main le nom du bon réseau essid dans l'applet réseau).

Cependant j'aimerais bien comprendre d'où vient ce bug, plutôt embêtant à la longue. Et j'aimerais savoir aussi s'il y a un moyen de relancer la connexion wifi, en ligne de commande, sans avoir à redémarrer ma machine à chaque fois...

@+

Greg


Quelques infos en ligne de commande :

greg@greg-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11g  ESSID:"Cerferez"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:07:CB:51:BB:2A   
          Bit Rate:24 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=59/100  Signal level=-74 dBm  Noise level=-81 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1749   Missed beacon:0

sit0      no wireless extensions.
greg@greg-laptop:~$ dmesg |grep eth1
[17179615.304000] ADDRCONF(NETDEV_UP): eth1: link is not ready
[17179617.496000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[17179628.448000] eth1: no IPv6 routers present

Ubuntu 9.04 Jaunty Jackalope sur Asus F8va (ATI Radeon HD 3650)
Petit à petit linux change la vie.
Le petit blog d'un linuxien heureux

Hors ligne

#2 Le 04/11/2006, à 17:12

Baque

Re : wifi : connexion qui disparait après qq heures...

Bonjour

Essaie dans une console : /etc/init.d/networking restart


J-Luc

Hors ligne

#3 Le 05/11/2006, à 12:01

greguti

Re : wifi : connexion qui disparait après qq heures...

Hello

bon ben ça me l'a refait : hier dans la soirée, j'étais devant mon ordi, je surfais sur le net quand soudain, plus de connexion. Pas un message d'erreur, rien. Juste, plus de connexion. Ca faisait bien 4 ou 5h que l'ordi était allumé et connecté. J'ai rebooté et puis j'ai laissé l'ordi allumé toute la nuit.

Ce matin, même punition : plus de connexion.

J'ai lancé la commande que tu m'as conseillée, voilà le résultat :

greg@greg-laptop:~$ sudo /etc/init.d/networking restart
Password:
 * Reconfiguring network interfaces...                                          There is already a pid file /var/run/dhclient.eth0.pid with pid 5612
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:17:31:b8:d6:ab
Sending on   LPF/eth0/00:17:31:b8:d6:ab
Sending on   Socket/fallback
DHCPRELEASE on eth0 to 192.168.0.254 port 67
There is already a pid file /var/run/dhclient.eth1.pid with pid 5333
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:13:02:7d:ad:09
Sending on   LPF/eth1/00:13:02:7d:ad:09
Sending on   Socket/fallback
DHCPRELEASE on eth1 to 192.168.0.254 port 67
There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:17:31:b8:d6:ab
Sending on   LPF/eth0/00:17:31:b8:d6:ab
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:13:02:7d:ad:09
Sending on   LPF/eth1/00:13:02:7d:ad:09
Sending on   Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 17
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
                                                                         [ ok ]

Finalement j'ai dû encore une fois rebooter pour que la connexion soit réactivée.

@+

Greg


Ubuntu 9.04 Jaunty Jackalope sur Asus F8va (ATI Radeon HD 3650)
Petit à petit linux change la vie.
Le petit blog d'un linuxien heureux

Hors ligne

#4 Le 05/11/2006, à 13:00

CeReAl KiLLeR Du 77

Re : wifi : connexion qui disparait après qq heures...

J'ai également ce souci. Dire que la gestion du wifi serai mieux sur edgy, je suis déçu sur ce point sad

Moi je coupe le wifi via le bouton du laptop, je fais un sudo ifdown eth1
je ralume le wifi via le bouton, et je fais un sudo ifup eth1
Sachant que eth1 est mon interface wifi.


SuperBox = Serveur (FreeBSD 7.2) (DEAD) | H²O = Serveur (FreeBSD 8.1) | Nephrotique = Desktop (Ubuntu Lucid Lynx 64 bits) | Skizophrene = Laptop (DesktopBSD 1.7/WinXP SP3) | Epileptik = Desktop (Diskless) | WRT54GL 1.1 (Openwrt Backfire 10.3 noyau 2.4) | WRT54GL 1.1 (DDWRT V24 SP1)

Hors ligne

#5 Le 07/11/2006, à 11:27

greguti

Re : wifi : connexion qui disparait après qq heures...

Hello, j'ai tenté ce que propose Cereal Killer, ça mouline un long moment et puis plus rien :-( Obligé de rebooter si je veux une connexion qui marche.

Et là j'ai eu pire, ce matin en rallumant mon ordi : la connexion internet a disparu après seulement quelques minutes d'utilisation ! J'ai juste lancé Rhythmbox et Gaim, et dans Rhythmbox j'ai lancé un flux radio. Après quelques secondes à peine, la connexion a sauté. Argh, le stress !!!

J'ai vérifié et bien sûr ma freebox était tout à fait ok (un deuxième portable, connecté en filaire, fonctionne très bien, lui).

C'est vraiment chiant, j'ai l'impression que la situation empire jour après jour... !

Je n'ai rien trouvé sur les forums anglo-saxons. Ca n'a pas l'air d'être un problème concernant grand monde.

@+

Greg


Ubuntu 9.04 Jaunty Jackalope sur Asus F8va (ATI Radeon HD 3650)
Petit à petit linux change la vie.
Le petit blog d'un linuxien heureux

Hors ligne

#6 Le 09/11/2006, à 21:35

greguti

Re : wifi : connexion qui disparait après qq heures...

Hello

bon ben finalement... j'ai résinstallé ma Edgy en formatant mon disque dur. Mais, mauvaise surprise, mon CD gravé Edgy a dû être mal gravé, car ça a bloqué irrémédiablement au bout de 50% d'install environ. Alors j'ai installé une Dapper, et j'ai tout de suite lancé l'upgrade. Me voilà avec une Edgy neuve installée depuis une Dapper neuve. Ouf.

J'ai installé le paquet linux-restricted-modules-generic qui contient le driver pour la puce wifi ipw3945, celle qui équipe mon PC (il me semble que je n'avais pas fait ça avant !).

Bon, pour le moment, ma connexion est toujours là... Ca fait 4h que le PC est connecté. Je prie pour que la connection soit encore là demain matin !

@+

Greg


Ubuntu 9.04 Jaunty Jackalope sur Asus F8va (ATI Radeon HD 3650)
Petit à petit linux change la vie.
Le petit blog d'un linuxien heureux

Hors ligne

#7 Le 26/12/2006, à 14:34

unfalkster

Re : wifi : connexion qui disparait après qq heures...

Salut,
j'ai le même problème et le mm materiel. J'ai une edgy installée depuis le cd. J'ai le driver ipw3945 sans avoir eu besoin de l'installer (lsmod -> ipw3945) et le wifi marche très bien, sauf quand je le met en veille ou en hibernation, à la sortie iwconfig me répond irrémédiablement no wireless extension ...

#8 Le 26/12/2006, à 15:06

unfalkster

Re : wifi : connexion qui disparait après qq heures...

Bon, apparament le module ipw3945 (entre autres) est déchargé lors de la mise en veille, si on en croit le contenu de /etc/default/acpi-support. Il faudrait rajouter ce module dans la "WHITE-LIST". Je vais essayer ça... Je pense que ceci est assez lié à l'hibernation malgré ce que tu crois
bon courage

#9 Le 11/02/2008, à 20:22

Tha Tawa'S

Re : wifi : connexion qui disparait après qq heures...

Salut,
quelqu un a trouvé une solution ???
j ai un pc asus V1S avec gutsy et quand il sort de veille, il ne "voit" plus d interface wifi !!
oblige de rebooter, relancer le service networking ne suffit meme pas !
bye


Si tu tapes ta tete contre une cruche et que ca sonne creux... ce n est peut-etre pas la cruche qui est creuse....

Hors ligne