Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/02/2018, à 12:19

Geneviève

Perte de l'accès Wifi [Résolu]

Bonjour,
Je suis nouvelle utilisatrice de Linux (six mois environ, avant j'avais Windows que j'ai bazardé au profit de Ubuntu, plus rapide) et je vous présente d'avance mes excuses si le problème que je rencontre a déjà été évoqué dans un post. mais cela fait quinze jours que j'effectue des recherches et que je teste différentes solutions sans résultat. Je ne suis pas une pro de l'informatique loin de là mais voilà ma question. J'ai perdu il y a une quinzaine de jours ma connection Wifi via carte interne à mon ordi (Dell Inspiron 1545) qui fonctionnait très bien avant. Est-ce qu'il y a eu un upgrade de Ubuntu qui a changé les modalités d'accès au Wifi. J'ajoute que je passe par une free box, que la coonnection ethernet fonctionne parfaitement mais pas l'accès Wifi. J'ai pensé d'abord que la rouche de mon clavier activant le wifi ne fonctionnait plus mais en réinstallant Windows, ça marche parfaitement. J'ai réinstallé Ubuntu 16.04.3 LTS via un CD-rom car je n'ai pas réussi à  faire une clé usb bootable malgré les nombreux tutoriels que j'ai trouvé sur les forums (c'est vous dire mon niveau d'expertise!). Et le Wifi ne marche toujours pas.
Ma carte wifi est une broadcom corporation BCM 4312 802.11b/g . Son id est 14e4:4315 et le subsystem est Dellwireless 1397 WLAN minicard 1028:000c. L'accès m'était "denied" avec la mention kernel driver b43-pci-bridge module ssh. Du coup je suis allée sur le site de Linux driver firmware pour obtenir le driver adhoc. Mais rien à faire, Vous avez une idée?
Pour info voilà ce que la commande sudo lshw -C network m'a répondu

  *-network               
       description: Network controller
       product: BCM4312 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:17 memory:f69fc000-f69fffff
  *-network
       description: Ethernet interface
       product: 88E8040 PCI-E Fast Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: enp9s0
       version: 13
       serial: a4:ba:db:ad:92:03
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 duplex=full ip=192.168.0.14 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:28 memory:f68fc000-f68fffff ioport:de00(size=256)
genevieve@genevieve-Inspiron-1545:~$ sudo ifconfig
enp9s0    Link encap:Ethernet  HWaddr a4:ba:db:ad:92:03  
          inet addr:192.168.0.14  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::55af:6b53:eab7:4e7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:88957 errors:0 dropped:0 overruns:0 frame:0
          TX packets:53004 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:126277485 (126.2 MB)  TX bytes:4197013 (4.1 MB)
          Interrupt:18 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:17311 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17311 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1289122 (1.2 MB)  TX bytes:1289122 (1.2 MB)

genevieve@genevieve-Inspiron-1545:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
genevieve@genevieve-Inspiron-1545:~$ sudo nm-tool
sudo: nm-tool: command not found
genevieve@genevieve-Inspiron-1545:~$

Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par Geneviève (Le 05/02/2018, à 18:57)

Hors ligne

#2 Le 05/02/2018, à 13:04

xubu1957

Re : Perte de l'accès Wifi [Résolu]

Bonjour,

Pour une carte Broadcom BCM4312, voir § 2 et début du § 3 > [Tuto] Pas de Wi-fi ? Eléments importants à vérifier pour désactiver le secure-boot.

Et installer le pilote wifi à partir de la Doc > wifi_broadcom_bcm43xx#quel_pilotefirmware_utiliser

michel_04 a écrit :

Afin de pouvoir installer le pilote en cliquant sur son nom dans la page de la documentation, installer au préalable apturl :

sudo apt-get install apturl

Dernière modification par xubu1957 (Le 05/02/2018, à 14:19)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

Hors ligne

#3 Le 05/02/2018, à 15:50

Geneviève

Re : Perte de l'accès Wifi [Résolu]

Merci beaucoup de votre réponse si rapide. Je teste immédiatement et vous tiens au courant....

Hors ligne

#4 Le 05/02/2018, à 17:17

Geneviève

Re : Perte de l'accès Wifi [Résolu]

Re- Bonjour,
J'ai vérifié étape par étape ce qui était proposé dans le tuto pas de wifi. Le pilote de ma carte Broadcom (14e4:4315) est correctement installé.
J'ai également vérifié les chiffrements de la box (la mienne est la freebox_ouiouify)

genevieve@genevieve-Inspiron-1545:~$ nmcli dev wifi
*  SSID              MODE   CHAN  RATE       SIGNAL  BARS  SECURITY    
   FreeWifi          Infra  11    54 Mbit/s  100     ▂▄▆█              
   FreeWifi_secure   Infra  11    54 Mbit/s  100     ▂▄▆█  WPA1 802.1X 
   --                Infra  11    54 Mbit/s  100     ▂▄▆█  WPA2        
 freebox_ouiouify  Infra  11    54 Mbit/s  100     ▂▄▆█  WPA1       
   orange            Infra  6     54 Mbit/s  44      ▂▄__              
   Livebox-1030      Infra  6     54 Mbit/s  44      ▂▄__  WPA2        
   FreeWifi          Infra  1     54 Mbit/s  37      ▂▄__              
   Freebox-61B652    Infra  1     54 Mbit/s  37      ▂▄__  WPA2        
   FreeWifi_secure   Infra  1     54 Mbit/s  35      ▂▄__  WPA2 802.1X 
   Livebox-A3B6      Infra  11    54 Mbit/s  25      ▂___  WPA1 WPA2   
genevieve@genevieve-Inspiron-1545:~$ ^C

Je suis allée ensuite dans le bios par la touche F12 au redémarage . Problème, je n'ai dans le bios que le choix de la séquence de boot. Je n'ai vu aucune ligne correspondant à boot settings d'où j'en déduis que je n'étais pas au bon endroit. J'ai cherché sur Internet et partout pour mon portable Dell, on me dit d'utiliser la touche F2 oou F12 pouraller dans le bios. Les deux touches activent le même menu. En descendant dans le menu du bios, j'ai trouvé une ligne onboard NIC dans la rubrique LAN controller. Et là j'avais trois options possible: disabled, enabled et enabled Pex. La troisième option était cochée. J'ai changé pour disabled et relancé la machine. Pas de wifi et cette fois plus d'ethernet!. J'ai remis aux précédents settings. Et là, j'avoue que je cale. Et je suis désolée de ne pas pouvoir vous montrer les écrans mais apparemment la touche capture d'écran ne fonctionne pas non plus ou plus exactement je ne sais pas comment l'utiliser entre un écran de bios et après le retour à Ubuntu...
Et surtout, je ne m'explique pas que le wifi a parfaitement fonctionné pendant six mois avant de disparaître brusquement alors que j'étais en ligne. A l'époque, je n'avais que Ubuntu sur l'ordi. Aujourd'hui, j'ai Windows 7 et Ubuntu et le wifi marche avec Windows et pas avec Ubuntu.


Modération - Rappel : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 05/02/2018, à 17:30)

Hors ligne

#5 Le 05/02/2018, à 17:23

Geneviève

Re : Perte de l'accès Wifi [Résolu]

J'ai oublié une chose. Sur la commande nm-tool la réponse est la suivante:

No command 'nm-tool' found, did you mean:
 Command 'dm-tool' from package 'lightdm' (main)
nm-tool: command not found
genevieve@genevieve-Inspiron-1545:~$ 

Je vais maintenant aller voir les paramètres de ma freebox et activer le mode WPA2 PSK/AES comme indiqué dans le tuto.


Modération - Rappel : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 05/02/2018, à 17:30)

Hors ligne

#6 Le 05/02/2018, à 17:54

Geneviève

Re : Perte de l'accès Wifi [Résolu]

Voici les paramètres de la Freebox qui étaient activés: WPA (TKIP + AES) et Wep
J'ai changé pour WPA (TKIC + AES) et j'ai redémarré la box pour qu'elle prenne en compte ce changement.

Hors ligne

#7 Le 05/02/2018, à 18:12

Geneviève

Re : Perte de l'accès Wifi [Résolu]

Merci pour le rappel des balises codes que je ne connaissais pas et que j'utiliserai à l'avenir..
Le changement des paramètres de la Freebox a rétabli le wifi! Merci encore de votre patience et au tuto indiqué!
Très bonne fin de journée.

Hors ligne

#8 Le 05/02/2018, à 18:14

xubu1957

Re : Perte de l'accès Wifi [Résolu]

Pour éditer ta discussion et rajouter [Résolu] au début du titre, il faut utiliser le bouton Modifier dans ton premier message.

Merci wink       

Et merci aussi, à Dame Sylvie/cqfd93 pour les balises. wink

Dernière modification par xubu1957 (Le 05/02/2018, à 18:17)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

Hors ligne

#9 Le 05/02/2018, à 18:56

Geneviève

Re : Perte de l'accès Wifi [Résolu]

Dernière chose avant de passer à [Résolu], la connection Wifi rétablie n'étant pas stable, je suis allée voir [doc]https://help.ubuntu.com/community/WifiD … er/bcm43xx[/doc] et j'ai suivi le mode opératoire conseillé de désinstaller le paquet bcmwl-kernel-source et de réinstaller les pilotes B43 . Cette fois-ci, ça a marché, la connection wifi est stable, je l'utilise pour envoyer ce post et je remercie encore mille fois les intervenants qui m'ont aidée. smile

genevieve@genevieve-Inspiron-1545:~$ sudo apt-get remove --purge bcmwl-kernel-source
[sudo] password for genevieve: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  dkms
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  bcmwl-kernel-source*
0 upgraded, 0 newly installed, 1 to remove and 232 not upgraded.
After this operation, 8 064 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 212994 files and directories currently installed.)
Removing bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) ...
Removing all DKMS Modules
Done.
update-initramfs: deferring update (trigger activated)
Purging configuration files for bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-28-generic
genevieve@genevieve-Inspiron-1545:~$ sudo apt-get update
Hit:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]    
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]     
Get:4 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]  
Get:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [713 kB]
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [62,7 kB]
Get:7 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [662 kB]
Get:8 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [70,8 kB]
Get:9 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [51,4 kB]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [85,1 kB]
Get:11 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [296 kB]
Get:12 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [307 kB]
Get:13 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [212 kB]
Get:14 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [580 kB]
Get:15 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [538 kB]
Get:16 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [234 kB]
Get:17 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [190 kB]
Get:18 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [272 kB]
Get:19 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5 888 B]
Get:20 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3 328 B]
Get:21 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [4 696 B]
Fetched 4 595 kB in 3s (1 294 kB/s)                                
Reading package lists... Done
genevieve@genevieve-Inspiron-1545:~$ sudo apt-get --reinstall install bcmwl-kernel-source
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  bcmwl-kernel-source
0 upgraded, 1 newly installed, 0 to remove and 237 not upgraded.
Need to get 0 B/1 544 kB of archives.
After this operation, 8 064 kB of additional disk space will be used.
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 212911 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu1~1.2_amd64.deb ...
Unpacking bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) ...
Setting up bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) ...
Loading new bcmwl-6.30.223.271+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 4.10.0-28-generic
Building for architecture x86_64
Building initial module for 4.10.0-28-generic
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.10.0-28-generic/updates/dkms/

depmod....

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-28-generic
genevieve@genevieve-Inspiron-1545:~$

Hors ligne

#10 Le 05/02/2018, à 18:59

xubu1957

Re : Perte de l'accès Wifi [Résolu]

and 237 not upgraded

Il faut faire les mises à jour, 237 paquets à mettre à jour :

sudo apt full-upgrade

Dernière modification par xubu1957 (Le 05/02/2018, à 18:59)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

Hors ligne

#11 Le 05/02/2018, à 19:27

Geneviève

Re : Perte de l'accès Wifi [Résolu]

Merci d'avoir vu les 237 paquets non mis à jour. Je vais les mettre à jour. Ca valait le coup vu le nombre de fichiers et la taille! Bonne soirée et encore merci.

Hors ligne

#12 Le 05/02/2018, à 19:30

xubu1957

Re : Perte de l'accès Wifi [Résolu]

Il vaut mieux les faire en filaire.

Dernière modification par xubu1957 (Le 05/02/2018, à 19:30)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

Hors ligne

#13 Le 07/02/2018, à 17:58

Geneviève

Re : Perte de l'accès Wifi [Résolu]

Oui, j'avais vu le conseil sur le forum et j'ai rebranché en ethernet avant de charger et installer les paquets. Encore merci pour tout.

Hors ligne

#14 Le 07/02/2018, à 18:02

xubu1957

Re : Perte de l'accès Wifi [Résolu]

Bonjour,

Tu as quel noyau ?

Fournis le noyau actif :

uname -a

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

Hors ligne