Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/10/2009, à 13:07

Ashitaka-san

[Kubuntu 9.04] problème de version de biblio à inst. (Résolu)

La raison de mon post sur ce forum commence ici (pour vous mettre dans le bain, J'ai le pseudo de Van sur ce Forum)

Donc pour résumé, je dois installer certaines bibliothèques dans kubuntu pour l'installation d'un logiciel libre développé par EDF, sauf que pour certaines, je ne trouve pas la version suffisemment récente (hdf5 1.6.6 et libmed 2.3.1) par le biais de KpakageKit comme par le terminal alors que les personnes m'ayant aider sur le forum dont le lien est ci-dessus trouvent des versions supérieures (hdf5 1.6.8 et libmed 2.3.5) à celles nécessaires (hdf5 1.6.7 et libmed 2.3.4) avec leur version d'ubuntu (cf. le forum en lien).

Sur le dernier post on me conseil de venir ici vous exposer mon problème avec les idées de celui qui m'a aider :

- dépôts sid + apt-pinning
- packages.debian.org puis téléchargement des sources ou des paquets

Etant novice sur Linux, je ne sais pas bien de quoi il parle et encore moins comment le faire. Pourriez-vous m'aider ?

Merci d'avance

Ashitaka-san

Dernière modification par Ashitaka-san (Le 06/10/2009, à 09:10)

Hors ligne

#2 Le 02/10/2009, à 15:31

xabilon

Re : [Kubuntu 9.04] problème de version de biblio à inst. (Résolu)

Salut

Effectivement, les versions de ces libs dispo sur Ubuntu (même sur la future 9.10) sont inférieures à ce qu'il te faut.

Donc, oui, faudra peut-être envisager de piocher chez Debian.
Ce n'est pas sans risque, si tu ne t'y connais pas trop. Dans un premier temps, le plus sûr c'est de télécharger le deb, et l'installer à la main.

AVERTISSEMENT : installer des paquets de Debian sur Ubuntu est déconseillé, ça doit être réservé à des cas exceptionnels, et toujours en sachant exactement ce que l'on fait.

Quels noms de paquets te faut-il exactement ?
libmed1 (version Fortran) ou libmedc1 (version C) ?
libmed1 dépend de libhdf5-serial, donc je suppose que c'est cette verion de hdf5 qu'il faut :
http://packages.debian.org/squeeze/libhdf5-serial-1.8.3

Pour les libmed, c'est :
http://packages.debian.org/squeeze/libmed1
ou
http://packages.debian.org/squeeze/libmedc1

Donc tu télécharges, et tu les installes par dpkg -i (libhdf5-serial en premier)

Si tu n'obtiens aucun message d'erreur, c'est que ça passe.
Si tu obtiens un problème de dépendances, là il faudra se méfier ...


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 02/10/2009, à 16:40

Ashitaka-san

Re : [Kubuntu 9.04] problème de version de biblio à inst. (Résolu)

Je me demande quand même si l'utilisation d'une version supérieur causera des bugs du programme EDF ? (utilisation de hdf5 1.8.3 au lieu de 1.6.7)

Par contre il n'est précisé nulle part dans les doc que j'ai trouvé s'il faut que "libmed" soit en fortran ou en C ...:(

Sinon, où faut-il placer le fichier .deb pour l'installation par la commande "dpkg -i" ?

Hors ligne

#4 Le 02/10/2009, à 17:41

xabilon

Re : [Kubuntu 9.04] problème de version de biblio à inst. (Résolu)

Il suffit de cliquer dessus (il y a une routine graphique qui fait le dpkg -i)
Voir ici :
http://doc.ubuntu-fr.org/tutoriel/comment_installer_un_paquet
Paragraphe "installer un paquet isolé"


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 06/10/2009, à 09:10

Ashitaka-san

Re : [Kubuntu 9.04] problème de version de biblio à inst. (Résolu)

Merci ! Ca a fonctionner big_smile

Ces bibliothèques sont nécessaires pour le logiciel qui va utiliser le code EDF, celui que j'ai choisi, après renseignement installe tout ce qui lui faut (donc ces bibliothèques en particuliers) comme un grand.

La conclusion c'est que je vous ai un peu déranger pour rien hmm et que je me suis em****é pour rien sad ....

En tout cas merci du temps que vous m'avez accordé !

Dernière modification par Ashitaka-san (Le 06/10/2009, à 09:10)

Hors ligne