Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/04/2021, à 09:48

Drakanor

SSH ne fonctionne plus en local

Bonjour,

J'héberge chez moi un serveur HP qui tourne sous ubuntu server 18.04 depuis quelques mois. Jusque là aucun problème pour me connecter sur ses services via internet et en SSH avec putty de mon pc windows sur le réseau local.

Depuis quelques jours j'ai installé un autre serveur (raspbian sur un raspberry, toujours sur le réseau local) cette fois pour superviser l'installation avec nagios. Je l'ai pour le moment paramétrer pour vérifier le ping et les ports SSH et HTTPS de mon serveur HP.

Il a marché quelque temps puis ensuite les ports ne répondaient plus en local (alors que les services étaient toujours disponible via le net). Après quelque recherche j'ai finalement trouvé que c'était fail2ban et portsentry qui avaient bloqué l'IP de ma raspberry pour requêtes intempestives. Après avoir modifié les fichiers de configurations respectifs pour autoriser l'ip de la raspberry à aller interroger le serveur HP, seul le ping et HTTPS s'est remis à marche, mais le SSH reste indisponible sur le réseau local. Et parallèlement à ça, je n'arrive plus à me connecter en local avec putty de mon PC windows alors que d'un autre PC qui n'est pas sur le réseau local la connexion en SSH fonctionne très bien.

J'en conclu donc que SSH ne marche plus sur le réseau local alors qu'il fonctionne via un réseau externe, donc le port 22 et le service sshd fonctionne correctement. N'y connaissant pas grand chose, je me suis dit que ça pouvait venir du pare-feu de mon serveur HP. J'ai donc désactivé ufw, portsentry et fail2ban. Mais la connexion SSH ne marche toujours pas que ce soit de mon PC windows ou d'un autre PC de mon réseau.

Est-ce que quelqu'un aurait une idée du problème ? Merci !

Dernière modification par Drakanor (Le 20/04/2021, à 09:49)

Hors ligne

#2 Le 20/04/2021, à 11:21

lejurassien40

Re : SSH ne fonctionne plus en local

Salut,
Une idée comme ça, regarde dans /etc/host.deny si ton ip n'y est pas ...

Si le blocage persiste, tu peux tenter:

route del -host IP reject

remplacer IP par la tienne



Pour avoir plus d’infos sur le port qui a déclenché le blocage + date/heure:

cat /var/lib/portsentry/portsentry.history

Bonne journée

Dernière modification par lejurassien40 (Le 20/04/2021, à 11:25)


"De tous ceux qui n'ont rien à dire, les plus agréables sont ceux qui se taisent !" Ubuntu 18.04-4, Debian Buster, W10 LTS pour jouer.
"Ne vous trompez pas entre ma personnalité et mon attitude. Ma personnalité est "qui je suis", mon attitude dépend de "qui vous êtes".

Hors ligne

#3 Le 20/04/2021, à 12:28

Drakanor

Re : SSH ne fonctionne plus en local

Merci pour ta réponse, le problème venait effectivement de là. Mes adresses IP locaux étaient dans le fichier hosts.deny.

Par contre j'ai deux questions : qui est-ce qui rempli automatiquement ce fichier ? Portsentry ? Et est-ce que si je met mon adresse IP dans le fichier hosts.allow alors je serai toujours accepté même si ufw ou iptables est sensé me bloquer ?

Hors ligne

#4 Le 20/04/2021, à 13:08

lejurassien40

Re : SSH ne fonctionne plus en local

Oui, c'est portsentry qui remplis host.deny (d'après mes souvenirs)
le "mieux" est de mettre tes ip dans le fichier /etc/portsentry/portsentry.ignore
et comme tu utilises aussi fail2ban tu peux aussi mettre dans le jail.conf ou sa copie jail.conf.local (bref dans le fichier où tes jails sont configurées)
une exception pour tes ip
ignoreip = 127.0.0.1/8 ::1 192.168.1.0/24 à mettre dans chaque jail

exemple de ma jail sshd

##To block the failed login attempts on the SSH server, use the below jail.
[sshd]
enabled = true
port = ssh
filter = sshd
logpath = /var/log/auth.log
maxretry = 3
bantime = 2d
ignoreip = 127.0.0.1/8 ::1 192.168.1.0/24
destemail = root@localhost
banaction = nftables-multiport
banaction_allports = nftables-allports
action = %(action_mw)s

Quand à ta question sur host.allow j'avoue que je ne sais pas si ça va empêcher ufw ,iptables etc de bloquer tes ip...
je n'utilise pas le host.allow.. pas plus que ufw ni iptables mais nftables  désolé...

Quelqu'un pour qui c'est plus frais t'aideras probablement mieux que moi 

Une bonne journée à toi et aux autres qui liront ces messages !

Dernière modification par lejurassien40 (Le 20/04/2021, à 13:12)


"De tous ceux qui n'ont rien à dire, les plus agréables sont ceux qui se taisent !" Ubuntu 18.04-4, Debian Buster, W10 LTS pour jouer.
"Ne vous trompez pas entre ma personnalité et mon attitude. Ma personnalité est "qui je suis", mon attitude dépend de "qui vous êtes".

Hors ligne

#5 Le 21/04/2021, à 08:01

jplemoine

Re : SSH ne fonctionne plus en local

Le hosts.allow et le hosts.deny servent à être soit dans une logique de liste blanche ou de liste noire.
Soit tu interdis tout par défaut et tu autorises une liste (liste blanche)
Soit tu autorises tout par défaut et tu interdis une liste (liste noire).

Il est déconseillé de gérer les 2 : hosts.allow et hosts.deny
De mémoire, le deny prime sur le allow. Donc, si une IP est dans le deny, l'ajouter dans allow ne servira à rien.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne