Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous souhaite d'excellentes fêtes de fin d'année !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/09/2005, à 09:25

Miguel909

[Resolu]Problème avec VSFTPD

Bonjour tout le monde.
Voilà j'ai un serveur sous Ubuntu 5.04
Avec vsftpd installé dessus.
Tout fonctionne bien, j'ai créé mes utilisateurs et les transferts FTP marche correctement.

Par contre j'ai un soucis, lorsque l'un de mes utilisateur upload un fichier il se met automatiquement en CHMOD 600 c'est à dire lecture/ écriture uniquement pour le propriétaire.
Ce qui fait que les autres utilisateurs ne peuvent pas télécharger les fichiers d'un autres utilisateur. ce qui est vraiment gênant.
Que faut-il paramétrer pour que systématiquement on soit en chmod 764 c'est a dire :

Propriétaire : Lect / Ecriture / Execution
Groupe : Lect / Ecriture
Publique : Lect.

Merci d'avance pour votre aide.

#2 Le 08/09/2005, à 09:47

Miguel909

Re : [Resolu]Problème avec VSFTPD

Résolu....
j'ai fini par trouver.
Pour ceux que ça intéresse et qui peuvent tomber sur le même problème que moi
il faut aller voir dans /etc/vsftpd.conf
la variable local_umask
et lui attribuer une valeur du type 002 pour avoir ce que je recherche dans le post précédent.

Et redémarrer vsftpd.
/etc/init.d/vsftpd restart
Et voilà.

Merci de m'avoir lu...:P