Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/02/2016, à 13:11

freex

[résolu] Qualcomm Atheros AR8161 pas de réseau

Bonjour,
Lors du passage de la 14.10 à la 15.10 (je n'ai jamais utilisé la 15.04) j'ai remarqué que l'Ethernet ne fonctionnait plus.
Sur google j'ai trouvé ceci https://bugzilla.kernel.org/show_bug.cgi?id=70761 où une solution consiste à faire ceci : "Setting MTU to 8192"
Comment procéder pour modifier le "MTU" ??

Dernière modification par freex (Le 24/05/2016, à 07:53)

Hors ligne

#2 Le 25/02/2016, à 14:52

xubu1957

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Bonjour,

J'ai ce lien : commentcamarche


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 25/02/2016, à 15:34

MicP

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Bonjour freex et xubu1957

freex a écrit :

Le lien que tu donne concerne la carte AR8161
Dans le titre de ce fil, je vois : AR8191

quelle carte réseau sur ta machine ?
AR8161 ou AR8191 ?

=======
Pourrais-tu nous transmettre le retour des commandes suivantes :

lspci
dmesg | grep irmware
ifconfig -a

Merci

Dernière modification par MicP (Le 25/02/2016, à 15:52)

Hors ligne

#4 Le 25/02/2016, à 17:50

freex

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

C'est AR8161, j'ai changé le titre, merci pr la remarque

...bon, je reboot en 16.04 et je publie les résultats...

Hors ligne

#5 Le 25/02/2016, à 18:03

freex

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

lspci

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev a1)
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
04:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 08)

dmesg | grep irmware

[    0.221764] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[    1.924026] psmouse serio4: elantech: assuming hardware version 4 (with firmware version 0x361f03)

ifconfig -a

enp4s0    Link encap:Ethernet  HWaddr 10:bf:48:02:4e:2d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:19 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1462 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1462 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:108252 (108.2 KB)  TX bytes:108252 (108.2 KB)

wlp3s0    Link encap:Ethernet  HWaddr 00:08:ca:f1:aa:bb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1                                                                                                                                                                
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                                                                                                                                                        
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                                                                                                                                                      
          collisions:0 txqueuelen:1000                                                                                                                                                                              
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)  

Hors ligne

#6 Le 25/02/2016, à 18:33

sinbad83

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Si le réseau est effectivement branché, essaye

sudo dhclient -v enp4s0

Si cela la connexion ne revient pas, donne le retour de

sudo lshw -C network

Dernière modification par sinbad83 (Le 25/02/2016, à 18:34)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop AMD Ryzen 5-3600, RAM 16GB, Ubuntu 18.04.4 et 20.04,   HP Pavillon G6 U19.10 et Ten, Serveur Ubuntu 18.04

Hors ligne

#7 Le 25/02/2016, à 18:38

freex

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

...et résultat pour sudo ifconfig wlp3s0 mtu 9000 :

[sudo] password for xxx:                                                                                                                                                                                        
SIOCSIFMTU: Invalid argument 

Hors ligne

#8 Le 25/02/2016, à 19:01

sinbad83

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

La commande demandée était dhclient et non ifconfig

sudo dhclient -v enp4s0

Et si la connexion n'est pas revenue, que donne

sudo lshw -C network

Dernière modification par sinbad83 (Le 25/02/2016, à 19:02)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop AMD Ryzen 5-3600, RAM 16GB, Ubuntu 18.04.4 et 20.04,   HP Pavillon G6 U19.10 et Ten, Serveur Ubuntu 18.04

Hors ligne

#9 Le 26/02/2016, à 04:23

MicP

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

sinbad83 a écrit :

…Si le réseau est effectivement branché, essaye …

Car effectivement, le pilote a l'air bien installé, mais il semble qu'il n'y ait aucune connexion physique => vérifie aussi le câble RJ45 et sa connexion physique.

Je ne dis pas que le problème vient de là, mais ce serait trop bête de passer du temps à bidouiller le système si c'est la connexion physique qui cause le problème.

=======
Ne te trompe pas de commandes concernant les demandes de retour de commandes de simbab83

Dernière modification par MicP (Le 26/02/2016, à 04:42)

Hors ligne

#10 Le 05/03/2016, à 20:01

freex

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Cable branché, réseau disponible dans la liste et wifi activé et connecté :
sudo dhclient -v enp4s0 :

Internet Systems Consortium DHCP Client 4.3.3
Copyright 2004-2015 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/enp4s0/10:bf:48:02:4e:2d
Sending on   LPF/enp4s0/10:bf:48:02:4e:2d
Sending on   Socket/fallback
DHCPREQUEST of 192.168.0.3 on enp4s0 to 255.255.255.255 port 67 (xid=0x5db39012)
DHCPACK of 192.168.0.3 from 192.168.0.1
RTNETLINK answers: File exists
bound to 192.168.0.3 -- renewal in 1730 seconds.

Sans cable connecté :
sudo lshw -C network :
 

*-network               
       description: Wireless interface
       product: AR9485 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 01
       serial: 00:08:ca:f1:aa:bb
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=4.4.0-8-generic firmware=N/A ip=192.168.0.7 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f7900000-f797ffff memory:f7980000-f798ffff
  *-network
       description: Ethernet interface
       product: AR8161 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: enp4s0
       version: 08
       serial: 10:bf:48:02:4e:2d
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
       resources: irq:33 memory:f7800000-f783ffff ioport:d000(size=128)

J'ai aussi remarqué que le réseaux filaire n'apparait pas systématiquement lorsque je branche le câble.
On dirait qu'il s'intercale dans la liste après un certain laps de temps (le wifi lui est tjs branché)
Si je déconnecte le wifi, le réseau filaire reste connecté et fonctionne. à ce moment, si je déconnecte le filaire, il disparait de la liste des connexions disponible !!!
...et réapparait après un  sudo dhclient -v enp4s0 ...mais l'échange de données avec le réseaux est inexistant.

...Pour info, j'ai le même problème avec mon smartphone quand j'essaie de l'utiliser comme un "modem". Je le branche sur le port USB, je partage la connexion 3G, l'icone de networkmanager se modifie mais le réseaux "filaire-USB" n'apparait nulle par dans la liste et pas d'échange de donnée.
...alors que ces même manipulation fonctionne bien avec la 14.10

Dernière modification par freex (Le 05/03/2016, à 20:07)

Hors ligne

#11 Le 28/04/2016, à 15:16

freex

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Depuis la sortie officielle de la 16.04, la connexion ethernet fonctionne mais avec des coupures fréquentes.
Pour retrouver une connexion (momentanée :-( ), retirer et réinsérer le câble ethernet dans le PC.

Dernière modification par freex (Le 28/04/2016, à 15:17)

Hors ligne

#12 Le 24/05/2016, à 07:52

freex

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Depuis la sortie officielle de la 16.04 suivie de mises à jours, le problème n'est plus apparu

Dernière modification par freex (Le 24/05/2016, à 07:56)

Hors ligne

#13 Le 15/02/2020, à 17:56

sindara

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Est ce vraiment résolu ?

Hors ligne

#14 Le 15/02/2020, à 18:02

xubu1957

Re : [résolu] Qualcomm Atheros AR8161 pas de réseau

Bonjour,

@sindara

La solution concernait le réseau filaire et pas le wifi.

J'attends toujours tes infos dans ta discussion > qualcomm atheros AR8162 qui boude Ubuntu


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne