Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/02/2020, à 18:32

kalounne

Wake on wan ou lan impossible sous ubuntu

Bonjour,

Je ne peu pas démarrer ma machine en Wake on wan si elle a été éteinte depuis ubuntu!!
Seul un redémarrage sous windows me permet d’éteindre correctement la carte réseaux pour quel puisse être réveillé à partir de l'interface de ma Kbox!! (fournisseur: knet)
Comme quoi c'est windows qui sauve la vie pour le coût.


j'ai suivi un tuto qui m'a fait créer un service pour qu'il soit activé au démarrage mais ca n'a rien changé. Pire, cela a fini par ne plus faire reconnaître ma connexion Ethernet même si elle fonctionnait vue que j'avais accès à internet. J'ai réinstallé ubuntu après multiples commandes pour essayer de réparer le problème.

J'ai trouvé ceci dans la doc d'ubuntu :
https://doc.ubuntu-fr.org/wakeonlan

sudo ethtool eth0  | egrep "^[[:blank:]]*Wake-on: (g|d)"

me donne "d"

Conserver le paramétrage

Avec certaines versions d'Ubuntu et/ou certains matériels, lors de l'extinction, le système désactive les interfaces réseaux.

Après essais, si le WOL ne fonctionne pas, pour supprimer cette sécurité2), un des moyens est d'écrire la ligne de commande suivante dans le fichier /etc/rc.local :

/sbin/ethtool -s eth0 wol g

A mettre avant la ligne :

exit 0

Ainsi à chaque démarrage, la ligne de commande est exécutée, activant la carte réseau pour le prochain démarrage.


Le problème c'est qu'il n'y a pas de rc.local dans la nouvelle version mais rc0.d,rc1.d....rc6.d,rcS.d

De la est partit des créations de scripts mais rien n'a fonctionné : https://forum.ubuntu-fr.org/viewtopic.php?id=2028464

Merci à vous d'avance

Alex.

Dernière modification par kalounne (Le 12/02/2020, à 00:15)

Hors ligne

#2 Le 11/02/2020, à 18:38

xubu1957

Re : Wake on wan ou lan impossible sous ubuntu

Bonjour,

Montre :

ip a

pour voir les noms des interfaces.

_ _ _

Regarde > WOL avec free et Ubuntu

Dernière modification par xubu1957 (Le 11/02/2020, à 18:40)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 11/02/2020, à 18:46

kalounne

Re : Wake on wan ou lan impossible sous ubuntu

Voici: ip a

alexandre@hp:/etc/systemd/system$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether c8:0a:a9:2d:7b:ae brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.54/24 brd 192.168.1.255 scope global dynamic noprefixroute enp3s0
       valid_lft 12468sec preferred_lft 12468sec
    inet6 fe80::8a6b:6002:5103:5163/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp2s0b1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether c4:17:fe:b2:3c:08 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.29/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp2s0b1
       valid_lft 12468sec preferred_lft 12468sec
    inet6 fe80::cee1:3d02:87d7:a5cd/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Je viens de re créer un script pour que j 'ai bien "g" au démarrage


[Unit]
Description="Lancer WOL"

[Service]
Type=oneshot
ExecStart=/sbin/ethtool -s enp3s0 wol g

[Install]
WantedBy=multi-user.target
alexandre@hp:/etc$ cd systemd
alexandre@hp:/etc/systemd$ cd system
alexandre@hp:/etc/systemd/system$ nano wol.service
alexandre@hp:/etc/systemd/system$ sudo nano wol.service
[sudo] Mot de passe de alexandre : 
alexandre@hp:/etc/systemd/system$ sudo systemctl enable wol.service
Created symlink /etc/systemd/system/multi-user.target.wants/wol.service → /etc/systemd/system/wol.service.
alexandre@hp:/etc/systemd/system$ sudo systemctl start wol.service
alexandre@hp:/etc/systemd/system$ sudo ethtool enp3s0  | egrep "^[[:blank:]]*Wake-on: (g|d)"
	Wake-on: g

Je vais eteindre et tester mais j'y crois pas...

Dernière modification par kalounne (Le 11/02/2020, à 18:47)

Hors ligne

#4 Le 11/02/2020, à 18:52

kalounne

Re : Wake on wan ou lan impossible sous ubuntu

C'est toujours pareil !

Agaçant comme comme quoi windows fait les choses mieux pour le coup.
Pas fichu d’éteindre cette carte proprement grrr

alexandre@hp:~$ sudo ethtool enp3s0  | egrep "^[[:blank:]]*Wake-on: (g|d)"
[sudo] Mot de passe de alexandre : 
	Wake-on: g

Pourtant Wake-on est bien a "g" au démarrage.

Dernière modification par kalounne (Le 11/02/2020, à 18:54)

Hors ligne

#5 Le 11/02/2020, à 18:53

xubu1957

Re : Wake on wan ou lan impossible sous ubuntu

Je n'y connais rien en matière de script, il faut attendre des aidants pointus.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne