Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/11/2019, à 10:39

Spyynox

Could not resolve 'proxy.iiit.ac.in'

Bonjour,
Hier soir, j'ai voulu installer docker dans ubuntu 18, j'ai rencontrer plusieurs problèmes.
Du coup je me suis vers stackoverflow, d'après ce lien: https://askubuntu.com/questions/1045547 … xy/1045627
il fallait ajouter dans le le fichier .bashrc cette ligne de code:

alias iiitproxy='export http_proxy="http://proxy.iiit.ac.in:8080"; export https_proxy="http://proxy.iiit.ac.in:8080";export ftp_proxy="http://proxy.iiit.ac.in:8080"; echo "Acquire::http::proxy \"http://proxy.iiit.ac.in:8080/\";" | sudo tee /etc/apt/apt.conf'

et écire ça dans le terminal:

iiitproxy

.
Mais lorsque je fais sudo apt-get update, il m'affiche des messages d'erreurs centrés sur le proxi.iniit:

sudo apt-get update
Err:1 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu bionic InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:2 https://dl.yarnpkg.com/debian stable InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:3 http://security.ubuntu.com/ubuntu bionic-security InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:4 http://archive.ubuntu.com/ubuntu bionic InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:5 https://deb.nodesource.com/node_10.x bionic InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:6 https://download.docker.com/linux/ubuntu bionic InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:7 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
  Could not resolve 'proxy.iiit.ac.in'
Err:10 http://ppa.launchpad.net/openjdk-r/ppa/ubuntu bionic InRelease
  Could not resolve 'proxy.iiit.ac.in'
Reading package lists... Done
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic-updates/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic-backports/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/bionic-security/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch https://download.docker.com/linux/ubuntu/dists/bionic/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch http://ppa.launchpad.net/deadsnakes/ppa/ubuntu/dists/bionic/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch https://deb.nodesource.com/node_10.x/dists/bionic/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/dists/bionic/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch http://ppa.launchpad.net/openjdk-r/ppa/ubuntu/dists/bionic/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Failed to fetch https://dl.yarnpkg.com/debian/dists/stable/InRelease  Could not resolve 'proxy.iiit.ac.in'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Du coup j'ai enlevé cette ligne de code dans le fichier mais l'erreur persiste et je n'arrive plus à update... aidez moi svp sad

Merci d'avance!

Hors ligne

#2 Le 08/11/2019, à 10:41

krodelabestiole

Re : Could not resolve 'proxy.iiit.ac.in'

t'es sur WSL ?

Hors ligne

#3 Le 08/11/2019, à 10:45

Spyynox

Re : Could not resolve 'proxy.iiit.ac.in'

krodelabestiole a écrit :

t'es sur WSL ?

Oui.

Hors ligne

#4 Le 08/11/2019, à 12:18

krodelabestiole

Re : Could not resolve 'proxy.iiit.ac.in'

alors aux dernières nouvelles docker ne fonctionne pas sur WSL :
https://doc.ubuntu-fr.org/docker (cadre rose)
https://forum.ubuntu-fr.org/viewtopic.php?id=2023871

je ne sais pas où ça en est actuellement.
WSL 2 utilise(ra) hyper-v, donc on retombe sur de la bête virtualisation et docker sera sûrement compatible. il est possible que ça mette les travaux sur WSL1 en stand-by.

en tout cas à ce sujet (docker), n'essaie pas de suivre des docs qui ne sont pas spécifiques à WSL. c'est un cas très particulier, tout n'est pas implémenté et la doc officielle recommande d'installer docker sur windows (via hyper-v), seul le client est officiellement compatible avec WSL (qui permet de contrôler les containers, ça a finalement très peu d'intérêt).

sinon là le problème c'est simplement que le domaine proxy.iiit.ac.in n'existe pas. et je pige vraiment pas pourquoi tu suis ce fil qui parle d'installer sublime text, et absolument pas de docker... ?

Dernière modification par krodelabestiole (Le 08/11/2019, à 12:19)

Hors ligne

#5 Le 08/11/2019, à 14:12

Spyynox

Re : Could not resolve 'proxy.iiit.ac.in'

Il était 1h, je n'avais pas pas bien lu le titre à cause de la fatigue

Hors ligne

#6 Le 08/11/2019, à 20:36

Spyynox

Re : Could not resolve 'proxy.iiit.ac.in'

N'a-t'il donc aucun moyen de régler ce message d'erreur? sad

Hors ligne