Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/08/2019, à 21:58

ilym

[Résolu] Apparmor impossible à démarrer (Snap ne fonctionne pas)

Bonjour,

Suite à l'installation d'un certain nombre de logiciels, j'ai souvent le message d'erreur suivant après redémarrage :

snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks

Après recherches, j'ai trouvé sur un site internet que le problème viendrait de Apparmor qui n'est pas démarré avant l'installation desdits logiciels. Effectivement après avoir fait un :

systemctl status apparmor

j'obtiens :

 apparmor.service - Load AppArmor profiles
   Loaded: loaded (/lib/systemd/system/apparmor.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:apparmor(7)
           https://gitlab.com/apparmor/apparmor/wikis/home/

Du coup je tente un :

systemctl start apparmor

et je vérifie l'état d'Apparmor :

● apparmor.service - Load AppArmor profiles
   Loaded: loaded (/lib/systemd/system/apparmor.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
Condition: start condition failed at Tue 2019-08-13 19:47:16 UTC; 1s ago
           └─ ConditionPathExists=!/rofs/etc/apparmor.d was not met
     Docs: man:apparmor(7)
           https://gitlab.com/apparmor/apparmor/wikis/home/

Du coup je suis bloqué, impossible de démarrer Apparmor pour une erreur dont je ne sais pas comment la résoudre. J'ai tout essayé, réinstaller Apparmor et Snad avec purge après redémarrage et ça ne donne rien.

Merci pour votre aide.

Dernière modification par ilym (Le 13/08/2019, à 23:49)

Hors ligne

#2 Le 13/08/2019, à 23:48

ilym

Re : [Résolu] Apparmor impossible à démarrer (Snap ne fonctionne pas)

ilym a écrit :

Bonjour,

Suite à l'installation d'un certain nombre de logiciels, j'ai souvent le message d'erreur suivant après redémarrage :

snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks

Après recherches, j'ai trouvé sur un site internet que le problème viendrait de Apparmor qui n'est pas démarré avant l'installation desdits logiciels. Effectivement après avoir fait un :

systemctl status apparmor

j'obtiens :

 apparmor.service - Load AppArmor profiles
   Loaded: loaded (/lib/systemd/system/apparmor.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:apparmor(7)
           https://gitlab.com/apparmor/apparmor/wikis/home/

Du coup je tente un :

systemctl start apparmor

et je vérifie l'état d'Apparmor :

● apparmor.service - Load AppArmor profiles
   Loaded: loaded (/lib/systemd/system/apparmor.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
Condition: start condition failed at Tue 2019-08-13 19:47:16 UTC; 1s ago
           └─ ConditionPathExists=!/rofs/etc/apparmor.d was not met
     Docs: man:apparmor(7)
           https://gitlab.com/apparmor/apparmor/wikis/home/

Du coup je suis bloqué, impossible de démarrer Apparmor pour une erreur dont je ne sais pas comment la résoudre. J'ai tout essayé, réinstaller Apparmor et Snad avec purge après redémarrage et ça ne donne rien.

Merci pour votre aide.

J'ai trouvé le problème :
Je suis sous Ubuntu live en persistant et le problème vient du fichier /lib/systemd/system/apparmor.service dans lequel il y a cette ligne :

# Don't start this unit on the Ubuntu Live CD
ConditionPathExists=!/rofs/etc/apparmor.d

Ce qui signifie en gros que si le fichier existe et que donc on est dans le cas d'un Ubuntu Live, Apparmor ne se lance pas.

Du coup pour forcer la chose et comme je suis sur du persistant, je supprime le "!" et je réessaye et ça marche !

Dernière modification par ilym (Le 14/08/2019, à 16:34)

Hors ligne