Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 14/04/2019, à 15:09

saihaj

Re : Installation de packages R sous Ubuntu 18.04

Bonjour,
Pour la première commande elle n'a rien donné,

pour la deuxième:

sudo apt install --reinstall install-info
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 23 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
E: Internal Error, No file name for install-info:amd64

Merci

Hors ligne

#27 Le 14/04/2019, à 15:20

nany

Re : Installation de packages R sous Ubuntu 18.04

sudo rm -v /var/lib/dpkg/info/install-info.*
sudo dpkg -P --force-remove-reinstreq install-info
sudo apt update
sudo apt install -y install-info

Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#28 Le 14/04/2019, à 15:24

saihaj

Re : Installation de packages R sous Ubuntu 18.04

sudo rm -v /var/lib/dpkg/info/install-info.*
'/var/lib/dpkg/info/install-info.list' supprimé
'/var/lib/dpkg/info/install-info.md5sums' supprimé
'/var/lib/dpkg/info/install-info.postinst' supprimé
'/var/lib/dpkg/info/install-info.triggers' supprimé
sudo dpkg -P --force-remove-reinstreq install-info
dpkg: un problème de dépendance empêche la suppression de install-info :
 info dépend de install-info.

dpkg: erreur de traitement du paquet install-info (--purge) :
 problème de dépendance - suppression ignorée
Des erreurs ont été rencontrées pendant l'exécution :
 install-info
sudo apt update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease
Atteint :2 http://archive.ubuntu.com/ubuntu bionic InRelease                   
Réception de :3 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Réception de :4 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Atteint :5 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu bionic InRelease
Atteint :6 http://ppa.launchpad.net/marutter/c2d4u3.5/ubuntu bionic InRelease  
Atteint :7 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease   
Réception de :8 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Atteint :9 https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ InRelease
Atteint :10 https://download.sublimetext.com apt/stable/ InRelease             
252 ko réceptionnés en 2s (128 ko/s)                                           
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
23 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
sudo apt install -y install-info
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
install-info est déjà la version la plus récente (6.5.0.dfsg.1-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 23 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Paramétrage de install-info (6.5.0.dfsg.1-2) ...
W: APT had planned for dpkg to do more than it reported back (0 vs 4).
   Affected packages: install-info:amd64

Hors ligne

#29 Le 14/04/2019, à 15:29

nany

Re : Installation de packages R sous Ubuntu 18.04

Que donne

sudo apt full-upgrade

 ?


Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#30 Le 14/04/2019, à 17:21

saihaj

Re : Installation de packages R sous Ubuntu 18.04

sudo apt full-upgrade
[sudo] Mot de passe : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  gir1.2-upowerglib-1.0 gnome-control-center gnome-control-center-data
  gnome-control-center-faces gnome-software gnome-software-common
  gnome-software-plugin-snap libidn11 libnss-systemd libpam-systemd
  libsmbclient libsystemd0 libudev1 libupower-glib3 libwbclient0
  r-cran-cluster r-cran-nlme samba-libs systemd ubuntu-software udev upower
  wpasupplicant
23 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 19,7 Mo dans les archives.
Après cette opération, 21,5 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsystemd0 amd64 237-3ubuntu10.19 [204 kB]
Réception de :2 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libnss-systemd amd64 237-3ubuntu10.19 [105 kB]
Réception de :3 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libpam-systemd amd64 237-3ubuntu10.19 [108 kB]
Réception de :4 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 systemd amd64 237-3ubuntu10.19 [2901 kB]
Réception de :5 https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ r-cran-cluster 2.0.8-1bionic0 [522 kB]
Réception de :6 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 udev amd64 237-3ubuntu10.19 [1102 kB]
Réception de :7 https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ r-cran-nlme 3.1.139-1bionic0 [2217 kB]
Réception de :8 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libudev1 amd64 237-3ubuntu10.19 [53,5 kB]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsmbclient amd64 2:4.7.6+dfsg~ubuntu-0ubuntu2.9 [54,4 kB]
Réception de :10 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 samba-libs amd64 2:4.7.6+dfsg~ubuntu-0ubuntu2.9 [5248 kB]
Réception de :11 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libwbclient0 amd64 2:4.7.6+dfsg~ubuntu-0ubuntu2.9 [33,7 kB]
Réception de :12 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libidn11 amd64 1.33-2.1ubuntu1.2 [46,6 kB]
Réception de :13 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libupower-glib3 amd64 0.99.7-2ubuntu0.18.04.1 [42,8 kB]
Réception de :14 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gir1.2-upowerglib-1.0 amd64 0.99.7-2ubuntu0.18.04.1 [5268 B]
Réception de :15 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-control-center-data all 1:3.28.2-0ubuntu0.18.04.3 [507 kB]
Réception de :16 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-control-center amd64 1:3.28.2-0ubuntu0.18.04.3 [1627 kB]
Réception de :17 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-control-center-faces all 1:3.28.2-0ubuntu0.18.04.3 [819 kB]
Réception de :18 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-plugin-snap amd64 3.28.1-0ubuntu4.18.04.9 [28,4 kB]
Réception de :19 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software amd64 3.28.1-0ubuntu4.18.04.9 [484 kB]
Réception de :20 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-common all 3.28.1-0ubuntu4.18.04.9 [2482 kB]
Réception de :21 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 ubuntu-software all 3.28.1-0ubuntu4.18.04.9 [25,3 kB]
Réception de :22 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 upower amd64 0.99.7-2ubuntu0.18.04.1 [102 kB]
Réception de :23 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 wpasupplicant amd64 2:2.6-15ubuntu2.2 [954 kB]
19,7 Mo réceptionnés en 3s (5910 ko/s)   
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « install-info » étant manquant, il est considéré qu'aucun fichier du paquet n'est actuellement installé
(Lecture de la base de données... 206033 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libsystemd0_237-3ubuntu10.19_amd64.deb ...
Dépaquetage de libsystemd0:amd64 (237-3ubuntu10.19) sur (237-3ubuntu10.15) ...
Paramétrage de libsystemd0:amd64 (237-3ubuntu10.19) ...
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « install-info » étant manquant, il est considéré qu'aucun fichier du paquet n'est actuellement installé
(Lecture de la base de données... 206033 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libnss-systemd_237-3ubuntu10.19_amd64.deb ...
Dépaquetage de libnss-systemd:amd64 (237-3ubuntu10.19) sur (237-3ubuntu10.15) ...
Préparation du dépaquetage de .../libpam-systemd_237-3ubuntu10.19_amd64.deb ...
Dépaquetage de libpam-systemd:amd64 (237-3ubuntu10.19) sur (237-3ubuntu10.15) ...
Préparation du dépaquetage de .../systemd_237-3ubuntu10.19_amd64.deb ...
Dépaquetage de systemd (237-3ubuntu10.19) sur (237-3ubuntu10.15) ...
Préparation du dépaquetage de .../udev_237-3ubuntu10.19_amd64.deb ...
Dépaquetage de udev (237-3ubuntu10.19) sur (237-3ubuntu10.15) ...
Préparation du dépaquetage de .../libudev1_237-3ubuntu10.19_amd64.deb ...
Dépaquetage de libudev1:amd64 (237-3ubuntu10.19) sur (237-3ubuntu10.15) ...
Paramétrage de libudev1:amd64 (237-3ubuntu10.19) ...
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « install-info » étant manquant, il est considéré qu'aucun fichier du paquet n'est actuellement installé
(Lecture de la base de données... 206033 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libsmbclient_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.9_amd64.deb ...
Dépaquetage de libsmbclient:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.9) sur (2:4.7.6+dfsg~ubuntu-0ubuntu2.7) ...
Préparation du dépaquetage de .../01-samba-libs_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.9_amd64.deb ...
Dépaquetage de samba-libs:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.9) sur (2:4.7.6+dfsg~ubuntu-0ubuntu2.7) ...
Préparation du dépaquetage de .../02-libwbclient0_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.9_amd64.deb ...
Dépaquetage de libwbclient0:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.9) sur (2:4.7.6+dfsg~ubuntu-0ubuntu2.7) ...
Préparation du dépaquetage de .../03-libidn11_1.33-2.1ubuntu1.2_amd64.deb ...
Dépaquetage de libidn11:amd64 (1.33-2.1ubuntu1.2) sur (1.33-2.1ubuntu1.1) ...
Préparation du dépaquetage de .../04-libupower-glib3_0.99.7-2ubuntu0.18.04.1_amd64.deb ...
Dépaquetage de libupower-glib3:amd64 (0.99.7-2ubuntu0.18.04.1) sur (0.99.7-2) ...
Préparation du dépaquetage de .../05-gir1.2-upowerglib-1.0_0.99.7-2ubuntu0.18.04.1_amd64.deb ...
Dépaquetage de gir1.2-upowerglib-1.0:amd64 (0.99.7-2ubuntu0.18.04.1) sur (0.99.7-2) ...
Préparation du dépaquetage de .../06-gnome-control-center-data_1%3a3.28.2-0ubuntu0.18.04.3_all.deb ...
Dépaquetage de gnome-control-center-data (1:3.28.2-0ubuntu0.18.04.3) sur (1:3.28.2-0ubuntu0.18.04.2) ...
Préparation du dépaquetage de .../07-gnome-control-center_1%3a3.28.2-0ubuntu0.18.04.3_amd64.deb ...
Dépaquetage de gnome-control-center (1:3.28.2-0ubuntu0.18.04.3) sur (1:3.28.2-0ubuntu0.18.04.2) ...
Préparation du dépaquetage de .../08-gnome-control-center-faces_1%3a3.28.2-0ubuntu0.18.04.3_all.deb ...
Dépaquetage de gnome-control-center-faces (1:3.28.2-0ubuntu0.18.04.3) sur (1:3.28.2-0ubuntu0.18.04.2) ...
Préparation du dépaquetage de .../09-gnome-software-plugin-snap_3.28.1-0ubuntu4.18.04.9_amd64.deb ...
Dépaquetage de gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.9) sur (3.28.1-0ubuntu4.18.04.8) ...
Préparation du dépaquetage de .../10-gnome-software_3.28.1-0ubuntu4.18.04.9_amd64.deb ...
Dépaquetage de gnome-software (3.28.1-0ubuntu4.18.04.9) sur (3.28.1-0ubuntu4.18.04.8) ...
Préparation du dépaquetage de .../11-gnome-software-common_3.28.1-0ubuntu4.18.04.9_all.deb ...
Dépaquetage de gnome-software-common (3.28.1-0ubuntu4.18.04.9) sur (3.28.1-0ubuntu4.18.04.8) ...
Préparation du dépaquetage de .../12-r-cran-cluster_2.0.8-1bionic0_amd64.deb ...
Dépaquetage de r-cran-cluster (2.0.8-1bionic0) sur (2.0.7-1-1cranBionic0) ...
Préparation du dépaquetage de .../13-r-cran-nlme_3.1.139-1bionic0_amd64.deb ...
Dépaquetage de r-cran-nlme (3.1.139-1bionic0) sur (3.1.137-1cranBionic0) ...
Préparation du dépaquetage de .../14-ubuntu-software_3.28.1-0ubuntu4.18.04.9_all.deb ...
Dépaquetage de ubuntu-software (3.28.1-0ubuntu4.18.04.9) sur (3.28.1-0ubuntu4.18.04.8) ...
Préparation du dépaquetage de .../15-upower_0.99.7-2ubuntu0.18.04.1_amd64.deb ...
Dépaquetage de upower (0.99.7-2ubuntu0.18.04.1) sur (0.99.7-2) ...
Préparation du dépaquetage de .../16-wpasupplicant_2%3a2.6-15ubuntu2.2_amd64.deb ...
Dépaquetage de wpasupplicant (2:2.6-15ubuntu2.2) sur (2:2.6-15ubuntu2.1) ...
Paramétrage de libwbclient0:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.9) ...
Paramétrage de gnome-software-common (3.28.1-0ubuntu4.18.04.9) ...
Paramétrage de samba-libs:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.9) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:amd64 (2.56.3-0ubuntu0.18.04.1) ...
Paramétrage de r-cran-nlme (3.1.139-1bionic0) ...
Paramétrage de wpasupplicant (2:2.6-15ubuntu2.2) ...
Paramétrage de libsmbclient:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.9) ...
Paramétrage de gnome-control-center-faces (1:3.28.2-0ubuntu0.18.04.3) ...
Paramétrage de gnome-control-center-data (1:3.28.2-0ubuntu0.18.04.3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Paramétrage de udev (237-3ubuntu10.19) ...
update-initramfs: deferring update (trigger activated)
Paramétrage de gnome-software (3.28.1-0ubuntu4.18.04.9) ...
Paramétrage de libupower-glib3:amd64 (0.99.7-2ubuntu0.18.04.1) ...
Paramétrage de gir1.2-upowerglib-1.0:amd64 (0.99.7-2ubuntu0.18.04.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour dbus (1.12.2-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Paramétrage de libidn11:amd64 (1.33-2.1ubuntu1.2) ...
Paramétrage de r-cran-cluster (2.0.8-1bionic0) ...
Paramétrage de ubuntu-software (3.28.1-0ubuntu4.18.04.9) ...
Paramétrage de gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.9) ...
Paramétrage de upower (0.99.7-2ubuntu0.18.04.1) ...
Paramétrage de gnome-control-center (1:3.28.2-0ubuntu0.18.04.3) ...
Paramétrage de systemd (237-3ubuntu10.19) ...
Paramétrage de libnss-systemd:amd64 (237-3ubuntu10.19) ...
Paramétrage de libpam-systemd:amd64 (237-3ubuntu10.19) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.130ubuntu3.7) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-47-generic
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...

Hors ligne

#31 Le 14/04/2019, à 19:24

nany

Re : Installation de packages R sous Ubuntu 18.04

Que donne maintenant

sudo dpkg --configure install-info

 ?


Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#32 Le 14/04/2019, à 22:40

saihaj

Re : Installation de packages R sous Ubuntu 18.04

sudo dpkg --configure install-info
[sudo] Mot de passe : 
dpkg: erreur de traitement du paquet install-info (--configure) :
 le paquet install-info est déjà installé et configuré
Des erreurs ont été rencontrées pendant l'exécution :
 install-info

Hors ligne

#33 Le 15/04/2019, à 09:27

nany

Re : Installation de packages R sous Ubuntu 18.04

Et ceci :

sudo dpkg -P --force-all install-info

Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#34 Le 15/04/2019, à 10:06

saihaj

Re : Installation de packages R sous Ubuntu 18.04

sudo dpkg -P --force-all install-info
[sudo] Mot de passe : 
dpkg: install-info : problème de dépendance, mais suppression comme demandé :
 info dépend de install-info.

dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « install-info » étant manquant, il est considéré qu'aucun fichier du paquet n'est actuellement installé
(Lecture de la base de données... 206031 fichiers et répertoires déjà installés.)
Suppression de install-info (6.5.0.dfsg.1-2) ...

Hors ligne

#35 Le 15/04/2019, à 10:09

nany

Re : Installation de packages R sous Ubuntu 18.04

Ok. Maintenant :

sudo apt install -y install-info

Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#36 Le 15/04/2019, à 12:07

saihaj

Re : Installation de packages R sous Ubuntu 18.04

sudo apt install -y install-info
[sudo] Mot de passe: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  install-info
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 55,4 ko dans les archives.
Après cette opération, 391 ko d'espace disque supplémentaires seront utilisés.
Réception de :1 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 install-info amd64 6.5.0.dfsg.1-2 [55,4 kB]
55,4 ko réceptionnés en 0s (285 ko/s)   
Sélection du paquet install-info précédemment désélectionné.
(Lecture de la base de données... 206032 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../install-info_6.5.0.dfsg.1-2_amd64.deb ...
Dépaquetage de install-info (6.5.0.dfsg.1-2) ...
Paramétrage de install-info (6.5.0.dfsg.1-2) ...
/usr/sbin/update-info-dir: 2: /etc/environment: Syntax error: Unterminated quoted string
dpkg: erreur de traitement du paquet install-info (--configure) :
 installed install-info package post-installation script subprocess returned error exit status 2
Des erreurs ont été rencontrées pendant l'exécution :
 install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#37 Le 15/04/2019, à 12:13

xubu1957

Re : Installation de packages R sous Ubuntu 18.04


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#38 Le 15/04/2019, à 12:56

nany

Re : Installation de packages R sous Ubuntu 18.04

Oui, /etc/environment a encore été modifié et je ne sais pas pourquoi. On tourne en rond.

@saihaj ; donne les retours de :

cat /etc/environment
history 100

Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#39 Le 15/04/2019, à 13:10

saihaj

Re : Installation de packages R sous Ubuntu 18.04

cat /etc/environment
La commande « cat » est disponible dans « /bin/cat »
La commande n'a pas pu être trouvée car « /bin » n'est pas incluse dans la variable d'environnement PATH.
cat : commande introuvable
/bin/cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/local/ssl/bin:/usr/sbin:/usr/bin:
history 100
  830  vim /etc/environment
  831  openssl version -a
  832  sudo apt install vim
  833  cat /etc/environment
  834  /etc/environment
  835  usr/etc/environment
  836  sudo /etc/environment
  837  sudo nano /etc/environment
  838  cat /etc/environment
  839  sudo sed -i 's#/sbin:/bin:/usr/games:/usr/local/games"$##' /etc/environment && sudo apt install -fy
  840  sudo nano /etc/environment
  841  sudo sed -i 's#/sbin:/bin:/usr/games:/usr/local/games"$##' /etc/environment && sudo apt install -fy
  842  R
  843  pacman -Q tcl tk
  844  sudo apt install pacman
  845  sudo dpkg --configure -a
  846  sudo apt -f install
  847  install-info
  848  --help
  849  (--help)
  850  sudo dpkg --configure -a
  851  sudo apt -f install
  852  sudo apt upgrade
  853  STAR --Version
  854  cd STAR/
  855  STAR --Version
  856  cd ..
  857  STAR --Version
  858  genomeDir=/path/to/hg19
  859  mkdir $genomeDir
  860  STAR --runMode genomeGenerate --genomeDir $genomeDir --genomeFastaFiles hg19.fa\  --runThreadN <n>
  861  cd STAR/
  862  genomeDir=/path/to/hg19
  863  mkdir $genomeDir
  864  cd ..
  865  vi PremierScriptShell.sh
  866  cd STAR/
  867  vi PremierSTArscript.sh
  868  mkdir $genomeDir
  869  /bin/
  870  mkdir genome
  871  /bin/mkdir $genomeDir
  872  /bin/mkdir --help
  873  vi PremierSTArscript.sh
  874  env
  875  cd STAR/
  876  bash Star_Script.sh 
  877  chmod +x Star_Script.sh 
  878  echo $PATH
  879  cd..
  880  cd ..
  881  echo $PATH
  882  PATH="/bin:/usr/bin:/sbin:/usr/sbin" 
  883  ~/.bashrc
  884  sudo updatedb && locate chmod
  885  ls -l /bin/chmod
  886  cd STAR/
  887  /bin/chmod a+x Star_Script.sh 
  888  /bin/chmod +x Star_Script.sh 
  889  /bin/bash +x Star_Script.sh 
  890  cd ..
  891  /bin/bash +x Star_Script.sh 
  892  STAR --Version
  893  cd STAR
  894  STAR --Version
  895  sudo apt install rna-star
  896  cd ..
  897  sudo dpkg --configure -a
  898  cd STAR
  899  wget ftp://ftp.ensembl.org/pub/release-79/gtf/homo_sapiens/Homo_sapiens.GRCh38.79.gtf.gz
  900  gunzip Homo_sapiens.GRCh38.79.gtf.gz
  901  wget https://www.encodeproject.org/files/ENCFF001RFH/@@download/ENCFF001RFH.fastq.gz -O
  902  ENCFF001RFH.fastq.gz wget https://www.encodeproject.org/files/ENCFF001RFH/@@download/ENCFF001RFG.fastq.gz -O
  903  ENCFF001RFG.fastq.gz
  904  wget https://www.encodeproject.org/files/ENCFF001RFH/@@download/ENCFF001RFH.fastq.gz 
  905  wget https://www.encodeproject.org/files/ENCFF001RFH/@@download/ENCFF001RFH.fastq.gz -O
  906  ENCFF001RFH.fastq.gz wget https://www.encodeproject.org/files/ENCFF001RFH/@@download/ENCFF001RFG.fastq.gz -O
  907  ENCFF001RFG.fastq.gz
  908  cd source/
  909  STAR --Version
  910  STAR --VERSION
  911  ls -l /cluster/projects/p116/Indexed/Genome/
  912  cd ..
  913  ls -l /cluster/projects/p116/Indexed/Genome/
  914  cd STAR
  915  /bin/bash +x Star_Script.sh 
  916  ls -l /cluster/projects/p116/Indexed/Genome/
  917  sudo apt clean
  918  sudo apt install --reinstall install-info
  919  sudo rm -v /var/lib/dpkg/info/install-info.*
  920  sudo dpkg -P --force-remove-reinstreq install-info
  921  sudo apt update
  922  sudo apt install -y install-info
  923  sudo apt full-upgrade
  924  sudo dpkg --configure install-info
  925  sudo dpkg -P --force-all install-info
  926  sudo apt install -y install-info
  927  cat /etc/environment
  928  /bin/cat /etc/environment
  929  history 100

Hors ligne

#40 Le 15/04/2019, à 13:21

nany

Re : Installation de packages R sous Ubuntu 18.04

saihaj a écrit :
history 100
  830  vim /etc/environment
  […]
  837  sudo nano /etc/environment
  […]
  840  sudo nano /etc/environment
  […]

Que cherches-tu à modifier dans /etc/environment ?

En attendant, pour réparer, donne les retours de :

echo 'PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"' | sudo tee /etc/environment
sudo apt install -fy

Dernière modification par nany (Le 15/04/2019, à 13:21)


Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#41 Le 15/04/2019, à 13:24

saihaj

Re : Installation de packages R sous Ubuntu 18.04

echo 'PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"' | sudo tee /etc/environment
[sudo] Mot de passe: 
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
sudo apt install -fy
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Paramétrage de install-info (6.5.0.dfsg.1-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
W: APT had planned for dpkg to do more than it reported back (0 vs 4).
   Affected packages: install-info:amd64

Hors ligne

#42 Le 15/04/2019, à 13:34

nany

Re : Installation de packages R sous Ubuntu 18.04

nany a écrit :

Que cherches-tu à modifier dans /etc/environment ?


Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#43 Le 15/04/2019, à 13:41

saihaj

Re : Installation de packages R sous Ubuntu 18.04

la commande

sudo nano /etc/environment

je l'avais lancé juste pour ajouter l'ssl sur le path quand j'avais le problème d'installation de l'openssl, et après je l'ai enlevé.

Hors ligne

#44 Le 15/04/2019, à 17:46

nany

Re : Installation de packages R sous Ubuntu 18.04

saihaj a écrit :

je l'avais lancé juste pour ajouter l'ssl sur le path quand j'avais le problème d'installation de l'openssl, et après je l'ai enlevé.

Donc tu n’a, a priori, plus besoin d’éditer ce fichier. Il faut toujours faire attention à ce que l’on fait lorsqu’on manipule des fichiers système. wink

Bon, ton système devrait fonctionner (malgré ce warning dont je n’arrive pas à trouver l’explication).


As-tu réussi à avancer sur ton problème avec R ?


Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#45 Le 15/04/2019, à 20:21

saihaj

Re : Installation de packages R sous Ubuntu 18.04

D'accord,
Merci beaucoup pour vos efforts et le temps que vous aviez consacré pour me répondre.

pour le R j'arrive toujours pas à installer les packages dont j'ai besoin sad

il me renvoie les erreurs suivantes

/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé

The downloaded source packages are in
	‘/tmp/Rtmp9MmcES/downloaded_packages’
installation path not writeable, unable to update packages: rpart
Update old packages: 'backports', 'clipr', 'data.table', 'ggplot2', 'plotrix',
  'remotes', 'rlang', 'sandwich', 'shiny', 'tinytex', 'urltools'
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé
/usr/lib/R/bin/R: ligne 8: uname : commande introuvable
/usr/lib/R/bin/R: ligne 143 : exec: sh : non trouvé

The downloaded source packages are in
	‘/tmp/Rtmp9MmcES/downloaded_packages’
There were 28 warnings (use warnings() to see them)

Hors ligne

#46 Le 15/04/2019, à 20:48

Alex10336

Re : Installation de packages R sous Ubuntu 18.04

B'soir,

les retour de

echo "$PATH"
cat ~/.bashrc
cat ~/.bash_aliases

C'est quoi la commande que tu as fait pour avoir

/usr/lib/R/bin/R: ligne 8: uname : commande introuvable

N.B. Penser a laisser le $ ou le # devant les commandes faites

Dernière modification par Alex10336 (Le 15/04/2019, à 20:54)


« On ne répond pas à une question par une autre question. » (moi ;-) )

Hors ligne

#47 Le 15/04/2019, à 21:06

saihaj

Re : Installation de packages R sous Ubuntu 18.04

Bonsoir,

$echo "$PATH"
/usr/local/sbin:/usr/local/bin:/usr/local/ssl/bin:/usr/sbin:/usr/bin:
$cat ~/.bashrc
La commande « cat » est disponible dans « /bin/cat »
La commande n'a pas pu être trouvée car « /bin » n'est pas incluse dans la variable d'environnement PATH.
cat : commande introuvable
$/bin/cat ~/.bashrc
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
	# We have color support; assume it's compliant with Ecma-48
	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
	# a case would tend to support setf rather than setaf.)
	color_prompt=yes
    else
	color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi
$cat ~/.bash_aliases
La commande « cat » est disponible dans « /bin/cat »
La commande n'a pas pu être trouvée car « /bin » n'est pas incluse dans la variable d'environnement PATH.
cat : commande introuvable
$/bin/cat ~/.bash_aliases
/bin/cat: /home/saida/.bash_aliases: Aucun fichier ou dossier de ce type

Pour

/usr/lib/R/bin/R: ligne 8: uname : commande introuvable

j'ai voulu juste installer BiomaRt et c'est l'un des messages d'erreurs affichés.

MErci

Hors ligne

#48 Le 15/04/2019, à 22:34

Alex10336

Re : Installation de packages R sous Ubuntu 18.04

Ton $PATH est encore pété.

refaire le #40

echo 'PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"' | sudo tee /etc/environment

avec

ls -lh /etc/environment
getfacl /etc/environment

refermer le terminal/session puis re

echo "$PATH"

Dernière modification par Alex10336 (Le 15/04/2019, à 22:40)


« On ne répond pas à une question par une autre question. » (moi ;-) )

Hors ligne

#49 Le 15/04/2019, à 22:59

saihaj

Re : Installation de packages R sous Ubuntu 18.04

$echo 'PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"' | sudo tee /etc/environment
[sudo] Mot de passe de saida : 
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
$echo 'PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"' | sudo tee /etc/environment
[sudo] Mot de passe de saida : 
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
$getfacl /etc/environment
getfacl : suppression du premier « / » des noms de chemins absolus
# file: etc/environment
# owner: root
# group: root
user::rw-
group::r--
other::r--
$ echo "$PATH"
/usr/local/sbin:/usr/local/bin:/usr/local/ssl/bin:/usr/sbin:/usr/bin:

Hors ligne

#50 Le 16/04/2019, à 02:37

bishop

Re : Installation de packages R sous Ubuntu 18.04

Salut !
Pour R, la version des paquets du site officiel sont incompatibles avec la version R des dépôts Ubuntu. Le sujet a été traité il y a peu ici.


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne