Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/12/2018, à 14:53

pti-jean

Pb de résolution 640x480...

Bonjour,

J'ai un ordinateur de bureau installé avec lubuntu qui fonctionnait bien... mais actuellement quand il démarre normalement l"affichage graphique se fait en résolution 640x480... et pas possible de changer cette résolution...
Alors que si je démarre en "recovery mode" en interceptant grub au démarrage... puis je choisis l'option "resume"... j'ai la bonne résolution... cad 1024x768.

Une idée ?


Voila ce que dit xrandr en démarrage normal:

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480       73.00* 

Alors qu'en démarrant en "recovery mode":

$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768      61.00* 
   800x600       61.00  
   640x480       60.00
$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)

JM

Hors ligne

#2 Le 13/12/2018, à 15:08

pti-jean

Re : Pb de résolution 640x480...

Je viens de progresser dans mon problème...
Donc... si je démarre avec le dernier kernel... le 4.15.0.42, j'ai le problème... alors que si je démarre avec un ancien kernel... le 4.15.0.36, cela fonctionne normalement!

S'agit-il d'un bug qui va être corrigé ??

JM

Hors ligne

#3 Le 13/12/2018, à 15:22

xubu1957

Re : Pb de résolution 640x480...

Bonjour,

Tu n'as rien de proposé dans le gestionnaire_de_pilotes_proprietaires ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#4 Le 13/12/2018, à 16:02

pti-jean

Re : Pb de résolution 640x480...

Bonjour xubu1957,

Oui, le gestionnaire de pilote propriétaire propose un pilote propriétaire... le Nvidia 340... Pilote propriétaire activé ou pas... même symptôme...
Je dirai même pire... avec le pilote propriétaire je pas l'accélération activée... j'ai pas "direct rendering  Yes"... alors qu'avec le pilote libre oui!

JM

Hors ligne

#5 Le 13/12/2018, à 16:19

xubu1957

Re : Pb de résolution 640x480...


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#6 Le 13/12/2018, à 16:51

pti-jean

Re : Pb de résolution 640x480...

Donc je créai le mode 800x600... mais pour le moment je ne peux pas l'activé...
Je fais cette commende:

$ xrandr --addmode VGA-0 800x600_60.00
xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "VGA-0"

Comment je détermine "VGA-0" ?

JM

Hors ligne

#7 Le 13/12/2018, à 17:05

pti-jean

Re : Pb de résolution 640x480...

ok:

xrandr --listmonitors

Ce qui fait dans ma commande:

$ xrandr --addmode defauld 800x600_60.00

Mais bon... ça fonctionne pas quand-même!

$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 800 x 600
default connected 640x480+0+0 0mm x 0mm
   640x480       73.00* 
   800x600_60.00  59.86
$ xrandr -s 800x600_60.00
Failed to change the screen configuration!

JM

Hors ligne

#8 Le 13/12/2018, à 17:27

xubu1957

Re : Pb de résolution 640x480...

Je ne sais pas gérer !

Regarde les réponses > RESOLU Affichage 640X480 avec écran hpx20 lubuntu 16.04 si tu vois une idée.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 13/12/2018, à 17:55

pti-jean

Re : Pb de résolution 640x480...

xubu1957 a écrit :

Regarde les réponses > RESOLU Affichage 640X480 avec écran hpx20 lubuntu 16.04 si tu vois une idée.

Non... rien de plus que ce que j'ai déjà fait!

JM

Hors ligne

#10 Le 13/12/2018, à 18:03

pingouinux

Re : Pb de résolution 640x480...

Bonjour,

pti-jean #7 a écrit :
$ xrandr --addmode defauld 800x600_60.00

Es-tu sûr que ce n'est pas default ?

Hors ligne

#11 Le 13/12/2018, à 19:07

pti-jean

Re : Pb de résolution 640x480...

Oui c'est default... une erreur c'est glissé dans édition!

JM

Hors ligne

#12 Le 13/12/2018, à 20:07

moko138

Re : Pb de résolution 640x480...

Que retournent

cat /etc/default/grub

et   

cat /boot/grub/grub.cfg | grep -E "menuentry|vmlinuz"

?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#13 Le 13/12/2018, à 20:13

pti-jean

Re : Pb de résolution 640x480...

$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
$ cat /boot/grub/grub.cfg | grep -E "menuentry|vmlinuz"
if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
  menuentry_id_option=""
export menuentry_id_option
menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-65f83a78-ff89-473d-9b07-b2834593a8bd' {
        linux   /boot/vmlinuz-4.15.0-42-generic root=UUID=65f83a78-ff89-473d-9b07-b2834593a8bd ro  splash quiet $vt_handoff
submenu 'Options avancées pour Ubuntu' $menuentry_id_option 'gnulinux-advanced-65f83a78-ff89-473d-9b07-b2834593a8bd' {
        menuentry 'Ubuntu, avec Linux 4.15.0-42-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.15.0-42-generic-advanced-65f83a78-ff89-473d-9b07-b2834593a8bd' {
                linux   /boot/vmlinuz-4.15.0-42-generic root=UUID=65f83a78-ff89-473d-9b07-b2834593a8bd ro  splash quiet $vt_handoff
        menuentry 'Ubuntu, with Linux 4.15.0-42-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.15.0-42-generic-recovery-65f83a78-ff89-473d-9b07-b2834593a8bd' {
                linux   /boot/vmlinuz-4.15.0-42-generic root=UUID=65f83a78-ff89-473d-9b07-b2834593a8bd ro recovery nomodeset 
        menuentry 'Ubuntu, avec Linux 4.15.0-36-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.15.0-36-generic-advanced-65f83a78-ff89-473d-9b07-b2834593a8bd' {
                linux   /boot/vmlinuz-4.15.0-36-generic root=UUID=65f83a78-ff89-473d-9b07-b2834593a8bd ro  splash quiet $vt_handoff
        menuentry 'Ubuntu, with Linux 4.15.0-36-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.15.0-36-generic-recovery-65f83a78-ff89-473d-9b07-b2834593a8bd' {
                linux   /boot/vmlinuz-4.15.0-36-generic root=UUID=65f83a78-ff89-473d-9b07-b2834593a8bd ro recovery nomodeset 
menuentry 'Memory test (memtest86+)' {
menuentry 'Memory test (memtest86+, serial console 115200)' {

JM

Hors ligne

#14 Le 13/12/2018, à 21:25

moko138

Re : Pb de résolution 640x480...

Je croyais trouver des paramètres différents entre les deux noyaux, mais non :

linux   /boot/vmlinuz-4.15.0-42-generic root=UUID=65f83a78-ff89-473d-9b07-b2834593a8bd ro  splash quiet $vt_handoff
linux   /boot/vmlinuz-4.15.0-36-generic root=UUID=65f83a78-ff89-473d-9b07-b2834593a8bd ro  splash quiet $vt_handoff

  - -

si je démarre en "recovery mode" (...) j'ai la bonne résolution... cad 1024x768.

Alors il faut essayer de systématiser l'option nomodeset.

Commence par faire une copie de sécurité du fichier actuel :

sudo cp -av /etc/default/grub  /etc/default/grub.2018-12-12

puis
Dans le fichier /etc/default/grub, remplace

GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"

par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Si c'est bon, tu laisses.
Si ce n'est pas bon, tu rétablis la copie de sécurité - deux façons au choix :
     soit tu peux démarrer en recovery-root
alors tu remontes la racine en lecture-écriture :

mount -o remount,rw /

puis

cp -av /etc/default/grub.2018-12-12  /etc/default/grub

     Soit (peu probable) tu ne peux pas démarrer en recovery-root,
alors tu démarres en live, tu montes, d'un clic, ta racine installée.
puis

mount | tail -1

t'indiquera le point de montage effectif qui ressemblera à
/media/ubuntu/(un nombre à 32 caractères alphanumériques)

Tu feras

sudo cp -av /media/ubuntu/(ce nombre à 32 caractères alphanumériques)/etc/default/grub.2018-12-12  /media/ubuntu/(ce nombre à 32 caractères alphanumériques)/etc/default/grub

Et enfin, tu redémarreras ta session installée.  smile


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#15 Le 13/12/2018, à 21:59

pti-jean

Re : Pb de résolution 640x480...

Hello moko138,

Si on modifie le /etc/default/grub après il faut exécuter un "sudo update-grub" pour propager les modifications...
Quoi qu'il en soit j'ai une meilleure solution pour faire les tests... Au boot quand on est dans le menu grub... on appuie sur la touche "e" pour passer en mode édition... et donc une fois en mode édition... je vais au bon endroit (cad les paramètre du kernel) pour écrire le "nomodeset"... puis F10 pour démarrer... Chose faite... mais bon, cela ne résout pas le problème... je suis 640x480!
Et pourtant en recovery mode c'est ok!

JM

Hors ligne

#16 Le 13/12/2018, à 22:13

pti-jean

Re : Pb de résolution 640x480...

moko138... tu m'as donné des idées...
Au boot dans le menu grub j'ai édité le "recovery mode" (touche "e"), et j'ai supprimé le "recovery" dans les options du kernel... et là, cela démarre direct sur la bonne résolution!
Maintenant, je sais pas ce qui fait la différence ???

JM

Hors ligne

#17 Le 13/12/2018, à 22:23

pti-jean

Re : Pb de résolution 640x480...

Ok... je viens de trouver la ligne dans grub qui fait buger... c'est la ligne "gfxmode $linux_gfx_mode"... si je supprime cette ligne, ça fonctionne normalement!

Maintenant, faut voir si c'est un bug ponctuel... si cela va être réparé... ou si y a un truc à réparer dans ma distribution... ou si, j'automatise la suppression de cette ligne... voir comment ???

JM

Hors ligne

#18 Le 13/12/2018, à 22:41

pti-jean

Re : Pb de résolution 640x480...

Donc si dans mon /etc/default/grub je fixe "GRUB_GFXMODE=1024x768":

$ cat /etc/default/grub 
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Quand je démarre... je suis bien en 1024x768... mais xrandr ne connaît plus que ce mode vidéo:

$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768      76.00*

Cela m'embête un peu... je vouais pouvoir changer la résolution!

JM

Hors ligne

#19 Le 13/12/2018, à 22:51

moko138

Re : Pb de résolution 640x480...

pti-jean a écrit :

Si on modifie le /etc/default/grub après il faut exécuter un "sudo update-grub" pour propager les modifications...

Tu as raison (c'est un oubli de ma part).

Pour le reste, je ne peux pas te guider.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#20 Le 13/12/2018, à 22:57

pti-jean

Re : Pb de résolution 640x480...

Donc là... je cherche à désactiver l'option gfx_mode dans grub... pour que la ligne "gfxmode $linux_gfx_mode" disparaisse dans l'édition de grub!

Quelqu'un a une idée ??

JM

Hors ligne

#21 Le 10/04/2019, à 08:14

ntt_19

Re : Pb de résolution 640x480...

hello @pti-jean, j'ai exactement le même problème que toi. comment tu l'as résolu?

Hors ligne

#22 Le 10/04/2019, à 12:16

pti-jean

Re : Pb de résolution 640x480...

Salut ntt_19,

Je n'ai pas résolu le problème... j'ai juste fixé la résolution à 1024x768!
Le problème reste entier!

JM

Hors ligne

#23 Le 10/04/2019, à 22:04

ntt_19

Re : Pb de résolution 640x480...

@pti-jean: est ce que tu as déjà installé driver pour carte graphique? je me demande si le problème vient de ça car je l'ai pas installé

Hors ligne

#24 Le 11/04/2019, à 15:18

pti-jean

Re : Pb de résolution 640x480...

Tu peux essayer d'installer le driver vidéo... mais chez moi avec le driver privateur ça fonctionne moins bien!

Si-non... je viens de trouver une solution de contournement...
Exécuter cette commande:

sudo sed -i 's/gfxmode $linux_gfx_mode/# gfxmode $linux_gfx_mode/g' /boot/grub/grub.cfg

Après ça fonctionne... mais je suppose qu'il faudra relancer cette commande après chaque mise à jour du kernel!

En fait... c'est juste un patch pour Grub... mais c'est pas une vraie solution!

JM

Hors ligne