Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/03/2019, à 21:03

kersaweol

[résolu] pavé numérique inopérant

Bonjour,

Sur un ordi portable fraichement paré de la 18.04 mate, le pavé numérique est inopérant.

J'ai lu la doc numlockx à la section concernée (18.04 mate) où il est dit :
"Ouvrez l'outil Écran de connexion via le menu, dans l'onglet Options, cochez Activer le verrouillage du pavé numérique".

Le problème c'est que je n'ai pas la main pour cocher et il m'est dit d'installer numlockx alors que sur la doc il est dit qu'à partir de la 18.04 numlockx n'est plus nécessaire...

Au final je ne tiens pas compte de la doc et j'installe numlockx ??

Merci par avance (pas envie de me galérer à faire des bêtises...)

Dernière modification par kersaweol (Le 14/03/2019, à 16:26)

Hors ligne

#2 Le 13/03/2019, à 21:34

ylag

Re : [résolu] pavé numérique inopérant

Salut,

Je crois qu'il faut le paquet numlockx si on utIlise le gestionnaire d'affichage LightDM.

Au pire, il ne te sera pas difficile de désinstaller ce paquet si ça ne fonctionne pas.

A+

Hors ligne

#3 Le 13/03/2019, à 21:40

kersaweol

Re : [résolu] pavé numérique inopérant

OK pourquoi pas installe numlockx (même si la doc précise que ce la n'est plus nécessaire depuis la 18.04...

Mais ensuite je ne comprends pas quel fichier modifier ensuite, la doc est trop confuse...

Hors ligne

#4 Le 13/03/2019, à 22:47

ylag

Re : [résolu] pavé numérique inopérant

Salut,

Le paquet numlockx serait nécessaire si le fichier binaire numlockcx n'est pas présent sur ton système; pour vérifier:

which numlockx

...devrait retourner quelque chose du genre de:

yvan@yvan-maison:~$ which numlockx
/usr/bin/numlockx
yvan@yvan-maison:~$

...si le fichier est présent, sinon la commande ne retourne rien.

Une fois assuré d'avoir le binaire numlockx, réessaie ce que tu as tenté dans ton commentaire #1:
"Ouvrez l'outil Écran de connexion via le menu, dans l'onglet Options, cochez Activer le verrouillage du pavé numérique".
...ça devrait suffire ?

Note que je suppose toujours que ton gestionnaire d'affichage soit LightDM, tu ne l'a pas spécifié...

Tu pourrais aussi passer la commande:

lightdm --show-config

...histoire de voir si tu as un script relatif à numlockx dans la configuration de LightDM.

A+

Dernière modification par ylag (Le 13/03/2019, à 22:54)

Hors ligne

#5 Le 13/03/2019, à 23:03

ylag

Re : [résolu] pavé numérique inopérant

Salut,

kersaweol a écrit :

même si la doc précise que ce la n'est plus nécessaire depuis la 18.04

Je crois que ça s'applique pour une installation "conventionnelle" d'Ubuntu avec bureau Gnome, qui utilise par défaut le gestionnaire d'affichage gdm3.

A+

Hors ligne

#6 Le 14/03/2019, à 12:29

ylag

Re : [résolu] pavé numérique inopérant

Salut,

Pour un supplément d'info, voici ce que j'ai sur une Ubuntu 18.04 avec bureau Gnome et le gestionnaire d'affichage LightDM:

yvan@yvan-maison:~$ apt policy numlockx
numlockx:
  Installé : 1.2-7ubuntu1
  Candidat : 1.2-7ubuntu1
 Table de version :
 *** 1.2-7ubuntu1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
yvan@yvan-maison:~$
yvan@yvan-maison:~$ lightdm --show-config
   [Seat:*]
A  allow-guest=false
C  greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
D  guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
E  user-session=ubuntu
F  greeter-session=unity-greeter
G  xserver-command=X -core
H  greeter-setup-script=/usr/bin/numlockx on
I  autologin-user=

   [LightDM]
B  backup-logs=false

Sources:
A  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
B  /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
C  /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
D  /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
E  /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf
F  /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf
G  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
H  /etc/lightdm/lightdm.conf.d/50-greeter-script.conf
I  /etc/lightdm/lightdm.conf
yvan@yvan-maison:~$
yvan@yvan-maison:~$ gsettings list-recursively | grep -i numlock
org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true
org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'
yvan@yvan-maison:~$

En espérant que ça puisse être utile, même s'il est possible qu'il y ait des différences sous Mate...

A+

Dernière modification par ylag (Le 14/03/2019, à 12:41)

Hors ligne

#7 Le 14/03/2019, à 16:26

kersaweol

Re : [résolu] pavé numérique inopérant

Merci ylag pour ton dévouement.

Ce n'est plus très drôle car .jJe n'ose plus faire grand chose sans avis sur ce forum (déjà eu ce genre de pb de pavé et ce fut un peu la cata (envoyé sur une mauvaise piste)).

Donc numlockx pas installé et gestion lightDM.
J'ai donc installé numlockx puis fait les manip décrites en #1 et ça marche.

La doc... super bof mais ce n'est pas moi qui irait la modifier !

Merci encore !

Dernière modification par kersaweol (Le 14/03/2019, à 16:29)

Hors ligne

#8 Le 14/03/2019, à 16:50

ylag

Re : [résolu] pavé numérique inopérant

Salut,

Content que ça marche pour toi ! smile

Au sujet de la doc concernant le verrouillage du pavé numérique: ça me semble assez bien détaillé, quoique la présentation pourrait en être retravaillée. Il faudrait probablement insister sur la nécessité d'installer le paquet  numlockx pour les situations requiérant  l'utilisation du fichier binaire numlockx; peut-être serait-il bon de suggérer d'en vérifier la présence avant toute chose dans les environnements qui le requièrent ?

Je ne me sens pas non plus de taille à intervenir au niveau de la modification de la doc... hmm

A+

Dernière modification par ylag (Le 14/03/2019, à 16:51)

Hors ligne