Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/11/2018, à 15:55

Na_vi

performances très dégradées avec live USBpersistence Xubuntu18

Bonjour,
J'utilise une clé USB 3.0 avec persistence (qui me donne entière satisfaction) faite avec Linux Live USB creator (sous W$....) pour Xubuntu 15.04 qui est la dernière version de Xubuntu supportée par LiLicreator.
Comme LiLiUSB n'est plus développé depuis 2 ou 3 ans...j'ai décidé de franchir le fossé pour passer à la 18.04 de Xubuntu avec une nouvelle clé USB3.0 (DT50 de KingSton) mais en suivant la procédure décrite ici :
3 Ways To Create A Lightweight And Persistent Xubuntu Linux USB Drive
et en utilisant The Universal USB Installer vers. 1.9.8.4 sous W$ avec l'iso Xubuntu 18.04.01 64bits (PC=Lenovo ThinkPad T410)

L'instal sur la clé s'est bien passée (compter une bonne heure)
Mais au boot démarrage EXTRÊMEMENT LENT au point que la 1ere fois j'ai cru que c'était planté puis avec beaucoup de patience j'ai finalement (10minutes!) obtenu l'écran Xubuntu de la 18.04
et là aussi réactions extrêmement lentes du système pour toutes les commandes Exemple lancement de Firefox = 2minutes !
Alors qu'avec mes autres clés USB3.0 SanDik Xubuntu 15.04 faites avec LiLiUSB creator j'ai des temps de réponses très rapides sur le même PC.
Où est le problème ? peut-on le résoudre ?
Merci à tous (.... en particulier à la toute petite minorité d'utilisateurs de clefs USB live persistentes de Ubuntu......)

PS. je n'ai pas encore eu la patience de tester la persistence....

Dernière modification par Na_vi (Le 05/12/2018, à 15:53)

Hors ligne

#2 Le 28/11/2018, à 17:47

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

Bien, avec beaucoup de patience, persistence testée OK par save d'un fichier dans Documents, retrouvé après redémarrage....

Dernière modification par Na_vi (Le 28/11/2018, à 19:19)

Hors ligne

#3 Le 30/11/2018, à 16:57

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

Bon je me réponds à moi même.... en fait la clef USB "certifiée" 3.0 acheté chez A...n n'est que .... 2.0 !
(Kingston DT50 à ttes fins utiles)

Dernière modification par Na_vi (Le 30/11/2018, à 17:59)

Hors ligne

#4 Le 30/11/2018, à 23:00

moko138

Re : performances très dégradées avec live USBpersistence Xubuntu18

"10 minutes", ce n'est pas une question d'usb3/usb2.

En usb2, j'obtiens habituellement un démarrage en 2 à 3 minutes. Exceptionnellement, j'ai déjà obtenu 10 minutes, dans une configuration très particulière. Mais le démarrage/décompression fini, une live usb2 fonctionne aussi vite qu'une session installée sur un HDD.
Sans certitude, je dirais que pour une raison à déterminer, la décompression initiale se fait en utilisant le module uhci ou ohci, ceux de l'usb1. (Au lieu de ehci pour usb2 ou xhci pour usb3.)


Peux-tu montrer, clef branchée (pas forcément en live)

lsusb ; echo ; lsusb -t

?
Merci !


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#5 Le 03/12/2018, à 16:17

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

Bonjour,
Merci pour l'interet que vous portez à mon post... Finalement en retrouvant l'emballage de la clé USB elle est bien USB 3.0...!!??
Oui pour moi aussi mes 2 autres clefs USB 3 ont elles un fonctionnement "correct" et normal.
Voici le résultat des commandes demandées avec la live USB lancée :

xubuntu@xubuntu:~$ lsusb;echo;lsusb -t
Bus 002 Device 003: ID 0951:1666 Kingston Technology DataTraveler G4
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 17ef:480f Lenovo Integrated Webcam [R5U877]
Bus 001 Device 005: ID 0a5c:217f Broadcom Corp. BCM2045B (BDC-2.1)
Bus 001 Device 004: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 008: ID 04b3:3107 IBM Corp. ThinkPad 800dpi Optical Travel Mouse
Bus 001 Device 006: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 001 Device 003: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 1: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 2: Dev 3, If 0, Class=Hub, Driver=hub/4p, 480M
            |__ Port 1: Dev 6, If 0, Class=Mass Storage, Driver=usb-storage, 480M
            |__ Port 4: Dev 8, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 3: Dev 4, If 0, Class=Vendor Specific Class, Driver=, 12M
        |__ Port 4: Dev 5, If 1, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 5, If 2, Class=Vendor Specific Class, Driver=, 12M
        |__ Port 4: Dev 5, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 5, If 3, Class=Application Specific Interface, Driver=, 12M
        |__ Port 6: Dev 7, If 0, Class=Video, Driver=uvcvideo, 480M
        |__ Port 6: Dev 7, If 1, Class=Video, Driver=uvcvideo, 480M
xubuntu@xubuntu:~$ 

En complément, après avoir fait une clé USB avec la procédure indiquée dans mon 1er post, j'ai refait une live USB avec la même clé en utilisant LiLiUSB creator avec les mêmes lenteurs.
En fait et après réflexion, la seule différence - dans la façon de les faire - que j'ai vue entre les 2 clés qui marchent bien et la clé qui rame, c'est que les 2 premières ont été faites sur une tablette Surface Microsoft / prise USB bleue et celle qui rame sur un ThinkPad T410 / prise USB jaune.
Toujours en complément, j'ai refait la clef usb live sur un autre ThinkPad AVEC connecteur usb bleu:

xubuntu@xubuntu:~$ lsusb;echo;lsusb -t
Bus 002 Device 003: ID 0bdb:1911 Ericsson Business Mobile Networks BV 
Bus 002 Device 004: ID 04b3:3107 IBM Corp. ThinkPad 800dpi Optical Travel Mouse
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0951:1666 Kingston Technology DataTraveler G4
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b221 Chicony Electronics Co., Ltd integrated camera
Bus 001 Device 003: ID 0a5c:217f Broadcom Corp. BCM2045B (BDC-2.1)
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 2: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 4: Dev 3, If 7, Class=CDC Data, Driver=cdc_ncm, 480M
        |__ Port 4: Dev 3, If 5, Class=Communications, Driver=cdc_wdm, 480M
        |__ Port 4: Dev 3, If 3, Class=Communications, Driver=cdc_acm, 480M
        |__ Port 4: Dev 3, If 1, Class=Communications, Driver=cdc_acm, 480M
        |__ Port 4: Dev 3, If 8, Class=Communications, Driver=cdc_wdm, 480M
        |__ Port 4: Dev 3, If 6, Class=Communications, Driver=cdc_ncm, 480M
        |__ Port 4: Dev 3, If 10, Class=CDC Data, Driver=cdc_acm, 480M
        |__ Port 4: Dev 3, If 4, Class=CDC Data, Driver=cdc_acm, 480M
        |__ Port 4: Dev 3, If 2, Class=CDC Data, Driver=cdc_acm, 480M
        |__ Port 4: Dev 3, If 0, Class=Communications, Driver=, 480M
        |__ Port 4: Dev 3, If 9, Class=Communications, Driver=cdc_acm, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 4: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 3, If 2, Class=Vendor Specific Class, Driver=, 12M
        |__ Port 4: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 3, If 3, Class=Application Specific Interface, Driver=, 12M
        |__ Port 6: Dev 4, If 0, Class=Video, Driver=uvcvideo, 480M
        |__ Port 6: Dev 4, If 1, Class=Video, Driver=uvcvideo, 480M
xubuntu@xubuntu:~$ 

Mêmes lenteurs !! Je pense définitivement que c'est la clé usb....

Et cela est la meme commande sur le système où j'ai booté avec la clef qui marche bien (une Sandisk) (et que j'utilise en ce moment):

xubuntu@xubuntu:~$ lsusb;echo;lsusb -t
Bus 004 Device 004: ID 0bdb:1911 Ericsson Business Mobile Networks BV 
Bus 004 Device 003: ID 04b3:3107 IBM Corp. ThinkPad 800dpi Optical Travel Mouse
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0781:5581 SanDisk Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 04f2:b221 Chicony Electronics Co., Ltd integrated camera
Bus 003 Device 003: ID 0a5c:217f Broadcom Corp. BCM2045B (BDC-2.1)
Bus 003 Device 005: ID 058f:6387 Alcor Micro Corp. Flash Drive
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 2: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 4: Dev 4, If 0, Class=Communications, Driver=, 480M
        |__ Port 4: Dev 4, If 1, Class=Communications, Driver=cdc_acm, 480M
        |__ Port 4: Dev 4, If 2, Class=CDC Data, Driver=cdc_acm, 480M
        |__ Port 4: Dev 4, If 3, Class=Communications, Driver=cdc_acm, 480M
        |__ Port 4: Dev 4, If 4, Class=CDC Data, Driver=cdc_acm, 480M
        |__ Port 4: Dev 4, If 5, Class=Communications, Driver=cdc_wdm, 480M
        |__ Port 4: Dev 4, If 6, Class=Communications, Driver=cdc_ncm, 480M
        |__ Port 4: Dev 4, If 7, Class=CDC Data, Driver=cdc_ncm, 480M
        |__ Port 4: Dev 4, If 8, Class=Communications, Driver=cdc_wdm, 480M
        |__ Port 4: Dev 4, If 9, Class=Communications, Driver=cdc_acm, 480M
        |__ Port 4: Dev 4, If 10, Class=CDC Data, Driver=cdc_acm, 480M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 2: Dev 5, If 0, Class=Mass Storage, Driver=usb-storage, 480M
        |__ Port 4: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M
        |__ Port 4: Dev 3, If 2, Class=Vendor Specific Class, Driver=, 12M
        |__ Port 4: Dev 3, If 3, Class=Application Specific Interface, Driver=, 12M
        |__ Port 6: Dev 4, If 0, Class=Video, Driver=uvcvideo, 480M
        |__ Port 6: Dev 4, If 1, Class=Video, Driver=uvcvideo, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 480M
xubuntu@xubuntu:~$ 

Dernière modification par Na_vi (Le 05/12/2018, à 15:50)

Hors ligne

#6 Le 06/12/2018, à 13:01

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

moko138 a écrit :

Sans certitude, je dirais que pour une raison à déterminer, la décompression initiale se fait en utilisant le module uhci ou ohci, ceux de l'usb1. (Au lieu de ehci pour usb2 ou xhci pour usb3.)

Oui bizarre. On voit du xhci pour la SanDick qui marche bien (dernier affichage lsusb) et aussi du xhci (avant dernière sortie du lsusb) pour la Kingston qui rame !

Hors ligne

#7 Le 06/12/2018, à 15:24

moko138

Re : performances très dégradées avec live USBpersistence Xubuntu18

/!\ Si on branche en 110 Volts une ampoule conçue pour le 220 V, elle éclairera beaucoup moins.

1er retour :
pas trace d'usb3/xhci
xubuntu@xubuntu:~$ lsusb;echo;lsusb -t
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 003: ID 0951:1666 Kingston Technology DataTraveler G4

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 1: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
xubuntu@xubuntu:~$
La clef Kingston branchée sur une prise usb2 fonctionne en usb2.
Tu es surtout sur une machine dépourvue de matériel usb3...

  - -

2ème retour :
cette fois-ci, la machine a du matériel usb3 et on est en usb3 (module xhci_hcd)
xubuntu@xubuntu:~$ lsusb;echo;lsusb -t
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 004 Device 002: ID 0951:1666 Kingston Technology DataTraveler G4

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
xubuntu@xubuntu:~$
"5000M" : la clef Kingston fonctionne effectivement en usb3.

  - -

3ème retour :
Même machine que pour le 2ème retour.
Clef Sandisk branchée sur une prise usb2 ; clef Kingston non branchée.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub (*a)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0781:5581 SanDisk Corp.

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M # (*a)
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M (*b)
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 480M


(*a) usb3 mais sur un autre circuit que celui de la clef Sandisk
(*b) module usb3 inutilement appliqué au hub interne en usb2


Conclusion :
Ta Kingston est bien capable d'usb3 ; il te reste à démarrer en live sur la Kingston branchée à une prise usb3.

Dernière modification par moko138 (Le 06/12/2018, à 15:29)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#8 Le 10/12/2018, à 17:44

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

Merci pour cette analyse et ces explications pour lire la sortie de lsusb.
Ceci étant cela ne m'avance pas beaucoup quant à la clé Kingstone.
En effet sur le "retour 2" si la clé Kingstone était comme tu le vois bien branchée en usb3.... ELLE RAMAIT je t'assure !!

En fait j'ai fait plusieurs essais en constatant que sur le PC équipé de l'usb3 mais en y branchant en usb2 la Scandisk, j'ai les mêmes (quasi, je n'ai pas chronométré) performances bonnes qu'elle soit en usb2 ou usb3 (*) ; donc cette clé branchée en 110V ou en 220V éclaire toujours aussi bien....  cool
Cette Scandisk (ces car en fait j'en ai 2 qui marchent parfaitement bien) a été faite (comme je l'expliquais plus haut) avec LiLiusb mais avec Xubuntu 15 (dernière version supportée par LiLiusb)
C'est pour cela que j'ai même réessayé de refaire le même système Xubuntu 15 sur la Kingstone avec LiLiusb.... avec les mêmes lenteurs (je n'ai essayé qu'en usb3, j'ai pas eu la patience de tenter de la brancher en usb2....  smile
Ah et j'oubliais : cette clé Kingstone constituée aussi bien selon la procédure indiquée plus haut ou avec LiLiusb.... ne bootait pas sur l'usb3, seulement sur l'usb2 !!!

Bon, en résumé je tourne en rond ne sachant toujours pas si c'est la clé Kingstone qui m...e ou si c'est la procédure pour la constituer en Xubuntu ! sad

Dernier test: j'ai fait un erase de la clef Kingstone et j'ai lancé (clé branchée en usb3....)  une copie de gros fichiers : le débit de la copie plafonne à 5Mo/s, alors que je crois que la vitesse usb3 tourne autour de 20Mo/s si je ne m'abuse ?

Une dernière précision: je n'ai bien sûr pas eu la patience d’appliquer les "optimisations" préconisées par nam1962 [Tuto] Mon optimisation / personnalisation Xubuntu, Ubuntu (et autres variantes) sur le Xubuntu (15 ou 18) de la clé Kingstone...

(*) en fait j'utilise ces clés Scandisk lors de mes déplacements à l'étranger en particulier sur des vieux PC Windows XP et .... usb2.... sans jamais avoir constaté la lenteur de la clé KingStone

Dernière modification par Na_vi (Le 10/12/2018, à 18:25)

Hors ligne

#9 Le 10/12/2018, à 22:47

moko138

Re : performances très dégradées avec live USBpersistence Xubuntu18

Tu as peut-être mis le doigt sur quelque chose ! Je pense aux modules (incluant ou non le xhci_hcd) chargés par le démarreur.
Je ne sais pas quel est le démarreur d'une clef faite avec liliusb.

  - -
Je n'ai aucun matériel en usb3, mais je peux te dire qu'en usb2, des débits  de 20-22 Moctets/s sont habituels. Et que certains affirment avoir obtenu du 30 Mo/s.
  Alors en usb3 tu devrais atteindre 200 Mo/s sans problème, j'imagine.
  - -

Pour en revenir à Kingston, j'ai depuis longtemps une live sur Kingston Pendrive 2 Gio
ID 0951:1603, gravée sous Windows avec Pendrive Son démarreur est syslinux.
Elle n'a pas de souci de lenteur, bien qu'elle comporte une zone persistante chiffrée.
  Mes autres clefs persistantes sont faites avec usb-creator-gtk (qui, je crois, a été retiré des dépôts récents. Mais si tu as une 14.04 ou même une 12.04...)
  Mes clefs non-persistantes je les fais avec dd.

Maintenant, il est aussi possible que le noyau de ta 15.XX ait un module xhci_hcd bugué !

Dernière modification par moko138 (Le 10/12/2018, à 22:48)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#10 Le 12/12/2018, à 12:58

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

Je n'ai à ma disposition malheureusement pour faire une clé usb avec persistence qu'un PC sous windows, d'ou LiLiusb ou l'Universal Usb Installer (UUI) utilisé aussi par toi.

Mes 2 clés Scandisk utilisées dans mes déplacements à l'étranger (divers PC utilisés, dont de vieux coucous sous XP et avec des usb2) ont été faites avec LiLiUsb sous windows (XUbuntu 15.x) aussi mais sur une tablette Surface Microsoft qui a un port USB3. Et comme ces clés marchent très bien j'hésite à en "sacrifier" une pour faire un essai avec les 2 procédures qui n'ont pas marchés sur la Kingstone.

N'étant pas un cador dans les boots Linux et sans pouvoir ou savoir faire d'autres essais, je ne sais pas si je saurais m'en sortir pour avoir une clé 18.2...

Merci quand même !

Hors ligne

#11 Le 12/12/2018, à 15:18

moko138

Re : performances très dégradées avec live USBpersistence Xubuntu18

Na_vi a écrit :

l'Universal Usb Installer (UUI) utilisé aussi par toi.

Absolument pas.

  - -

j'hésite à en "sacrifier" une

Il n'y a rien à sacrifier, tu sembles ne pas réaliser que depuis une de tes clefs live optimales, tu peux lancer usb-creator-gtk, s'il est installé (ou tout autre graveur d'iso).
Et t'en servir pour refaire en mode persistant ta clef Kingston avec une iso 18.04.1.

Et pour mémoire,
si tu es prêt à renoncer à la persistence, c'est encore plus facile à graver, puisque dd (et même cp) le permettent et sont préinstallés dans n'importe quel GNU/Linux.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#12 Le 12/12/2018, à 15:38

Nasman

Re : performances très dégradées avec live USBpersistence Xubuntu18

A propos de l'outil utilisé pour créer le LiveUSB voici mon expérience :
Sur un vieux PC - lequel avait feisty - le démarrage d'une LiveUSB d'ubuntu 18.04.1 réalisé avec le créateur de disque de démarrage (usb-creator-gtk) ne se faisait pas - blocage au niveau du bios.
J'ai refait la clé bootable avec la usb-creator gtk d'une version 14.10 qui trainait sur une autre clé - la clé est devenue opérationnelle.

Ma conclusion actuelle :
- le créateur de disque de démarrage actuel (qui crée deux partitions, l'une au format DVD et l'autre au format EFI) pose parfois des problèmes alors que l'ancienne version (une seule partition en fat32) est fonctionnelle.

A priori ce problème a dû arriver depuis les iso hybrides (qui posent aussi des pb à gparted)


PC fixe sous Bionic 64 bits et portable avec Xenial 64 bits

Hors ligne

#13 Le 12/12/2018, à 17:55

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

moko138 a écrit :

usb-creator-gtk, s'il est installé

justement c'est là qu'est le hic : sur mes 2 clefs 15.xx je n'avais pas installé ce package.... et depuis la fin du support de la 15.xx.... je n'ai plus accès aux librairies.... et l'autre problème c'est que lorsque je boote avec mes clef (dont la capacité est limitée donc sans les iso dessus) le DD du PC windows est inaccessible depuis windows 10 - donc impossible d'accèder aux iso xubuntu qui sont sur ce dd du pc....

moko138 a écrit :

si tu es prêt à renoncer à la persistence,

justement non et c'est pour avoir une clé persistente utilisable n'importe où avec mes fichiers et ma configuration (firefox en particulier) que je galère....

Nasman a écrit :

- le créateur de disque de démarrage actuel (qui crée deux partitions, l'une au format DVD et l'autre au format EFI) pose parfois des problèmes alors que l'ancienne version (une seule partition en fat32) est fonctionnelle.

A priori ce problème a dû arriver depuis les iso hybrides (qui posent aussi des pb à gparted)

Bon, je ne suis pas sûr d'avoir compris le problème si il n'y a pas de solution. Merci quand même.

Hors ligne

#14 Le 13/12/2018, à 04:27

moko138

Re : performances très dégradées avec live USBpersistence Xubuntu18

Na_vi a écrit :

c'est là qu'est le hic : sur mes 2 clefs 15.xx je n'avais pas installé ce package.... et depuis la fin du support de la 15.xx....

1) Vérifie s'il n'est pas pré-installé :

dpkg -l | grep creator

2) Corrige tes dépôts :
https://doc.ubuntu-fr.org/old-releases# … fin_de_vie dit :

Les paquets sont déportés dans un dépôt d'archives : le serveur old-releases.

Pour continuer à installer des logiciels dans votre système Ubuntu arrivé en fin de vie, vous devrez modifier vos sources de logiciels afin que les listes de paquets disponibles soient récupérées dans le serveur old-releases :

    À l'aide d'un éditeur de texte simple exécuté en mode administrateur(*), ouvrez le fichier /etc/apt/sources.list ;
    Appliquez les changements suivants dans le document :

Remplacez toutes les instances
http://xx.archive.ubuntu.com/ubuntu, où xx est un code de pays (fr, ca, ch, be…), par
http://old-releases.ubuntu.com/ubuntu ;

Remplacez toutes les instances
http://security.ubuntu.com/ubuntu     par
http://old-releases.ubuntu.com/ubuntu ;

Retirez toutes les lignes faisant référence au dépôt partner ;
Retirez toutes les lignes faisant référence au serveur http://extras.ubuntu.com/ubuntu.

Enregistrez vos modifications ;
Rechargez votre banque de paquets disponibles à l'installation.

"Rechargez" : donc tu devras ensuite faire

sudo apt-get update

Après quoi tu pourras faire

sudo apt-get install usb-creator-gtk

.
/!\  Mais tu ne devras en aucun cas faire de dist-upgrade, sous peine de casser ton système live.


(*) Si gksudo n'est pas installé et que tu n'es pas familiarisé avec l'usage de l'éditeur (en ligne de commande) nano, je te conseille vigoureusement de procéder comme je l'explique là : ./viewtopic.php?id=2019480.

= =

Nasman,
Rappelle-toi, il y avait aussi ./viewtopic.php?pid=18363671 :

bug connu. Voici l’explication : En raison de changements dans syslinux, il n'est actuellement pas possible d'utiliser usb-creator de Ubuntu 14.04 et versions antérieures pour écrire des images USB pour Ubuntu 14.10.
(...)
solution simple: à la question

"gfxboot.c32: not a COM32R image
boot:"

répondre : live

Dernière modification par moko138 (Le 13/12/2018, à 04:44)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#15 Le 13/12/2018, à 08:09

Nasman

Re : performances très dégradées avec live USBpersistence Xubuntu18

moko138 a écrit :

bug connu. Voici l’explication : En raison de changements dans syslinux, il n'est actuellement pas possible d'utiliser usb-creator de Ubuntu 14.04 et versions antérieures pour écrire des images USB pour Ubuntu 14.10.
(...)
solution simple: à la question

"gfxboot.c32: not a COM32R image
boot:"

répondre : live

C'est avec ce léger bug (devoir taper live) que j'ai pu installer


PC fixe sous Bionic 64 bits et portable avec Xenial 64 bits

Hors ligne

#16 Le 16/12/2018, à 21:20

Na_vi

Re : performances très dégradées avec live USBpersistence Xubuntu18

Merci pour tous ces conseils.... qui n'auront finalement servi à rien car la clé Kingstone bien qu'elle a été faite dans l'orhodoxie Ubuntu .... rame toujours autant (10minutes de chargement, firefox après 5minutes, arrêt en 5 minutes et j'en passe, bref inutilisable  sad  )
Je détaille :
grâce aux conseils :

moko138 a écrit :

(....)Remplacez toutes les instances
http://xx.archive.ubuntu.com/ubuntu, où xx est un code de pays (fr, ca, ch, be…), par
http://old-releases.ubuntu.com/ubuntu  (....) ;

j'ai pu récupérer un usb-creator-gtk (seulement sur la clef usb 15.xx, car sur celle 14.04LTS.... ça ne marche pas ; bon une suffit)

J'ai donc pu faire un système xubuntu 18.04 avec la clé Kingstone et un iso xubuntu 18.04

J'ai alors testé sur un XP (usb2) puis un Thinkpad (usb2) puis sur un autre Thinkpad usb3 .... qui lui n'a pas booté mais boote par contre en usb2 ! (comme d'ailleurs avec les précédentes clés Kingstone faites avec LiLiusb ou avec la procédure UUI)
.... et tous ces PC bootés avec cette clé ramaient (sauf bien sûr le PC avec celle qui n'a pas booté (???))

Rappel: mes 2 autres clés Scandisk constituées avec LiLiUSB (que ce soit la 14.04 ou la 15.xx) bootent sur TOUS les ports USB (usb2 ou usb3.... et contrairement à la clé Kingstone) de TOUS les PC (Thinkpad W$10 ou XP) - les temps de réponses en usb2 bien qu'étant un peu plus long qu'en usb3 (à l’œil +20% à la louche), sont tout à fait supportables (pas chronométré) mais chargement environ 1 minute à tout casser (usb2 ET usb3)

PS. Même si je pense que la Kingstone (vendue usb3 !) doit avoir un problème (????), il y a autre chose avec la 18.04. Tout ça me fait penser à un commentaire du développeur de LiLiusb écrit avant qu'il n'arrête le développement de LiLiusb disant : qu'il arrêtait car Ubuntu à partir de la version 16.... ne supportait plus la persistance (je pense que cela doit être le fichier style "casper" particulier où s'enregistre tous les changements)
Please be aware that persistence support is currently broken in Debian 7.8 / 8.0 and later. I'm working on a solution but I'm not sure it could be done easily.
Blog LiLiUSB creator

Hors ligne