Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#1 Le 16/03/2018, à 09:32

Christophe C

démarrage de xubuntu 18.04 devenu très lent

Entre grub et le lancement de xub, j'ai normalement 10 secondes (SSD).

Depuis quelques jours, c'est passé à 46 secondes. Il y a manifestement quelque chose qui bloque après le grub.

J'ai essayé de regarder dans /var/log, en particulier kern.log, mais dans ce fichier, le démarrage est indiqué en 3 secondes, donc ce n'est pas là.

Je n'y connais pas grand chose sur les démarrages systèmes, donc si quelqu'un peut m'expliquer où regarder....

Dernière modification par Christophe C (Le 16/03/2018, à 09:35)


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#2 Le 16/03/2018, à 09:40

Christophe C

Re : démarrage de xubuntu 18.04 devenu très lent

J'ai trouvé une commande  : dmesg. Et là je vois mes secondes manquantes :

[    1.788059] tsc: Refined TSC clocksource calibration: 3292.524 MHz
[    1.788071] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x2f75b5c437d, max_idle_ns: 440795270427 ns
[    1.826507] ata8: SATA link down (SStatus 0 SControl 300)
[    2.812213] clocksource: Switched to clocksource tsc
[   34.746503] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   34.865391] ip_tables: (C) 2000-2006 Netfilter Core Team

Si je comprends bien, il y aurait un pb dans le montage de sda1 ? (c'est la partition de mon Xubuntu devenu si lent, mais j'en ai d'autres). Par contre, je ne sais pas très bien interpréter ces messages, encore moins leurs solutions.

Dernière modification par Christophe C (Le 29/04/2018, à 21:37)


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#3 Le 29/04/2018, à 19:42

grigouille

Re : démarrage de xubuntu 18.04 devenu très lent

Même problème :

$ dmesg | grep -C 2 sdb1
[    1.884728] sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.884748] sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.885207]  sdb: sdb1 sdb2
[    1.885560] sd 2:0:0:0: [sdb] Attached SCSI disk
[    1.901950]  sda: sda1
--
[    2.409794] usb 2-1.6: SerialNumber: 000000000QH2222PPR1a
[    3.324160] clocksource: Switched to clocksource tsc
[   34.355546] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[   34.512149] ip_tables: (C) 2000-2006 Netfilter Core Team
[   34.520879] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
--
[   34.664548] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[   34.664681] systemd[1]: Created slice system-systemd\x2dfsck.slice.
[   34.682700] EXT4-fs (sdb1): re-mounted. Opts: errors=remount-ro
[   34.718197] lp: driver loaded but no devices found
[   34.729846] ppdev: user-space parallel port driver

Xubuntu 18.04

Hors ligne

#4 Le 29/04/2018, à 21:39

Christophe C

Re : démarrage de xubuntu 18.04 devenu très lent

J'ai résolu le problème en réinstallant. Mais je n'ai toujours pas compris d’où cela venait.


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#5 Le 30/04/2018, à 12:34

grigouille

Re : démarrage de xubuntu 18.04 devenu très lent

La solution vient de ce fil :
https://askubuntu.com/questions/1013830 … ume-device

Voici mon cas. Avant la correction :

$ systemd-analyze time
Startup finished in 34.462s (kernel) + 10.151s (userspace) = 44.614s
graphical.target reached after 6.755s in userspace
$ cat /etc/initramfs-tools/conf.d/resume
RESUME=UUID=3d167dee-169e-4358-bd15-fa706446dfaa
$ blkid -U 3d167dee-169e-4358-bd15-fa706446dfaa
/dev/mapper/vgab-swap
$ grep swap /etc/fstab 
/dev/mapper/vgab-swap none            swap    sw              0       0

Dans mon cas, le swap et la racine ('/') ne sont pas sur le même disque.

La solution consiste à modifier (ou supprimer ?) le fichier resume

$ cat /etc/initramfs-tools/conf.d/resume
RESUME=none

et à appliquer le changement :

sudo update-initramfs -u

Après redémarrage, j'ai gagné 30 secondes :

$ systemd-analyze time
Startup finished in 2.352s (kernel) + 10.071s (userspace) = 12.424s
graphical.target reached after 6.658s in userspace

Xubuntu 18.04

Hors ligne

#6 Le 30/04/2018, à 12:40

Christophe C

Re : démarrage de xubuntu 18.04 devenu très lent

C'est bon à savoir, merci.


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#7 Le 30/04/2018, à 13:50

grigouille

Re : démarrage de xubuntu 18.04 devenu très lent

Est-ce que tu as aussi un swap "spécial" ?


Xubuntu 18.04

Hors ligne

#8 Le 30/04/2018, à 16:00

Christophe C

Re : démarrage de xubuntu 18.04 devenu très lent

Avait smile
Peut-être. En fait j'avais un disque avec un swap et son home normal, et un disque avec d'autres install (en quadruple boot), sans swap (pas besoin => 8 Mo de RAM). Peut-être que cela déstabilisait le grub. Cela a marché longtemps, ceci dit, avant de bloquer.


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#9 Le 30/04/2018, à 17:49

grigouille

Re : démarrage de xubuntu 18.04 devenu très lent

Le swap sert aussi pour l'hibernation. Pour ma part, je n'hiberne pas smile.


Xubuntu 18.04

Hors ligne

#10 Le 01/05/2018, à 18:11

seebz

Re : démarrage de xubuntu 18.04 devenu très lent

Salut à tous,
j'ai le même problème semble-t-il si ce n'est que le fichier `/etc/initramfs-tools/conf.d/resume` est absent (forcément, je n'ai pas cherché au bon endroit).


$ dmesg | grep -C 2 sda2
[    1.791324] ata3.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    1.793315] ata3.00: ATAPI: MATSHITA DVD-RAM UJ8E1, 1.00, max UDMA/100
[    1.796413]  sda: sda1 sda2
[    1.797534] sd 0:0:0:0: [sda] supports TCG Opal
[    1.797538] sd 0:0:0:0: [sda] Attached SCSI disk
--
[    3.296364] clocksource: Switched to clocksource tsc
[   11.019935] random: crng init done
[   34.421007] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[   34.517118] ip_tables: (C) 2000-2006 Netfilter Core Team
[   34.531399] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
--
[   35.638889] systemd[1]: Listening on Syslog Socket.
[   35.638951] systemd[1]: Listening on Journal Socket.
[   35.663215] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro
[   35.680621] lp: driver loaded but no devices found
[   35.688421] ppdev: user-space parallel port driver
$ cat /etc/initramfs/conf.d/resume
cat: /etc/initramfs/conf.d/resume: Aucun fichier ou dossier de ce type

edit: c'est normal car le chemin de fichier est /etc/initramfs-tools/conf.d/resume et non pas /etc/initramfs/conf.d/resume


Mon fstab, où l'on voit mon `/swapfile` (aucun cryptage):

$ cat /etc/fstab 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=8eb811b3-37e9-4639-9c73-c6a7a157cdf1 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=C16C-364E  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0


# /tmp
tmpfs    /tmp                       tmpfs    defaults,size=1g    0    0
# apt/archives
tmpfs    /var/cache/apt/archives    tmpfs    defaults,size=4g    0    0

Dois-je créer moi-même le fichier `/etc/initramfs-tools/conf.d/resume` ?

----

Edit: j'ai créé le fichier manquant, effectué les opérations indiquées précédemment et le système démarre enfin correctement.
Edit 2: le fichier n'était pas "manquant", je me suis juste trompé de chemin. Quoi qu'il en soit, remplacer son contenu par RESUME=none a effectivement corrigé le problème

Dernière modification par seebz (Le 22/05/2018, à 09:12)

Hors ligne

#11 Le 02/07/2018, à 06:49

grigouille

Re : démarrage de xubuntu 18.04 devenu très lent

Si cette solution, ne fonctionne pas, il faut modifier grub :
https://forum.ubuntu-fr.org/viewtopic.p … #p21915610


Xubuntu 18.04

Hors ligne

#12 Le 02/07/2018, à 07:43

nam1962

Re : démarrage de xubuntu 18.04 devenu très lent

Merci ! Noté smile


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#13 Le 04/07/2018, à 20:51

chinois02

Re : démarrage de xubuntu 18.04 devenu très lent

Bonsoir, j'ai un problème similaire...qui semble lié à la version du noyau.
Depuis ce jour, j'ai:

~$ systemd-analyze time
Startup finished in 2.535s (kernel) + 3min 31.691s (userspace) = 3min 34.226s
graphical.target reached after 3min 31.686s in userspace

3minutes 30 de démarrage avec le dernier noyau.
Avec le noyau précédent sélectionné au moment ou grub donne le choix, c'est 15-20 secondes.
Problème: les modifs suggérées ne donnent rien, même executées avec les droits qui vont bien.
D'un point de vue technique mon /, home et swap sont sur le même disque ssd.

Dernière modification par chinois02 (Le 04/07/2018, à 20:52)


N'importe qui peut voir ce que tu semble être; quelques rares seulement peuvent tâter ce que tu est. Et ces derniers n'osent contredire l'opinion du grand nombre, renforcé par toute la majesté de l'État. Machiavel-Le Prince.

Hors ligne

#14 Le 04/07/2018, à 21:24

ylag

Re : démarrage de xubuntu 18.04 devenu très lent

Salut,

chinois02 a écrit :

... j'ai un problème similaire...qui semble lié à la version du noyau.

Voir cette discussion récente: Démarrage très lent

A+

Dernière modification par ylag (Le 04/07/2018, à 21:25)

Hors ligne

#15 Le 04/07/2018, à 21:57

chinois02

Re : démarrage de xubuntu 18.04 devenu très lent

ylag a écrit :

Salut,

chinois02 a écrit :

... j'ai un problème similaire...qui semble lié à la version du noyau.

Voir cette discussion récente: Démarrage très lent

A+

Merci pour la solution ... smile


N'importe qui peut voir ce que tu semble être; quelques rares seulement peuvent tâter ce que tu est. Et ces derniers n'osent contredire l'opinion du grand nombre, renforcé par toute la majesté de l'État. Machiavel-Le Prince.

Hors ligne

#16 Le 11/07/2018, à 07:53

Zakhar

Re : démarrage de xubuntu 18.04 devenu très lent

Merci !..

J'ai copié l'installation d'un HDD à un SSD, et je pensais que les 30 secondes d'attente au démarrage provenaient du "bug de l'entropie"...

Mais en réalité, c'est que j'avais dans le "resume" l'UUID d'un disque qui n'est plus sur la machine. Aussi lorsque je branchais cet ancien disque en USB, tout redevenait normal... ce qui s'explique par le fait qu'alors il retrouvait son UUID de 'resume' !..

J'ai donc corrigé par "none" vu que je ne vais pas me servir de la fonction "hibernate" sur ce PC.

Merci encore pour l'astuce.


"A computer is like air conditioning: it becomes useless when you open windows." (Linus Torvald)

Hors ligne