Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#2326 Le 10/06/2018, à 12:55

Carlus

Re : Script d'installation pour imprimantes Brother

Mon fichier /etc/udev/rules.d/60-brother-libsane-type1.rules

#
#   udev rules sample for Brother MFP
#         version 1.0.0-1
#
#   Copyright (C) 2012 Brother. Industries, Ltd.
#
#   copy to /etc/udev/rules.d or /lib/udev/rules.d
#

ACTION!="add", GOTO="brother_mfp_end"

SUBSYSTEM=="usb", GOTO="brother_mfp_udev_1"
SUBSYSTEM!="usb_device", GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_1"


SYSFS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
ATTRS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_2"

#  ATTRS{bInterfaceNumber}=="01", GOTO="brother_mfp_udev_3"
#  ATTRS{bInterfaceNumber}=="02", GOTO="brother_mfp_udev_3"
#  ATTRS{bInterfaceNumber}=="03", GOTO="brother_mfp_udev_3"
#  GOTO="brother_mfp_end"
#  LABEL="brother_mfp_udev_3"

ATTRS{bInterfaceClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceSubClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceProtocol}!="0ff", GOTO="brother_mfp_end"

#MODE="0666"
#GROUP="scanner"
ENV{libsane_matched}="yes"
#SYMLINK+="scanner-%k"


LABEL="brother_mfp_end"

et pour les droits....

carl@Papa:~$ sudo adduser $USER scanner
The user `carl' is already a member of `scanner'.
carl@Papa:~$ sudo adduser $USER saned
The user `carl' is already a member of `saned'.

Hors ligne

#2327 Le 11/06/2018, à 23:35

jna

Re : Script d'installation pour imprimantes Brother

mon fichier /etc/udev/rules.d/60-brother-libsane-type1.rules

# This file was automatically created based on description files (*.desc)
#
# udev rules file for supported USB and SCSI devices
#
# For the list of supported USB devices see /usr/lib/udev/hwdb.d/20-sane.hwdb
#
# The SCSI device support is very basic and includes only
# scanners that mark themselves as type "scanner" or
# SCSI-scanners from HP and other vendors that are entitled "processor"
# but are treated accordingly.
#
# If your SCSI scanner isn't listed below, you can add it to a new rules
# file under /etc/udev/rules.d/.
#
# If your scanner is supported by some external backend (brother, epkowa,
# hpaio, etc) please ask the author of the backend to provide proper
# device detection support for your OS
#
# If the scanner is supported by sane-backends, please mail the entry to
# the sane-devel mailing list (sane-devel@lists.alioth.debian.org).
#
ACTION!="add", GOTO="libsane_rules_end"

# The following rule will disable USB autosuspend for the device
ENV{DEVTYPE}=="usb_device", ENV{libsane_matched}=="yes", TEST=="power/control", ATTR{power/control}="on"

SUBSYSTEMS=="scsi", GOTO="libsane_scsi_rules_begin"
GOTO="libsane_rules_end"

LABEL="libsane_scsi_rules_begin"
KERNEL!="sg[0-9]*", GOTO="libsane_rules_end"

# Generic: SCSI device type 6 indicates a scanner
ATTRS{type}=="6", ENV{libsane_matched}="yes"

# Some scanners advertise themselves as SCSI device type 3

# Wildcard: for some Epson SCSI scanners
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="SCANNER*", ENV{libsane_matched}="yes"

# Epson Expression 800 | Epson Expression 800
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="Expression800", ENV{libsane_matched}="yes"

# Epson Perfection 2450 | Epson GT-9700F | Epson Perfection 2450 PHOTO
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="GT-9700", ENV{libsane_matched}="yes"

# Epson Perfection 3200 | Epson GT-9800F | Epson Perfection 3200 PHOTO
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="GT-9800", ENV{libsane_matched}="yes"

# Epson GT-X900 | Epson Perfection V700 Photo | Epson Perfection V750 Photo
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="GT-X900", ENV{libsane_matched}="yes"

# Epson Perfection 636S | Epson Perfection 1200S | Epson Perfection 1200S
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="Perfection1200", ENV{libsane_matched}="yes"

# Epson Perfection 636 | Epson Perfection 636S
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="Perfection636", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 4p
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C1130A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet IIc
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C1750A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet IIp
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C1790A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet IIcx
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C2500A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 4c
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C2520A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 5p
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C5110A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 6200C
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C6270A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 6300C
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C7670A", ENV{libsane_matched}="yes"

## Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

LABEL="libsane_rules_end"

J'ai fait add user aux 2 groupes scanner et saned, le scanner n'est toujours pas reconnu

Hors ligne

#2328 Le 12/06/2018, à 16:12

eric63

Re : Script d'installation pour imprimantes Brother

petite récap
il y a des fichiers qui ont migrés vers d'autres dossiers sur la version 17.10 64bits
et brother n'a pas encore fait la modification de son script
je ne sais pas si le script de démonipuch le prend en compte.

à priori par rapport à la distribution 16.04 il faut sur 17.10:

1 - remplacer la librairie lib-ia32 qui n'existe plus (pour 64 bits, normalement pris en compte dans le script, mais pas interdit d'essayer dans le doute)

sudo apt-get install libusb-0.1-4 libusb-0.1-4:i386
sudo apt-get install libc6-i386

2 -  créer des liens et copier des dossiers (appliquer code ligne par ligne et vérif éventuelle par reboot pour vérifier ce qui est utile de ce qui ne l'est pas)

sudo ln -s /usr/lib64/sane /usr/lib/sane
sudo cp -R /usr/lib64/* /usr/lib
sudo cp -R /usr/lib64/* /usr/lib/x86_64-linux-gnu 

3 - le fichier

/lib/udev/rules.d/40-libsane.rules

n'existe pas et est remplacé par

/lib/udev/rules.d/60-libsane.rules ou
/lib/udev/rules.d/60-libsane1.rules (pourquoi ce 1 ?? le fichier est peut être à renommer ?)

4 - ce fichier est à modifier si vous êtes usb (en réseau ou wifi il y a un fichier créé en  /etc/udev/rules.d/60-brother-libsane-type1.rules)
Ajoute les deux lignes suivantes à la fin de la liste de matériel
(avant la ligne « # The following rule will disable …»)

# Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

en réseau ou wifi il y a un fichier créé en  /etc/udev/rules.d/60-brother-libsane-type1.rules qui contient

#
#   udev rules sample for Brother MFP
#         version 1.0.0-1
#
#   Copyright (C) 2012 Brother. Industries, Ltd.
#
#   copy to /etc/udev/rules.d or /lib/udev/rules.d
#

ACTION!="add", GOTO="brother_mfp_end"

SUBSYSTEM=="usb", GOTO="brother_mfp_udev_1"
SUBSYSTEM!="usb_device", GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_1"


SYSFS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
ATTRS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_2"

#  ATTRS{bInterfaceNumber}=="01", GOTO="brother_mfp_udev_3"
#  ATTRS{bInterfaceNumber}=="02", GOTO="brother_mfp_udev_3"
#  ATTRS{bInterfaceNumber}=="03", GOTO="brother_mfp_udev_3"
#  GOTO="brother_mfp_end"
#  LABEL="brother_mfp_udev_3"

ATTRS{bInterfaceClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceSubClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceProtocol}!="0ff", GOTO="brother_mfp_end"

#MODE="0666"
#GROUP="scanner"
ENV{libsane_matched}="yes"
#SYMLINK+="scanner-%k"


LABEL="brother_mfp_end"

5 - vérifier qu’il existe bien une ligne de type brotherX ) dans le fichier /etc/sane.d/dll.conf
6 -Si ce n’est pas le cas, éditer le fichier avec les droits d’administration et ajouter à la fin « brotherX » (où « X » correspond au même chiffre que dans le nom du paquet « brscanX » que vous avez installé).
Normalement après ça l'imprimante et le scanner doivent être pris en compte au redémarrage
Bon c'est mon cheminement pour avoir quelque chose qui fonctionne chez moi
il y a sans doute des choses inutiles car je ne comprends pas l'intégralité du processus (notamment les liens lib) mais il est pas interdit de rectifier et de s'en inspirer.

il devrait y avoir un dossier /sane  dans /usr/lib/sane ou /usr/lib32/sane
qui contient au moins ces trois fichiers (le x remplace un chiffre)
libsane-brotherx.so
libsane-brotherx.so.1
libsane-brotherx.so.1.0.7

taper la commande « lsusb » dans un terminal, si ton scanner n’apparaît pas dans la liste, il te faudra ajouter l’utilisateur au groupe « lp ». Via la commande:
sudo adduser $USER lp
Puis déconnecte/reconnecte-toi.
si ça ne suffit pas
il peut également s’agir des groupes scanner ou saned (groupe à créer si besoin) via la commande suivante :
sudo adduser $USER scanner
sudo adduser $USER saned

Dernière modification par eric63 (Le 12/06/2018, à 16:19)


kdeïste convaincu avec Kubuntu 18.04 plasma 5.12.5 et KDE framaworks 5.44.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2329 Le 12/06/2018, à 18:37

jibel

Re : Script d'installation pour imprimantes Brother

eric63,
Tant mieux pour toi si tes brother's ont pu être installées sans ennuis . Si le tuto de demonipuch avec lequel il n'y a jamais eu d'ennuis 12.04 14.04 jusqu'a la 16.04 64 bits et non en 32 bits ne se sont pas révélés.. Par contre avoir un S.A.V de Brother en France avec un spécialiste des OSs libres, ce que, perso j'ai eu en Belgique ou la brother MFC 7460DN qui fonctionne très bien avec le scanner et tout et tout....
Par contre ce que tu as fais avec les scripts ont eus une superbe installes soit en 64 bits ou 32 bits... Super...Y-a rien a dire !
Aussi bizarre qu'étrange, j'ai deux printer's une HP 5652 et son pendant HP scanjet 3670 qui date de + de 10 ans et qui fonctionnent parfaitement.... + bien sur  ma brother, citée plus haut, a son achat de + de 300€ € croyant  être au top des fonctions de cette printer !
Qu'est-ce qu'on doit penser??? Je me suis fait couillonné ??
Acheter la der des sociétés de printer au summum de leur qualité aux prix les plus fort des prix d'achat avec les printer 4 X fonctions qui aurait du fonctionner  OK???
Qui est trucmachinchose avec ce bénéfique art du pognon??? Choisir son printer ou deux avec un scanner en plus... C'est tout, il suffit de voir  avec quel vendeur de printer tout devrait fonctionner,  selon la marque  des  printers !
Faut pas oublier que nous sommes dans un forum d'aides en tout genres.... Surtout pour les  nouveaux  membres.... qui sont surpris et ennuyés avec leur achat  lol roll@


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2330 Le 12/06/2018, à 20:33

eric63

Re : Script d'installation pour imprimantes Brother

jibel je comprends pas tout.
j'amène juste mon expérience et ce que j'en ais compris.
J'aimerais savoir pourquoi malgré tout ça ne fonctionne pas pour certains
Je ne suis pas le SAV de brother mais il me semble qu'ils fournissent quand même des paquets utilisables sur leurs sites pour toutes leurs imprimantes ce qui est déjà bien.Sûr qu'il pourrait se fendre plus encore et je suis pas sûr qu'un "spécialiste" brother (ayant des connaissances sur la dernière mouture d'ubuntu et de ses variantes) puisse t'aider quand ça merdouille à l'install .
Le script facilite de loin l'installation des paquets que délivre brother
le script est peut être perfectible avec certaines imprimantes dans certains contextes et les paquets sont sans doute perfectible eux aussi, mais le script positionne une même manière de faire pour tout le monde et ça c'est incomparable.
Après y toujours d'autre alternatives (gueuler auprès de brother pour que ça marche, acheter du HP, etc...)


kdeïste convaincu avec Kubuntu 18.04 plasma 5.12.5 et KDE framaworks 5.44.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2331 Le 13/06/2018, à 07:40

jibel

Re : Script d'installation pour imprimantes Brother

eric63 a écrit :

jibel je comprends pas tout.

[i]"Ah bon ???"[/i]

j'amène juste mon expérience et ce que j'en ais compris.
J'aimerais savoir pourquoi malgré tout ça ne fonctionne pas pour certains

[i]"ceci et normal pour tous et le changements des versions des OSs libres 12.04 puis 14.04 puis 16.04 etc etc a chaque fois  a cause des modifications apportées aux OSs libres"[/i]

Je ne suis pas le SAV de brother mais il me semble qu'ils fournissent quand même des paquets utilisables sur leurs sites pour toutes leurs imprimantes ce qui est déjà bien.Sûr qu'il pourrait se fendre plus encore et je suis pas sûr qu'un "spécialiste" brother (ayant des connaissances sur la dernière mouture d'ubuntu et de ses variantes) puisse t'aider quand ça merdouille à l'install .

[i]"Ce que j'ai dis est l'exemple de ce qu'on peut avoir comme aide du S.A.V . de Brother a Bruxelles.. Le contact soit par mail soir par  un déplacement vers Brother avec un "spécialiste"  des OSs libres est très avantageux pour un type qui c'est  payé une Brother de  4 fonctions, scan, copie, transfert et fichier."[/i]

Le script facilite de loin l'installation des paquets que délivre brother
le script est peut être perfectible avec certaines imprimantes dans certains contextes et les paquets sont sans doute perfectible eux aussi, mais le script positionne une même manière de faire pour tout le monde et ça c'est incomparable.

[i]" Ce qui doit être fait  avec les recommandations de Brother pour installer  leurs printers est tout a fait logique" y-aura-t-il un spécialiste des OSs libres dans le S.A.V. de Brother en France ??? Va savoir ? [/i]

Après y toujours d'autre alternatives (gueuler auprès de brother pour que ça marche, acheter du HP, etc...)

[i]"Mais ça n'est pas la solution de  "gueuler" avec le S.A.V. de Brother faut y aller mollo? non?"[/i]
[i]Et dernier point , il n'est pas nécessaire de se payer une printer de haut de gamme selon nos possibilités de fric, selon la marque des  printers et de leurs  prix a régler... Avec W$ il n'y aura  jamais d'ennuis des installes de n'importe quelle  printer....C'est tout"
[/i]

Dernière modification par jibel (Le 13/06/2018, à 07:44)


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2332 Le 13/06/2018, à 08:00

jibel

Re : Script d'installation pour imprimantes Brother

1528869309.png
1528869375.png

Voila ce que disent les captures d'écran dans  cet OS Xubuntu/voyager  14.04 Lts tout cela avec  xsane avec lequel on voit  quelles sont les  imprimantes  installées... et hop la @ + wink


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2333 Le 13/06/2018, à 15:17

eric63

Re : Script d'installation pour imprimantes Brother

enfin là chez  jna
que ce soit avec simple scan ou xsane , aucun ne voit de périphériques.


kdeïste convaincu avec Kubuntu 18.04 plasma 5.12.5 et KDE framaworks 5.44.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2334 Le 13/06/2018, à 16:39

Carlus

Re : Script d'installation pour imprimantes Brother

Eric, grace à ton dernier message, ça fonctionne !!!
Comme les fichiers étaient déjà ok et les droits aussi, je pense que c'est soit le remplacement des bibliothèques lib-ia32 ou l'ajout des liens symboliques 2 et 3 qui ont résolu le problème.
En tout cas un grand merci pour les messages et le temps passé.
J'espère qu'il en sera de même pour jna.

Hors ligne

#2335 Le 13/06/2018, à 16:46

jibel

Re : Script d'installation pour imprimantes Brother

eric63 a écrit :

enfin là chez  jna
que ce soit avec simple scan ou xsane , aucun ne voit de périphériques.


@eric63,
C'est très curieux  cette réponse? d'abord tu es avec "kubuntu" mais si je clique sur le lien je tombe sur kubuntu.forum en bleu , il suffit de taper le MdeP et ça revient au forum.ubuntu.fr et voir les sujets suivies..... C'est kif-kif a la "maison" forum.ubuntu.fr
J'ai cette chance a Bxls d'être aller chez Brother a leur service technique, j'ai pratiquement tout dans mes 11 OSs installés pour les fonctions de mes printers HP ou Brother..
J'ai des doutes avec le S.A.V. de Brother en France? Est-ce qu'ils acceptent de filer une grosse aide aux utilisateurs des Oss libres??? Va savoir? mais si on installe une Brother ou d'autres printers, il faut en principe, utiliser le tuto de Demonipuch qui existe depuis + de 8 ans...pour Brother...
Ce qui veut dire que l'installe d'une Brother n'a pas été faite correctement.... roll


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2336 Le 13/06/2018, à 17:33

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Toutes et Tous bonjour, smile
Si vous remontez ces pages vous trouverez ce que j'ai réussi à faire fonctionner avec mes déboires... hmm
Avec l'expérience, l'imprimante se rate rarement, sauf bourrage où elle perd la page en cours...
Le scanner ne fonctionne jamais au démarrage de xsane ou autre, il cherche dit qu'il ne trouve pas, en prévisualisation ou numérisation directe.
Quant il a fini son caprice à la 2ème tentative ça fonctionne et ce tout le temps qu'il reste ouvert !
Je m'en contente comme ça.
MFC-J6510DW sous Ubuntu 16.04 LTS
Merci ! wink

Dernière modification par Alain_Le_Bel (Le 13/06/2018, à 17:34)


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2337 Le 14/06/2018, à 01:08

jna

Re : Script d'installation pour imprimantes Brother

re bonjour
J'ai regardé les manip que Éric propose
les 2 1ère biblio je les avais
ensuite la lib6 voici la réponse :

jean-noel@jeannoel-Vostro-1015:~$ sudo apt-get install libc6-i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libc6-i386 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  libc6

E: Le paquet « libc6-i386 » n'a pas de version susceptible d'être installée

donc rien de nouveau.
D'autre part je n'ai pas de répertoire /usr/lib64 mais simplement /usr/lib donc je n'ai fait aucun lien

J'ai ajouté au fichier /etc/udev/rules.d/60-brother-libsane-type1.rules
# Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"
je l'avais déjà fait au lib/udv/rules.d/60-libsane.rules

sachant que ma brother  est en réseau
bref rien de nouveau
si Carlus peut me dire point par point ce qu'il a fait peut-être que ... puisque l'on est tous les deux sous Xubuntu 18-04 en 32  bits

Hors ligne

#2338 Le 14/06/2018, à 08:57

jibel

Re : Script d'installation pour imprimantes Brother

@jna,
Est-ce que tu as été visiter  le site de Brother France ? Oui ou Non?  remplacer tout par  les données fournies par  le site  Brother pour ton matos et la version de linux de l'installe de ta brother qui d'apres ce a que tu dis tout est OK sauf avec le scanner ? exact oui ou non ? Surtout avec la Xub. 18.04 qui est la derniere version . Je sais que c'est compliqué, mais rien n'est facile, malheureusement... A toi de savoir si tu gardera ton matos en 32 bits qui devrait ne plus être commercialisé dans QQs temps... Va savoir quand ?? smile

https://www.brother.fr/
Voia le lien de Brother Fr. il suffit de bien suivre leurs conseils pas a pas pour ton matos en 32 bits de Dell

Dernière modification par jibel (Le 14/06/2018, à 09:18)


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2339 Le 14/06/2018, à 10:07

fabux

Re : Script d'installation pour imprimantes Brother

salut,

@jibel : j'ai du mal à comprendre ton intervention (que je trouve un poil méprisante mais je ne saurais dire envers qui exactement lol) d'autant que tu semble satisfait de ta brother. Tu les remercies de fournir des paquets, puis tu tape dessus de pas faire de SAV en france. Oui c'est perfectible mais c'est moins pire que rien (comme canon ou epson ou c'est un vrai bor... bazar à installer).
Que eric soit sur kuxulubuntu on s'en fiche. Il propose son aide. Libre à la personne en face de l'écouter surtout qu'ici il explique ce qu'il lui demande et que jna semble maitriser un minimum.
Et sinon tu as relu les réponses de jna ? À part "va sur le site de brother" ou "achète un vrai pc en 64bits et une HP" tu as une autre piste de conseil ?
Enfin rien n'est spécialement compliqué si on s'y intéresse un peu et qu'on a les bonnes explications wink

@jna : tente le ln -s c'est pas ce que ça coute. Sinon un paramétrage de l'imprimante ou de la box. Est-ce que tu as la possibilité de tester en usb ?

Hors ligne

#2340 Le 14/06/2018, à 10:43

jibel

Re : Script d'installation pour imprimantes Brother

@fabux,
Comment ose tu écrire ça? jamais je n'ai un poil de mépris envers QQu'un ... Fait donc attention a ce que tu lis... et surtout de le comprendre.  wink lol
Bien au contraire, malgré le tuto de Demonipuch, qui a aidé les membres du forum, son boulot au top, malheureusement, des fois ne fonctionne plus beaucoup a cause des changements des versions des Oss libres ! Surtout pour des nouveaux membres qui débutent dans ce forum...
Depuis QQs années il y a les ennuis des membres avec les installes d'une Brother quelle qu'elle soit ! wink
Si les "conseils" que j'ai tenté de donner, tester le tuto de Démonipuch? Puis si rien ne fonctionne a 100% !
Ensuite, justement pour se rendre chez Brother Fr pour télécharger des installes de paquets spécifiques pour la Brother de Jna en 32 bits... Il n'y a pas de raison de ne pas s'y rendre??
Je ne vois pas en quoi toi tu trouve que je n'y comprends rien ??? Bizarroïde lol  lol
Moi? j'ai l'impression que tu ...comprends a l'envers  roll  lol
Pourtant nous sommes toi et moi arrivés la même année dans ce forum.ubuntu.fr... et oui M'sieur wink

Dernière modification par jibel (Le 14/06/2018, à 11:01)


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2341 Le 14/06/2018, à 11:00

fabux

Re : Script d'installation pour imprimantes Brother

Ok j'ai mal compris. Au temps pour moi wink

Hors ligne

#2342 Le 14/06/2018, à 11:20

jibel

Re : Script d'installation pour imprimantes Brother

Merki Fabux  @ +  wink


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2343 Le 14/06/2018, à 13:45

eric63

Re : Script d'installation pour imprimantes Brother

jibel ce que tu ne semble pas comprendre c'est que le script de demonipuch fait exactement ça
il va sur le site de brother
il télécharge les paquets qui sont nécessaires à l'imprimante que tu lui a indiqué
il verifie qu'entre deux variante 32 ou 64 bits il télécharge la bonne variante
bref il fait le boulot et plus que brother qui ne regarde pas tes manques sur ta machine
Le sript de demonipuch est bien plus évolutif lui, contrairement aux paquets livré de brother, quand ça ne marche pas le script peut être enrichi pour que ça marche pour un maximum de configs.
Ici on essaye de résoudre les x petits % qui ne marche pas.


kdeïste convaincu avec Kubuntu 18.04 plasma 5.12.5 et KDE framaworks 5.44.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2344 Le 14/06/2018, à 16:36

jibel

Re : Script d'installation pour imprimantes Brother

@eric63, 
Je crois que toi tu n'a pas bien compris, je me suis servi du tuto de Démonipuch  il y a  +/- 8 ans avec succès dans les versions 12.04 et plus..
Ce qui veut dire qu'avec SON avantage, puis  de mes conseils reçus en Belgique chez Brother Belge! Puis des installes de  mes deux printer Brother tout a été correct...En Belgique avec un gars qui travaille chez Brother et par chance a été la personne qui m'a conseillé pour les versions nouvelles  des OSs libres qu'il utilisait lui MËME...Est-ce clair ? ?
Qu'il y a des différences entre la Xubuntu 16.04Lts et la version 18.04Lts toujours  Lts !
Par contre avec les utilisateurs qui ne savent pas voir les écarts qui sont avec les OSs "temporaires" libres style  17.04 non LTS , ni avec la version 17.10 non LTS non plus d'une durée de fonctions de  +/- 6/8 mois....
Alors que les versions en LTS sont de +/- 4 voir 5 ans sans PB...
Voila  la course des nouveaux utilisateurs qui se disent d'avoir une installe de n'importe quoi des OSs libres... Qu'ils soient étonnés? que rien ne fonctionne avec une installe des printers dans les forum.ubuntu.fr par exemple ou d'autres forum concernant leur installation ! ! pourquoi cela leur est arrivé ? Hein?
Que l'on sache faire des corrections dans le tuto de Démonipuch? tant mieux surtout pour qu'a chaque fois, ce tuto devrait être modifié par Demonipuch ou QQs spécialiste des corrections des scripts....pour chaque version des OSs pour une installe de  printer Brother ? ? ? Ce qui fait que son tuto est toujours  payant et souvent avec une installes qui fiche un sacré bazar pour qu'une Brother soit la et fonctionne dans son intégralité....a chaque changement des versions roll
Quand on sait que les "printer's" de toutes les marques seront présentent qui sont pour les intérêts fricable avec Microsoft ou Mac ! !  Crois tu qu'ils seraient super sympa avec les utilisateurs des OSs libres ? ? ?  La , y-a de quoi se marrer? non? Ils n'en n'ont rien a fiche... Voila ou nous en sommes...point barre... et hop la
C'est vrai que depuis cet "encouragement" de chez "Windows"  pour que les OSs libres puissent fonctionner.... La aussi il y a du foutage de gueule venant de ces OSs qui représentent  90% dans le monde... C'est-y mieux chez eux ou AVEC les OSs libres? lol

Dernière modification par jibel (Le 14/06/2018, à 16:43)


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2345 Le 14/06/2018, à 17:35

jna

Re : Script d'installation pour imprimantes Brother

Des nouvelles du front !
Comme je vis au Québec il y a un décalage ...
En tout cas merci à chacun, particulièrement à Éric pour vos conseils. j'ai une expérience sur linux depuis 1998, à l'époque, n'importe quel pilote était une galère, en passant par les modem etc ...
Cependant, je ne suis pas un spécialiste, faute de temps, car le projet linux est une superbe plateforme de collaboration.
Ceci étant dit, je me fais un point d'honneur d'essayer de conserver mes machines, qui rendent de bons services dans le milieu associatif et communautaire dans lequel je suis, qui sont souvent de la récupération, d'où une 32bits encore !
@jibel j'ai commencé par aller sur le site brother et de faire tout ce qu'il indiquait point par point, pas de résultat, alors je suis arrivé sur le forum avec ma question.

pour faire suite
J'ai essayé de mettre ma brother en usb, pas plus de résultat, j'avoue que c'est bizzare, le script a très bien fonctionné pour les 64bits.
Je réitère :   si Carlus peut me dire point par point ce qu'il a fait peut-être que ... puisque l'on est tous les deux sous Xubuntu 18-04 en 32  bits

Hors ligne

#2346 Le 14/06/2018, à 18:03

jibel

Re : Script d'installation pour imprimantes Brother

Dommage il se trouve que peut être c'est la 32 bits qui pose PB qui risque de ne plus être utilisable même dans un assos au Québec ? Va savoir ?


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2347 Le 15/06/2018, à 13:50

eric63

Re : Script d'installation pour imprimantes Brother

j'ai pas trop de temps cet après midi
mais jna  vérifie si tous tes paquets 32 bits sont installés dans le dossier de demonipuch il me semble que le script n'a pas chargé le dernier (scansetting 1.0.2-0).
tu dois avoir pour ta machine au minimum LPR version 2.0.2-1     cups version 2.0.2-1       scan32 version 0.2.1.3-1     scan key 32 version 0.2.4-1  et scansetting 1.0.2-0
donc il faut télecharger et installer ceux qui manquent (scansetting pour toi)
il y à d'autres paquets qui concernent
les paquet en 64 bits pour le scan (comme tu est en 32 bits tu n'en as pas besoin)
le fax sur le site de brother( mais je ne crois pas que tu en ais besoin )
un paquet driver 2.2.0-1 (c'est le script d'installation de brother comme demonipuch mais en moins bien; pas utile dans notre cas)
pour les installer inspire toi de ce fil
https://forum.kubuntu-fr.org/viewtopic. … #p21877509


kdeïste convaincu avec Kubuntu 18.04 plasma 5.12.5 et KDE framaworks 5.44.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2348 Le 15/06/2018, à 18:26

jna

Re : Script d'installation pour imprimantes Brother

Bonjour Éric
Les paquets installés avec le script sont bien, je les ai réinstallés manuellement pour être certain
brmfc7840wlpr-2.0.2-1.i386.deb  brother-udev-rule-type1-1.0.0-1.all.deb  cupswrapperMFC7840W-2.0.2-1.i386.deb   brscan-skey-0.2.4-1.i386.deb  brscan3-0.2.13-1.i386.deb
Donc j'ai bien les paquets 32 bits que tu nommes, mais je ne trouve pas le scansetting avec le gest. synaptic ??

Hors ligne

#2349 Le 15/06/2018, à 19:09

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Bonjour, smile
As-tu cherché sur le site en français, je sais qu'à l'époque j'avais du faire des recherches pas toujours fructueuses mais en recherchant directement en téléchargement brscan3-0.2.13.i386.deb,
ça pourrait fonctionné.
Le site en français :

brother en français

Bon courage ! wink


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2350 Le 15/06/2018, à 21:05

eric63

Re : Script d'installation pour imprimantes Brother

si tu regardes sur le  site de brother anglais(le même en français ne fonctionne pas)
tu peux voir que le fichier scansetting  c'est le brother-udev-rule-type1-1.0.0-1.all.deb que tu as mais il n'y a pas la même version que toi (il inscrit les 2 lignes dans le fichier /etc/udev/rules.d/60-libsane.rules)
donc c’est plutôt une modif (mineure ?) pour une autre raison(mandriva ,si on lit les mise à jour ?).
j'ai pas trop d'autres choses malheureusement à te proposer
A priori le script de demonipuch FORCE la version de UDEV à une version la 1.0.0-1 mais pas à la dernière version du site de brother. Pourquoi ?

Nouvelles infos tiré de ce site
pour voir si le scan est connecté

sane-find-scanner 
scanimage -L 
dpkg -l | grep Brother 
sudo apt-get install sane sudo apt-get install libsane-extras 

si a ce stade ça coince toujours
il faut peut être ajouter les sane-backends

sudo add-apt-repository ppa:rolfbensch/sane-git
sudo apt-get update
sudo apt-get upgrade

Dernière modification par eric63 (Le 16/06/2018, à 10:50)


kdeïste convaincu avec Kubuntu 18.04 plasma 5.12.5 et KDE framaworks 5.44.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne