Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/05/2016, à 19:04

Gacko

[Résolu] Imprimante Canon et le fameux libtiff4

Bonjour,
Décidément les imprimantes Canon ce n'est pas ce qu'il y a de plus facile à installer sous Linux. Avec ma MP495 à chaque fois c'est la corrida...
En général j'y arrive toujours à partir (ou en bricolant à partir) de cet excellent tuto d'alba94 https://forum.ubuntu-fr.org/viewtopic.php?id=1479381

alca94 a écrit :

2 - Téléchargez les pilotes sur le site  CANON
      Pour la MG2450 je l'ai déjà fait =
http://pix.toile-libre.org/upload/img/1391852372.png
a - Télécharger le pilote de l'imprimante ci dessous (juste a cliquer dessus et choisir "enregistrer" le fichier" )
http://gdlp01.c-wss.com/gds/0/010000550 … deb.tar.gz
b - Télécharger le pilote du scanner (idem ci-dessus)
http://gdlp01.c-wss.com/gds/7/010000551 … deb.tar.gz

3 - Une fois fait
Dans "Téléchargement" vous extrayez les fichiers de chacun (les marrons) par clic droit = extraire ICI = ce qui va vous donner deux nouveau dossier (les oranges)
http://pix.toile-libre.org/upload/img/1391594878.png
Sur chaque dossier (oranges) vous faites un clic droit "ouvrir" et dans le dossier "Package" vous choisissez =
POUR L'IMPRIMANTE soit le Dossier "Cnijfilter" =
EN PREMIER = le fichier "common" en 32 ou 64 bits suivant votre version
EN SECOND  = le fichier "series"     en 32 ou 64 bits  "         "                "
vous les installer en faisant un clic droit ---> Ouvrir avec la Logithèque SI VOUS N'AVEZ PAS CETTE PROPOSITION = installer gdebi et choisissez cette option
POUR LE SCANNER soit Dossier "Scangearmp"
EN PREMIER = le fichier "common" en 32 ou 64 bits suivant votre version
EN SECOND  = le fichier "series"     en 32 ou 64 bits  "         "                "

Et 'aujourd'hui sur un PC sous Voyager (Xubuntu) 14.04 l'ouverture dans la logithèque du fichier cnijfilter-mp495series_3.40-1_amd64.deb a une fois de plus généré l'erreur: "La dépendance ne peut être satisfaite libtiff4" Problème, libtiff4 est difficile à trouver surtout pour les nullos comme moi qui ne jurent que par les .deb qui s'installent automatiquement (ah sous Windows ces .exe étaient tellement biens !). En général vous arrivez sur des pages imbitables réservées aux initiés !
Donc pour apporter ma petite pierre à l'édifice et aider mes collègues linuxtar.gzotophobes voici un site où vous pourrez télécharger les libtiff4 et les installer en 1 clic big_smile
Ici pour la version 64 bit https://packages.debian.org/wheezy/amd6 … 4/download
Ici pour la version 32 bit https://packages.debian.org/wheezy/i386 … 4/download

Bien le bonjour chez vous lol

Dernière modification par Gacko (Le 26/05/2016, à 07:49)


Ubuntu 17.04 sur portable MSi basique
Pas bac + 15 en informatique, à quand le truc qui n'existera jamais: un OS qui n'imposerait pas de se prendre la tête ?!

Hors ligne

#2 Le 25/05/2016, à 20:03

Compte anonymisé

Re : [Résolu] Imprimante Canon et le fameux libtiff4

@Gacko,
Cela veut dire que  l’imprimante Canon ne fonction pas son installation de libtiff4 ??
Nous avons déjà parler de  libtiff4 dans ce lien

#3 Le 25/05/2016, à 21:24

grandtoubab

Re : [Résolu] Imprimante Canon et le fameux libtiff4


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#4 Le 25/05/2016, à 21:50

Gacko

Re : [Résolu] Imprimante Canon et le fameux libtiff4

Non la Canon MP495 ne fonctionne pas sans libtiff4 car cette librairie(?) est obligatoire lors de l'installation des drivers.

Désolé mais vos liens ou il faut 10 ans de Linux pour y comprendre quelque chose, ne pas tenir compte de la moitié et deviner le reste c'est exactement ce que j'appelle un OS qui oblige à se prendre la tête et parfois cet OS me gonfle autant que celui que j'avais avant et qui commence par W mad


Ubuntu 17.04 sur portable MSi basique
Pas bac + 15 en informatique, à quand le truc qui n'existera jamais: un OS qui n'imposerait pas de se prendre la tête ?!

Hors ligne

#5 Le 26/05/2016, à 04:21

lynn

Re : [Résolu] Imprimante Canon et le fameux libtiff4

Bonjour,

Et si tu essayais d'installer le paquet libtiff5...

sudo apt install libtiff5

«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

Hors ligne

#6 Le 26/05/2016, à 06:29

PPdM

Re : [Résolu] Imprimante Canon et le fameux libtiff4

Non si le driver appelle machin4 ça ne marchera pas avec machin5.

Gacko a écrit :

Non la Canon MP495 ne fonctionne pas sans libtiff4 car cette librairie(?) est obligatoire lors de l'installation des drivers.

Désolé mais vos liens ou il faut 10 ans de Linux pour y comprendre quelque chose, ne pas tenir compte de la moitié et deviner le reste c'est exactement ce que j'appelle un OS qui oblige à se prendre la tête et parfois cet OS me gonfle autant que celui que j'avais avant et qui commence par W mad

Je suis d'accord avec toi.
Beaucoup d'entre nous  oublient facilement de faciliter la vie de utilisateurs, en utilisant gdebi par exemple

sudo apt-get install gdebi

Clique droit sur le fichier téléchargé et installer avec gdebi
Tu devrais ajouter résolu a ton titre

Hors ligne

#7 Le 01/06/2018, à 04:27

Corto Celtic

Re : [Résolu] Imprimante Canon et le fameux libtiff4

Salut a tous,

On peut le trouver ou le paquet libtiff4 pour Bionic Ubuntu 18.04 ?

Merci d 'avance

Hors ligne

#8 Le 01/06/2018, à 05:49

PPdM

Re : [Résolu] Imprimante Canon et le fameux libtiff4

Je doute fort qu'il soit compatible, c'est pour quoi faire exactement ?

Hors ligne

#9 Le 03/06/2018, à 16:51

Corto Celtic

Re : [Résolu] Imprimante Canon et le fameux libtiff4

rendre le scanner de l'imprimante Canon MP5350 utilisable.
Sans  le paquet libtiff4 l'installation de Scangear ne ce faisait pas....

Hors ligne

#11 Le 02/07/2018, à 08:27

New Kleth

Re : [Résolu] Imprimante Canon et le fameux libtiff4

Bonjour je me permets d'intervenir, le paquet "libtiff4" n'est plus disponible au lien fourni dans la précédente réponse, seul aujourd’hui subsiste "libtiff4-dev" dans la section "Trusty". Cependant il est disponible ici  https://packages.debian.org/wheezy/libtiff4 mais dans la section Wheezy. J'ai pu l'installer et après installer le paquet pour mon imprimante canon (MG-5250 Pixman dans mon cas). Archiver ce paquet tant qu'il est encore disponible est il une solution viable ?

Hors ligne

#12 Le 02/07/2018, à 10:07

grandtoubab

Re : [Résolu] Imprimante Canon et le fameux libtiff4

le pense que seul Canon se fout que libtiff4 a ete remplacé par libtiff5

Ils ne  refabriquent pas  leur paquet
puisque libtiff5 existe

locate libtiff.so.5
/usr/lib/i386-linux-gnu/libtiff.so.5
/usr/lib/i386-linux-gnu/libtiff.so.5.3.0
/usr/lib/x86_64-linux-gnu/libtiff.so.5
/usr/lib/x86_64-linux-gnu/libtiff.so.5.3.0

faudrait essayer en créant des liens par exemple chez moi ça donnerait

 cd /usr/lib/i386-linux-gnu
sudo ln -s /usr/lib/i386-linux-gnu/libtiff.so.5 libtiff.so.4

et

cd /usr/lib/x86_64-linux-gnu/libtiff.so.5
sudo ln -s /usr/lib/x86_64-linux-gnu/libtiff.so.5 libtiff.so.4

Dernière modification par grandtoubab (Le 02/07/2018, à 10:10)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne