Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/03/2018, à 19:57

iwanael

affichage réseaux Wifi [Résolu]

Bonjour,
Il arrive (parfois) que l'affichage de mes réseaux Wifi disparaisse. Je veux dire la liste des réseaux quand je clique sur l'applet network dans mon tableau de bord. Ma connexion se fermant quand je rabats le couvercle de mon portable, je suis amené à relancer le Wifi en cliquant sur cet applet puis en y choisissant mon réseau -mais là, les réseaux ont disparu ! Ce n'est pas dramatique car je clique alors sur "se connecter à un réseau invisible et là, miracle, apparaît le réseau qui était disparu, et je peux donc le choisir. La connexion se relance correctement, mais n'apparaît toujours pas sous mon applet nm.
Qu'est-ce qui se passe ? Qui peut me donner une piste de recherche ?

Dernière modification par iwanael (Le 13/03/2018, à 19:30)

Hors ligne

#2 Le 13/03/2018, à 17:38

iwanael

Re : affichage réseaux Wifi [Résolu]

Peu de motivation ! ! !
Je crois avoir trouvé quelque chose ici au point 4.4

Hors ligne

#3 Le 13/03/2018, à 17:57

xubu1957

Re : affichage réseaux Wifi [Résolu]

Bonjour,

Ce site est inaccessible
Impossible de trouver l'adresse IP du serveur de sudo%20service%20network-manager%20restart.
DNS_PROBE_FINISHED_NXDOMAIN

Tu peux revoir ton lien ?

C'est > doc.ubuntu-fr.org/wifi#autorisation_du_canal

Dernière modification par xubu1957 (Le 13/03/2018, à 18:40)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#4 Le 13/03/2018, à 18:36

iwanael

Re : affichage réseaux Wifi [Résolu]

Il s'agit de la doc Wifi de ubuntu : https://doc.ubuntu-fr.org/wifi
Il me semble que c'est quand j'ai précisé le pays FR (alors que c'était 00) que mes connexions sont réapparues.
Hasard ou correction ! !

Hors ligne

#5 Le 13/03/2018, à 18:43

xubu1957

Re : affichage réseaux Wifi [Résolu]

extrait § 4.4 a écrit :

Il peut arriver qu'Ubuntu choisisse la zone US pour le Wi-Fi. Or cette zone ne contient pas plusieurs canaux régulièrement utilisés en France (comme les canaux 12, 13).

Fais voir :

nmcli dev wifi

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#6 Le 13/03/2018, à 18:47

iwanael

Re : affichage réseaux Wifi [Résolu]

jo@jo-X540YA:~$ nmcli dev wifi
*  SSID             MODE   CHAN  DÉBIT    SIGNAL  BARS  SÉCURITÉ    
   FreeWifi         Infra  11    54 Mo/s  55      ▂▄__              
   FreeWifi_secure  Infra  11    54 Mo/s  55      ▂▄__  WPA1 802.1X 
*  Johannie         Infra  11    54 Mo/s  53      ▂▄__  WPA1        
   --               Infra  11    54 Mo/s  52      ▂▄__  WPA2    

là, je reconnais bien mes connexions. C'est Johannie celle qui est activée.

Hors ligne

#7 Le 13/03/2018, à 18:52

grandtoubab

Re : affichage réseaux Wifi [Résolu]

xubu1957 a écrit :
extrait § 4.4 a écrit :

Il peut arriver qu'Ubuntu choisisse la zone US pour le Wi-Fi. Or cette zone ne contient pas plusieurs canaux régulièrement utilisés en France (comme les canaux 12, 13).

Fais voir :

nmcli dev wifi

l'info que tu mentionnes est le CRDA

 cat /etc/default/crda
# Set REGDOMAIN to a ISO/IEC 3166-1 alpha2 country code so that iw(8) may set
# the initial regulatory domain setting for IEEE 802.11 devices which operate
# on this system.
#
# Governments assert the right to regulate usage of radio spectrum within
# their respective territories so make sure you select a ISO/IEC 3166-1 alpha2
# country code suitable for your location or you may infringe on local
# legislature. See `/usr/share/zoneinfo/zone.tab' for a table of timezone
# descriptions containing ISO/IEC 3166-1 alpha2 country codes.

REGDOMAIN=FR

tu peux assi rescanner le réseau

nmcli dev wifi rescan
nmcli dev wifi list

Dernière modification par grandtoubab (Le 13/03/2018, à 18:53)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#8 Le 13/03/2018, à 18:54

iwanael

Re : affichage réseaux Wifi [Résolu]

jo@jo-X540YA:~$ nmcli dev wifi rescan
jo@jo-X540YA:~$ nmcli dev wifi list
*  SSID             MODE   CHAN  DÉBIT    SIGNAL  BARS  SÉCURITÉ    
   FreeWifi         Infra  11    54 Mo/s  57      ▂▄▆_              
   FreeWifi_secure  Infra  11    54 Mo/s  55      ▂▄__  WPA1 802.1X 
   --               Infra  11    54 Mo/s  55      ▂▄__  WPA2        
*  Johannie         Infra  11    54 Mo/s  54      ▂▄__  WPA1        

Hors ligne

#9 Le 13/03/2018, à 19:01

xubu1957

Re : affichage réseaux Wifi [Résolu]

*  SSID             MODE   CHAN  DÉBIT    SIGNAL  BARS  SÉCURITÉ    
*  Johannie         Infra  11    54 Mo/s  53      ▂▄__  WPA1 

C'est identifié avec l'astérisque.

Tu es sur un canal 11 avec un chiffrement WPA1.

Sans commentaire pour le chiffrement, les conseils ayant déjà été donnés, dans tes discussions précédentes.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#10 Le 13/03/2018, à 19:13

iwanael

Re : affichage réseaux Wifi [Résolu]

Avec ma frebox, j'ai le choix entre WPA(TKIP), WPA(TKIP+AES) et WPA(AES/CCMP)
Lequel dois-je choisir ?

Hors ligne

#11 Le 13/03/2018, à 19:26

xubu1957

Re : affichage réseaux Wifi [Résolu]

L'expert donnait ces conseils :

Le 29/04/2011, toutafai a écrit :

bonsoir,

si tu as changé ton chiffrement alors que tu été connecté en wifi ....normal que cela ai coupé. En admettant que le changement de chiffrement a bien été effectué, essaye en modifiant ta connexion sous ubuntu en conséquence.

(...)

Enfin dernière piste : attention les fai disent très souvent n'importe quoi . Il ne faut pas mélanger n'importe quel système de chiffrement (=wpa1 ou wpa2) avec n'importe quel type de clef de chiffrement (=TKIP ou AES ; le mélange TKIP+AES est a éviter). pour conclure a ce sujet, la norme dit : le wpa1 devrait être en TKIP, et le wpa 2 en AES .. ce sont des paramètres a vérifier dans la configuration de ta box

Ps : et la prochaine fois que tu change le chiffrement fait le avec une connexion cable :-)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#12 Le 13/03/2018, à 19:30

iwanael

Re : affichage réseaux Wifi [Résolu]

Mes connexions viennent encore de disparaître (donc ce n'est pas le regdomain=FR qui est en cause) par contre, c'est en faisant un

sudo service network-manager restart

que je les retrouve.
Bon, ça va, je ne sais toujours pas pourquoi elles disparaissent mais je sais les faire revenir, alors fin.
Merci à toi xubu1957 pour le temps que tu as pris pour m'aider.

Dernière modification par iwanael (Le 13/03/2018, à 19:31)

Hors ligne

#13 Le 13/03/2018, à 19:36

xubu1957

Re : affichage réseaux Wifi [Résolu]

Tu as quelle réponse avec :

iw reg get

?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#14 Le 13/03/2018, à 19:43

iwanael

Re : affichage réseaux Wifi [Résolu]

jo@jo-X540YA:~$ iw reg get
country FR: DFS-ETSI
	(2402 - 2482 @ 40), (N/A, 20), (N/A)
	(5170 - 5250 @ 80), (N/A, 20), (N/A)
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS
	(5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

Hors ligne

#15 Le 13/03/2018, à 19:45

xubu1957

Re : affichage réseaux Wifi [Résolu]

Le code FR est bon.

_ _ _

Tu as vu le message #7 ?

extrait du post #7, grandtoubab a écrit :

tu peux aussi rescanner le réseau

nmcli dev wifi rescan
nmcli dev wifi list

Dernière modification par xubu1957 (Le 13/03/2018, à 19:51)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#16 Le 14/03/2018, à 12:09

grandtoubab

Re : affichage réseaux Wifi [Résolu]

il est possible que l'équipement soit en limite minimal d'alimentation

verifier power management  par:

sudo iwconfig

et éventuellement essayer en desactivant l'économie d'énergie (le  nom-de-la-connexion-wifi tel qu'indiqué dans le compte-rendu de la commande précédente)

sudo iwconfig nom-de-la-connexion-wifi power off

Dernière modification par grandtoubab (Le 14/03/2018, à 12:12)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#17 Le 14/03/2018, à 13:35

iwanael

Re : affichage réseaux Wifi [Résolu]

jo@jo-X540YA:~$ sudo iwconfig
[sudo] Mot de passe de jo : 
enp2s0    no wireless extensions.

lo        no wireless extensions.

wlp1s0    IEEE 802.11bgn  ESSID:"Johannie"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 12:E5:92:EE:E3:C4   
          Bit Rate=81 Mb/s   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=43/70  Signal level=-67 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:102   Missed beacon:0

puis

jo@jo-X540YA:~$ sudo iwconfig Johannie power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device Johannie ; No such device.
jo@jo-X540YA:~$ 

Pour être franc, je n'ai pas vraiment compris ce que tu voulais m'expliquer.

Hors ligne

#18 Le 14/03/2018, à 13:54

xubu1957

Re : affichage réseaux Wifi [Résolu]

C'est :

sudo iwconfig wlp1s0 power off

Mais il était déjà désactivé :

 Power Management:off

Dernière modification par xubu1957 (Le 14/03/2018, à 13:55)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#19 Le 14/03/2018, à 13:55

grandtoubab

Re : affichage réseaux Wifi [Résolu]

iwanael a écrit :
jo@jo-X540YA:~$ sudo iwconfig
[sudo] Mot de passe de jo : 
enp2s0    no wireless extensions.

lo        no wireless extensions.

wlp1s0    IEEE 802.11bgn  ESSID:"Johannie"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 12:E5:92:EE:E3:C4   
          Bit Rate=81 Mb/s   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=43/70  Signal level=-67 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:102   Missed beacon:0

puis

jo@jo-X540YA:~$ sudo iwconfig Johannie power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device Johannie ; No such device.
jo@jo-X540YA:~$ 

Pour être franc, je n'ai pas vraiment compris ce que tu voulais m'expliquer.

tu es déjà en   Power Management:off donc ok

et le nom de la connexion wifi c'est wlp1s0, tu confonds avec le nom d'identifiant  de ton point d'accès réseau ESSID:"Johannie"

Dernière modification par grandtoubab (Le 14/03/2018, à 14:00)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#20 Le 14/03/2018, à 14:00

xubu1957

Re : affichage réseaux Wifi [Résolu]

Vu la Doc > wifi_liste_carte#atheros

§ 2.2 Atheros a écrit :

Les cartes WIFI Atheros fonctionnent plus ou moins facilement sous GNU/Linux Ubuntu au gré des versions. Un pilote unique est utilisé pour tous les modèles, le module ath5k ou ath9k. Parfois, ce pilote ne fonctionne que partiellement et des réglages/optimisations sont nécessaires selon les modèles de cartes.

En cas de lenteur, dans l'interface de configuration de votre routeur, vérifiez le canal utilisé : s'il est en mode "automatique", tentez d'attribuer un canal manuel inférieur à 10. ou essayez la commande :

echo "options ath9k nohwcrypt=1" | sudo tee -a /etc/modprobe.d/ath9k.conf

En cas de difficultés persistantes on peut essayer de faire charger le pilote au démarrage avec la commande :

echo ath9k | sudo tee -a /etc/modules

Suite à un précédent retour :

jo@jo-ASUS-X540YA:~$ lshw -class network
ATTENTION: ce programme devrait être lancé en tant que super-utilisateur.
  *-network               
       description: Interface réseau sans fil
       produit: QCA9565 / AR9565 Wireless Network Adapter
       fabriquant: Qualcomm Atheros
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       nom logique: wlp1s0
       version: 01
       numéro de série: f0:03:8c:83:36:79
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=4.4.0-112-generic firmware=N/A ip=192.168.0.6 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       ressources: irq:36 mémoire:fe900000-fe97ffff mémoire:fe980000-fe98ffff

Dernière modification par xubu1957 (Le 14/03/2018, à 14:02)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#21 Le 14/03/2018, à 14:11

FrancisFDZ

Re : affichage réseaux Wifi [Résolu]

Bonjour,
Tu as confondu "essid" et "nom-de-la-connection" : "Johannie" est le nom (essid) du réseau que tu cherches à atteindre, qui apparait quand tu fais un scan. Ce que grandtoubab entendait par "nom-de-la-connection", c'est le nom de la connexion donné par iwconfig, soit dans ton cas "wlp1s0". La commande demandée était

sudo iwconfig wlpls0 power off

D'ailleur elle me semble superflue vu que dans la réponse de iwconfig on a

          Power Management:off

(tu peux la faire, ça ne devrait rien changer)

[Edit] grillé, grandtoubab s'est autocorrigé, et son vocabulaire est d'ailleurs plus précis que le mien wink )  [/Edit]

Dernière modification par FrancisFDZ (Le 14/03/2018, à 14:19)


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#22 Le 14/03/2018, à 15:13

iwanael

Re : affichage réseaux Wifi [Résolu]

Que de monde au chevet du pauv'malade ! Merci à tous.
Donc confusion entre l et 1 mais:

jo@jo-X540YA:~$ sudo iwconfig wlpls0 power off
[sudo] Mot de passe de jo : 
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlpls0 ; No such device.
jo@jo-X540YA:~$ sudo iwconfig wlp1s0 power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlp1s0 ; Operation not supported.

wlpls0 ou wpl1s0, c'est du pareil au même.
Pour voir, j'ai refait

jo@jo-X540YA:~$ sudo lshw -class network
  *-network               
       description: Interface réseau sans fil
       produit: QCA9565 / AR9565 Wireless Network Adapter
       fabriquant: Qualcomm Atheros
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       nom logique: wlp1s0
       version: 01
       numéro de série: f0:03:8c:83:36:79
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=4.4.0-116-generic firmware=N/A ip=192.168.0.6 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       ressources: irq:38 mémoire:fe900000-fe97ffff mémoire:fe980000-fe98ffff
  *-network
       description: Ethernet interface
       produit: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: enp2s0
       version: 07
       numéro de série: 70:4d:7b:9a:a3:15
       taille: 10Mbit/s
       capacité: 100Mbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       ressources: irq:32 portE/S:e000(taille=256) mémoire:fe800000-fe800fff mémoire:d0800000-d0803fff

et c'est quoi ce "power management" ?
Excusez mon incompétence.

Hors ligne

#23 Le 14/03/2018, à 15:37

FrancisFDZ

Re : affichage réseaux Wifi [Résolu]

Mon truc pour avoir la bonne appellation de la connexion wifi : je lance d'abord iwconfig, puis je sélectionne le nom attribué à la connexion : il ne reste plus qu'à le copier et ensuite à le coller au bon endroit dans la commande qui le demande. (après, pour le copier/coller, il y a plusieurs variantes, toutes aussi efficaces, c'est au gout de l'utilisateur).
Ça évite les erreurs dues à ces appellations compliquées qui ont rempacé "wlan0", trop simple (?!)

Dernière modification par FrancisFDZ (Le 14/03/2018, à 15:39)


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#24 Le 14/03/2018, à 17:19

xubu1957

Re : affichage réseaux Wifi [Résolu]

A la recherche d'informations, dans > wireless-power-management-in-ubuntu

traduction a écrit :

Gestion de l'alimentation sans fil sous Ubuntu
15 février 2012         Testé sur: Ubuntu 11.04 (natty)

J'ai eu une connexion réseau extrêmement lente à chaque fois que mon ordinateur portable était sur batterie. Les résultats de Speedtest ont montré une réduction de la vitesse de 50 fois lorsque mon ordinateur portable était sur batterie. J'ai spéculé que la vitesse inférieure a à voir avec la gestion de l'énergie, ce qui réduit la vitesse du réseau afin d'économiser la batterie. Ubuntu, comme les autres systèmes d'exploitation, dispose également d'options de gestion de l'alimentation installées par défaut. Il y a une interface graphique / interface utilisateur pour les préférences de gestion de l'alimentation. Mais je ne pouvais pas trouver quelque chose lié à la connexion sans fil ou Wi-Fi dans l'interface graphique. En regardant sur internet, j'ai trouvé beaucoup de pages. Voici un journal des choses que j'ai trouvées.
Confirmation du comportement: Afin de s'assurer que la gestion de l'alimentation est responsable de la lenteur de l'accès au réseau, exécuter la commande suivante à la fois sur le pouvoir et sur batterie.

iwconfig

La sortie devrait ressembler à ceci: Notez la ligne cinq de la sortie. S'il indique autre chose que la gestion de l'alimentation: éteint alors que la batterie est allumée, il peut s'agir de la gestion de l'alimentation qui ralentit puis du réseau. Vérifiez l' argument de puissance dans la page de manuel iwconfig pour d'autres options possibles.

wlan0     IEEE 802.11bgn  ESSID:"USC Wireless"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:00:00:00:00:00  
          Bit Rate=65 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:27329  Invalid misc:204   Missed beacon:0

Désactivez temporairement la gestion de l'alimentation: lorsque vous êtes sur batterie, exécutez la commande suivante (remplacez wlan0 par votre nom Ethernet).

sudo iwconfig wlan0 power off 

Cela n'affecte que les paramètres sans fil de la gestion de l'alimentation. et devrait changer la sortie de la commande précédente à la gestion de l'alimentation: éteint et la plupart du temps ramener la vitesse du réseau à la vitesse habituelle. Cependant, lors du redémarrage du système, la gestion de l'alimentation sera activée.

Désactivez définitivement la gestion de l' alimentation pour le réseau sans fil: Si vous ne voulez pas continuer à exécuter la commande ci-dessus chaque fois que vous redémarrez votre ordinateur portable, créez un fichier /etc/pm/power.d/wireless avec le contenu suivant :

#!/bin/sh
/sbin/iwconfig wlan0 power off

Rendre le fichier exécutable en passant la commande :

sudo chmod +x /etc/pm/power.d/wireless

Ce nouveau fichier remplacera le script sans fil par défaut exécuté par la gestion de l'alimentation et veillera également à ce que la gestion de l'alimentation sans fil soit désactivée. L'astuce ci-dessus est tirée de la documentation d'Ubuntu (Cochez quelques lignes avant l'exemple). Il dit :

Lorsque vous exécutez pm-powersave, il combine les scripts dans ces deux répertoires et les exécute dans l'ordre de tri. Si les deux répertoires contiennent un script avec le même nom, celui dans /etc/pm/power.d/a une priorité plus élevée et seul celui-ci sera exécuté.
Par conséquent, pour désactiver un script de /usr/lib/pm-utils/power.d/, créez simplement un fichier vide dans /etc/pm/power.d/ avec le même nom et sans le bit d'exécution défini.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#25 Le 14/03/2018, à 20:43

grandtoubab

Re : affichage réseaux Wifi [Résolu]

FrancisFDZ a écrit :

Mon truc pour avoir la bonne appellation de la connexion wifi : je lance d'abord iwconfig, puis je sélectionne le nom attribué à la connexion : il ne reste plus qu'à le copier et ensuite à le coller au bon endroit dans la commande qui le demande. (après, pour le copier/coller, il y a plusieurs variantes, toutes aussi efficaces, c'est au gout de l'utilisateur).
Ça évite les erreurs dues à ces appellations compliquées qui ont rempacé "wlan0", trop simple (?!)

les nouvelles regles de nommage ont ete introduite avec systemd, basée sur l'emplacement matériel
Exemple ma carte wifi

lspci -nnk | grep -i network -A2
03:00.0 Network controller [0280]: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
	Subsystem: Hewlett-Packard Company BCM4313 802.11bgn Wireless Network Adapter [103c:1483]
	Kernel driver in use: bcma-pci-bridge
	Kernel modules: bcma
journalctl -xb | grep brcmsmac
mars 14 18:31:30 debian kernel: brcmsmac bcma0:1: mfg 4bf core 812 rev 24 class 0 irq 17
mars 14 18:31:31 debian kernel: brcmsmac bcma0:1 wlp3s0b1: renamed from wlan0

ma connexion s'appelle donc  wlp3s0b1
wl wlan
port 3
slot 0
board 1
https://www.freedesktop.org/wiki/Softwa … faceNames/

avant il y avait une règle udev du genre /etc/udev/rules.d/70-persistent-net.rules
https://www.debian.org/releases/stable/ … face-names

Dernière modification par grandtoubab (Le 14/03/2018, à 20:53)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne