Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/03/2018, à 15:25

clementp

[Résolut] Apache 2 sur Ubuntu 17

Bonjour

je chercher a crée un environnement de dev php sur mon ordinateur.

j'ai suivi l'installation de LAM (https://doc.ubuntu-fr.org/lamp) ou tout a l'aire de fonctionné correctement mais je n'arrive pas a configuré apache comme je le souhaite.

mais le service apache n'est pas lancé, j'ai fait la commande pour le lancer automatique mais ça n'a rien faite et quand je le lance manuellement cela donne

clement@Eli:~$ sudo systemctl start apache2
La commande « sudo » est introuvable, vouliez-vous dire :
 La commande « sudo » du paquet « sudo-ldap » (universe)
 La commande « sudo » du paquet « sudo » (main)
sudo : commande introuvable

les commandes que j'utilise je les est trouvé ici -> https://doc.ubuntu-fr.org/apache2

Pourtant sur http://localhost/ j'ai bien la "Apache2 Ubuntu Default Page". (edit : en faite non http://localhost/ ne fonctionne plus c’était une page en cache que j'avais).

J'essai de configuré apache2 pour que mon répertoire par defaut soit "sites" dans mon dossier personnel.

voici ce que j'ai fait (suivi).

Pour les commandes suivantes, il faudra remplacer **TON_USER** par ton nom d’utilisateur (la partie avant le @ dans le prompt).

$ sudo sed -i 's/www-data/**TON_USER**/g' /etc/apache2/envvars

Ceci permettra à Apache de se lancer en tant que toi-même, et plus www-data. Les modifications ne sont pas encore prises en compte.

Ensuite, il faut configurer le virtualhost par défaut d’Apache, pour servir le dossier /home/**TON_USER**/sites.

$ mkdir ~/sites

On commence par créer le dossier en question

$ sudo nano /etc/apache2/sites-available/000-default.conf

Il faut remplacer "var/www/html/ par le chemin de ton dossier : ce sera /home/**TON_USER**/sites. Ce n’est pas encore fini pour ce fichier : il faut rajouter un bloc <Directory> à la suite de la ligne DocumentRoot :

<Directory /home/**TON_USER**/sites>
    Options Indexes FollowSymlinks
    AllowOverride All
    Require all granted
</Directory>

Voila j’espère que vous pourrez m'aider.

merci smile

Dernière modification par clementp (Le 13/03/2018, à 15:58)

Hors ligne

#2 Le 13/03/2018, à 15:58

gl38

Re : [Résolut] Apache 2 sur Ubuntu 17

Si sudo n'est pas installé, il y a un problème grave dans ton installation d'ubuntu.
Comment as-tu installé ubuntu ?
Cordialement,
Guy

Hors ligne

#3 Le 13/03/2018, à 16:00

clementp

Re : [Résolut] Apache 2 sur Ubuntu 17

bonjour et merci d'avoir pris le temps gl38.

sudo ne m'indique cette erreur que pour cette commande sinon il fonctionne correctement (de ce que j'ai constaté)

en faite mon problème venais que le nom des session prend une majuscule, mais cette majuscule n'est pas présente dans le nom du repertoir réelement.

ce qui faisai planter ma config.

j'ai modifié ça dans "/etc/apache2/envvars" et ça a l'aire de fonctionné.

d'ailleur depuis je n'ai plus l'erreur sudo avec cette commande depuis cette modif.

Dernière modification par clementp (Le 13/03/2018, à 16:03)

Hors ligne