Contenu | Rechercher | Menus

Annonce

Toute l'équipe d'ubuntu-fr vous souhaite un joyeux Noël et une bonne et heureuse année 2018.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 22/04/2009, à 11:20

Tch3tch

Comment mettre ma carte son USB par defaut?

Bonjour!

J'ai une carte son USB (Alesis IO|2) branchée a mon laptop qui possède une carte intel interne.

Je souhaiterais utiliser ma carte son USB et pas l'autre CEPENDANT, la plupart des applications s'obstinent a utiliser les sorties de ma carte son interne (le son flash du net, LMMS, VLC...)!!!!

Rhythmbox, Totem, et la prévisualisation du son par Compiz marchent sans souci...peut-être d'autres, mais j'ai pas encore listé.

Les préférences dans Système->préférence->Son, sont toutes mises sur "ALSA USB audio IO|2"

J'ai essayé quelques trucs mais :
- Impossible de désactiver ma carte son interne dans le BIOS
- J'ai pas pulse, donc inutile de me conseiller "pavucontrol" cool (j'ai de bonnes raisons, mais c'est pas le sujet!)


Tout aide, aussi petite soit-elle, sera très appréciée! Merci infiniment!

T.

Dernière modification par Tch3tch (Le 22/04/2009, à 13:08)

Hors ligne

#2 Le 22/04/2009, à 13:18

wido

Re : Comment mettre ma carte son USB par defaut?

Bonjour tape:

asoundconf list

dès que tu repères ta carte:

asoundconf set-default-card <nom de ta carte>

autre solution:

cat /proc/asound/modules

cette commande retourne une liste qui ressemble à ceci :

 0 snd_hda_intel
 1 snd_usb_audio

Si vous souhaitez que la carte son reconnu en 1 prenne la place de la carte son reconnu en 0 pour que votre deuxième carte son deviennent la carte son par defaut, éditez votre fichier de configuration
gksudo gedit /etc/modprobe.d/alsa-base

et changez l"ordre des modules son (ils commencent par snd) afin de mettre la carte favorite en premier, il faut changer par exemple :

install sound-slot-0 modprobe snd-card-0
install sound-slot-1 modprobe snd-card-1

en

install sound-slot-1 modprobe snd-card-0
install sound-slot-0 modprobe snd-card-1

Puis à la fin du fichier, commentez toutes les lignes commençant par option, et rajoutez ces 2 lignes (remplacez snd-usb-audio et snd-hda-intel par le nom de vos cartes que cat /proc/asound/modules vous a retourné, en veillant à utiliser des - à la place des _) :

options snd-usb-audio index=0
options snd-hda-intel index=1

Puis redémarrez.

dans les commandes que je te donne , il y en a qu'il faut modifier par les noms de tes cartes son.

http://doc.ubuntu-fr.org/son_problemes

Hors ligne

#3 Le 22/04/2009, à 13:48

Tch3tch

Re : Comment mettre ma carte son USB par defaut?

la première solution marche direct! Sans reboot! Awesome!

Merci!

Hors ligne

#4 Le 22/04/2009, à 17:14

wido

Re : Comment mettre ma carte son USB par defaut?

Ajoute un [résolu] dans le titre de ton 1er post merci.

Hors ligne

#5 Le 18/11/2010, à 00:25

fr03

Re : Comment mettre ma carte son USB par defaut?

Tch3tch n'a pas mis [RESOLU] dans son titre. Ca me permet de remercier wido !

Et peut-être de faire remonter ce topic qui devrait servir à d'autres !   smile


Kubuntu 10.04
ACER TM 5730G -  Core2 duo 2,1 GHz

Hors ligne

#6 Le 18/11/2010, à 12:53

wido

Re : Comment mettre ma carte son USB par defaut?

ça fonctionne aussi pour ta 10.04?

Hors ligne

#7 Le 13/01/2018, à 19:06

xavier67

Re : Comment mettre ma carte son USB par defaut?

Je remonte vieux topic car je dois acheter une carte son usb (ma sortie jack est hs) mais j'ai besoin de renseignements ou d'expériences d'autres utilisateurs.

Je vais devoir écrire un fichier de configuration?

Le retour des commandes citées:

xav@xav-VGN-NS21S-W:~$ asoundconf list
asoundconf : commande introuvable
xav@xav-VGN-NS21S-W:~$ cat /proc/asound/modules
 0 snd_hda_intel

et la commande gksudo gedit /etc/modprobe.d/alsa-base m'ouvre une page planche sur gedit.

Par contre en cherchant avec nautilus j'ai vu qu'il n'y avait pas de fichier /etc/modprobe.d/alsa-base mais un autre  alsa-base.conf avec plein de choses maquées dedans.
Est-ce normal?
Et que vais-je devoir écrire exactement? (il existe déjà un fichier /etc/modprobe.d/alsa-base.conf mais pas de asla-base)
Vais-je avoir des trucs à changer dans le alsa-base.conf?

Hors ligne

#8 Le 16/01/2018, à 12:31

xavier67

Re : Comment mettre ma carte son USB par defaut?

Personne pour répondre à la question ?
C'est que ça m'embêterait d'acheter sans me renseigner avant...
Il faut peut être que je crée un nouveau sujet?

Hors ligne