Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 02/01/2018, à 20:05

wanterzen

Serveur ssh :Permission denied (publickey)

Bonjour,

J'ai installé récemment un serveur ssh et j'essaye d'utiliser le système de clés publique/privée pour m'authentifier.

Malheureusement, après avoir suivis ce tutoriel : https://doc.ubuntu-fr.org/ssh et tenter de résoudre mon problème en suivant les instructions des différentes personnes sur ce sujet ./viewtopic.php?id=134524 je ne parviens toujours pas à me connecter.

La version de mon serveur ssh : OpenSSH_6.7p1 Raspbian-5+deb8u4, OpenSSL 1.0.1t  3 May 2016
Pour récapituler, j'ai généré une clé rsa sur mon ordinateur que j'ai ensuite placé sur le serveur dans le fichier ~/.ssh/authorized_keys à l'aide de la commande
ssh-copy-id -i ~/.ssh/id_rsa.pub -p <num_port> "<username>@<ipaddress>"

Lorsque j'essaye de me connecter avec la commande ssh <username>@<ipaddress> -p <num_port>
Le serveur me retourne ceci : Permission denied (publickey).

J'ai bien fait attention au droit sur le dossier $HOME (j'ai utilisé la commande chmod 0700) ainsi que sur le dossier .ssh
et utilisé la commande chmod 0600 sur le dossier .ssh/authorized_keys.

Je vous transmets aussi la configuration de mon fichier /etc/ssh/sshd_config :


# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 443
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 40
PermitRootLogin no
StrictModes yes
AllowGroups sshusers

RSAAuthentication no
PubkeyAuthentication yes
AuthorizedKeysFile ~/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

MaxStartups 2
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM no

Voilà s'il vous plait aidez-moi cela fait des heures que je suis bloqué sur ce problème. Je ne comprends pas.
Si vous avez besoin d'informations complémentaire dites le moi.

Merci d'avance.


Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 02/01/2018, à 20:34)

Hors ligne

#2 Le 04/01/2018, à 17:34

bruno

Re : Serveur ssh :Permission denied (publickey)

Bonjour,

Tu as fait des modifications curieuses dans ton fichier de configuration, dont certaines sont probablement bloquantes;

Port 443

Mauvaise idée, le port 443 est utilisé pour le HTTPS, reviens au port standard 22 ou choisis un port supérieur à 1024 (2222 par exemple)

AllowGroups sshusers

Si ton utilisateur n'est pas membre du groupe sshusers il ne pourra pas se connecter.

UsePAM no

Impossible de se connecter puisque aucune autre méthode d’authentification n'est renseignée. Remets à 'yes'

Dernière modification par bruno (Le 04/01/2018, à 17:35)

Hors ligne