Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/02/2017, à 12:55

L_d_v_c@

[RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

Bonjour,
je suis en train d'organiser mes sauvegardes, et éliminations des n-uplons vers le NAS, jusqu'à tomber sur une documentation d'électronique que fslint ne peut supprimer (je n'aime pas lancer fslint en root).

Ce fichier est apparu en 600 (rw-------). Normal… Mais ma session Ubuntu n'est pas au même nom que les droits sur le NAS, je suis donc, par soucis de rapidité, obligé de passer les droits en 660.

Et je me rends compte, que j'ai fait n'importe quoi, pour une fois, avec des droits aléatoires vers ce NAS :

En lançant la commande à la racine des sauvegardes m'intéressant pour ce NAS :

# chmod 660 -cR datas_Ludovic/

Je me suis aperçu de grand n'importe quoi que j'ai fait par le passé : du 600 avec du 755, parfois du 750 et même du 775 !

(Rassurez-vous, pas de 777 !)

En attendant de regarder du coté de fstab si je peux monter le NAS vers l'utilisateur du NAS, avec le nom de la session Ubuntu, une autre solution serait de créer un utilisateur sur le NAS avec le même nom que la session Ubuntu, que penser vous des droits 660 (rw-rw----) pour la sauvegarde des documents (textes - PDF - photographies - projets audio - …), s'il-vous-plaît ?

Merci,
L_d_v_c@

ÉDIT : oups ! 660 NE FONCTIONNE PAS, je vais être obligé de créer un utilisateur du même nom sur le NAS, car je n'ai pas envie de mettre les droits 666…

ls -al affiche les fichiers d'index i-nodes à la place des répertoires.

Je vais investir un peu de temps pour mieux comprendre le montage de ces NAS Synology, j'avais juste changé de nom d'utilisateur sous Ubuntu.

#NAS
192.168.1.200:/volume1/Datas/Données	/media/NAS/	nfs	user,noauto,noatime,rsize=32768,wsize=32768	0	0

ou alors : https://doc.ubuntu-fr.org/synology

//Syno/partage	/media/nas/partage	cifs	user,noauto,username=utilisateur,password=motdepasse	0 0

Mais je préfère NFS :
[TUTO]Serveur Synology avec partage NFS et montage FSTAB

Je vais y arriver ! smile
https://doc.ubuntu-fr.org/nfs#client_nfs

J'ai réussi, mais je n'aime pas la bricole.
J'ai appliqué les droits 700 sur tous mes fichiers et dossiers, ce qui me permet de voir mes icônes de répertoires du NAS à la place des fichiers index i-nodes :

sudo chmod 700 -cR *

Je n'aime pas du tout ça, mais en attendant de pouvoir remettre mes fichiers en 600, je vais faire très attention.
Ou alors, il faudrait que je mette mes fichiers en 600 et mes répertoires en 700 ? Mais pourquoi ?

Merci.
L_d_v_c@
---------------------------------------------------------------------------
édit : La solution ici.

Dernière modification par L_d_v_c@ (Le 25/02/2017, à 18:25)


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#2 Le 15/02/2017, à 15:16

moko138

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

600 vs 700 (si c'est ta question) :
droits dit :

Pour accéder au contenu d'un répertoire (pour ouvrir un fichier ou se déplacer dans un sous-répertoire), un utilisateur doit disposer de la permission d'exécution (x) sur ce répertoire.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#3 Le 15/02/2017, à 17:12

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

moko138 a écrit :

600 vs 700 (si c'est ta question) :
droits dit :

Pour accéder au contenu d'un répertoire (pour ouvrir un fichier ou se déplacer dans un sous-répertoire), un utilisateur doit disposer de la permission d'exécution (x) sur ce répertoire.

Merci moko138,

Ah, je suis mal habitué avec les Amiga (Unix'like). GNU/Linux n'est pas Amiga Unix'like.

«Apparemment» les répertoires Unix nécessiteraient également d'être 'x' en plus d'être 'r' pour pouvoir être ouverts.

Alors que j'ai appris qu'un répertoire non-R était illisible, un répertoire R était listable, sans avoir besoin d'être exécutable sur Amiga.

Je trouve redondant sous GNU/Linux avec les normes POSIX, qu'un répertoire doive être "rx" pour être lu.

Je vais lire le man de chmod, pour trouver l'option qui transforme mes répertoire en "rx", puisqu'il ne semble pas y avoir la possibilité de faire autrement sous GNU/Linux pour ouvrir un répertoire, tout en ne rendant pas les fichiers exécutables.

Donc, j'espère abandonner chmod 700 -R * …


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#4 Le 15/02/2017, à 17:24

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

Mais ce problème de répertoire ou de corbeille qui a besoin d'être rwx, au lieu de rw, explique bien des problèmes que j'ai eu, en ayant gardé la logique des droits d'accès de l'Amiga.

Quel serait l'intérêt d'avoir un répertoire lisible "r", mais non exécutable, et un autre répertoire exécutable "x", mais non lisible ?
Alors que pour fonctionner : soit il est au minimum "rx", sinon il est inaccessible en lecture.

Dernière modification par L_d_v_c@ (Le 15/02/2017, à 17:31)


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#5 Le 15/02/2017, à 17:42

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

Non, je ne trouve pas cela pas cohérent. L'occasion de contacter mon ami informaticien GNU/Linux au GRETA.

ubuntu@ubuntu-64:~/test2$ ls 
ubuntu@ubuntu-64:~/test2$ mkdir essai
ubuntu@ubuntu-64:~/test2$ ls -al essai/
total 8
drwxrwxr-x 2 ubuntu ubuntu 4096 févr. 15 16:35 .
drwxrwxr-x 3 ubuntu ubuntu 4096 févr. 15 16:35 ..
ubuntu@ubuntu-64:~/test2$ cd essai/
ubuntu@ubuntu-64:~/test2/essai$ touch toto titi tata
ubuntu@ubuntu-64:~/test2/essai$ ls -al
total 8
drwxrwxr-x 2 ubuntu ubuntu 4096 févr. 15 16:35 .
drwxrwxr-x 3 ubuntu ubuntu 4096 févr. 15 16:35 ..
-rw-rw-r-- 1 ubuntu ubuntu    0 févr. 15 16:35 tata
-rw-rw-r-- 1 ubuntu ubuntu    0 févr. 15 16:35 titi
-rw-rw-r-- 1 ubuntu ubuntu    0 févr. 15 16:35 toto
ubuntu@ubuntu-64:~/test2/essai$ cd ..
ubuntu@ubuntu-64:~/test2$ chmod 400 essai/
ubuntu@ubuntu-64:~/test2$ ls -al
total 12
drwxrwxr-x  3 ubuntu ubuntu 4096 févr. 15 16:35 .
drwxr-xr-x 48 ubuntu ubuntu 4096 févr. 14 18:55 ..
dr--------  2 ubuntu ubuntu 4096 févr. 15 16:35 essai
ubuntu@ubuntu-64:~/test2$ cd essai/
bash: cd: essai/: Permission non accordée
ubuntu@ubuntu-64:~/test2$ ls essai/
ls: impossible d'accéder à 'essai/titi': Permission non accordée
ls: impossible d'accéder à 'essai/tata': Permission non accordée
ls: impossible d'accéder à 'essai/toto': Permission non accordée
tata  titi  toto
ubuntu@ubuntu-64:~/test2$ ls essai/toto
ls: impossible d'accéder à 'essai/toto': Permission non accordée
ubuntu@ubuntu-64:~/test2$ chmod 100 essai/
ubuntu@ubuntu-64:~/test2$ ls -al
total 12
drwxrwxr-x  3 ubuntu ubuntu 4096 févr. 15 16:35 .
drwxr-xr-x 48 ubuntu ubuntu 4096 févr. 14 18:55 ..
d--x------  2 ubuntu ubuntu 4096 févr. 15 16:35 essai
ubuntu@ubuntu-64:~/test2$ cd essai/
ubuntu@ubuntu-64:~/test2/essai$ ls
ls: impossible d'ouvrir le répertoire '.': Permission non accordée
ubuntu@ubuntu-64:~/test2/essai$ ls -al toto
-rw-rw-r-- 1 ubuntu ubuntu 0 févr. 15 16:35 toto

Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#6 Le 15/02/2017, à 20:08

kholo

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

salut,
un peu de lecture :
https://doc.ubuntu-fr.org/acl
mais c'est imbuvable...
alors j'ai fait ça :
https://forum.ubuntu-fr.org/viewtopic.php?id=1990458
pour résumer :
on peut donner des droits par défaut qui seront attribués automatiquement quand on crée un dossier ou un fichier.
là on va travailler avec les groupes.
mais il ne faut pas utiliser un groupe au nom d'un utilisateur car cela donne accès aux dossiers personnels.
donc on crée un groupe de partage (comme parents dans mon exemple).

Pour les droits, ya pas de soucis à prendre 770 !
comme ça des utilisateurs peuvent facilement partager l'écriture sur un dossier ou un fichier
en ayant un groupe en commun.

et comme dit Moko138 l'exécution pour les dossiers pour pouvoir y entrer.

Hors ligne

#7 Le 15/02/2017, à 23:01

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

Merci kholo,
je suis habitué à ce que les droits des dossiers créés soient hérité du dossier parents, ce qui est une forme de logique, que je comprenais facilement. Mais tout comme GNU/Linux n'est pas windows, GNU/Linux n'est pas Amiga Workbench, et je dois réapprendre, normal, je ne cherche pas à ce que GNU/Linux soit le clone de l'AmigaShell - AmigaOS Manual: AmigaDOS Command Reference.
(dingue le nombre de fois que j'ai écrit unmount /media/… à la place de umount /media/… sur Ubuntu smile )

Les droits acl me rappellent Fedora, je crois, à une époque où je l'ai testé.

Et comme expliqué précédemment, ce droit 'x' pour entrer dans le répertoire me perturbe par rapport à mes habitudes Amiga Unix'like (calquées sur Unix).

Un dossier ne s'exécutait pas. L'exécution était réservée aux programmes exécutables.

Les commandes basiques d'Amigashell sont très proches de celles de GNU/Linux, ce qui m'a parfois induit en erreurs.

Sur Amiga :
mount périphérique
puis le périphérique apparaît comme périphérique:

Sur GNU/Linux
mount chemin_du_périphérique (à condition qu'il soit défini dans /etc/fstab)
puis le périphérique apparaît comme /un_truc ou /media/un_truc ou …

Pour éjecter le périphérique de l'Amiga :
assign dismount périphérique:  #vide les buffers mémoire d'écriture avant d'éjecter le périphérique.

Sur GNU/Linux :
umount chemin_du_périphérique

C'est assez proche.

J'adorais les assign add (L'option [ADD] permet de rajouter un ou plusieurs {chemin} à une affectation déjà existante, sans effacer les précédentes.)

Ça  permettait de faire des chemins de recherches multiples par exemple (et je ne sais pas faire ça sur GNU/Linux) :
assign images: hd0:images #le chemin images: pointait sur le répertoire images de la partition nommée hd0:
assign images: df0: df2: df3: add

Le chemin images: fusionnait virtuellement les chemins de lectures hd0:images et trois lecteurs de disquettes sur quatre par exemple, tout en gardant l'écriture prioritaire vers hd0:images.

Pratiques pour faire des chemins de recherches croisées. Je m'égare.

L'exécution pour les dossiers GNU/Linux pour entrer dedans… (ouais…) il faut que je m'y fasse, mais mon chmod 700 -R appliqué à un chemin GNU/Linux ajoute le bit exécutable 'x' à mes fichiers shell/scripts contenus dans les répertoires… et ça, ce n'est pas bien !

Dernière modification par L_d_v_c@ (Le 15/02/2017, à 23:10)


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#8 Le 15/02/2017, à 23:09

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

PS: pour mon exemple de la commande unmount, c'était un alias de la commande assign dismount, sur AmigaDOS.


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#9 Le 16/02/2017, à 10:15

kholo

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

... comme pour un site web,
on donne les droits 770 750 aux dossiers et 640 ou 660 aux fichiers (droits par défaut) wink

Dernière modification par kholo (Le 16/02/2017, à 10:16)

Hors ligne

#10 Le 16/02/2017, à 10:23

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

kholo a écrit :

... comme pour un site web,
on donne les droits 770 750 aux dossiers et 640 ou 660 aux fichiers (droits par défaut) wink

Ok…
Et quelle est la ligne de commande unique à appliquer à une arborescence, pour faire ça ?

C'est là où ça coince chez moi. J'ai lu le man de chmod plusieurs fois, j'ai cherché sur internet, rien.

Mais il me semble qu'autrefois, même sous GNU/Linux, les dossiers 640 ou 660 suffisaient, les fichiers créés dedans était automatiquement non exécutables, mais le fait de créer un dossier 750 ou 770 rendait la création de fichiers internes, possiblement exécutables automatiquement.

Je me trompe sûrement, ce n'est pas quelque chose que je maîtrise. Mais l'esprit de "parent" est respecté. Les enfants héritent des droits des parents.


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#11 Le 16/02/2017, à 11:07

kholo

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

pour les droits par défaut tu as umask lors du montage voire avec setfacl
ou
une solution en chmod ici

Hors ligne

#12 Le 16/02/2017, à 11:29

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

kholo a écrit :

pour les droits par défaut tu as umask lors du montage voire avec setfacl
ou
une solution en chmod ici

Merci kholo !
J'ai un peu honte, c'était écrit dans le man que je lisais en anglais en mode non-attentif sur mon ordinateur de dépannage avec clé USB Ubuntu, enfin je ne comprends toujours pas l'explication du man en français (esprit occupé par une liste de choses à faire wink ), et je vais suivre la méthode de ton lien.

man chmod a écrit :
…
       Les lettres rwxXst sélectionnent les bits de comportement de fichier des utilisateurs
       concernés : lecture (r), écriture (w), exécution (ou recherche pour les  répertoires)
       (x),  exécution/recherche  uniquement  si le fichier est un répertoire ou s'il a déjà
       une autorisation d'exécution pour une des catégories d'utilisateur (X), spécification
       de  l'identifiant du propriétaire ou du groupe propriétaire du fichier lors de l'exé‐
       cution (s), du drapeau de suppression restreinte ou du bit sticky (t). À la place  de
       ces  lettres,  vous  pouvez indiquer une et une seule des lettres de l'ensemble ugo :
       les permissions dont dispose le propriétaire du fichier  (u),  les  permissions  dont
       disposent les autres membres du groupe propriétaire du fichier (g) et des permissions
       dont disposent tous les autres utilisateurs (o).

…

La superbe solution de ton lien :

https://forum.ubuntu-fr.org/viewtopic.php?pid=2546470#p2546470 a écrit :

Si tu utilise la récursion de la commande chmod, tu peux mettre un X (x majuscule) pour ne toucher que les dossiers :

$ chmod -r u-x+Xrw,u-xw+Xr,o-Xxrw .

(et ne pas virer le point '.' répertoire courant (erreur de débutant…))

Merci ! Sujet résolu grâce à kholo !
Je vais faire ça par chmod et insérer umask dans le fichier /etc/fstab pour le NAS.

big_smile


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#13 Le 16/02/2017, à 11:35

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

big_smile
Ça fonctionne mieux avec -R !

Dernière modification par L_d_v_c@ (Le 16/02/2017, à 11:56)


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#14 Le 16/02/2017, à 11:57

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

Ça y est !!! Parfait !!!

sudo chmod -vR u=rw-x+X,g=r-x+X,o=- NAS/

640 pour les fichiers et 750 pour les dossiers.


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#15 Le 26/12/2017, à 08:37

L_d_v_c@

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

Qu'est-ce que c'est compliqué pour rien ce Linux !!!
Autrefois (Ubuntu 5.10) ça fonctionnait en chmod -vR 640 en plus, et ça fonctionnait très bien tout en restant ultra-logique.
---

Dernière modification par L_d_v_c@ (Le 26/12/2017, à 08:41)


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.

Hors ligne

#16 Le 26/12/2017, à 19:26

kholo

Re : [RÉSOLU] Droits pour sauvegardes vers NAS - 600 ou 660 mais ni 750…

salut,

en ligne de commande depuis l'endroit où on se trouve :
pour les dossiers

find . -type d -exec chmod 755 {} \;

pour les fichiers

find . -type f -exec chmod 644 {} \;

NB : 750 / 640 selon l'usage
et, avec sudo ou sans (devant) suivant le propriétaire.

-------------------------------------------
sinon,
j'ai glaner quelques fonctions pour changer les droits
c'est assez simple donc compréhensible, modifiable et intégrable

set_this_dir_permissions () {
# YOUR_DIR="/srv/html"
YOUR_DIR="$@"
# Donne le chmod 644 pour tous les fichiers dans le dossier "YOUR_DIR"
find $YOUR_DIR/ -type f -print0 | xargs -0 chmod 644
     
# Donne le chmod 755 pour tous les dossiers dans le répertoire YOUR_DIR 
find $YOUR_DIR/ -type d -print0 | xargs -0 chmod 755
}
set_this_dir_permissions ;
# https://framagit.org/vv221/play.it/blob/997f257be7ecb5b881ded05bdc488333f1382205/play.it-2/src/10_common.sh
# set defaults rights on files (755 for dirs & 644 for regular files)
# USAGE: set_standard_permissions $element[…]
set_standard_permissions() {
	for element in "$@"; do
		[ -d "$element" ] || return 1
		find "$element" -type d -exec chmod 755 '{}' +
		find "$element" -type f -exec chmod 644 '{}' +
	done
}
# set defaults rights on files ($1 for dirs & $2 for regular files)
# USAGE: set_standard_permissions $1 $2 $dir[…]
set_this_permissions() {
	dir_r=$1
	shift
	file_r=$1
	shift
	for element in "$@"; do
		[ -d "$element" ] || return 1
		find "$element" -type d -exec chmod $dir_r '{}' +
		find "$element" -type f -exec chmod $file_r '{}' +
	done
}

...
bonnes fêtes ! cool

Hors ligne