Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/12/2017, à 13:21

Pympc

Openshot, MLT et problème...

Bonjour à tous

Sous ubuntu 17.10, openshot me fait des misères.
En effet lorsque j'ouvre celui-ci, j'ai une fenêtre ayant pour titre MLT qui s'ouvre et qui ne contient que du noir....... Ensuite plus rien ne fonctionne, je peux sélectionner les menus mais dès que je tombe sur un formulaire rien ne se passe, le clic souris est inopérant.

En passant par le terminal, j'ai le message suivant :

$ openshot
Added /usr/share/openshot to system path

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------
--------------------------------
   OpenShot (version 1.4.3)
--------------------------------
Process no longer exists: 23995.  Creating new pid lock file.

Detecting formats, codecs, and filters...

Quelqu'un a t'il ce soucis ??
A noter que sous manjaro, tout fonctionne

merci et bonnes fêtes

Dernière modification par Pympc (Le 25/12/2017, à 13:22)

Hors ligne

#2 Le 25/12/2017, à 13:28

michel_04

Re : Openshot, MLT et problème...

Bonjour,

renomme le répertoire ~/.openshot  et relance openshot :

mv ~/.openshot  ~/.openshot-bak
openshot

A+

Hors ligne

#3 Le 25/12/2017, à 17:28

Coeur Noir

Re : Openshot, MLT et problème...

Tu as aussi une version plus récente ( peut-être roll ) davantage stable :

https://www.openshot.org/download/

C'est un fichier AppImage, il suffit de le rendre exécutable, double-cliquer dessus et zou…

Hors ligne

#4 Le 25/12/2017, à 17:43

michel_04

Re : Openshot, MLT et problème...

Re,

On peut installer openshot-qt 2.4.1 à partir du ppa.

A+

Hors ligne

#5 Le 25/12/2017, à 19:58

Pympc

Re : Openshot, MLT et problème...

Merci à vous deux

Michel_04, l'installation via le ppa me donne :

sudo apt-get install openshot-qt 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet openshot-qt n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « openshot-qt » n'a pas de version susceptible d'être installée

Lorsque je vais sur le site c'est en Anglais et je suis plutôt nul dans la langue de Shakespeare.
A noter que après temps certains, j'ai un message d'erreur une histoire de python 2.3.... je crois avoir lu que Python est un langage de programmation. En regardant j'ai la version 1.4 d'oopen shot alors que je suis en train de télécharger la version 2.4 (merci coeurnoir) , enfin si j'y arrive car ce soir  j'ai des soucis de téléchargement ce soir.... les joies d'internet !

Dernière modification par Pympc (Le 25/12/2017, à 20:02)

Hors ligne

#6 Le 26/12/2017, à 00:12

Tmi

Re : Openshot, MLT et problème...

Salut pympc

D'après mes souvenirs avec la dernière version d'openshot, il faut installer l'ancien python.
Cela se fait par synaptic.
Mais de toute façon cela n'empêche pas les plantages à tout va . Même sous Windows.
J'utilise maintenant shotcut, qui reçoit régulièrement des mise à jour à condition d'entrer le ppa
Il ne plante pas, et facile à utiliser.


Voir aussi ici pour openshot
https://forum.ubuntu-fr.org/viewtopic.php?id=1994902


Linux en vie de Lux

Hors ligne

#7 Le 26/12/2017, à 01:20

Coeur Noir

Re : Openshot, MLT et problème...

Le ppa openshot ne propose pas de version spécifique à 17.10, ça s'arrête à la 17.04 tout simplement, d'où le :

Aucune version du paquet openshot-qt n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « openshot-qt » n'a pas de version susceptible d'être installée

Hors ligne

#8 Le 26/12/2017, à 09:21

michel_04

Re : Openshot, MLT et problème...

Bonjour,

J'avais les deux versions installées sous 16.04, openshot 1.4.3 (universe) et openshot-qt 2.4.1 (ppa).
Je n'avais pas vu qu'il y avait un trou entre 17.04 et 18.04...
Sur mon matériel pas vraiment récent, les LTS suffisent et je n'installe pas de version intermédiaire.
Sous 18.04, j'ai installé les deux versions, openshot et openshot-qt, qui sont dans le dépôt universe.

A+

Dernière modification par michel_04 (Le 26/12/2017, à 09:26)

Hors ligne

#9 Le 01/01/2018, à 12:16

Pympc

Re : Openshot, MLT et problème...

Merci et j'en profite pour adresser mes meilleurs vœux pour cette nouvelles années.

J'en suis arrivée à utiliser Manjaro pour tous ce qui est vidéo (kdenlive, openshot....). Peut être que le fait qu'il s'agisse d'une distribution  de type rolling release explique que tout fonctionne. J'ai remarqué que très souvent avec Kfdenlive, par exemple, il vaut mieux avoir les toutes dernières versions que celles proposé par les dépôts Ubuntu aussi bien pour les possibilités du logiciels que pour la correction des bugs.

Pour le moment je travaille principalement sous ubuntu mais je passe à Manjaro dès qu'il s'agît de gérer mes montages vidéos.

Hors ligne

#10 Le 01/01/2018, à 12:38

michel_04

Re : Openshot, MLT et problème...

Bonjour,

Meilleurs vœux.
Un site très intéressant pour les logiciels vidéos (entre autres) : FUNIX Mettez un manchot dans votre PC

A+

Hors ligne