Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 31/03/2017, à 22:19

franckysolo

Grub a disparu

Bonjour,

j'ai installer un dual boot pour un pote y qq mois - pc portable Dell tatoué
première mouture windows 8 / ubuntu 16.04 non efi sur un ssd de 250 giga pas de soucis lors de l'intall d'ubuntu le dual boot a fonctionné nickel

mon pote est marin il se barre en voyage bientôt faire le tour du monde sur un voilier et donc j'avais entendu parler de navigatrix un linux spécial marin
donc je tente une install aujourd'hui de navigatrix pour remplacer ubuntu tout se passe nickel lors de l'install mais quand je redémarre
plus de grub au démarrage un message :
Invalid partition table!

je tape enter j'accède au grub de navigatrix, puis je peux demarrer sur navigatrix mais pas de mention de ma partition windows
le pb c'est que pour rebooter sur windows je dois maintenant repasser par le bios réactiver uefi
J'ai donc visiblement cassé le grub ou foiré l'install...

je n'ai plus le pc sous la main pour le moment mais je le récupère bientôt pour essayer de corriger le problème
comme je ne sais pas trop quoi faire je viens demander de l'aide pour éclairer ma lanterne
Si vous avez déjà connu ce problème et vous avez une solution je suis preneur

Merci
franckysolo

Hors ligne

#2 Le 31/03/2017, à 22:51

Bougron

Re : Grub a disparu

Bonsoir
Que peux-t-on faire sans un boot-info https://doc.ubuntu-fr.org/tutoriel/boot-info ? Rien sinon dire des bêtises. Alors allons-y

Windows est installé  en EFI. Tu avais eu manifestement la chance d'installer ubuntu en EFI et tu as pris une variante non EFI du nouveau logiciel.
A moins que cela soit l'inverse.
Je comprends que cela réussit à fonctionner. C'est déjà pas mal!
et comme je n'ai pas envie de m'inscrire
"Navigatrix est un projet communautaire qui compte sur les dons des utilisateurs de temps, d'argent, d'expertise et d'enthousiasme.
Votre don permet de libérer des ressources additionnelles et nous fait avancer.
Veuillez considérer comment vous allez faire de votre contribution pour le développement de Navigatrix.
Cliquez ici pour vous aider en faisant un don.
Inscrivez-vous ici pour obtenir le libre accès à la zone de téléchargement."
je ne saurais te conseiller pour le choix du logiciel  à choisir  Mais si tu donnes la liste de ce qui est téléchargeable, il peut y avoir des noms parlants

Dernière modification par Bougron (Le 31/03/2017, à 22:57)


Ubuntu  BASH 16.04.1 sous windows 10        et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  avec le noyau 4.8.0.36
Un site que les débutants en ubuntu doivent consulter  http://ubuntu.i17.fr/

Hors ligne

#3 Le 01/04/2017, à 13:34

franckysolo

Re : Grub a disparu

Bonjour merci de répondre,

pour le boot-info je n'ai plus le pc sous la main pour le moment, je le récupère bientôt, je posterais le boot-info à cette occasion
navigatrix est basé sur ubuntu, c'est une version avec les softs pour la navigation maritime installés de base (OpenCpn Zygrib, Jtides....)

en attendant j'ai fais un test dans un vbox pour essayer de comprendre où j'ai merdé
j'ai installé dans un premier temps win8.1 dans la vbox puis j'ai fais un dual boot avec ubuntu 16.04 côte à côte pour me remettre dans les conditions
et donc installation ok, le dual boot fonctionne parfaitement
ensuite j'installe navigatrix en lieu et place de ubuntu, et là pas de soucis dans la vbox je retrouve bien le grub version navigatrix mais cette fois ma partition win8.1 est bien présente

Visiblement c'est un problème lié avec efi, ou peut être le fait que le pc soit tatoué?!?...je ne sais pas!
Je vais fouillé dans ce sens, j'espère être sur la bonne voie...

Hors ligne

#4 Le 01/04/2017, à 14:36

Bougron

Re : Grub a disparu

Ton PC n'est pas tatoué. Tu indiques que tu as réussi à faire booter ubuntu.
Peux-tu faire un boot-info de ta vbox . On va essayer de voir comment cela se présente. https://doc.ubuntu-fr.org/tutoriel/boot-info


Ubuntu  BASH 16.04.1 sous windows 10        et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  avec le noyau 4.8.0.36
Un site que les débutants en ubuntu doivent consulter  http://ubuntu.i17.fr/

Hors ligne

#5 Le 01/04/2017, à 19:31

franckysolo

Re : Grub a disparu

Ok je pensais que les pc avec Windows pré installés étaient tatoués...
voici le boot info de ma vbox
Merci pour ton aide

Hors ligne

#6 Le 01/04/2017, à 22:15

Bougron

Re : Grub a disparu

Tu as fais ici une installation NON EFI
avec un logiciel en 32 bits incapable de s'installer en EFI.
S'il te faut de l'EFI, ton test n'est pas significatif.
De plus ton disque dur n'est pas correctement formaté pour booter en EFI. il n'a pas de table de partition GPT.

Dernière modification par Bougron (Le 01/04/2017, à 22:21)


Ubuntu  BASH 16.04.1 sous windows 10        et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  avec le noyau 4.8.0.36
Un site que les débutants en ubuntu doivent consulter  http://ubuntu.i17.fr/

Hors ligne

#7 Le 01/04/2017, à 23:26

franckysolo

Re : Grub a disparu

En effet je viens de me rendre contre que navigatrix est en 32 bits
résultat de la commande lscpu dans navigatrix :

Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                1
On-line CPU(s) list:   0
Thread(s) per core:    1
Core(s) per socket:    1
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 58
Stepping:              9
CPU MHz:               3412.270
BogoMIPS:              6824.54
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              6144K
Bourgon a écrit :

De plus ton disque dur n'est pas correctement formaté pour booter en EFI. il n'a pas de table de partition GPT.

Le disque virtuel?
Visiblement sur son pc windows 8 est installé en EFI, j'avais fais le boot ubuntu sur son pc en non EFI, puis le boot navigatrix aussi
Je dois ré-installer win8 en EFI sur la vbox, faire ub boot en non efi ubuntu et le boot navigatrix en suivant?
Que me conseilles tu?

Hors ligne

#8 Le 02/04/2017, à 10:09

Bougron

Re : Grub a disparu

Bonjour
Dans le monde virtuel, l'important est que tu installes une version du navigateur en 64 bits..
Même si elle s'installe en legacy.
Le prochain boot-info devrait montrer la présence de fichiers efi non activés. Du moins je l'espère.
Dans ton contexte, tu sais que c'est normal.

Dernière modification par Bougron (Le 02/04/2017, à 10:11)


Ubuntu  BASH 16.04.1 sous windows 10        et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  avec le noyau 4.8.0.36
Un site que les débutants en ubuntu doivent consulter  http://ubuntu.i17.fr/

Hors ligne