Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 18/03/2017, à 11:36

Karpon

Problème mise à jour.

Bonjour à tous,

Il y a quelques temps, j'ai trouvé le message suivant, lors d'une mise à jour :

1489833498.png

En cliquant sur  "Essayer de mettre le maximum", j'ai eu comme l'impression que le système tentait de me mettre la version suivante de xubuntu, ce que je ne souhaite pas, pour l'instant, je tiens à conserver la version 16.04.
En cliquant sur "continuer", je retrouve une MàJ normale, sauf que le truc ci-dessus affiché m'est re-présenté à chaque fois : pas vraiment un souci, une gêne tout au plus.
Qu'est-ce que je fais ?
Merci de votre attention.

Dernière modification par Karpon (Le 18/03/2017, à 11:43)


Machine assemblée perso - xubuntu 16.04.1 -  Xfce 4.12
Carte-mère MSI H110 PRO D - Ram DDR3 4G° - CPU Intel S1151

Hors ligne

#2 Le 18/03/2017, à 11:48

Laurent85

Re : Problème mise à jour.

Bonjour, ouvre un terminal pour générer un rapport bisnext, donne le lien c'est la première ligne du rapport, copie colle une a une les commandes suivantes dans un terminal, touche entrée pour l'exécuter puis commande suivante etc... :

sudo apt update
sudo apt install gawk mesa-utils pastebinit smartmontools --no-install-recommends
wget https://github.com/laurent85v/bisnext/raw/master/bisnext
sudo bash bisnext --pastebin

Hors ligne

#3 Le 18/03/2017, à 12:26

gbakyem

Re : Problème mise à jour.

bonsoir les amis je viens de mettre mon système à jour et dans les message j'ai ceci :

Paramétrage de grub-common (2.02~beta2-36ubuntu3.8) ...
Installation de la nouvelle version du fichier de configuration /etc/grub.d/10_linux ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Paramétrage de grub2-common (2.02~beta2-36ubuntu3.8) ...
Paramétrage de grub-pc-bin (2.02~beta2-36ubuntu3.8) ...
Paramétrage de grub-pc (2.02~beta2-36ubuntu3.8) ...
Installation pour la plate-forme i386-pc
grub-install : attention : Le secteur 32 est déjà utilisé par le programme « FlexNet » ; à éviter. Ce logiciel risque de poser des problèmes d'amorçage ou autre à l'avenir. Veuillez demander à ses auteurs de ne pas sauver de données dans la piste d'amorçage.
Installation terminée, sans erreur.
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.4.0-64-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-64-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-31-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-31-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Failed to probe /dev/sda5 for filesystem type
Windows 7 (loader) trouvé sur /dev/sda1
fait

j'ai peur qu'en redémarrant l'ordinateur grub ait de problème. Est-ce que je cours un risque ?


Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 18/03/2017, à 13:17)

Hors ligne

#4 Le 19/03/2017, à 16:46

Laurent85

Re : Problème mise à jour.

gbakyem a écrit :

grub-install : attention : Le secteur 32 est déjà utilisé par le programme « FlexNet » ; à éviter. Ce logiciel risque de poser des problèmes d'amorçage ou autre à l'avenir. Veuillez demander à ses auteurs de ne pas sauver de données dans la piste d'amorçage.

grub a pu s'installer mais supprime FlexNet du secteur 32 qui squatte un emplacement utilisé par grub.

Donne le retour de cette commande avant de nettoyer :

sudo parted /dev/sda unit s print

Hors ligne

#5 Le 19/03/2017, à 17:30

erresse

Re : Problème mise à jour.

@Karpon:
Tu rencontres des problèmes parce-que ce n'est pas une "mise à jour" que tu as faite, mais une "mise à niveau" (peut-être involontaire puisque tu veux rester en 16.04).
Le mieux serait de régler tes paramètres dans le gestionnaire de mise à jour pour qu'il ne te propose de monter de version que pour les versions à long terme (LTS). Là il a manifestement essayé de te passer en 16.10...

Edit: Vérifie dans le gestionnaire de mise à jour si le dépôt "proposed" ne serait pas activé. Si c'est le cas, désactive-le car ce dépôt est destiné aux testeurs aguerris et n'apporte que des ennuis à l'utilisateur courant.
Également, règle la montée de version sur "pour les versions LTS seulement" si ce n'est pas déjà le cas.
Peut-être cela fera-t-il disparaître cette proposition récurrente de mise à niveau...

Dernière modification par erresse (Le 19/03/2017, à 18:14)


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#6 Le 19/03/2017, à 21:03

Pimprelune

Re : Problème mise à jour.

Karpon a écrit :

Bonjour à tous,

Il y a quelques temps, j'ai trouvé le message suivant, lors d'une mise à jour :

http://pix.toile-libre.org/upload/thumb/1489833498.png

En cliquant sur  "Essayer de mettre le maximum", j'ai eu comme l'impression que le système tentait de me mettre la version suivante de xubuntu, ce que je ne souhaite pas, pour l'instant, je tiens à conserver la version 16.04.
En cliquant sur "continuer", je retrouve une MàJ normale, sauf que le truc ci-dessus affiché m'est re-présenté à chaque fois : pas vraiment un souci, une gêne tout au plus.
Qu'est-ce que je fais ?
Merci de votre attention.


Bonsoir, Karpon.

Je ne suis pas une crack comme les autres intervenants, mais j'ai tout récemment eu le même problème et message identique au tien : mini_114083BugMAJ.png, et je n'ai même pas calculé.
J'ai annulé la MAJ, j'ai ouvert Synaptic, j'ai choisi "Recharger", puis cliqué sur "Tout mettre à niveau" et ensuite "Appliquer", la mise à jour s'est faite sans problème.

En passant par là, je trouve que - s'il y a un problème - Synaptic le détaille mieux que le Gestionnaire de mise à jour. Mais bon, ce n'est que mon avis de néophyte...


Ne vous trompez pas entre ma personnalité et mon attitude. Ma personnalité est "qui je suis", mon attitude dépend de "qui vous êtes"...
Ubuntu Gnome 16.04.2 LTS / Linux Mint 17.2
5 clics i.c.i et l.à, pliz :)
Dragon !

Hors ligne

#7 Le 20/03/2017, à 12:17

erresse

Re : Problème mise à jour.

Pimprelune a écrit :

J'ai annulé la MAJ, j'ai ouvert Synaptic, j'ai choisi "Recharger", puis cliqué sur "Tout mettre à niveau" et ensuite "Appliquer", la mise à jour s'est faite sans problème.

Tout le problème vient précisément de cette ambiguïté : une "mise à jour" n'est pas une "mise à niveau" !
Dans le premier cas, on n'agit que sur les composants du système et des application installés en mettant à jour ce qui a évolué.
Dans le second, on provoque une montée de version su système lui-même avec tout ce que cela entraîne de différences entre la version courante et la prochaine (applications mises à jour ou abandonnées pour la nouvelle version, suppression des dépôts tiers, etc...).
Et malheureusement, on en a encore là une manifestation typique puisque, dans synaptic, on trouve "Tout mettre à niveau" alors qu'il ne s'agit que de "Tout mettre à jour" ! Et on s'étonne que les utilisateurs peu avertis se prennent les pieds dans le tapis...
roll


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#8 Le 20/03/2017, à 17:47

serapo

Re : Problème mise à jour.

Bonjour, j'ai eu exactement le même souci en lançant le gestionnaire de mise à jour (Ubuntu 16.04.2) j'ai sélectionné mise à jour partielle, ça m'a changé le noyau ou kernel (je crois qu'on dit comme cela), j'étais parti pour une réinstallation avec tout ce que ça implique, car mon bureau restait désespérément figé. Heureusement j'ai trouvé comment redémarrer sur l'ancien noyau. Dans "logiciels&mise à jour" c'est bien "pour les versions prises en charge à long terme" qui était et qui est coché. D'ailleurs après la réinstallation de la 16.04.2 j'ai à nouveau lancé le gestionnaire de MAJ, et même message, mais là je ne touche plus à rien.

Dernière modification par serapo (Le 20/03/2017, à 17:48)

Hors ligne

#9 Le 20/03/2017, à 17:56

erresse

Re : Problème mise à jour.

@serapo: ...et tu as vérifié que le dépôt "proposed" n'est pas activé ?
Peut-être que c'est particulier à Xubuntu (moi je n'ai pas ce problème, j'ai Ubuntu-Mate 16.04) ?

En tout cas, si on te propose "Mise à niveau" (partielle ou pas) tu vas forcément monter de version et ça va te foutre le bazar !


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#10 Le 20/03/2017, à 18:43

serapo

Re : Problème mise à jour.

J'ai vérifié, "proposed" n'est pas coché, je suis sur Ubuntu "classique" avec Unity, je pense que le soucis viens des dépôts.

Hors ligne

#11 Le 20/03/2017, à 20:55

marcodel

Re : Problème mise à jour.

salut

erresse a écrit :

En tout cas, si on te propose "Mise à niveau" (partielle ou pas) tu vas forcément monter de version et ça va te foutre le bazar !

n'est-ce pas le but d'une mise a jour ?
a+

Hors ligne

#12 Le 21/03/2017, à 10:49

erresse

Re : Problème mise à jour.

Non marcodel, le but de la mise à jour est de maintenir les logiciels installés, la montée de version du système fait l'objet d'une mise à niveau, c'est tout à fait différent !


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#13 Le 21/03/2017, à 13:03

Christophe C

Re : Problème mise à jour.

Mise à jour = maintenance des logiciels (corrections de bugs) SANS changer de version logicielle (sauf exception genre firefox).
Mise à niveau = changement de version d'ubuntu. Par exemple passage de la 16.04 à la 16.10. Et là, beaucoup de logiciels changeront de version.

La politique d'Ubuntu, c'est que sauf exceptions, au sein d'une même version de l'OS, on "gèle" les versions des logiciels, qui n'ont que des mises à jours pour bugs ou de la sécurité. L'idée est de privilégier la stabilité à la nouveauté.
C'est cela que met en cause la "mise à niveau".

Dernière modification par Christophe C (Le 21/03/2017, à 13:04)


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#14 Le 21/03/2017, à 15:00

marcodel

Re : Problème mise à jour.

salut
@ erresse et Christophe C
vous n'avez pas compris la subtilitee de ma question !!! smile
@erresse
je suis intervenu a cause de cette phrase :

erresse a écrit :

En tout cas, si on te propose "Mise à niveau" (partielle ou pas) tu vas forcément monter de version

la capture d'ecran en #1 ,   induit en erreur
il faut comprendre : (  mise a niveau partielle ) par ( mise a jour partielle  )
a+

Hors ligne

#15 Le 21/03/2017, à 16:01

erresse

Re : Problème mise à jour.

Là, c'est moi qui ne comprends pas... Sur la capture du message #1, il est bien marqué "Mise à niveau partielle", pas "Mise à jour partielle".
Pour moi, ce qui induit en erreur, c'est l'ambiguïté des ces deux expressions qui recouvrent en fait des actions très différentes.

Dernière modification par erresse (Le 21/03/2017, à 16:02)


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#16 Le 21/03/2017, à 16:14

marcodel

Re : Problème mise à jour.

re
le traducteur a juge bon de marquer mise a niveau et non mise a jour , pourquoi ?????
mais dans le cas de ce fil , c'est bien une mise a jour partielle
a+

Hors ligne

#17 Le 21/03/2017, à 16:49

serapo

Re : Problème mise à jour.

Ce qui est bizarre c'est que j'ai eu le même message de Karpon (qui est sous Xubuntu), à l'instant je viens de relancer le gestionnaire, et il me propose des MAJ de façon tout à fait classique sans proposer de mise à niveau partielle ou quoi que se soit, pourtant j'ai éteint mon ordi hier soir et l'ai rallumé il y a peu. Les MAJ se sont passé sans encombres ! Il semble que tout soit rentré dans l'ordre.

Hors ligne

#18 Le 21/03/2017, à 17:30

Pimprelune

Re : Problème mise à jour.

erresse a écrit :
Pimprelune a écrit :

J'ai annulé la MAJ, j'ai ouvert Synaptic, j'ai choisi "Recharger", puis cliqué sur "Tout mettre à niveau" et ensuite "Appliquer", la mise à jour s'est faite sans problème.

Tout le problème vient précisément de cette ambiguïté : une "mise à jour" n'est pas une "mise à niveau" !
Dans le premier cas, on n'agit que sur les composants du système et des application installés en mettant à jour ce qui a évolué.
Dans le second, on provoque une montée de version su système lui-même avec tout ce que cela entraîne de différences entre la version courante et la prochaine (applications mises à jour ou abandonnées pour la nouvelle version, suppression des dépôts tiers, etc...).
Et malheureusement, on en a encore là une manifestation typique puisque, dans synaptic, on trouve "Tout mettre à niveau" alors qu'il ne s'agit que de "Tout mettre à jour" ! Et on s'étonne que les utilisateurs peu avertis se prennent les pieds dans le tapis...
roll

Bizarrement - et je comprends ton propos parfaitement (à jour/à niveau), erresse - il s'agit bien d'une mise à jour via Synaptic, car il me semble bien qu'en bas de la fenêtre (dès que la MAJ est faite), en cas de proposition de changement de niveau/version, c'est indiqué (ou je me trompe ?). Mais effectivement, ce serait sans doute une formule - inexacte - à faire corriger dans cette application, erresse.
En tout cas, je ne me verrais pas cliquer sur mise à niveau (partielle ou pas) dans le Gestionnaire de MAJ... alors que ça ne me gêne pas de le faire via Synaptic.
Mais cela vient du fait qu'un collègue de l'Axul faisait toujours les MAJ via S. et j'avoue que (bêtement et automatiquement) je n'avais pas noté la terminologie exacte. C'est incontestablement un couac de cette application hmm

D'autre part, Synaptic indique aussi les paquets "à réparer", ce qui est un plus par rapport au Gestionnaire de mise à jour.

M'enfin, j'dis ça, j'dis rien...


Ne vous trompez pas entre ma personnalité et mon attitude. Ma personnalité est "qui je suis", mon attitude dépend de "qui vous êtes"...
Ubuntu Gnome 16.04.2 LTS / Linux Mint 17.2
5 clics i.c.i et l.à, pliz :)
Dragon !

Hors ligne