Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 07/03/2017, à 11:00

speedstream

[Résolu] Icones "négativés" en barres de menus et applications

Bonjour à Tous,

J'ai une distrib basée sur UB16.04 avec Mate+Compiz installés pour la gestion du bureau et des fenêtres. Suite à un apt-upgrade récent, le problème est apparu après un redémarrage.

J'ai eu un changement de couleur des icones qui sont passés du bleu-vert au rouge. En fait, j'obtiens le même résultat en terme de couleur si je "négativise" les icones d'origine dans un logiciel de manipulation graphique.
Dans le répertoire /usr/share/icons/..., la couleur d'origine est respectée. C'est seulement dans les barres de menus, le menu démarrer de Mate, et dans de rares applications que la couleur est altérée dans les menus, comme Gimp.

Voici une capture :
mini_391093Negativizedicons2.png

J'ai regardé via conf editor tout ce qui pouvait me sembler lié aux barres de menus. Mais je n'ai pas trouvé de paramètre "couleurs négatives" ou en tout cas rien de proche. De plus, comme cela se produit aussi pour pluma (pour ne citer que lui) dans les barres de menus ou pour Gimp dans toute son interface et même lors de son lancement (le renard est un camaïeu de roses), je pense que le problème est peut-être plus proche d'un paramètre général, voire d'un détail dans le driver mesa (j'ai une carte ATI)

Je cherche depuis plusieurs heures dans le conf editor sans succès et je ne vois pas bien où continuer de chercher.

Quelques idées, avis (solutions ? smile ) seraient les bienvenus si quelqu'un en possède smile

Merci à Tous.


Edit : lien avec miniature

Dernière modification par speedstream (Le 09/03/2017, à 11:11)

Hors ligne

#2 Le 07/03/2017, à 11:10

abelthorne

Re : [Résolu] Icones "négativés" en barres de menus et applications

Ça ressemble énormément au bug de LLVM 3.9.1 (corrigé en 4.0) : quelle version de Mesa utilises-tu et comment l'as-tu installée ?

Dernière modification par abelthorne (Le 07/03/2017, à 11:11)

Hors ligne

#3 Le 07/03/2017, à 11:36

jibel

Re : [Résolu] Icones "négativés" en barres de menus et applications

Salut Speedstream ,
Peut-être qu'en allant dans "gestionnaire de paramètres"===> apparences===> icônes, choisir celles qui sont a ton goût... Il est possible que lors de ton apt-update ces couleurs ont étés installées et changées d'office ? ? a toi de vérifier...
PS: avant qu'on te le dise ..pour tes captures d'écran? il faut utiliser "la toile libre" 3ème ou 4ème ligne a copier/coller dans le forum . Ce qui sera moins encombrant dans ton post ..... smile


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub14.04,VoyagerX2,X8,Debian 8.2, 8,3 , handy-linux 2.2, emma 3 .PC medion akira  DD 1T + 2 .

Hors ligne

#4 Le 07/03/2017, à 12:08

abelthorne

Re : [Résolu] Icones "négativés" en barres de menus et applications

Non mais c'est pas du tout un problème de thème d'icônes sélectionné, c'est un bug du pilote graphique qui concerne les applis en Gtk2, d'où le fait que ça touche aussi les barres d'outils des softs comme Gimp.

Le seul détail qui m'intrigue dans la situation de speedstream, c'est que tous les PPA qui proposent Mesa devraient avoir une version de LLVM non buggée et la version des dépôts (surtout sur Xenial) est trop ancienne et devrait avoir au mieux LLVM 3.8. Donc, à moins d'avoir compilé soi-même Mesa, c'est assez bizarre que le bug soit présent.

Dernière modification par abelthorne (Le 07/03/2017, à 12:08)

Hors ligne

#5 Le 08/03/2017, à 00:11

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

jibel a écrit :

Salut Speedstream ,
Peut-être qu'en allant dans "gestionnaire de paramètres"===> apparences===> icônes, choisir celles qui sont a ton goût... Il est possible que lors de ton apt-update ces couleurs ont étés installées et changées d'office ? ? a toi de vérifier...
PS: avant qu'on te le dise ..pour tes captures d'écran? il faut utiliser "la toile libre" 3ème ou 4ème ligne a copier/coller dans le forum . Ce qui sera moins encombrant dans ton post ..... smile

J'avais oublié d'en parler. Mais j'étais aussi allé là dès le départ wink
Et pour la "toile libre", je ferai plus attention la prochaine fois. Merci pour l'info smile

Hors ligne

#6 Le 08/03/2017, à 00:40

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

abelthorne a écrit :

Ça ressemble énormément au bug de LLVM 3.9.1 (corrigé en 4.0) : quelle version de Mesa utilises-tu et comment l'as-tu installée ?

Effectivement, abelthorne. Tu as mis le doigt dessus. Après lecture du forum pointé par ton lien, il semble bien que la version 3.9.1 soit la version problématique et qu'il faille passer à la V4 puisqu'il ne devrait pas y avoir de 3.9.2.

Voici ce que j'ai quant au driver. Je ne le "trafique" pas. Je suis sur les dépôts plus ou moins classiques de Xenial.

$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN (DRM 2.43.0 / 4.4.0-64-generic, LLVM 3.9.1)
OpenGL core profile version string: 4.2 (Core Profile) Mesa 17.0.0-rc3
OpenGL core profile shading language version string: 4.20
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.0.0-rc3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.0.0-rc3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Et les paquets suivants seraient-ils liés à llvm ? Comme le numéro de version semble correspondre, je pense avoir vu juste.

$ sudo apt list --installed *llvm*
libllvm3.6v5/xenial,now 1:3.6.2-3ubuntu2 amd64  [installé, automatique]
libllvm3.9/xenial,now 1:3.9.1-0ubuntu0~xedgers16.04.1 amd64  [installé, automatique]

J'ai deux machines en ATI (un desktop avec deux 7870 et un laptop avec un A4-5000) qui fonctionnent avec cette distribution "exotique" (Ultimate Edition) qui marche par ailleurs très bien... quand on peut l'installer big_smile
Plus sérieusement, pour les deux machines, cela s'est produit après update. Je ne cherche pas plus loin. C'est visiblement le problème. Je vais essayer de trouver une version 4 ou + du llvm. Si ça fonctionne, je vous tiendrai au courant.

Merci beaucoup pour avoir rapproché le problème, abelthorne.

Hors ligne

#7 Le 08/03/2017, à 00:53

abelthorne

Re : [Résolu] Icones "négativés" en barres de menus et applications

Je suis sur les dépôts plus ou moins classiques de Xenial.

Et qu'est-ce que tu appelles les dépôts "plus ou moins" classiques ? Tu es sur Mesa 17.0 (RC3), tu utilises donc un PPA : lequel ? Ça aiderait pour te dire quoi désinstaller / installer parmi les cinq ou six PPA plus ou moins stables qui proposent des mises à jour de Mesa.

Si tu as un doute, donne le retour de :

ls /etc/apt/sources.list.d

Dernière modification par abelthorne (Le 08/03/2017, à 00:59)

Hors ligne

#8 Le 08/03/2017, à 09:08

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Bonjour abelthorne,

Voici le résultat de ta commande (j'ai enlevé les fichiers .save redondants du résultat pour alléger le texte).

boot-repair.list
cairo-dock-team-ppa.list
cinelerra.list
getdeb.list
gimp-paint-studio.list
gimp-svn.list
google-earth.list
grub-customizer.list
gwendal-lebihan-dev-cinnamon-stable.list
librecad-dev-ubuntu-librecad-stable-yakkety.list
mate.sources.list
mjblenner-ubuntu-ppa-hal-xenial.list
ondrej-ubuntu-php-xenial.list
playonlinux.list
screenlets-ppa.list
skype-stable.list
tualatrix-ppa.list
ubuntu-audio-dev-ppa.list
ubuntu-wine-ubuntu-ppa-yakkety.list
ultamatix.sources.list
ultimateedition.list
webupd8.list
webupd8team-y-ppa-manager.list
wine-ppa.list
xbmc.list
xorg-crack-pushers.list

Et à tout hasard, voici les dépôts listés dans mon /etc/apt/sources.list

deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse

Merci smile

Hors ligne

#9 Le 08/03/2017, à 09:36

abelthorne

Re : [Résolu] Icones "négativés" en barres de menus et applications

Je ne vois pas de PPA "classique" pour Mesa, donc donne aussi le contenu des fichiers .list pour regarder ça de plus près. Je soupçonne xorg-crack-pushers mais il faudrait vérifier exactement ce qu'il y a dans ce dépôt (après vérification, il s'agirait du PPA xorg-edgers ; à confirmer).

cat /etc/apt/sources.list.d/*.list

EDIT : et donne aussi le retour de ça pendant qu'on y est :

apt-cache policy llvm*

Dernière modification par abelthorne (Le 08/03/2017, à 10:24)

Hors ligne

#10 Le 08/03/2017, à 10:28

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Voici les lignes qui ne commencent pas par un dièse (#)

$ cat /etc/apt/sources.list.d/*.list
deb http://ppa.launchpad.net/cinelerra-ppa/ppa/ubuntu xenial main #Cinelerra
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp-edge/ubuntu xenial main #Bleeding Edge Gimp
deb http://dl.google.com/linux/earth/deb/ stable main
deb http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial main #Grub Customizer PPA
deb http://ppa.launchpad.net/librecad-dev/librecad-stable/ubuntu yakkety main
deb http://ppa.launchpad.net/mjblenner/ppa-hal/ubuntu xenial main
deb http://ppa.launchpad.net/ondrej/php/ubuntu xenial main
deb http://deb.playonlinux.com/ trusty main
deb [arch=amd64] https://repo.skype.com/deb stable main
deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu yakkety main
deb http://os-builder.com/Apps Apps all #Ultimate Edition Applications
deb http://os-builder.com/Games Games all #Ultimate Edition Games
deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial main #PPA for xorg crack pushers
deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial main #PPA for xorg crack pushers Source

Hors ligne

#11 Le 08/03/2017, à 10:31

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

...et le retour de la seconde commande :

apt-cache policy llvm*
llvm-4.0-doc:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main i386 Packages
llvm-3.5:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.6:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
llvm-3.7:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.8:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
llvm-3.9:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
llvm-4.0-tools:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
llvm-4.0:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
llvm:
  Installé : (aucun)
  Candidat : 1:3.8-33ubuntu3.1
 Table de version :
     1:3.8-33ubuntu3.1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     1:3.8-33ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-dev:
  Installé : (aucun)
  Candidat : 1:3.8-33ubuntu3.1
 Table de version :
     1:3.8-33ubuntu3.1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     1:3.8-33ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.7-tools:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.9-dev:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
llvm-3.9-doc:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main i386 Packages
     1:3.9-1ubuntu1~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main i386 Packages
llvm-3.7-dev:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.7-doc:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
llvm-4.0-examples:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main i386 Packages
llvm-3.5-dev:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.5-doc:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
llvm-3.5-examples:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
llvm-3.9-tools:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
llvm-3.7-examples:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
llvm-runtime:
  Installé : (aucun)
  Candidat : 1:3.8-33ubuntu3.1
 Table de version :
     1:3.8-33ubuntu3.1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     1:3.8-33ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.9-examples:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main i386 Packages
     1:3.9-1ubuntu1~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main i386 Packages
llvm-3.5-runtime:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.8-dev:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
llvm-3.8-doc:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages
llvm-3.6-dev:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
llvm-3.6-doc:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages
llvm-3.7-runtime:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.5-tools:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-3.6-runtime:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
llvm-3.6-examples:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages
llvm-3.9-runtime:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
llvm-3.6-tools:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
llvm-4.0-runtime:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
llvm-3.8-examples:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main i386 Packages
llvm-3.8-runtime:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
llvm-4.0-dev:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages

Hors ligne

#12 Le 08/03/2017, à 10:40

abelthorne

Re : [Résolu] Icones "négativés" en barres de menus et applications

Ok, c'est bien xorg-edgers. Personnellement, je te conseillerais d'utiliser un autre PPA mais c'est toi qui vois : xorg-edgers propose non seulement Mesa en version de développement (problèmes possibles à chaque mise à jour) mais aussi le serveur X (problèmes potentiels multipliés par deux).

Si tu veux juste avoir Mesa à jour, il y a notamment :
- le PPA de Padoka pour Mesa stable
- le PPA de Padoka ou Oibaf pour Mesa en version de développement

Qu'est-ce que tu préfères :
1) garder xorg-edgers et essayer de résoudre le problème ?
2) avoir Mesa à jour mais limité à la version stable (actuellement 17.0) ?
3) avoir Mesa à jour en version de développement (actuellement 17.1) sans pour autant mettre X à jour ?

Pour apt-cache policy, je me suis planté de nom de paquet, c'est plutôt libllvm qu'il faudrait vérifier :

apt-cache policy libllvm*

Hors ligne

#13 Le 08/03/2017, à 11:07

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Voici le retour de la seconde commande. Effectivement, il y a quelques champs [Installé] qui sont remplis smile

$ apt-cache policy libllvm*
libllvm-3.5-ocaml-dev-p5zd8:i386:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm-4.0-ocaml-dev-c8y98:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm-3.8-ocaml-dev-c8y98:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm4.0-dbg:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
libllvm-3.6-ocaml-dev:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm-3.9-ocaml-dev:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
libllvm-3.6-ocaml-dev-c8y98:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm3.9-dbg:
  Installé : (aucun)
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
libllvm3.7-dbg:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm-3.9-ocaml-dev-c8y98:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm3.5-dbg:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm3.5:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm3.6:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm3.7:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm3.8:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
libllvm3.9:
  Installé : 1:3.9.1-0ubuntu0~xedgers16.04.1
  Candidat : 1:3.9.1-0ubuntu0~xedgers16.04.1
 Table de version :
 *** 1:3.9.1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
libllvm4.0:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
libllvm-3.7-ocaml-dev:
  Installé : (aucun)
  Candidat : 1:3.7.1-2ubuntu2
 Table de version :
     1:3.7.1-2ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm-3.7-ocaml-dev-c8y98:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm-3.5-ocaml-dev-kuc34:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libllvm-4.0-ocaml-dev:
  Installé : (aucun)
  Candidat : 1:4.0~+rc1-0ubuntu0~xedgers16.04.1
 Table de version :
     1:4.0~+rc1-0ubuntu0~xedgers16.04.1 500
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial/main amd64 Packages
libllvm-ocaml-dev:
  Installé : (aucun)
  Candidat : 1:3.8-33ubuntu3.1
 Table de version :
     1:3.8-33ubuntu3.1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     1:3.8-33ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm3.8-dbg:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
libllvm-3.5-ocaml-dev:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm3.5v5:
  Installé : (aucun)
  Candidat : 1:3.5.2-3ubuntu1
 Table de version :
     1:3.5.2-3ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
libllvm3.6-dbg:
  Installé : (aucun)
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
     1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
libllvm3.6v5:
  Installé : 1:3.6.2-3ubuntu2
  Candidat : 1:3.6.2-3ubuntu2
 Table de version :
 *** 1:3.6.2-3ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
libllvm-3.8-ocaml-dev:
  Installé : (aucun)
  Candidat : 1:3.8-2ubuntu4
 Table de version :
     1:3.8-2ubuntu4 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     1:3.8-2ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

Sinon, j'aime bien m'instruire. Donc l'option 1 "garder xorg-edgers et essayer de résoudre le problème" a ma préférence.
C'est ce que je ferai dans un premier temps, avec ou sans l'aide de quelqu'un. Bien entendu, toute aide sera la bienvenue smile

L'option 2 (retour sur un ppa de version mesa stable) sera celle que je retiendrai s'il n'est pas possible de résoudre le problème.
L'option 3 me refroidit un peu trop. Ma machine est "sensible" car j'en ai besoin pour beaucoup de choses "sérieuses". Donc je ne suis pas à fond dans l'expérimentation.

De toutes façons, je vais probablement commencer les modifs sur le laptop qui est atteint du même problème. Il est beaucoup moins stratégique pour moi.
Car il faut bien admettre que ce n'est qu'un léger problème d'affichage qui grève un peu (trop) le confort. C'est surtout sa résolution qui le rend intéressant pour moi. C'est une occasion d'apprendre.

Hors ligne

#14 Le 08/03/2017, à 11:12

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Le résultat de ta dernière commande nous montre qu'il y a une version 4.0 du LLVM dans le PPA xedgers. Mais c'est une RC1... C'est jeune. J'ignore ce que ça peut donner... smile

Hors ligne

#15 Le 08/03/2017, à 11:40

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Je viens de lancer ce qui suit sur le laptop.

sudo apt install libllvm4.0

Aucune différence au redémarrage. Les icones sont toujours rouges.
Donc je me suis dit  "Soyons fous, j'ai aussi ajouté la ligne suivante :

sudo apt install llvm-4.0

Même chose après redémarrage.

Hors ligne

#16 Le 08/03/2017, à 11:45

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

$ apt list --installed *llvm*
En train de lister... Fait
libllvm3.9/xenial,now 1:3.9.1-0ubuntu0~xedgers16.04.1 amd64  [installé, automatique]
libllvm4.0/xenial,now 1:4.0~+rc1-0ubuntu0~xedgers16.04.1 amd64  [installé]
llvm-4.0/xenial,now 1:4.0~+rc1-0ubuntu0~xedgers16.04.1 amd64  [installé]
llvm-4.0-dev/xenial,now 1:4.0~+rc1-0ubuntu0~xedgers16.04.1 amd64  [installé, automatique]
llvm-4.0-runtime/xenial,now 1:4.0~+rc1-0ubuntu0~xedgers16.04.1 amd64  [installé, automatique]

J'ai toujours une libllvm3.9 installée. Et forcément, tenter de la désinstaller amène ce qui suit puisque mon PPA n'est pas une version stable :

$ sudo apt-get remove --purge libllvm3.9
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libkf5configgui5 : Dépend: libqt5gui5 (>= 5.2.0) mais ne sera pas installé ou
                             libqt5gui5-gles (>= 5.2.0) mais ne sera pas installé
 libkf5waylandclient5 : Dépend: libqt5gui5 (>= 5.0.2) mais ne sera pas installé ou
                                 libqt5gui5-gles (>= 5.0.2) mais ne sera pas installé
 libonline-accounts-daemon1 : Dépend: libonline-accounts-client1 mais ne sera pas installé
 libqmenumodel0 : Dépend: libqt5gui5 (>= 5.0.2) mais ne sera pas installé ou
                           libqt5gui5-gles (>= 5.0.2) mais ne sera pas installé
 libqt5svg5 : Dépend: libqt5gui5 (>= 5.3.0) mais ne sera pas installé ou
                       libqt5gui5-gles (>= 5.3.0) mais ne sera pas installé
 libqt5waylandclient5 : Dépend: libqt5gui5 (>= 5.5.0) mais ne sera pas installé ou
                                 libqt5gui5-gles (>= 5.5.0) mais ne sera pas installé
 libqt5widgets5 : Dépend: libqt5gui5 (>= 5.5.0) mais ne sera pas installé ou
                           libqt5gui5-gles (>= 5.5.0) mais ne sera pas installé
 qml-module-qtfeedback : Dépend: libqt5feedback5 mais ne sera pas installé
 ubuntu-sso-client : Dépend: python-ubuntu-sso-client (= 13.10-0ubuntu11) mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Avant de toucher plus de choses, j'attends ton avis, si tu en as un.

Hors ligne

#17 Le 08/03/2017, à 13:03

abelthorne

Re : [Résolu] Icones "négativés" en barres de menus et applications

speedstream a écrit :

Sinon, j'aime bien m'instruire. Donc l'option 1 "garder xorg-edgers et essayer de résoudre le problème" a ma préférence.
L'option 3 me refroidit un peu trop. Ma machine est "sensible" car j'en ai besoin pour beaucoup de choses "sérieuses". Donc je ne suis pas à fond dans l'expérimentation.

Tu as peut-être mal compris mais l'option 1 (xorg-edgers) est beaucoup plus expérimentale que la 3 (Mesa devel), puisque en plus d'avoir le pilote graphique en version de développement, tu as aussi le serveur d'affichage en version de développement. Deux fois plus de chances de tout casser à chaque mise à jour.

Quoi qu'il en soit, j'allais te suggérer de faire ce que tu as essayé, c.à.d. installer LLVM 4.0 au lieu de la 3.9 depuis le dépôt pouvoir si les paquets de Mesa pouvaient gérer l'un ou l'autre mais ce n'est apparemment pas le cas. Donc, ce que je te suggère, c'est de passer à Mesa stable à jour via le PPA de Padoka.

Dans un premier temps, vérifie que tu n'as pas de paquets cassés suite à ta tentative de supprimer LLVM 3.9 :

sudo apt-get install -f

Ensuite, supprime LLVM 4 :

sudo apt-get remove --purge libllvm4.0 llvm-4.0

Une fois que c'est fait, dans l'optique de passer à Mesa 17.0 stable :
1) Installe ppa-purge pour supprimer proprement xorg-edgers :

sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa

Il va supprimer les paquets du PPA et réinstaller les versions des dépôts à la place.

2) Si tout s'est bien passé, redémarre ton PC.

3) Ajoute le PPA stable de Padoka :

sudo add-apt-repository ppa:paulo-miguel-dias/pkppa
sudo apt-get update && sudo apt-get dist-upgrade

4) Après la mise à jour, redémarre à nouveau. Tu devrais être débarrassé de la teinte rouge sur tes icônes.

Dernière modification par abelthorne (Le 08/03/2017, à 13:03)

Hors ligne

#18 Le 08/03/2017, à 14:18

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

OK. Je te tiens au courant d'ici ce soir.
Merci.

Hors ligne

#19 Le 08/03/2017, à 15:09

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Je trouve finalement un peu de temps pour m'en occuper.

Le   sudo apt-get install -f   n'a pas trouvé de paquets cassés => OK

Le ppa-purge n'a pas fonctionné. J'avais toujours le dépot actif pour   xorg-crash-pushers
Donc j'ai commenté d'un dièse les deux lignes dans le fichier   xorg-crash-pushers.list   pour le rendre transparent durant les updates.

Reboot puis ajout du dépôt stable.

apt update   puis   dist-upgrade  =>  Houla ! Grosse update smile

Reboot puis    sudo apt-get autoremove   et 768 Mo de libérés.
Mais surtout, dès le redémarrage, les icones étaient revenus à la couleur normale.

A noter que la manipulation a fait passer ma machine de la version 17.0.0rc3 avec llvm-3.9 à la version 17.0.1 avec llvm-4.0. En gros, que du mieux !

$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD KABINI (DRM 2.43.0 / 4.4.0-64-generic, LLVM 4.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.0.1 - padoka PPA
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.0.1 - padoka PPA
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.0.1 - padoka PPA
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

Merci beaucoup pour le coup de main. Je pense que j'y serais parvenu mais... dans 3 jours big_smile

Je m'occuperai de ma machine principale ce soir sur le même mode.
Je rapporterai l'état des choses après intervention.

Hors ligne

#20 Le 08/03/2017, à 16:56

abelthorne

Re : [Résolu] Icones "négativés" en barres de menus et applications

Très franchement, je suis étonné que sans purger proprement xorg-edgers et en ajoutant le dépôt de Padoka tu n'aies pas mis complètement ton système en vrac. Le dépôt xorg-edgers étant désactivé, va quand même faire un tour dans Synaptic voir si tu as une rubrique "Installés (locaux ou obsolètes)" et auquel cas, ce qui est listé dedans. Il y a de fortes chances que tu aies des paquets orphelins liés à X.org...

Hors ligne

#21 Le 09/03/2017, à 10:57

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Bonjour,

Et bien voila. C'est résolu. Ma machine principale a été beaucoup plus revêche que mon laptop. J'ai dû rentrer la clef gpg du dépôt à la main. Quand on n'a jamais fait ça, ça prend du temps...
Je pense que le ppa-purge n'était pas innocent dans ce dysfonctionnement.
Sans parler d'un problème (qui n'avait rien à voir) que je me suis créé tout seul avec Plymouth.

Mais bon. A minuit, tout était rentré dans l'ordre smile

Merci beaucoup pour votre aide avec mention spéciale pour abelthorne cool

Hors ligne

#22 Le 09/03/2017, à 11:07

speedstream

Re : [Résolu] Icones "négativés" en barres de menus et applications

Au sujet des paquets, j'en ai 9 qui refusent de se mettre à jour.
Je vais ouvrir un autre sujet.

Hors ligne